[E3-hacking] v2 release

Alex Goodyear Alex.Goodyear at jet.uk
Tue Sep 26 18:13:54 BST 2006

I've also got the V2 release working without any major problems (a
fantastic achievement, thanks Jonathan et al). I have a few observations
and questions that may help others.

I did stop the NAND backup process because it was incredibly slow. "top"
showed that the system wasn't using much CPU but the load was over 2.0
Using "df" also revealed that the USB stick was only having 16 bytes
written to it every second or so.

The E3 keyboard is mapped as a standard desktop keyboard so most shifted
characters are wrong and symbol-shift characters are ignored.

I replaced the supplied 2.6.16 uImage with the one from the 2.6.17
directory in the hope that the keyboard mappings would be fixed. It
worked but it only provided a shell login for the serial connection
unlike the 2.6.16 image which provides both a serial and an onboard E3

The copying of the Linux image from NAND seems slow, I recall some
discussion about this being fixed within u-boot. Does the copy of u-boot
in the V2 release contain this fix?

My USB-to-Ethernet dongle is a Psion Dacom Gold Port using the Kawasaki
LSI KL5KUSB101B chip which was detected by both the 2.6.16 and 2.6.17
kernels (it uses the kaweth device driver). Upon connection it reports
some "rx-16" problem or other but it works fine.

Again, thanks to everyone involved in contributing to this project,


> -----Original Message-----
> From: e3-hacking-bounces at earth.li [mailto:e3-hacking-bounces at earth.li]
> Behalf Of David Given
> Sent: 19 September 2006 23:40
> To: Discussion of the Amstrad E3 emailer hardware/software
> Subject: [E3-hacking] v2 release
> I've just given the v2 release a try --- impressive stuff! The
> Just
> Worked. No more faffing around with serial downloads every time I want
> boot
> the thing, hurrah. It's also really nice to have a real boot loader.
> thanks to the magic of jffs2 there's an astonishing amount of root
> system
> space...
> A few minor quibbles:
> - Busybox's loadkmap is very stupid and can't cope with my ASCII
> table.
> (It also wants to refer to the obsolete /dev/vc/0.) I can't figure out
> to
> compile my keymap, or even if such a concept makes sense these days.
> - Is there an ipkg feed available where I can get iwconfig? I've tried
> same feed that I use for my NSLU2, but it's not compatible. The
> compiled version I built myself (I couldn't make a dynamically
> version to work) is over five megabytes. Ho hum.
> - OpenEmbedded wants to rebuild monotone's roster cache. Apparently
> is
> going to take about four hours.
> Currently I'm trying to build a working zd1201 driver for wireless
> networking,
> which is involving some entertaining messing around with cross
compilers -
> --
> it's suprisingly hard to find a decent cross compiler package for
> --
> +- David Given --McQ-+ "Gaping from its single obling socket was
> |  dg at cowlark.com    | scintillating, many fauceted scarlet
> | (dg at tao-group.com) | --- Jim Theis, _The Eye of Argon_ (spelling
> +- www.cowlark.com --+ original)

More information about the e3-hacking mailing list