[E3-hacking] pbltool problem

Edward Robbins edd.robbins at googlemail.com
Mon Nov 26 13:18:06 GMT 2012

Hi again,

I've got some free time today and have been playing with the emailer
again. I've managed to build a 3.6 kernel a while ago but when I tried
to upload the V2 stuff I had problems.

Today I made up a new cable thinking that might be the issue, but it
hasn't helped. I can get a boot log just fine, but when I run pbltool
with "sudo ./pbltool -f /dev/ttyUSB0 oe-install.pbl" I get:

Done handshaking
Compressed return block?
Flushing: 0x00
Flushing: 0x0E
Flushing: 0x00
Flushing: 0x82
Flushing: 0x00
Flushing: 0x52
Flushing: 0x00
Flushing: 0x04
Flushing: 0x09
Flushing: 0x1F
Flushing: 0x05
Flushing: 0x10
Flushing: 0x40
Flushing: 0xFE
Flushing: 0x7B
Flushing: 0x0E
Flushing: 0xB0
Flushing: 0x9A
Compressed return block?

Which then repeats forever. I've tried editing oe-install.pbl to
change the baud rate (38400, 19200, 9600) but it makes no difference.
I also looked for pblq but the link on
http://cowlark.com/amstrad/index.html is broken.

Any ideas?


More information about the e3-hacking mailing list