[E3-hacking] Newbie help please .......

Andy Brown andyb at uk8.net
Fri Feb 8 23:15:13 GMT 2013

Hi David,

Thanks for the reply. I tried the E3-release-V2 using the USB port and it worked! Now have an E3 booting Linux.

Many thanks,


-----Original Message-----
From: e3-hacking-bounces at earth.li [mailto:e3-hacking-bounces at earth.li] On Behalf Of David Given
Sent: 08 February 2013 21:12
To: e3-hacking at earth.li
Subject: Re: [E3-hacking] Newbie help please .......

On 08/02/13 20:10, Andy Brown wrote:
> “ kernel panic – not syncing: VFS: unable to mount root FS on unknown 
> block(1,0)”
> I do get the “penguin” and a load of text on the E3 screen before the 
> error, so I rekon I’m not far away.

Yup, that means the Linux kernel is running; it just can't find the root filesystem. This does mean it's almost working.

I'd hazard a guess that it means it's failed to correctly upload the initrd image --- it's large and the serial link isn't very reliable.
Does pbltool say anything interesting during the upload process?

You could also try copying the ramdisk image (uncompressed) onto a USB key and changing the root= parameter to root=/dev/sda or root=/dev/sda1.

I've always had luck using the E3_release_v2 system at
http://the.earth.li/pub/e3 --- this has the advantage that it will also reflash the device for you, so it'll boot automatically into Linux and you don't need to use the serial link each time. (Instructions inside the package.)

┌─── dg@cowlark.com ───── http://www.cowlark.com ───── │ "Of course, on a sufficiently small planet, 40 km/hr is, in fact, │ sufficient to punt the elastic spherical cow into low orbit." --- │ Brooks Moses on r.a.sf.c

More information about the e3-hacking mailing list