[E3-hacking] Serial port oddity

David Given dg at cowlark.com
Mon Nov 28 12:12:05 GMT 2011

I realise that the E3 is almost entirely irrelevant these days, but just
in case anyone wants to get one working...

I recently pulled mine out of storage and tried to put Debian on it. (I
want to use it as a modem.) Unfortunately PBL wouldn't handshake.
Investigation showed that at baud rates of 57600 and above, the E3's
serial port seemed to be unable to receive data reliably, getting
frequent single-bit errors. Transmission seems fine.

I eventually managed to get everything working by dropping the baud rate
to 38400 (uploading the kernel and initrd takes an *age* at that speed),
and everything works now.

This might be age-related; my E3 is now years old. A flaky capacitor
causing the pulses to get smeared so that the UART isn't registering
them properly? This seems particularly likely given that I don't have a
level shifter, so I'm driving the UART at out-of-spec voltages.
Alternatively it could be clock drift, but given that the UART is on the
processor this seems unlikely.

So if anyone has an E3 which won't handshake any more, try lowering the
baud rate and seeing if that helps. (pblq has an option for this.)


Incidentally, I don't suppose any of the uboot patches got accepted by
upstream, did they? Editing the environment with a hex editor is
slightly harrowing and it'd be so nice to have a version which could
store them in NAND...

┌─── dg@cowlark.com ───── http://www.cowlark.com ─────
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 262 bytes
Desc: OpenPGP digital signature
URL: <http://www.earth.li/pipermail/e3-hacking/attachments/20111128/16863b36/attachment.pgp>

More information about the e3-hacking mailing list