[E3-hacking] Serial port oddity

Janusz Krzysztofik jmkrzyszt at gmail.com
Sun Dec 11 15:17:17 GMT 2011

On Monday 28 of November 2011 at 13:12:05, David Given wrote:
> I realise that the E3 is almost entirely irrelevant these days, but just
> in case anyone wants to get one working...
> I recently pulled mine out of storage and tried to put Debian on it.

A Debian on Amstrad Delta howto posted to the list could be a nice thing 
for those who may want to give it a try. Personally, I've been using 
Debian for years, but never tried to install it on any of my E3's, which 
are running Angstrom, so I'm not the right person to write such howto.

BTW, I found writing an Angstrom howto a nightmare due to its instability when it came to upgrading the set of packages I had managed 
to build and install two years ago. I must had been lucky while doing 
that, as my consecutive upgrade attempts all failed. I'm still running 
that 2 years old userspace, as well as booting that 5 years old installation ram disk on recent kernels without problems.

> (I
> want to use it as a modem.) Unfortunately PBL wouldn't handshake.
> Investigation showed that at baud rates of 57600 and above, the E3's
> serial port seemed to be unable to receive data reliably, getting
> frequent single-bit errors. Transmission seems fine.
> I eventually managed to get everything working by dropping the baud rate
> to 38400 (uploading the kernel and initrd takes an *age* at that speed),
> and everything works now.

From my experience, it depends much on the serial port/adapter you use. 
I had been fighting with several USB models for months before I 
discovered that best results I can get with the regular serial port 
found on one of my PC motherboards. 

> This might be age-related; my E3 is now years old. A flaky capacitor
> causing the pulses to get smeared so that the UART isn't registering
> them properly? This seems particularly likely given that I don't have a
> level shifter, so I'm driving the UART at out-of-spec voltages.
> Alternatively it could be clock drift, but given that the UART is on the
> processor this seems unlikely.
> So if anyone has an E3 which won't handshake any more, try lowering the
> baud rate and seeing if that helps. (pblq has an option for this.)

I've never used pblq, only pbltool found in 
http://the.earth.li/pub/e3/E3_release_v2.tar.gz. Perhaps that makes a 

> ...
> Incidentally, I don't suppose any of the uboot patches got accepted by
> upstream, did they? Editing the environment with a hex editor is
> slightly harrowing and it'd be so nice to have a version which could
> store them in NAND...

I tried once to refresh those patches on top of current PBL version, but 
failed due to lack of spare time. Perhaps some time I'll get back to 
that once again if nobody else does it.


More information about the e3-hacking mailing list