[cgi-wiki-dev] CGI-Wiki-Store-Kwiki

Kate L Pugh cgi-wiki-dev@earth.li
Wed, 25 Feb 2004 08:42:09 +0000

On Tue 24 Feb 2004, Justin Kao <justin+earth@dicatek.com> wrote:
> Why is it C::W::Datastore instead of C::W::Store? (Not objecting, just not
> sure what is being implied by the name change.)

(a) I think it's a better description of what it is.  A Datastore
    stores data (as opposed to say indexes).
(b) It's a non-verbable noun.  When you look at a method called ->store,
    what does that do?  Does it store something or does it return an
    object capable of storing things?

I guess we're going to need to keep the old names of
CGI::Wiki::Store::MySQL etc though, since people won't want to rewrite
all of their code, so let's stick with CGI::Wiki::Store::*

I *will* rename CGI::Wiki::Store::Database to CGI::Wiki::Store::DBI,
though, unless someone can come up with a reason why I shouldn't.