Subject: [E3-hacking] FW: Factory reset of e3 emailer

From: "SJSD ." <[email-masked]>
Date: Fri, 5 Nov 2010 17:13:08 +0000

Folks:
 
Any suggestions to reset the E3?
 
Many thanks
 
James

From: [email-masked]
To: [email-masked]
Subject: Factory reset of e3 emailer
Date: Fri, 5 Nov 2010 16:07:17 +0000

Jason:
 
I found your question on the E3 forum: http://www.mail-archive.com/[email-masked]/msg00028.html
 
I just bought three of the E3 machines  from e-bay and I'm having no joy trying to reset them back to factory state.
 
I seem to be stuck with the usernames and accounts from the previous owners.
 
Your reply would oblige.
 
Many thanks,
 
James Doherty
County Tyrone

---

From: Antony Stone <[email-masked]>
Date: Fri, 5 Nov 2010 19:48:50 +0200

> Any suggestions to reset the E3?

I have a nasty suspicion that if the machine has already been used, the 
Primary Boot Loader will have been updated to 5.1 (the machines were 
generally sold with 4.9 installed, but connecting them to a phone line 
prompts an automatic update).

See http://www.earth.li/~noodles/hardware-e3.html for the comment you don't 
want to read: "Note that only PBL 4.9 will work at present; PBL 5.1 is known 
to have made changes preventing this mode from being entered. If you allow 
your E3 to receive updates from Amstrad then it's highly likely it will be 
upgraded to PBL 5.1"

I don't know how to find out the PBL version from the machine itself (unless 
it's unused, when you can press Setup on the pull-out keyboard as described 
at http://inputplus.co.uk/ralph/emailer/e3.html - unfortunately yours is 
clearly used), except by connecting a serial cable and talking to it.

That's not hard, though - see http://inputplus.co.uk/ralph/emailer/pbl.html

Hope this helps,

Antony.

> I found your question on the E3 forum:
> http://www.mail-archive.com/[email-masked]/msg00028.html
>
> I just bought three of the E3 machines  from e-bay and I'm having no joy
> trying to reset them back to factory state.
>

-- 
If you were ploughing a field, which would you rather use - two strong oxen or 
1024 chickens?

 - Seymour Cray, pioneer of supercomputing

                                                     Please reply to the list;
                                                           please don't CC me.

---

From: Antony Stone <[email-masked]>
Date: Fri, 5 Nov 2010 20:13:34 +0200

On Friday 05 November 2010 at 18:48, Antony Stone wrote:

> I don't know how to find out the PBL version from the machine itself

See page 153 of the E3 user guide, still available for download from 
http://www.amstrad.com/support

ftp://ftp.amstrad.co.uk/e3_userguide_web_v1.zip

I notice that in reference to your original question, page 26 of that guide 
also says "If you wish to ... restore the original factory settings, contact 
Amserve Support (see page 29) who will advise you of the procedure."

I strongly suspect Amserve Support 0906 6816816 or [email-masked] will 
no longer do this, however it does at least confirm that there's a way of 
doing it from the keyboard alone.

Therefore it is possible that someone still knows the answer to your question.

Sorry I can't be of any more help.

Antony.

-- 
Normal people think "If it ain't broke, don't fix it".
Engineers think "If it ain't broke, it doesn't have enough features yet".

---

From: David Given <[email-masked]>
Date: Fri, 05 Nov 2010 17:48:25 +0000

On 05/11/10 17:13, SJSD . wrote:
[...]
> trying to reset them back to factory state.

Dredged up from the depths of the archive I find:

---snip---
The boot process goes like this:

     1. Splash screen (pretty picture of the emailer).
     2. Title screen (with 'Personal Communication Centre' across the
        middle).
     3. Main menu.

If on the transition between 1 and 2, you are pressing STOP+HANDSFREE,
the machine will reset itself back into a virgin state.
---snip---

It might work...

-- 
┌─── ｄｇ＠ｃｏｗｌａｒｋ．ｃｏｍ ───── http://www.cowlark.com ─────
│
│ life←{ ↑1 ⍵∨.^3 4=+/,¯1 0 1∘.⊖¯1 0 1∘.⌽⊂⍵ }
│ --- Conway's Game Of Life, in one line of APL

---

From: "SJSD ." <[email-masked]>
Date: Fri, 5 Nov 2010 22:23:28 +0000

Folks:
 
I think I've cracked it - basically by guessing which buttons they were likely to use for reset - I knew the two required for E2 reset so I thought that three wouldn't be beyond them for the E3.
 
1. Remove power cord from E3
2. Hold down: DELETE, STOP and HANDSFREE together
3. Keep holding all three and insert power cord
4. Keep holding all three - E3 boots as normal but after about 15/20 seconds displays message "Initialising system" (I can't remember the exact wording)
5. Keep holding until you have your final screen which prompts you to register as a new user (you may let go now)
6. Old address book entries and other previously stored information is gone. 
7. Have a cup of tea.
 
Best regards
 
James

From: [email-masked]
To: [email-masked]
Subject: FW: Factory reset of e3 emailer
Date: Fri, 5 Nov 2010 17:13:08 +0000

Folks:

Many thanks
 
James

Jason:

 
 
Your reply would oblige.
 
Many thanks,
 
James Doherty
County Tyrone