Subject: [E3-hacking] Linux 2.6 & USB _almost_ works

From: Mark Underwood <[email-masked]>
Date: Fri, 17 Feb 2006 22:39:36 +0000 (GMT)

I have been hacking around with the 2.6.15 kernel and now have got the USB host to successfully
register. It detects a USB device that I plug into it, but then fails to get the interrupt (the
kernel prints out a time out error message). Looking at the proc enteries from the 2.4 kernel
(from the website) the interrupt number is the same so I guess that there is some init code
missing. Please could someone boot their E3, plug & unplug a USB device and do 'cat
/proc/interrupts' and confirm that the usb-ohci interrupt has seen some interrupts. 
 
Many thanks, 
 
Mark

___________________________________________________________ 
Yahoo! Messenger - NEW crystal clear PC to PC calling worldwide with voicemail http://uk.messenger.yahoo.com

---

From: Jonathan McDowell <[email-masked]>
Date: Sat, 18 Feb 2006 09:59:38 +0000

On Fri, Feb 17, 2006 at 10:39:36PM +0000, Mark Underwood wrote:
> I have been hacking around with the 2.6.15 kernel and now have got the
> USB host to successfully register. It detects a USB device that I plug
> into it, but then fails to get the interrupt (the kernel prints out a
> time out error message). Looking at the proc enteries from the 2.4
> kernel (from the website) the interrupt number is the same so I guess
> that there is some init code missing. Please could someone boot their
> E3, plug & unplug a USB device and do 'cat /proc/interrupts' and
> confirm that the usb-ohci interrupt has seen some interrupts. 

# cat /proc/interrupts 
 14:          0   OMAP1510 GPIO IRQ demux
 25:          0   console/lcddma
 30:   47416923   timer
 31:          0   console/lcd
 38:         47   usb-ohci                                                      
 46:       2820   serial
 57:          0   omap-rtc
 58:          0   omap-rtc alarm
Err:          0

That's just from inserting a USB device - my E3 is far away from where I
am at present so I can't try disconnecting it too.

J.

-- 
                     Is it real, or is it Mimozine?
[ Black Cat Networks ] [ 0845 PAYG dialup ] [ ADSL from £20+VAT/month ]
                [ http://www.blackcatnetworks.co.uk/ ]

---

From: Don Alexander <[email-masked]>
Date: Sun, 19 Feb 2006 07:53:50 +0000

> /proc/interrupts' and confirm that the usb-ohci interrupt has seen some interrupts. 

This is fantastic news Mark, and well done guys to getting as far as you
have so soon. Is there any hope of the modified code being uploaded this
weekend still? I would love to get my hands on it and start hacking away
at a level I can understand :) To my mind the most useful part will be
getting the networking stack fully functional to be able to mount NFS
shares and try out different combinations of programs code and drivers.
Really fantastic progress guys. Let hope it is just the tip of the
iceberg as it were :)

Cheers,

Don.

---

From: "Adam Spence" <[email-masked]>
Date: Sun, 19 Feb 2006 08:22:21 -0000

Hey Mark,

It's a small world isn't it! So, what have you actually got the E3 to do
yet?

Adam 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Mark Underwood
Sent: 17 February 2006 22:40
To: [email-masked]
Subject: [E3-hacking] Linux 2.6 & USB _almost_ works

I have been hacking around with the 2.6.15 kernel and now have got the USB
host to successfully register. It detects a USB device that I plug into it,
but then fails to get the interrupt (the kernel prints out a time out error
message). Looking at the proc enteries from the 2.4 kernel (from the
website) the interrupt number is the same so I guess that there is some init
code missing. Please could someone boot their E3, plug & unplug a USB device
and do 'cat /proc/interrupts' and confirm that the usb-ohci interrupt has
seen some interrupts. 
 
Many thanks, 
 
Mark

___________________________________________________________
Yahoo! Messenger - NEW crystal clear PC to PC calling worldwide with
voicemail http://uk.messenger.yahoo.com

_______________________________________________
e3-hacking mailing list
[email-masked]
http://www.earth.li/cgi-bin/mailman/listinfo/e3-hacking

---

From: Mark Underwood <[email-masked]>
Date: Sun, 19 Feb 2006 18:35:56 +0000 (GMT)

> Really fantastic progress guys. Let hope it is just the tip of the

Hi Don,

Hopefully it will be uploaded by the end of today. I have created a v1 release which has got a
kernel that boots and working USB, although not NFS mounts as the shell is somewhat broken :-(.
The next step for me is to get the LCD up and running and then sound (I would like my E3 to play
my MP3's while I work on it :-). After that I guess I will either try to fix the shell problem or
try to build microwindows/nano-X.

Mark

		
___________________________________________________________ 
To help you stay safe and secure online, we've developed the all new Yahoo! Security Centre. http://uk.security.yahoo.com

---

From: Mark Underwood <[email-masked]>
Date: Sun, 19 Feb 2006 18:41:39 +0000 (GMT)

> It's a small world isn't it! So, what have you actually got the E3 to do

Hi Adam,

Good to hear from you. Have you got an E3?

I have got a (slightly broken) shell and working USB so you can work on a driver, put it onto the
USB stick, mount the USB stick, and insmod it (thus saving you the 3 1/2 minute wait when uplading
the kernel + u-boot + rootfs). You should also be able to compile simple programs for the E3 and
run them, but with any sound or display your a bit limited, but I'm working on that ;-).

Mark

---

From: Mark Underwood <[email-masked]>
Date: Mon, 20 Feb 2006 19:32:47 +0000 (GMT)

> run them, but with any sound or display your a bit limited, but I'm working on that ;-).

Just to let you know Jonathan has kindly hosted my release which is available from:

http://the.earth.li/pub/e3/
ftp://the.earth.li/pub/e3/

Have fun!

Mark

		
___________________________________________________________ 
Yahoo! Photos – NEW, now offering a quality print service from just 8p a photo http://uk.photos.yahoo.com

---

From: "J. Snell" <[email-masked]>
Date: Mon, 20 Feb 2006 21:06:26 +0000

Excellent! I can confirm that it works a treat for me. Thanks for the
hard work Mark.
Now to go compile a driver for my USB ethernet adapter. :-)

---

From: "Adam Spence" <[email-masked]>
Date: Tue, 21 Feb 2006 07:24:07 -0000

Not as yet... I'm sneakly sat here watching how the development goes ;)

I'm playing around with a PC104 board at the mo with an Xscale 255 processor
on it. It runs linux very well but I've got a long way to go :(

Adam 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Mark Underwood
Sent: 19 February 2006 18:42
To: [email-masked]; Discussion of the Amstrad E3 emailer
hardware/software
Subject: RE: [E3-hacking] Linux 2.6 & USB _almost_ works

--- Adam Spence <[email-masked]> wrote:

> Hey Mark,
> 
> It's a small world isn't it! So, what have you actually got the E3 to 
> do yet?
> 
> Adam

Hi Adam,

I have got a (slightly broken) shell and working USB so you can work on a
driver, put it onto the USB stick, mount the USB stick, and insmod it (thus
saving you the 3 1/2 minute wait when uplading the kernel + u-boot +
rootfs). You should also be able to compile simple programs for the E3 and
run them, but with any sound or display your a bit limited, but I'm working
on that ;-).

Mark

> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Mark Underwood
> kernel (from the
> website) the interrupt number is the same so I guess that there is 
> some init code missing. Please could someone boot their E3, plug & 
> unplug a USB device and do 'cat /proc/interrupts' and confirm that the 
> usb-ohci interrupt has seen some interrupts.
>  
> Many thanks,
>  
> Mark
> 
> 
> 	
> 	
> 		

___________________________________________________________
To help you stay safe and secure online, we've developed the all new Yahoo!
Security Centre. http://uk.security.yahoo.com