Subject: [E3-hacking] Newbie help please .......

From: "Andy Brown" <[email-masked]>
Date: Fri, 8 Feb 2013 20:10:56 -0000

Hi,

Looking for some help with an Amstrad E3 I was given recently.

I'm a computer technician, but have very little experience with Linux based
systems ( all our systems at work are Windows).

I was looking for a small screen to fit in the  Comanche helicopter cockpit
simulator I'm building. All it has to do is display some web pages and
change them based on about 8 different key presses.

I have set up a machine with Ubuntu on it and it is talking to the E3. I
followed the instructions here http://wiki.earth.li/E3_Getting_Started and
everything went fine until the last "bootm" command.

It did give a lot of info about the image but didn't end with a shell
prompt. Instead I get a message:

" kernel panic - not syncing: VFS: unable to mount root FS on unknown
block(1,0)"

I do get the "penguin" and a load of text on the E3 screen before the error,
so I rekon I'm not far away.

I've also tried the system from 2.6.16 here http://the.earth.li/pub/e3/ with
exactly the same results.

Can somebody advise what I'm doing wrong please ?

Many thanks in advance,

Andy

---

From: David Given <[email-masked]>
Date: Fri, 08 Feb 2013 21:11:59 +0000

On 08/02/13 20:10, Andy Brown wrote:
[...]
> “ kernel panic – not syncing: VFS: unable to mount root FS on unknown
> block(1,0)”
>
> I do get the “penguin” and a load of text on the E3 screen before the
> error, so I rekon I’m not far away.

Yup, that means the Linux kernel is running; it just can't find the root
filesystem. This does mean it's almost working.

I'd hazard a guess that it means it's failed to correctly upload the
initrd image --- it's large and the serial link isn't very reliable.
Does pbltool say anything interesting during the upload process?

You could also try copying the ramdisk image (uncompressed) onto a USB
key and changing the root= parameter to root=/dev/sda or root=/dev/sda1.

I've always had luck using the E3_release_v2 system at
http://the.earth.li/pub/e3 --- this has the advantage that it will also
reflash the device for you, so it'll boot automatically into Linux and
you don't need to use the serial link each time. (Instructions inside
the package.)

-- 
┌─── ｄｇ＠ｃｏｗｌａｒｋ．ｃｏｍ ───── http://www.cowlark.com ─────
│ "Of course, on a sufficiently small planet, 40 km/hr is, in fact,
│ sufficient to punt the elastic spherical cow into low orbit." ---
│ Brooks Moses on r.a.sf.c

---

From: "Andy Brown" <[email-masked]>
Date: Fri, 8 Feb 2013 23:15:13 -0000

Hi David,

Thanks for the reply. I tried the E3-release-V2 using the USB port and it worked! Now have an E3 booting Linux.

Many thanks,

Andy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of David Given
Sent: 08 February 2013 21:12
To: [email-masked]
Subject: Re: [E3-hacking] Newbie help please .......

> error, so I rekon I’m not far away.

Yup, that means the Linux kernel is running; it just can't find the root filesystem. This does mean it's almost working.

I'd hazard a guess that it means it's failed to correctly upload the initrd image --- it's large and the serial link isn't very reliable.
Does pbltool say anything interesting during the upload process?

You could also try copying the ramdisk image (uncompressed) onto a USB key and changing the root= parameter to root=/dev/sda or root=/dev/sda1.

I've always had luck using the E3_release_v2 system at
http://the.earth.li/pub/e3 --- this has the advantage that it will also reflash the device for you, so it'll boot automatically into Linux and you don't need to use the serial link each time. (Instructions inside the package.)

--
┌─── ｄｇ＠ｃｏｗｌａｒｋ．ｃｏｍ ───── http://www.cowlark.com ───── │ "Of course, on a sufficiently small planet, 40 km/hr is, in fact, │ sufficient to punt the elastic spherical cow into low orbit." --- │ Brooks Moses on r.a.sf.c

---

From: Aaro Koskinen <[email-masked]>
Date: Sat, 9 Feb 2013 01:01:14 +0200

> Does pbltool say anything interesting during the upload process?

Also try checking for "Unpacking initramfs..." console message. If
it reports "junk in compressed archive", it may scrap the whole
image. Another possible reason for this is that the size reported to
the kernel (by the bootloader) does not match the actual image size.

A.

---

From: Edward Robbins <[email-masked]>
Date: Sat, 9 Feb 2013 02:12:22 +0000

> you don't need to use the serial link each time. (Instructions inside

Unless you get bad blocks where the kernel should be located... I still
haven't found a way around that one... so I have to boot over serial every
single time! :( (I think I need a newer uboot? Or maybe to just locate the
kernel somewhere else on the flash...)

---

From: Edward Robbins <[email-masked]>
Date: Tue, 12 Feb 2013 09:37:10 +0000

> you don't need to use the serial link each time. (Instructions inside

Unless you get bad blocks where the kernel should be located... I
still haven't found a way around that one... so I have to boot over
serial every single time! :( (I think I need a newer uboot? Or maybe
to just locate the kernel somewhere else on the flash...)

---

From: en4rab <[email-masked]>
Date: Wed, 13 Feb 2013 02:27:26 -0800 (PST)

Hello,  I realise that this might be a little pointless. I have just spent 2 hours fixing the fault with my E3 and I thought it might be of interest to one or tow people.
I dragged my emailer out of the box of stuff a few days ago as the constant stream of cold calls about PPI were really beginning to annoy me.
There had been an article on http://www.theregister.co.uk/2013/02/08/bt6500/ about BT selling a phone that will check the caller id and go straight to answerphone if its international or withheld and in the comment someone suggested robodialer could be fooled into thinking a number was out of service if you played the no circuit SIT tones (the dee doo daah you hear before the voice telling you the number you have dialed is incorrect)

This all got me thinking could you build such a setup with a usb modem and a raspberry pi, turns out someone already did:
http://jcblock.sourceforge.net/

Which obviously then lead to the thought perhaps i could finally do something with my E3 (although i can barely manage "hello world"), after alot of frustration and with alot of thanks due to Janusz Krzysztofik both for keeping support in the kernel and his posts on setting it up I finally managed to get openembedded to build a minimal image, I rashly configured it to build a 2.6.39.4 kernel and angstrom 2010 distro, since i had no idea what i was doing i thought it would probably be broken in the 3.x versions, im guessing though that was stupid thinking on my part.

I did encounter problems installing this on my phone though, i couldnt get pbltool to talk to the phone at all, yet i was able to see kernel boot messages fine, I eventually got round this by using the uboot shell and Tera Term (but any terminal client that supports kermit transfers should work) which seemed to work ok over serial, a few hung sends but got there eventually, as my e3 was already flashed with the v2release the commands for this are:
loadb 0x11d00000             {then send uImage by kermit}
loadb 0x11800000             {then send install-initrd.ext2.gz by kermit}
setenv bootargs mem=32M console=tty0 console=ttyS0,115200n8 root=/dev/ram0 initrd=0x11800000,8M
bootm 11d00000

at this point I was pretty happy, apart from id left out the driver of my usb ethernet adapter, I was just about to install a rebuilt kernel with the driver included when serial comms and usb both died, the phone would still boot but i couldnt do anything with it.
I know i should take this as a sign to throw it out but its personal now so I took the E3 apart and took a multimeter to it :)
When I checked it I was only getting about 2.1v across the power pins of the USB port and the serial port shares this 5v rail, which is why both usb and serial died.
I couldnt find a 5v regulator but alot more poking led me to the 8 pin chip U17 next to the blue 2 pin socket, which is a DC/DC converter controller chip from ST:
http://www.st.com/internet/com/TECHNICAL_RESOURCES/TECHNICAL_LITERATURE/DATASHEET/CD00001232.pdf
Page 11 of that datasheet is pretty much the schematic for the 5v power on the E3 as far as i can tell, some more poking and it turns out the current shunt resistor  was open circuit, i think its marked as R223 you can find it between the ST chip and te 3 electrolytic caps just to the side of the crystal.
If you were to look at noodles picture here http://www.earth.li/~noodles/images/e3-logic.jpg and imagine a line fron the bottom left of the blue 2 pin socket to the middle of the crystal just below it the black and silver chip (marked 3R3) the line goes over is the one at fault.
Unless i have totally stuffed up the markings it should be a 3.3ohm resistor I havent got a suitable replacement to hand so at the the moment the board is on my desk with a 100 ohm throughole resistor bodged across the dead one, but that was good enough to confirm im now seeing 5.1V on the usb socket and serial comms is working again.
Switch mode psu's are a mystery to me so im guessing you should probably get a 3.3ohm resistor if you encounter this problem rather than bodging it like i did.

I hope this is of use to someone :)
Robin Bradshaw