Subject: [E3-hacking] E3 u-boot & Linux

From: Mark Underwood <[email-masked]>
Date: Mon, 6 Feb 2006 22:53:54 +0000 (GMT)

I have managed to not only get u-boot running (now with u-boot setting up the UART baud rate) but
have also managed to get a 2.6.15 kernel with omap patchs to boot :-). I'm still having a problem
getting the startup scripts to give me a login, but once I've fixed that problem I will make my
modifications to u-boot and the kernel available (need to find somewhere to put them first) and
then start working on getting USB up and running (the probe of the OHCI is failing for some
reason).

Mark

___________________________________________________________ 
To help you stay safe and secure online, we've developed the all new Yahoo! Security Centre. http://uk.security.yahoo.com

---

From: Jonathan McDowell <[email-masked]>
Date: Wed, 15 Feb 2006 13:33:41 +0000

On Mon, Feb 06, 2006 at 10:53:54PM +0000, Mark Underwood wrote:
> I have managed to not only get u-boot running (now with u-boot setting
> up the UART baud rate) but have also managed to get a 2.6.15 kernel
> with omap patchs to boot :-). I'm still having a problem getting the
> startup scripts to give me a login, but once I've fixed that problem I
> will make my modifications to u-boot and the kernel available (need to
> find somewhere to put them first) and then start working on getting
> USB up and running (the probe of the OHCI is failing for some reason).

Oh wow, that's fantastic news. Do you have access to the flash device
ok? That would allow the use of JFFS2 which suddenly makes the whole
thing a lot more useful for hacking about on.

Access to the modifications would be nice, even if they don't fully
work. If you have nowhere to put them then I'm happy to host them on my
site for you.

J.

-- 
Suburbia: where they tear out the trees & then name streets after them.

---

From: Mark Underwood <[email-masked]>
Date: Wed, 15 Feb 2006 21:24:45 +0000 (GMT)

> thing a lot more useful for hacking about on.

No JFFS yet but that shouldn't be too hard, I haven't tried it yet. With my modified pbltool with
scripting support I can upload all I need in about 3 1/2 min.

> work. If you have nowhere to put them then I'm happy to host them on my

That would be great. I am happy with my modifications to u-boot and pbltool but both need a bit of
a clean up. I could create a patch for u-boot and the kernel.
For pbltool I would prefer to just send you the source file as my modifcations have been
extensive.
Also I could put my buildroot & busybox configs on there so everyone can build their own rootfs,
but I will also make all my images available.

All this probably will not happen till the weekend as I want a little longer working on the USB
host.

B.T.W I now have a (slightly broken) shell.

Mark

> _______________________________________________
> e3-hacking mailing list
> [email-masked]
> http://www.earth.li/cgi-bin/mailman/listinfo/e3-hacking
>

---

From: Jonathan McDowell <[email-masked]>
Date: Wed, 22 Feb 2006 17:22:53 +0000

> USB up and running (the probe of the OHCI is failing for some reason).

This rocks, btw. Works fine on my E3 and I've been fiddling with the
kernel a little.

I registered the MACH_AMS_DELTA type a while back with the ARM guys, so
have added this to your patch and started trying to get some support for
the flash devices in; I've got the NOR being detected, but it's non CFI
compatible so I can't actually get mtd to talk to it.

I'd really like to get the NAND up and running; I think it's hanging off
what Amstrad call latch2? 0xEC000000?

Anyway, my minor patch to use the proper Delta machine type is at:

http://the.earth.li/pub/e3/delta-20060222.diff

You'll need to patch u-boot to use a machine type of 862 as well
obvious, otherwise the kernel won't boot.

J.

-- 
Black Cat Networks Ltd. Support.
101 things you can't have too much of : 24 - Taglines.
Email: [email-masked]
Web:   http://www.blackcatnetworks.co.uk/support/

---

From: Mark Underwood <[email-masked]>
Date: Wed, 22 Feb 2006 19:21:35 +0000 (GMT)

> obvious, otherwise the kernel won't boot.

That's great. Once I get the LCD up and running (almost there I think (famous last words ;-)) I'll
merge my changes with yours and create another diff.

Martin is trying to track down the shell problem and has found that if you configure busybox to
statically link it works.

Mark

---

From: Jonathan McDowell <[email-masked]>
Date: Wed, 22 Feb 2006 19:24:43 +0000

On Wed, Feb 22, 2006 at 07:21:35PM +0000, Mark Underwood wrote:
> That's great. Once I get the LCD up and running (almost there I think
> (famous last words ;-)) I'll merge my changes with yours and create
> another diff.

Cool. Mine's against the one you distributed obviously. I've started
trying to teach the omap-keypad driver about the E3's keypad layout, so
if you get LCD working then that give us local console. \o/

> Martin is trying to track down the shell problem and has found that if
> you configure busybox to statically link it works.

I've worked on OpenEmbedded in the past; it should be easy to get it
generating full images, but I'd like to get flash going before that
ideally. I might take a look at a basic E3 target to help people get up
and running if I find time though.

J.

-- 
    I've got a trigger inside.      |       Black Cat Networks Ltd
                                    | http://www.blackcatnetworks.co.uk/
                                    |  UK Web, domain and email hosting

---

From: "Luke Schneider" <[email-masked]>
Date: Wed, 22 Feb 2006 20:53:18 -0000

Just a question.. probably stupid... but while you're doing all this does it 
still work as a phone?

-- BinoX