Subject: RE: [E3-hacking] Another hello

From: Cliff Lawson <[email-masked]>
Date: Thu, 19 Jan 2006 16:49:23 -0000

I'd have thought the protection was vital. It's not so much whether the PC
can detect the "weedy" 0V..5V swing coming out of an E2/E3 but whether the
UART input buffers on the OMAP/Sharp can stand getting -12V shoved up them
coming from the PC (I'm assuming that PCs still transmits true RS232 even if
they're a bit more lenient about what they can detect?)

(Or maybe my h/w designing colleague did splash for sufficient inbound
protection on the board - I can't remember off hand)

Cliff

> -----Original Message-----
> From: Ian Stirling [mailto:[email-masked]]
> Sent: 19 January 2006 16:44
> To: Discussion of the Amstrad E3 emailer hardware/software
> Subject: Re: [E3-hacking] Another hello
> 
> Back in the dim and distant past, this may have been true.
> However, with the growth of low-power devices on the 232 bus, 
> more and 
> more stuff has quietly lowered the level at which 0 becomes 1 
> from 7(?) 
> of the MC1488/1489, down to 5V, or even lower.
> 5V signalling will work just fine with many of todays PCs, 
> even 3.3V on 
> quite a lot of them.

This e-mail and any attachments are confidential and intended exclusively for the addressee. If you are not the intended recipient please delete it from your system and notify the sender immediately. This message is attributed to the sender and may not necessarily reflect the views of Amstrad Plc or its subsidiaries.

For further information on Amstrad Plc please visit our website: www.amstrad.com

Amstrad Plc.
Brentwood House
169 Kings Road
Brentwood
Essex CM14 4EF
Registered in England : No. 955321

---

From: Ian Stirling <[email-masked]>
Date: Thu, 19 Jan 2006 17:03:10 +0000

> protection on the board - I can't remember off hand)
Sorry - I was just addressing the fact that it might work.
It's a very bad idea - as you say, 20ma is not a nice current to shove 
into a nominally 5V port.

But, along with the trend to lower threshold voltages, has come more and 
more things with rather weedy outputs, rather than 'proper' 12V/20ma.
And many 'TTL' level ports won't immediately, or even soon die from a 
12V signal limited to 20mA.
A simple resistor will limit the current, and would be good enough for 
some prototyping, but be a bad idea for a number of reasons in production.

---

From: [email-masked]
Date: Thu, 19 Jan 2006 17:44:18 +0000

Hi Chaps,

Hi Chaps,

Just had a quick look in my trusty copy of "The Art of Electronics" by Horowitz and Hill. It has an excellent section on serial stuff.

An RS232 driver should drive out at least +/-5v. It can drive up to +/-15V. A receiver must be able to detect +/-3v or greater. Anything less than this is not defined by the spec and what an individual receiver will do can, and will vary.

On the well known MAX323 anything less than 0.8V, or more than 2.4V will have guaranteed results. Anything between this might do what you expect, or it might not. Other parts will of course differ... On the transmit side, it will typically put out +/-8v but only +/-5v is guaranteed. Other parts will of course vary...

I've got an old E2 on my desk at work I'm stealing bits off for work projects. At a VERY QUICK look I think the rx pin is connected to the rest of the circuitry via a small resistor. I think it’s a 100 Ohm one but the text is darn small and hard to read... The signal then disappears into a via. 

On the E3 (home hacking) I'm scared to shove more than 3.3V in as I believe the OMAP is a 3.3V part on a 0.18ish micron process. I suspect it would die if connected directly to an RS232 level signal if there isn't some protection.  

Anyone looked properly at the input circuit on the E3?

It would be nice to get a good interface circuit for on the web, constructed out of easy to get bits (e.g. maplins). If the logic level signals were interfaced to the line driver via an XOR gate it would be easy to have a jumper to invert the polarity to support the E2 and E3 on the same board. Anyone done anything like that or is that my project for the weekend? :-)

                Andy M

[email-masked] wrote:
> I'd have thought the protection was vital. It's not so much whether the =
> PC
> can detect the "weedy" 0V..5V swing coming out of an E2/E3 but whether =
> the
> UART input buffers on the OMAP/Sharp can stand getting -12V shoved up =
> them
> coming from the PC (I'm assuming that PCs still transmits true RS232 =
> even if
> This e-mail and any attachments are confidential and intended =
> exclusively for the addressee. If you are not the intended recipient =
> please delete it from your system and notify the sender immediately. =
> This message is attributed to the sender and may not necessarily reflect =
> the views of Amstrad Plc or its subsidiaries.
> 
> For further information on Amstrad Plc please visit our website: =
> www.amstrad.com
> 
> Amstrad Plc.
> Brentwood House
> 169 Kings Road
> Brentwood
> Essex CM14 4EF
> _______________________________________________
> e3-hacking mailing list
> [email-masked]
> http://www.earth.li/cgi-bin/mailman/listinfo/e3-hacking
>