Subject: [E3-hacking] Anyone know the Pinout of the Amstrad E3 Videophone Mailboard

From: Nick Griffin <[email-masked]>
Date: Mon, 19 Aug 2019 15:26:43 +0000

Hi Long time no speak… 😊 Anyone know the pinout ,I want to connect it to a PS/2 connector, The PS/2 connector has 6 pins when the Mailboard has 4 pins…?

Anyone..?

Spanner..

http://amstrad-e3-hacking.freeforums.net

---

From: David Given <[email-masked]>
Date: Mon, 19 Aug 2019 17:37:42 +0200

Huh, it is actually PS/2. I didn't know that.

https://github.com/octronic-uk/amstrad-mailboard

On Mon, 19 Aug 2019 at 17:26, Nick Griffin <[email-masked]> wrote:

> Hi Long time no speak… 😊 Anyone know the pinout ,I want to connect it to
> a PS/2 connector, The PS/2 connector has 6 pins when the Mailboard has 4
> pins…?
>
> Anyone..?
>
> Spanner..
>
> _______________________________________________
> e3-hacking mailing list
> [email-masked]
> https://www.earth.li/mailman/listinfo/e3-hacking
>

-- 
┌─── http://www.cowlark.com ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

---

From: Nick Griffin <[email-masked]>
Date: Mon, 19 Aug 2019 17:10:11 +0000

Had a idea, couldn’t you use a arduino nano to made a converter for it so it works like a PC keyboard and put the key codes or its key map on the arduino nano so when you press “P” on the Mailboard “P” is on the screen…is pressed and so on .?
https://www.engineersgarage.com/embedded/arduino/how-to-interface-ps2-keyboard-arduino

From: David Given<mailto:[email-masked]>
Sent: ‎Monday‎, ‎19‎ ‎August‎ ‎2019 ‎16‎:‎38
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

https://github.com/octronic-uk/amstrad-mailboard<https://eur02.safelinks.protection.outlook.com/?url=https://github.com/octronic-uk/amstrad-mailboard&data=02%7c01%7c%7c3a6b4347218b44fff44d08d724bb3c08%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c637018258900234074&sdata=r69tEu6I93s10rc%2BMp/mAg8OIYqpPdrVhhYJSkxVew8%3D&reserved=0>

On Mon, 19 Aug 2019 at 17:26, Nick Griffin <[email-masked]<mailto:[email-masked]>> wrote:
Hi Long time no speak… 😊 Anyone know the pinout ,I want to connect it to a PS/2 connector, The PS/2 connector has 6 pins when the Mailboard has 4 pins…?

Anyone..?

Spanner..

http://amstrad-e3-hacking.freeforums.net<https://eur02.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net&data=02%7c01%7c%7c3a6b4347218b44fff44d08d724bb3c08%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c637018258900244079&sdata=Jn9wGNPTJ2DqvJZ6jNuzx7uyk/Vmw2onNg0H1uZJi%2B4%3D&reserved=0>

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://eur02.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c3a6b4347218b44fff44d08d724bb3c08%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c637018258900254085&sdata=DMVW5aml%2BcSqenYeUAHBcavbzjndCpOEsoCySBid8ag%3D&reserved=0>

--
┌─── http://www.cowlark.com<https://eur02.safelinks.protection.outlook.com/?url=http://www.cowlark.com&data=02%7c01%7c%7c3a6b4347218b44fff44d08d724bb3c08%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c637018258900264102&sdata=Eh4C4SNVP/YAhgyjASSOQ%2BcMb41XFdkkmI64ReWPXSw%3D&reserved=0> ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

---

From: Nick Griffin <[email-masked]>
Date: Wed, 21 Aug 2019 18:39:56 +0000

Just connected the Mailboard to a PS/2 adapter and its works on Windows but the keys are wrong so how would I go about changing each key to the right one..?

Anyone know..?

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Monday‎, ‎19‎ ‎August‎ ‎2019 ‎18‎:‎10
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Had a idea, couldn’t you use a arduino nano to made a converter for it so it works like a PC keyboard and put the key codes or its key map on the arduino nano so when you press “P” on the Mailboard “P” is on the screen…is pressed and so on .?
https://www.engineersgarage.com/embedded/arduino/how-to-interface-ps2-keyboard-arduino<https://eur03.safelinks.protection.outlook.com/?url=https://www.engineersgarage.com/embedded/arduino/how-to-interface-ps2-keyboard-arduino&data=02%7c01%7c%7c05ca9946ee8a4915196d08d724c825b2%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c637018314348199389&sdata=Q0srCSSE9LrjtoRkykQugnm5Ux0a29o3EXQXZ5RXqfA%3D&reserved=0>

https://github.com/octronic-uk/amstrad-mailboard<https://eur03.safelinks.protection.outlook.com/?url=https://github.com/octronic-uk/amstrad-mailboard&data=02%7c01%7c%7c05ca9946ee8a4915196d08d724c825b2%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c637018314348209394&sdata=a6MtPv4TEx7NoHvjdYdu1IvKpf3ahvNUsUFrm0XVTTU%3D&reserved=0>

Anyone..?

Spanner..

http://amstrad-e3-hacking.freeforums.net<https://eur03.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net&data=02%7c01%7c%7c05ca9946ee8a4915196d08d724c825b2%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c637018314348219399&sdata=7lLJT7SzupYaRfemjhqFfkTris%2B2ZHDcRk6AquQUaSw%3D&reserved=0>

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://eur03.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c05ca9946ee8a4915196d08d724c825b2%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c637018314348229410&sdata=vC95j%2BzutNC3zFr2McWR8/CYxqk2Ee6ZUo1a%2BOkXuw8%3D&reserved=0>

--
┌─── http://www.cowlark.com<https://eur03.safelinks.protection.outlook.com/?url=http://www.cowlark.com&data=02%7c01%7c%7c05ca9946ee8a4915196d08d724c825b2%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c637018314348239415&sdata=7W1mLY5iIb%2BAwiOU9LG3s1LVGC/G0yOJhcIPYVXRkrA%3D&reserved=0> ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

---

From: Antony Stone <[email-masked]>
Date: Wed, 21 Aug 2019 20:55:48 +0200

On Wednesday 21 August 2019 at 20:39:56, Nick Griffin wrote:

> Just connected the Mailboard to a PS/2 adapter and its works on Windows but
> the keys are wrong so how would I go about changing each key to the right
> one..?

https://www.makeuseof.com/tag/create-custom-keyboard-layout-windows/ looks 
helpful to me.

Antony.

-- 
I lay awake all night wondering where the sun went, and then it dawned on me.

                                                   Please reply to the list;
                                                         please *don't* CC me.

---

From: Nick Griffin <[email-masked]>
Date: Wed, 21 Aug 2019 19:45:49 +0000

I plugged it into my PC just to see if it works ,I need it to work on Andriod, is there a way of mapping the keys on that, its Android 4.4.4…?

Spanner..

From: Antony Stone<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎21‎ ‎August‎ ‎2019 ‎20‎:‎15
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

> the keys are wrong so how would I go about changing each key to the right

https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.makeuseof.com%2Ftag%2Fcreate-custom-keyboard-layout-windows%2F&amp;data=02%7C01%7C%7Cc3b3bccf939048af03f008d7266be258%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637020117130312902&amp;sdata=su0ITBGFu5lR6wYKejkaHXTeu%2FMw%2F9h6cCq9N146vuA%3D&amp;reserved=0 looks
helpful to me.

Antony.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7Cc3b3bccf939048af03f008d7266be258%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637020117130312902&amp;sdata=ufw6u6dsdl8SBLj4JE6zsFB4pb6GsjQt25wdS2IKjL8%3D&amp;reserved=0

---

From: Ralph Corderoy <[email-masked]>
Date: Thu, 22 Aug 2019 10:58:01 +0100

Hi Nick,

> I plugged it into my PC just to see if it works ,I need it to work on
> Andriod, is there a way of mapping the keys on that, its Android
> 4.4.4…?

That's more of an Android question, you may be better off asking
somewhere else.  Google suggests things like
https://pyra-handheld.com/boards/threads/tutorial-how-to-remap-android-hardware-keys.69593/
so it looks possible.

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Fri, 23 Aug 2019 12:37:24 +0000

Its funny realy Android is Linux and the E3 run on Linux… 😊

I am using a app called Keyboard/Button Mapper its on Google Play got it from XDA,It works but the keys don’t work properly in games or Emulators so just looked it up and I need to make a .kl Keyboard layout file for it so it knows where the keys are.
Anyone made a keyboard layout file, it works the same way in Linux, Android uses the same layout files..? this is the app… https://play.google.com/store/apps/details?id=io.github.sds100.keymapper&rdid=io.github.sds100.keymapper

Ok just relised you answered this question already.. 😊

The Mailboard a good little keyboard for Android… 😊 If I manage to make a key file for it and it works I shear it here if anyone wants to use there's with Android.

Spanner..

From: Ralph Corderoy<mailto:[email-masked]>
Sent: ‎Thursday‎, ‎22‎ ‎August‎ ‎2019 ‎11‎:‎17
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Hi Nick,

That's more of an Android question, you may be better off asking
somewhere else.  Google suggests things like
https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fpyra-handheld.com%2Fboards%2Fthreads%2Ftutorial-how-to-remap-android-hardware-keys.69593%2F&amp;data=02%7C01%7C%7C5fb615a9f08b4ef2c9b808d726e9fb70%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637020658691998236&amp;sdata=cM3isLd%2FMsP760WSWNHJdCfBwZ4ehsZinGlbTykWzv4%3D&amp;reserved=0
so it looks possible.

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C5fb615a9f08b4ef2c9b808d726e9fb70%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637020658691998236&amp;sdata=DeQUPtCr3t9r4Q%2FahyzjuK804g8giyXkmFa9%2FH4iqQk%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Fri, 23 Aug 2019 12:57:17 +0000

All you need is a PS/2 Adapter and plug the 4 wires from the Mailboard into it and it works fine just needs mapping.

Posted about it here…  http://amstrad-e3-hacking.freeforums.net/thread/36/using-amstrad-mailboard-keyboard-android<https://eur04.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net/thread/36/using-amstrad-mailboard-keyboard-android&data=02%7c01%7c%7cd9bb2a0eed0543f0e83508d727c944dc%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c637021617699834319&sdata=p8euCRZxGf9%2BfHexInbRMYlLnQUmirGXznE0FMR7/mA%3D&reserved=0>

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Friday‎, ‎23‎ ‎August‎ ‎2019 ‎13‎:‎37
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

I am using a app called Keyboard/Button Mapper its on Google Play got it from XDA,It works but the keys don’t work properly in games or Emulators so just looked it up and I need to make a .kl Keyboard layout file for it so it knows where the keys are.
Anyone made a keyboard layout file, it works the same way in Linux, Android uses the same layout files..? this is the app… https://play.google.com/store/apps/details?id=io.github.sds100.keymapper&rdid=io.github.sds100.keymapper<https://nam03.safelinks.protection.outlook.com/?url=https://play.google.com/store/apps/details?id%3Dio.github.sds100.keymapper%26rdid%3Dio.github.sds100.keymapper&data=02%7c01%7c%7c296534ae3ba340eeec5708d727c6b23e%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c637021606666904248&sdata=WJHkHn8P8ykeDjA7dC92BJeC%2BaODrTgQZYfTyUwJyi8%3D&reserved=0>

Spanner..

Hi Nick,

--
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Sun, 29 Sep 2019 18:33:20 +0000

I noticed on the Amstrad E3 Video Phone that the Services on the home screen change with every update of the Main Software so V1 is different to V2 and so on so if you were look for a version you could spot it easterly by the service on the home screen. I own a V2,V4 and V5. I am trying to get photos of the E3 home screen of each Main Software version so V1,V2,V3,V4 and V5, I have V2,V4,V5, need V1 and V3 anyone can help...?

Probably will be hard it get a V1 photo of the E3 Home Screen..

http://amstrad-e3-hacking.freeforums.net/thread/38/amstrad-video-phone-main-software

Nick

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Friday‎, ‎23‎ ‎August‎ ‎2019 ‎13‎:‎57
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Posted about it here…  http://amstrad-e3-hacking.freeforums.net/thread/36/using-amstrad-mailboard-keyboard-android<https://nam12.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net/thread/36/using-amstrad-mailboard-keyboard-android&data=02%7c01%7c%7c5b9ef2b0def349a1028808d727c976c6%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c637021618547010903&sdata=LiE38X2BGxmlh98E85t%2B91Oe1nlRpWKWT9FiDB254UE%3D&reserved=0>

Spanner..

I am using a app called Keyboard/Button Mapper its on Google Play got it from XDA,It works but the keys don’t work properly in games or Emulators so just looked it up and I need to make a .kl Keyboard layout file for it so it knows where the keys are.
Anyone made a keyboard layout file, it works the same way in Linux, Android uses the same layout files..? this is the app… https://play.google.com/store/apps/details?id=io.github.sds100.keymapper&rdid=io.github.sds100.keymapper<https://nam12.safelinks.protection.outlook.com/?url=https://play.google.com/store/apps/details?id%3Dio.github.sds100.keymapper%26rdid%3Dio.github.sds100.keymapper&data=02%7c01%7c%7c5b9ef2b0def349a1028808d727c976c6%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c637021618547010903&sdata=2lN99eYoefJwLJ/un1YJFXyUxaflj/8zWRyhbjpWymY%3D&reserved=0>

Spanner..

Hi Nick,

--
Cheers, Ralph.