Subject: [E3-hacking] Making life easy for you

From: "Gavin Andrews" <[email-masked]>
Date: Thu, 16 Jun 2005 22:51:00 +0100

The reason I am interested in E3 hardware recycling is that the hardware
is good value.
 
It makes no sense to be to buy something at a reasonable price!  It's
the subsidy that makes the E3 make sense!
 
Just being realistic.
 
Regards,
Gavin

---

From: Cliff Lawson <[email-masked]>
Date: Fri, 17 Jun 2005 11:31:25 +0100

A bit like Slartiblartfast proudly announcing "I was responsible for those
twiddly bits"...

I was responsible for the NC200 design. :-)

Don't the public documents I posted on the net about NC100/NC150/200 include
info about the disk firmware API then? I thought they did. Think there's a
copy at http://web.ukonline.co.uk/cliff.lawson/files.htm

Sadly, if they didn't then I fear I may have lost these things about 3 hard
drive crashes ago (in the un-enlightened days before I stored everything on
secure network servers :-(

It's just vaguely possible that I may still have a printed copy though
(though the pile has been "weeded" a few times since the late 80's too!).
I'll have a rummage...

Cliff

> -----Original Message-----
> From: David Given [mailto:[email-masked]]
> 
> (Also incidentally, I own a NC200. It's a lovely piece of 
> hardware. I'm trying 
> to hack that, too --- I have my own code booting from the 
> SRAM card, but I 
> haven't deciphered the floppy disk boot code yet...)

This e-mail and any attachments are confidential and intended exclusively for the addressee. If you are not the intended recipient please delete it from your system and notify the sender immediately. This message is attributed to the sender and may not necessarily reflect the views of Amstrad Plc or its subsidiaries.

For further information on Amstrad Plc please visit our website: www.amstrad.com

Amstrad Plc.
Brentwood House
169 Kings Road
Brentwood
Essex CM14 4EF
Registered in England : No. 955321

---

From: Cliff Lawson <[email-masked]>
Date: Fri, 17 Jun 2005 11:34:27 +0100

> From: Cliff Lawson [mailto:[email-masked]]
> 

Actually the document I was thinking of was the NCIOPSPEC.TXT linked from:

http://web.ukonline.co.uk/cliff.lawson/notepad.htm

But sadly this seems to be the NC100 only version :-(

Cliff

Amstrad Plc.
Brentwood House
169 Kings Road
Brentwood
Essex CM14 4EF

---

From: Otaku <[email-masked]>
Date: Sun, 19 Jun 2005 10:52:49 +0100

>Fair enough but shortly the job of recycling our subsidised hardware is due
>to get a bit trickier for you I hope.(Assuming we've implemented SHA256
>hashing and MD5+RSA signing correctly ;-) 

Oooh.. When ? :D

>highlighting our security shortcomings - I'd be interested if anyone can
>"break in" to newly protected hardware (OK, desoldering the NOR doesn't
>count! ;-)
Heh.. Thats kinda an unrealistic limitation, innit ? 
's like saying "Our copy protection system is unbreakable (provided no-one uses a debugger, or a dumper)" ;)

Oh, btw - whats the party line on releasing the real source to the MVL distro on the E3 ?

Cheers
O.