Subject: RE: [E3-hacking] sound?!

From: Cliff Lawson <[email-masked]>
Date: Fri, 3 Mar 2006 09:50:49 -0000

Damn, I wish our h/w designers had told us about these aic23 (who he?) on
the board - to think of all those weeks and months we wasted developing DSP
software to drive the modem codec through McBSP1 when there was a far easier
solution sitting there on the board unused. It must be a VERY small chip
though as it's managing to hide in both the schematics and a visual
observation of the actual board!

Cliff

> -----Original Message-----
> 
> I'm talking about the aic23 stero codec which the E3 seems to 
> have 2 of ?! You don't need the DSP
> either as the BSP that sends the sound samples (via I2S) can 
> be mapped to either the DSP or the
> CPU. 

This e-mail and any attachments are confidential and intended exclusively for the addressee. If you are not the intended recipient please delete it from your system and notify the sender immediately. This message is attributed to the sender and may not necessarily reflect the views of Amstrad Plc or its subsidiaries.

For further information on Amstrad Plc please visit our website: www.amstrad.com

Amstrad Plc.
Brentwood House
169 Kings Road
Brentwood
Essex CM14 4EF
Registered in England : No. 955321

---

From: Mark Underwood <[email-masked]>
Date: Fri, 3 Mar 2006 19:41:37 +0000 (GMT)

> observation of the actual board!

I'm just reporting what the I2C adapter told me, it's not my fault it's broken ;). Being serious,
I'm surprised that it reported that the got an ack from the address of the aic23 code chip if
there isn’t one there, are there any I2C devices on the E3? If there was no device at the address
I would expect either a nack which would mean that the aic23 codec driver would fail it's attach,
or the bus operation would time out (if there was no pull-ups on the I2C bus).

Also please correct me if I'm wrong, I'm new to OMAP's, but isn't the DSP public peripheral bus
available to the MPU via the MPUI and both MsBSP1 & 3 are on the DSP public peripheral bus so you
don't need the DSP to use them.

Mark

> This e-mail and any attachments are confidential and intended exclusively for the addressee. If
> you are not the intended recipient please delete it from your system and notify the sender
> immediately. This message is attributed to the sender and may not necessarily reflect the views
> of Amstrad Plc or its subsidiaries.
> 
> _______________________________________________
> e3-hacking mailing list
> [email-masked]
> http://www.earth.li/cgi-bin/mailman/listinfo/e3-hacking
> 

___________________________________________________________ 
Win a BlackBerry device from O2 with Yahoo!. Enter now. http://www.yahoo.co.uk/blackberry