Subject: [E3-hacking] Re: e3-hacking Digest, Vol 16, Issue 18

From: [email-masked]
Date: Fri, 29 Sep 2006 16:22:38 -0400

REMOVE ME FROM  MAILING LIST

-----Original Message-----
From: [email-masked]
To: [email-masked]
Sent: Fri, 29 Sep 2006 12.00PM
Subject: e3-hacking Digest, Vol 16, Issue 18

Send e3-hacking mailing list submissions to
    [email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
    http://www.earth.li/cgi-bin/mailman/listinfo/e3-hacking
or, via email, send a message with subject or body 'help' to
    [email-masked]

You can reach the person managing the list at
    [email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of e3-hacking digest..."

Today's Topics:

   1. Re: v2 release (Jonathan McDowell)
   2. Re: v2 release (Piotr Michniewski)
   3. Re: v2 release (Jonathan McDowell)
   4. V2 release - Handling bad NAND blocks (Matt Callow)

----------------------------------------------------------------------

Message: 1
Date: Fri, 29 Sep 2006 09:10:55 +0100
From: Jonathan McDowell <[email-masked]>
Subject: Re: [E3-hacking] v2 release
To: [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=us-ascii

On Tue, Sep 26, 2006 at 06:13:54PM +0100, Alex Goodyear wrote:
> I've also got the V2 release working without any major problems (a
> fantastic achievement, thanks Jonathan et al). I have a few
> observations and questions that may help others.
>
> I did stop the NAND backup process because it was incredibly slow.
> "top" showed that the system wasn't using much CPU but the load was
> over 2.0 Using "df" also revealed that the USB stick was only having
> 16 bytes written to it every second or so.
>
> The E3 keyboard is mapped as a standard desktop keyboard so most
> shifted characters are wrong and symbol-shift characters are ignored.

There was a new keymap posted to the list by David Given a while back,
though I had meant to update the one in the driver itself.

> I replaced the supplied 2.6.16 uImage with the one from the 2.6.17
> directory in the hope that the keyboard mappings would be fixed. It
> worked but it only provided a shell login for the serial connection
> unlike the 2.6.16 image which provides both a serial and an onboard E3
> login.

2.6.16 is the one that supports most things; later kernels gradually get
more of the devices supported by mainline linux-omap rather than having
to be patched, but both the keyboard and sound drivers weren't written
by me so they tend to end up last on my list of things to forward port.
I'm hoping to find some time to get a 2.6.18 kernel up and running in
the next week or two, along with the diminishing patch set.

> The copying of the Linux image from NAND seems slow, I recall some
> discussion about this being fixed within u-boot. Does the copy of
> u-boot in the V2 release contain this fix?

No, the version in V2 is 1.4, but there's a patch against uboot git that
adds support but also speeds up the Linux image loading.

J.

--
Synonym: word used when you can't spell the one you want
This .sig brought to you by the letter Z and the number 48
Product of the Republic of HuggieTag

------------------------------

Message: 2
Date: Fri, 29 Sep 2006 11:03:05 +0200
From: "Piotr Michniewski" <[email-masked]>
Subject: Re: [E3-hacking] v2 release
To: "Discussion of the Amstrad E3 emailer hardware/software"
    <[email-masked]>
Message-ID:
    <[email-masked]>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

> No, the version in V2 is 1.4, but there's a patch against uboot git 
that
> adds support but also speeds up the Linux image loading.

Umm... Where would that patch be ? :)

I hope it's not u-boot-amsdelta-20060519.diff, because it made no
difference for me :(

--
Piotr Michniewski

------------------------------

Message: 3
Date: Fri, 29 Sep 2006 10:08:56 +0100
From: Jonathan McDowell <[email-masked]>
Subject: Re: [E3-hacking] v2 release
To: [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=us-ascii

On Fri, Sep 29, 2006 at 11:03:05AM +0200, Piotr Michniewski wrote:
> >No, the version in V2 is 1.4, but there's a patch against uboot git 
that
> >adds support but also speeds up the Linux image loading.
>
> Umm... Where would that patch be ? :)
>
> I hope it's not u-boot-amsdelta-20060519.diff, because it made no
> difference for me :(

http://www.earth.li/pipermail/e3-hacking/2006-June/000537.html

J.

--
Web [  No one told you when to run, you missed the starting gun.   ]
site: http:// [                                          ]       Made by
www.earth.li/~noodles/  [                      ]         HuggieTag 
0.0.23

------------------------------

Message: 4
Date: Fri, 29 Sep 2006 11:27:34 +0100
From: Matt Callow <[email-masked]>
Subject: [E3-Hacking] V2 release - Handling bad NAND blocks
To: Discussion of the Amstrad E3 emailer hardware/software
    <[email-masked]>
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed

I thought I'd give the release a try (up to now I've always copied the
kernel over serial and used nfs root) but it appears that I have some
bad blocks in the NAND on my device:

Found ldr.img
   Erasing /dev/mtd3
Erasing 16 Kibyte @ 0 --  0 % complete.
Skipping bad block at 0x00004000

Skipping bad block at 0x00008000
Erasing 16 Kibyte @ c000 -- 18 % complete.Erasing 16 Kibyte @ 10000 --
25 % complete.Erasing 16 Kibyte @ 14000 -- 31 % complete.Erasing 16
Kibyte @ 18000 -- 37 % complete.Erasing 16 Kibyte @ 1c000 -- 43 %
complete.Erasing 16 Kibyte @ 20000 -- 50 % complete.Erasing 16 Kibyte @
24000 -- 56 % complete.Erasing 16 Kibyte @ 28000 -- 62 %
complete.Erasing 16 Kibyte @ 2c000 -- 68 % complete.Erasing 16 Kibyte @
30000 -- 75 % complete.Erasing 16 Kibyte @ 34000 -- 81 %
complete.Erasing 16 Kibyte @ 38000 -- 87 % complete.Erasing 16 Kibyte @
3c000 -- 93 % complete.
   Writing ldr.img to /dev/mtd3
end_request: I/O error, dev mtdblock3, sector 32
dd: /dev/mtdblock3: Input/output error

Is it possible to move ldr further down in /dev/mtd3 ? I tried this 
using

dd if=/media/sda1/ldr.img of=/dev/mtdblock3 bs=16384 seek=3

that seemed to write OK, but the e3 wont boot of the nand yet. I get an
error about missing kernel params, which repeats continuously.

Anyone got any ideas?

Matt

------------------------------

_______________________________________________
e3-hacking mailing list
[email-masked]
http://www.earth.li/cgi-bin/mailman/listinfo/e3-hacking

End of e3-hacking Digest, Vol 16, Issue 18
******************************************

---

From: Jonathan McDowell <[email-masked]>
Date: Sun, 1 Oct 2006 09:17:53 +0100

or a mail to:

with a subject of unsubscribe will do this for you.

J.

-- 
/-\                             | 101 things you can't have too much
|@/  Debian GNU/Linux Developer |        of : 45 - Toblerone.
\-                              |