Subject: RE: [E3-hacking] sound?!

From: Cliff Lawson <[email-masked]>
Date: Thu, 2 Mar 2006 17:51:53 -0000

Jonathan,

Spot on as always. The two ways to make noise are to either play one of 48
fixed "notes" from the PWT or to stream PCM to the modem codec (after
switching it to take control rather than allowing the modem to control it)
which is the way we play polyphonic ringtones, Spectrum 128 sound and audio
on MPEG adverts. But to do this requires code running on the C55x DSP as
only it mcbsp2 (think it's 2, maybe 1 though!) is connected to the codec
chip and that mcbsp is a DSP "private" device and can't be programmed from
the ARM side of the OMAP.

For Linux use I'm therefore gonna suggest that you are probably limited to
PWT and your choice of the 12 notes in each of four octaves.

Cliff

> -----Original Message-----
> From: Jonathan McDowell [mailto:[email-masked]]
>
> The only other option I can see for talking to the handset/speaker/mic
> is via the modem codec.

This e-mail and any attachments are confidential and intended exclusively for the addressee. If you are not the intended recipient please delete it from your system and notify the sender immediately. This message is attributed to the sender and may not necessarily reflect the views of Amstrad Plc or its subsidiaries.

For further information on Amstrad Plc please visit our website: www.amstrad.com

Amstrad Plc.
Brentwood House
169 Kings Road
Brentwood
Essex CM14 4EF
Registered in England : No. 955321

---

From: David Given <[email-masked]>
Date: Thu, 2 Mar 2006 18:46:17 +0000

On Thursday 02 March 2006 17:51, Cliff Lawson wrote:
[...]
> PWT and your choice of the 12 notes in each of four octaves.

Back in the old BBC days I had a speech synth (Superior Software's SPEECH, and 
I've still to find a cheapo speech synth for my PC that was as good) that 
worked by playing a continuous tone on the SN76489 sound chip and then 
modulating the four-bit amplitude very quickly. Could a similar trick be done 
to wrange sampled sound out of the PWT?

-- 
+- David Given --McQ-+ "There is nothing in the world so dangerous ---
|  [email-masked]    | and I mean *nothing* --- as a children's story that
| ([email-masked]) | happens to be true." --- Master Li Kao, _The Bridge
+- www.cowlark.com --+ of Birds_

---

From: Mark Underwood <[email-masked]>
Date: Thu, 2 Mar 2006 21:55:51 +0000 (GMT)

> to wrange sampled sound out of the PWT?

I'm talking about the aic23 stero codec which the E3 seems to have 2 of ?! You don't need the DSP
either as the BSP that sends the sound samples (via I2S) can be mapped to either the DSP or the
CPU. 
 
Thanks for the FB patch's Jonathan, but your E3_defconfig doesn't seem to have been updated to
enable the FB :-(. In fact your patchs like very much like the changes I have made (great minds
;), however, your patch (like my version) only seem only yeild a blue display on my E3 (different
hardware version?!) I'll have a play around this weekend to see if I can find you what's wrong. In
the mean time would it be possible to post your working FB config plus a kernel uImage (just to
make sure that we are running execatly the same code). 
 
Keep on hacking :) 
 
Mark

> > _______________________________________________
> e3-hacking mailing list
> [email-masked]
> http://www.earth.li/cgi-bin/mailman/listinfo/e3-hacking
> 

___________________________________________________________ 
To help you stay safe and secure online, we've developed the all new Yahoo! Security Centre. http://uk.security.yahoo.com

---

From: Jonathan McDowell <[email-masked]>
Date: Thu, 2 Mar 2006 23:57:02 +0000

On Thu, Mar 02, 2006 at 09:55:51PM +0000, Mark Underwood wrote:

> I'm talking about the aic23 stero codec which the E3 seems to have 2
> of ?! You don't need the DSP either as the BSP that sends the sound
> samples (via I2S) can be mapped to either the DSP or the CPU. 

Er, really? You have this working?
  
> Thanks for the FB patch's Jonathan, but your E3_defconfig doesn't seem
> to have been updated to enable the FB :-(. In fact your patchs like
> very much like the changes I have made (great minds ;), however, your
> patch (like my version) only seem only yeild a blue display on my E3
> (different hardware version?!) I'll have a play around this weekend to
> see if I can find you what's wrong. In the mean time would it be
> possible to post your working FB config plus a kernel uImage (just to

That patch doesn't have the FB enabled because it doesn't work in it. It
has working NAND and an updated keymap over my first patch.

I'm going to have a new patch out before the end of the weekend
(hopefully split out and cleaner) that'll add the FB support; I have it
working locally.

J.

--

---

From: Mark Underwood <[email-masked]>
Date: Fri, 3 Mar 2006 08:44:22 +0000 (GMT)

> Er, really? You have this working?

Well, what to you mean by working ;). I looked through the E3 config for the 2.4 kernel and found
that it had enabled support for the the aic23 stero codec and after a bit of light hacking I got
it to complie under 2.6. The aic23 I2C driver probes for the device and will only try to attach to
if it got an ack back from a chip so either the I2C bus is in a state which means it always thinks
it has an ack, there is another I2C chip at the same address, or there are 2 aic23 stero codecs on
the E3. As I haven't taken mine apart I don't know which it is.

I have DMA interrupts & I2C interrupts, but no sound as yet.

> (hopefully split out and cleaner) that'll add the FB support; I have it

Ah, your blurred picture got me so excited I didn't read your website correctly!

Any hint on how you got the LCD to work? (my FB code seems to match the FB code in your patch), or
am I going to have to wait until the weekend!

What else is there to do? Just to confirm, the current status is:

Kernel booting
Serial port working
USB working
NAND reading & writing
FB working

Which leaves:
sound ?!
Mini keyboard (PS2 right?)
u-boot NAND read (& write ?)
Getting PBL tool to load & run u-boot from flash
DSP!!

Mark

		
___________________________________________________________ 
Win a BlackBerry device from O2 with Yahoo!. Enter now. http://www.yahoo.co.uk/blackberry

---

From: [email-masked]
Date: Fri, 3 Mar 2006 09:54:54 +0000 (GMT)

> DSP!!

...uh, given that the DSP is basically just a C55 with a little MMU
that can only be programmed from the ARM side, what exactly do you 
envisage doing with it?  In cellphones it's used for mp3 playback and 
speech coding, but that's probably not so useful on E3.

-J.