Subject: RE: [E3-hacking] Shell

From: Cliff Lawson <[email-masked]>
Date: Mon, 11 Jul 2005 11:11:36 +0100

> -----Original Message-----
> From: Matt Evans [mailto:[email-masked]]
> 
> Will start having a look at LDR;  am intrigued by the "Linux start-up 
> params (Any key to edit)" line, and want to see if this is 
> telling the 
> truth (i.e. the params could be edited without requiring a PARMS 
> reflash).

Matt just to save you a little time:

	DSI_printf("Linux start-up params (Any key to edit)\r\n");

	// Lets start by letting the user  Edit this command line
	
	// edited=getcmd(startup_string,sizeof(startup_string),0x00346000);

	cmd_line=startup_string;
	while(*cmd_line!='\0' && *cmd_line!=' ' && *cmd_line!='\t')
			cmd_line++; 	// find end of first string
	....

The fact is that the fact you see that message is simply an error from an
older version of LDR where we used to make it easy for ourselves to be able
to manually change the PARMS. The call to getcmd() (but unfortunatelly not
the printf() ) in the source is now commented so there's no way it's going
to be of any use to you. I'm sure a disassembly will confirm that the next
thing after that printf() is the code for the "cmd_line=startup_string;"

Cliff

This e-mail and any attachments are confidential and intended exclusively for the addressee. If you are not the intended recipient please delete it from your system and notify the sender immediately. This message is attributed to the sender and may not necessarily reflect the views of Amstrad Plc or its subsidiaries.

For further information on Amstrad Plc please visit our website: www.amstrad.com

Amstrad Plc.
Brentwood House
169 Kings Road
Brentwood
Essex CM14 4EF
Registered in England : No. 955321

---

From: Matt Evans <[email-masked]>
Date: Mon, 11 Jul 2005 11:27:55 +0100

On 11 Jul 2005, at 11:11, Cliff Lawson wrote:

> [snip]

Cliff,

Many thanks for pointing that out -- it's a big help, I appreciate it.

I can duly redirect the time towards getting reflashing working... :)

Regards,

Matt