Subject: [E3-hacking] FB driver update + sound?!

From: Mark Underwood <[email-masked]>
Date: Tue, 28 Feb 2006 08:59:52 +0000 (GMT)

Just to let you all know that I am still working on the FB driver :). I have the LCD lit up in a
nice all over turquoise colour but no Penguin and nothing I do seems to change that :(. The LCD
registers have almost the same settings (one of the unused bits is set in my driver which wasn't
set in the 2.4 kernel, but I can't see in the code where it could be set). I get 3 interrupts from
the FB which looks about right as once it is up and running it's frame interrupt is disabled.

The other news is that I have built all the sound stuff ok and I think it is working as the DMA
interrupts go up, but all I have done so far is to 'cat /dev/urandom > /dev/dsp' which makes some
difference to the noise, but as the unit is always generating noise I don't know if it is playing
my noise or its normal noise! I will hopefully have time to test it with mpeg321 tonight. If it
doesn't work then I guess there is a bit in the latch that I need to set to switch on the output
amp.

Mark

___________________________________________________________ 
To help you stay safe and secure online, we've developed the all new Yahoo! Security Centre. http://uk.security.yahoo.com

---

From: Jonathan McDowell <[email-masked]>
Date: Thu, 2 Mar 2006 12:47:11 +0000

On Tue, Feb 28, 2006 at 08:59:52AM +0000, Mark Underwood wrote:
> The other news is that I have built all the sound stuff ok and I think
> it is working as the DMA interrupts go up, but all I have done so far
> is to 'cat /dev/urandom > /dev/dsp' which makes some difference to the
> noise, but as the unit is always generating noise I don't know if it
> is playing my noise or its normal noise! I will hopefully have time to
> test it with mpeg321 tonight. If it doesn't work then I guess there is
> a bit in the latch that I need to set to switch on the output amp.

Er, what sound stuff have you built?

AFAICT the E3 has the PWT tone generator built into the 5910, which is
what ams_beep_mod.o talks to.

The only other option I can see for talking to the handset/speaker/mic
is via the modem codec.

I can't see anything else audio related on the 5910 block diagram, and
didn't see anything that was obviously an audio codec when I
disassembled the E3. What have I missed?

J.

-- 
Web [    101 things you can't have too much of : 43 - Penguins.    ]
site: http:// [                                          ]       Made by
www.earth.li/~noodles/  [                      ]         HuggieTag 0.0.23