Subject: [E3-hacking] [PATCH 2.6.37-rc1] OMAP1: camera.h: readd missing include

From: Janusz Krzysztofik <[email-masked]>
Date: Tue, 2 Nov 2010 15:04:01 +0100

#include <media/omap1_camera.h> directive, required for successfull 
compilation of dependant boards (board-ams-delta for now), has been lost 
somehow from arch/arm/mach-omap1/include/mach/camera.h on creation. Readd it.

Created and tested against linux-2.6.37-rc1.

Signed-off-by: Janusz Krzysztofik <[email-masked]>
---

 arch/arm/mach-omap1/include/mach/camera.h |    2 ++
 1 file changed, 2 insertions(+)

--- linux-2.6.37-rc1/arch/arm/mach-omap1/include/mach/camera.h.orig	2010-11-01 22:41:04.000000000 +0100
+++ linux-2.6.37-rc1/arch/arm/mach-omap1/include/mach/camera.h	2010-11-01 23:18:44.000000000 +0100
@@ -1,6 +1,8 @@
 #ifndef __ASM_ARCH_CAMERA_H_
 #define __ASM_ARCH_CAMERA_H_
 
+#include <media/omap1_camera.h>
+
 void omap1_camera_init(void *);
 
 static inline void omap1_set_camera_info(struct omap1_cam_platform_data *info)

---

From: Tony Lindgren <[email-masked]>
Date: Fri, 5 Nov 2010 09:57:53 -0700

> Created and tested against linux-2.6.37-rc1.

I've updated the description to use add instead of readd as it
never was there from Linux kernel change log point of view in
the first place:

OMAP1: camera.h: add missing include

#include <media/omap1_camera.h> directive is required to
compile the dependant boards (board-ams-delta for now).

Signed-off-by: Janusz Krzysztofik <[email-masked]>
[[email-masked]: updated comments]
Signed-off-by: Tony Lindgren <[email-masked]>

Also, for the future patches, please always Cc linux-arm-kernel
mailing list as well so I don't have to repost the patches
before merging.

Regards,

Tony