Subject: RE: [E3-hacking] E3 Memory Map?

From: Cliff Lawson <[email-masked]>
Date: Tue, 16 May 2006 10:30:04 +0100

> -----Original Message-----
> From: David Given [mailto:[email-masked]]
> 
> So far there's no (released) way of booting a Linux kernel 
> out of the NAND
> flash,

Except the Amstrad implementation that boots Montavista Pro 3 (2.4.18) ? ;-)

As long as you have a module header called "LINUX" then the PBL will load it
out to its RAM load address and enter it, it'll even pass into it the text
of a module called "PARMS" so I don't see why this can't be used to boot
other flavours of Linux?

Or, of course, the thing that you *call* "LINUX" could actually be a copy of
Das uBoot so that you have PBL in NOR as a Primary Boot Loader and then
uBoot acts as an SBL (Secondary Boot Loader) and is loaded out to RAM and
executed and IT then goes on to load your favourite flavour of Linux

Cliff

This e-mail and any attachments are confidential and intended exclusively for the addressee. If you are not the intended recipient please delete it from your system and notify the sender immediately. This message is attributed to the sender and may not necessarily reflect the views of Amstrad Plc or its subsidiaries.

For further information on Amstrad Plc please visit our website: www.amstrad.com

Amstrad Plc.
Brentwood House
169 Kings Road
Brentwood
Essex CM14 4EF
Registered in England : No. 955321

---

From: David Given <[email-masked]>
Date: Tue, 16 May 2006 10:52:15 +0100

Cliff Lawson wrote:
[...]
> Except the Amstrad implementation that boots Montavista Pro 3 (2.4.18) ? ;-)

Well, true.

And, uh, this may seem like a silly question, but, uh, why aren't we
doing this?

- --
+- David Given --McQ-+ "Preacher, don't the Bible have some pretty
|  [email-masked]    | specific things to say about killing?" "Quite
| ([email-masked]) | specific. It is, however, somewhat fuzzier on the
+- www.cowlark.com --+ subject of kneecaps." --- Firefly, _War Stories_

---

From: Jasmine Strong <[email-masked]>
Date: Tue, 16 May 2006 12:06:41 +0200

On 16 May 2006, at 11:52, David Given wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Cliff Lawson wrote:
> [...]

Because 2.4 is obsolete and basing new projects on it is a very bad  
idea.

-J.

---

From: Don Alexander <[email-masked]>
Date: Tue, 16 May 2006 11:49:11 +0100

> >> Except the Amstrad implementation that boots Montavista Pro 3

Ahem, to shamlessly steal from a real genius...

-- CUT --

"Bloody hell," said Majikthise, "now that is what I call thinking. Here
Vroomfondel, why do we never think of things like that?"

"Dunno," said Vroomfondel in an awed whisper, "think our brains must be
too highly trained Majikthise."

HHGTTG

-- CUT --

... hehe.. ;)

-- 
==

Don Alexander

E3 Development & tweaking ;)

RooSoft Ltd