Subject: [E3-hacking] pbltool problem

From: Edward Robbins <[email-masked]>
Date: Mon, 26 Nov 2012 13:18:06 +0000

Hi again,

I've got some free time today and have been playing with the emailer
again. I've managed to build a 3.6 kernel a while ago but when I tried
to upload the V2 stuff I had problems.

Today I made up a new cable thinking that might be the issue, but it
hasn't helped. I can get a boot log just fine, but when I run pbltool
with "sudo ./pbltool -f /dev/ttyUSB0 oe-install.pbl" I get:

Prodding...
Handshaking...
Done handshaking
Compressed return block?
Flushing: 0x00
Flushing: 0x0E
Flushing: 0x00
Flushing: 0x82
Flushing: 0x00
Flushing: 0x52
Flushing: 0x00
Flushing: 0x04
Flushing: 0x09
Flushing: 0x1F
Flushing: 0x05
Flushing: 0x10
Flushing: 0x40
Flushing: 0xFE
Flushing: 0x7B
Flushing: 0x0E
Flushing: 0xB0
Flushing: 0x9A
Compressed return block?

Which then repeats forever. I've tried editing oe-install.pbl to
change the baud rate (38400, 19200, 9600) but it makes no difference.
I also looked for pblq but the link on
http://cowlark.com/amstrad/index.html is broken.

Any ideas?

Thanks!

---

From: Edward Robbins <[email-masked]>
Date: Mon, 26 Nov 2012 13:32:22 +0000

Ok, so I just tried it with debugging and it has booted!

Cheers,
Ed

---

From: Edward Robbins <[email-masked]>
Date: Mon, 26 Nov 2012 14:00:35 +0000

Hmm... worked that once but no dice a second time... is this a common issue?

---

From: Edward Robbins <[email-masked]>
Date: Mon, 26 Nov 2012 14:25:11 +0000

Ok, got it finally.

Now installing to NAND so I guess I wont need this much now anyhow!

---

From: Edward Robbins <[email-masked]>
Date: Mon, 26 Nov 2012 16:10:41 +0000

Hmmm... so now I'm having trouble installing to NAND. I've done it 4
times so far using different USB drives. I get a couple of messages
about bad blocks, and then when u-boot starts I get:

Loading from device 0: <NULL> at 0x8000000 (offset 0x0)
   Image Name:   Linux-2.6.16-omap2
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    1576804 Bytes =  1.5 MB
   Load Address: 10008000
   Entry Point:  10008000
** Read error on 0
## Booting image at 11d00000 ...
   Image Name:   Linux-2.6.16-omap2
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    1576804 Bytes =  1.5 MB
   Load Address: 10008000
   Entry Point:  10008000
   Verifying Checksum ... Bad Data CRC
E3 #

o_O
Has anyone else had this problem? Sorry for the torrent of emails!