Subject: [E3-hacking] E3 rootfs problems

From: Tolly Nelson <[email-masked]>
Date: Tue, 21 Feb 2006 14:21:06 +0000

Hi all,

I've been hacking my E3 over the last few days, but I can't seem to get
my rootfs image to work...

My toolchain seems to work, as I can compile u-boot and the kernel with
no problems, and they both boot, but the root just doesn't want to
execute - i.e it stops after :

"...
RAMDISK: Compressed image found at block 0
VFS: Mounted root (ext2 filesystem).
Freeing init memory: 100K"

I've checked my inittab, and the relevant line is there:

"::respawn:/bin/ash"

I've mounted the ext2 image locally, and 'file busybox' says:

"busybox: setuid ELF 32-bit LSB executable, ARM, version 1 (ARM),
dynamically linked (uses shared libs), stripped"

So I know that its compiled correctly. (unless I require static linking)

I'm using the standard linux.pbl pbltool script, so maybe I'm getting
the memory locations wrong (my rootfs and kernel are slightly different
sizes)

When using the stock rootfs, the system works fine with my u-boot and
kernel.

Any help would be appreciated,

Tolly

---

From: Mark Underwood <[email-masked]>
Date: Tue, 21 Feb 2006 18:59:02 +0000 (GMT)

> Any help would be appreciated,

Hi Tolly, 
 
Did you use the configs in the release? These should work fine. It required a fair amount of trail
and error to get a buildroot & busybox configuration that worked and I'm really not sure why :-/. 
You will also have to stop the rc scripts from running (they don't work), it's best if you just
copy the inittab from the release over your version.

As for the memory layout, as long as your kernel is under 2M (compressed) and your rootfs is under
1M (compressed) you should be fine. If your rootfs is bigger then 1M then you will have to move it
up a bit, althought you would know about it as you would have over-written the kernels u-boot
header and it would refuse to boot.

> Tolly

Mark
> 
> 
> _______________________________________________
> e3-hacking mailing list
> [email-masked]
> http://www.earth.li/cgi-bin/mailman/listinfo/e3-hacking
> 

___________________________________________________________ 
To help you stay safe and secure online, we've developed the all new Yahoo! Security Centre. http://uk.security.yahoo.com