Subject: [E3-hacking] Hello - new member

From: "Ken Boak" <[email-masked]>
Date: Tue, 7 Feb 2006 18:08:42 -0000

Hi,

I just bought a couple of E2 emailers in the Post Office for £12.99 each.

I have read most of the archive posts from the last year and concluded that there is now a monitor program for the E2, and there has been some success in running C on the ARM 7.

I should like to enquire whether there has been any further work done on hi-jacking the software upgrade process, or diverting the emailer to call another server?

Any update infor on E2 activities would be appreciated - or should I go to Currys and buy an E3 ? ;-)

My interests in the E2 is to make a low cost platform suitable for the deaf-blind to communicate with one another, a sort of one to one chat keypad, with very large character fonts to suit the partially sighted.

With hour long evening and weekend calls on BT either free or 5.5p you could do a lot of one to one texting in an hour - very cheaply.

I have also been looking at alternative keypads for deaf-blind use, as qwerty can be a bit difficult, and resurrected the old 5 key "Microwriter" chord keypad, with a fair degree of success

I like the idea from the archives about putting an E3 in a plain box and making it available as a cheap platform for kids etc.  There was a project in India to do a sub-$100 laptop for school kids.

The low power requirements of the E2 of about 7 watts makes it a fraction of the power of a laptop - and the screen backlighting makes it possible to type messages with the lights out -  some kids might find that useful!

regards,

Ken Boak

---

From: David Given <[email-masked]>
Date: Wed, 15 Feb 2006 13:59:21 +0000

> Hi,

Ah --- you made it!

[...]
> Currys and buy an E3 ? ;-)

I haven't done anything for a while, due to a sudden resurgence of Life (plus 
a new house and managing to break my breadboarded line level converter). I do 
mean to go back to it; there's something I actually want to do with my E2.

(Incidentally, I originally got C running on my E2 using the tcc compiler, 
because I couldn't get gcc to work. tcc produces lousy code and was only 
suitable for prototyping. For doing real work, I need a better compiler --- 
but I *still* cannot get gcc to work. I'm using Ubuntu Linux and trying to 
build a toolchain with the toolchain-source package, and it always fails to 
compile. Does anyone know where I can get precompiled ARM7 compiler 
packages?)

[...]
> I like the idea from the archives about putting an E3 in a plain box and
> making it available as a cheap platform for kids etc.  There was a project
> in India to do a sub-$100 laptop for school kids.

It's worth pointing out that the E2 or E3 are only cheap because Amstrad are 
heavily subsidising them. They plan to make their money back through service 
charges. So while buying the odd one as a personal toy is reasonable, buying 
a hundred with an aim to modifying them and then selling them on is 
considered definitely bad form!

(In fact, Cliff Lawson from Amstrad is on this list and he's said --- later on 
in the thread you were reading --- that there are plans afoot to introduce an 
encryption layer specifically to prevent this kind of thing.)

-- 
+- David Given --McQ-+ "Est brilgum: toui slimici
|  [email-masked]    | In uabo tererotitant
| ([email-masked]) | Brogoui sunt macresculi
+- www.cowlark.com --+ Momi rasti strugitant." --- Anonymous

---

From: David Given <[email-masked]>
Date: Wed, 15 Feb 2006 14:13:45 +0000

On Wednesday 15 February 2006 13:59, David Given wrote:
[...]
> Does anyone know where I can get precompiled ARM7 compiler
> packages?

Found one. This list is amazing --- it can solve my problems without even 
replying to my posts!

-- 
+- David Given --McQ-+ "Quantum materiae materietur marmota monax si
|  [email-masked]    | marmota monax meteriam possit materiari?" --- Henry
| ([email-masked]) | Beard
+- www.cowlark.com --+