Subject: [E3-hacking] Re: e3 , perhaps strange question...

From: Jonathan McDowell <[email-masked]>
Date: Mon, 28 Nov 2005 17:40:11 +0000

On Mon, Nov 28, 2005 at 04:25:15PM +0000, Phil wrote:
> Well I am getting this:
> --start--
> g-%/y!75u#7/_{ggYy5%%!7'5'!=75w[S{-'7}5e!79=#!eue3'=/_}[eY3'=/gw[3'=/_}[eY3'=/gmcUO3'=/VkU=3'=/Q
> 
> '59/59)-#1gw[S=='-5'!=79/59)-#1gmcUOS=='-5'!=79/59)-#1gmcUOS=='-5'!=7!%!7'59=''57gmcUONj+S=='-5'!=7s9/59)-#1_}[eYS=='-5'!=79/59)-#1_}[eYS=='-5'!=7!%!7'59=''57_}[eYe!7'59557=='-7w[/-#)1'!;='#%;5!5%-!#7%!7gmcUOS=s!#7%!57-!#7%!7gmcUOS=U-#5%!7'5_}[eY3!#7=cmW[wc!3!#7-#=%}#
> 
> *-#1g-#4444444444444444444444444444444444444444444444444444
> 
> :
> 
> 
> -#1/5)5'
> --stop--
> 
> That string of "4"'s may well map to the uncompressing "."'s. So I am
> flumoxed. This is a brand new , unregistered box, and seems as if my
> serial cable is knackered (though I fail to see how), or perhap some
> strange parameter I have overlooked.....? If this were a parallel cable ,
> I would be thinking a flaky bit, however....
> 
> 	It has been a few years since I messed with raw serial, so any
> input would be appreciated.

I've no idea; mine works fine with no trickery. I suggest you ask the
list (and have cc'd this reply there).

> PS what is the domain "li"?

Liechtenstein.

J.

-- 
      Are you out of my mind?      |  .''`.  Debian GNU/Linux Developer
                                   | : :' :  Happy to accept PGP signed
                                   | `. `'   or encrypted mail - RSA +
                                   |   `-    DSA keys on the keyservers.

---

From: Phil <[email-masked]>
Date: Thu, 1 Dec 2005 20:49:56 +0000 (GMT)

Hi,

Tried a different serial convertor and got this ( shown below).
It does not get as far as your example John, and the PARAM's shows some
differences. Is the example you give from a modified flash?

In anycase, would you please post the params mod for the "init=/bin/sh" so
I can a feel for the inside of this box.

	Cheers

	PHiL

--cut here--
Amstrad Delta - PBL V4.9 Build:1311 Assert Debug ICE
PBL 32MB NAND
0MB.-->MEMv01.00.002,CopyLim=00220000h,CodeEnd=01400000h-->PBL......1MB.......2MB*

System module loader - LDR V1.5 Build:0008 Assert
Mod scan 10010100 to 10230100
MEM - 10024000 (flash 00404000)
PARMS - 10024400 (flash 00404400)
LDR - 10024800 (flash 00404800)
PARMS - 10034400 (flash 00414400)
LINUX - 10044000 (flash 00424000)
LINUX - 10144000 (flash 00524000)
num modules: 6
checking LDR V1 at 10024800, alive=0, load=10002000
checking LINUX V1 at 10044000, alive=0, load=11800000
checking LINUX V4 at 10144000, alive=0, load=11800000
two modules called LINUX
checking MEM V1 at 10024000, alive=0, load=11F00000
checking PARMS V1 at 10024400, alive=0, load=11900000
checking PARMS V2 at 10034400, alive=0, load=11900000
two modules called PARMS
6 Modules processed, 6 are valid
LDR thinks global number for them is 4
Found mod <LINUX> V=4 at 10144000
Found mod <PARMS> V=2 at 10034400
Linux command line module (PARMS) found at 10034400
INITRD Not found
Linux start-up params (Any key to edit)
Found mod <LINUX> V=4 at 10144000
Uncompressing
Linux........................................................ done, booting the kernel.

---

From: Matt Evans <[email-masked]>
Date: Fri, 2 Dec 2005 11:20:28 +0000

Hi Phil,

I seem to remember the linux kernel itself spits out stuff at a  
different baud rate (9600 from memory?) to the debug info from PBL...  
classic eh?  I'd suggest having a play, 9600, 115200 etc. etc. and  
you'll soon see the boot info.

Incidentally I tried mounting a USB storage device (via /bin/sh  
hack), chrooting, and running things from a basic rootfs on there...  
it sort of ran some things but I couldn't get anything interesting  
(e.g. tinyx) running.  I'll dig about, ISTR having to make some  
changes to the host program to get it to reflash the params block  
correctly, will see if they're useful for ppl here.

[Am also thinking of another bootloader.. heh ;-)  (I'd really like  
to get custom kernels going, and dropping them down via PBL isn't on  
my top-10 list of really fun things...)]

Cheers,

Matt

On 1 Dec 2005, at 20:49, Phil wrote:

> [snip]