Subject: [E3-hacking] Some things I have found on the Amstrad E3 while I was pressing different buttons.

From: Nick Griffin <[email-masked]>
Date: Wed, 3 Apr 2019 14:08:25 +0000

I found something the other day, if you press SETUP Button then 1 then 1 again, it looks like it comes up with driver info, Picture is here.. https://imgur.com/zjJc2oT

And if you press SETUP Button then 1 then 0 it has numbers on the Setup Info screen Picture here..  https://imgur.com/VpJRCRt

Anyone seen theses before..? Do not know what the numbers are on the Setup Info screen is..??

Spanner..

---

From: Paul Wayne <[email-masked]>
Date: Wed, 3 Apr 2019 14:19:07 +0000

Interesting, wonder if the info takes any closer to finding a way to hack the hardware and get these machines working again.

I wonder if anyone in the group  is interested in putting in some cash to fund instructing a geek/hacker to see if they can override the hardware?

Paul

From: e3-hacking [mailto:[email-masked]] On Behalf Of Nick Griffin
Sent: 03 April 2019 15:08
To: Discussion of the Amstrad E3 emailer hardware/software <[email-masked]>
Subject: [E3-hacking] Some things I have found on the Amstrad E3 while I was pressing different buttons.

Spanner..

---

From: Nick Griffin <[email-masked]>
Date: Wed, 3 Apr 2019 14:33:30 +0000

I was wondering If the Delta_e_live.config is the file it looks for to keep the E3 activated, its got to be looking for something every time it sends or receives email to keep it alive..????

Spanner..

From: Paul Wayne<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎3‎ ‎April‎ ‎2019 ‎15‎:‎19
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Paul

I found something the other day, if you press SETUP Button then 1 then 1 again, it looks like it comes up with driver info, Picture is here.. https://imgur.com/zjJc2oT<https://nam05.safelinks.protection.outlook.com/?url=https://imgur.com/zjJc2oT&data=02%7c01%7c%7c202f2fc8f13f4a564e0908d6b83f61b3%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636898979703168797&sdata=Zbet/ENSTHyC54JAGEA3TT%2BCIgTjhloAE7E%2B8NHIwr0%3D&reserved=0>

And if you press SETUP Button then 1 then 0 it has numbers on the Setup Info screen Picture here..  https://imgur.com/VpJRCRt<https://nam05.safelinks.protection.outlook.com/?url=https://imgur.com/VpJRCRt&data=02%7c01%7c%7c202f2fc8f13f4a564e0908d6b83f61b3%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636898979703188818&sdata=9pyeLuH62h%2B152HqrkXKWGXgZ8agl8BVxG46UKUEgx4%3D&reserved=0>

Spanner..

---

From: Nick Griffin <[email-masked]>
Date: Wed, 3 Apr 2019 15:09:43 +0000

Delta_e_live could stand for Delta Emailer Live, why have the name live in its name, so that could be the file that keeps in on and that file after 2 or 3 months gets deleted or it tells the Emailer how long to keep a live for and then the Emailer deactivates itself, maybe that's why if you copy the setup from a Emailer with the config change on to another that's deactivated(not working) it don't activate it because it only copies the setup and not that file.

That file looks important because it has a its own IP address so the Emailer can download it.
http://212.225.36.174/delta_e_live.config and it has a version number - config_a version: 0.
Just some idea.. 😊

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎3‎ ‎April‎ ‎2019 ‎15‎:‎33
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Spanner..

Paul

I found something the other day, if you press SETUP Button then 1 then 1 again, it looks like it comes up with driver info, Picture is here.. https://imgur.com/zjJc2oT<https://eur02.safelinks.protection.outlook.com/?url=https://imgur.com/zjJc2oT&data=02%7c01%7c%7c21b3b2fc642b4a6ba81208d6b8415f98%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636898988242076956&sdata=fiznopbM60fMlqXiNnWSrIpQc2Sr0YZtcyrwuKkt8Ak%3D&reserved=0>

And if you press SETUP Button then 1 then 0 it has numbers on the Setup Info screen Picture here..  https://imgur.com/VpJRCRt<https://eur02.safelinks.protection.outlook.com/?url=https://imgur.com/VpJRCRt&data=02%7c01%7c%7c21b3b2fc642b4a6ba81208d6b8415f98%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636898988242086961&sdata=WSY2FgRN6QQ1Rq0tZX2lwZC5pK01izOlNBRDeDAIbyA%3D&reserved=0>

Spanner..

---

From: Antony Stone <[email-masked]>
Date: Wed, 3 Apr 2019 17:24:23 +0200

On Wednesday 03 April 2019 at 17:09:43, Nick Griffin wrote:

> Delta_e_live could stand for Delta Emailer Live, why have the name live in
> its name, so that could be the file that keeps in on and that file after 2
> or 3 months gets deleted or it tells the Emailer how long to keep a live
> for and then the Emailer deactivates itself

Or, possibly it refers to the "Live" release of the software, distinct from 
"Development" and "Test" etc?

> That file looks important because it has a its own IP address so the
> Emailer can download it. http://212.225.36.174/delta_e_live.config and it
> has a version number - config_a version: 0. Just some idea.. 😊

I also wanted to reply to this thread simply to confirm that there's at least 
one other person out here who's still interested in these things (I believe I 
have either 4 or 5 in total, never connected to a phone line, and I also have 
a serial connector cable (somewhere), although it's still RS232, not USB (but 
I think that can't be hard to change)).

Happy to help out further if I can make the time for it :)

Antony.

-- 
.evah I serutangis sseltniop tsom eht fo eno eb tsum sihT

                                                   Please reply to the list;
                                                         please *don't* CC me.

---

From: Jake Sloan <[email-masked]>
Date: Wed, 3 Apr 2019 16:53:32 +0100

Enough time has passed that bruteforcing the required key is probably 
feasible..

I think the list has the details, somewhere.

You need to send a packet that hashes to a specific value to enable any 
of the fun pbl functionality.

good luck.

o.

---

From: Antony Stone <[email-masked]>
Date: Wed, 3 Apr 2019 18:22:43 +0200

> I think the list has the details, somewhere.

I seem to remember a posting along the lines of "this has got close enough 
that we're not going to give more details, because we don't want to annoy 
Amstrad, but anyone with enough clue might be able to take it from here".

I don't believe the actual steps needed were ever publicly posted (but I'd be 
happy to be pointed at a correction if I'm wrong).

> of the fun pbl functionality.

Is that "specific value" generic, or device-specific?

Antony.

-- 
In the Beginning there was nothing, which exploded.

 - Terry Pratchett

---

From: Nick Griffin <[email-masked]>
Date: Wed, 3 Apr 2019 16:35:58 +0000

Weed need to know how the Amstrad E3 or E2,E1 connected to Amserve and how it active itself when it did, has anyone got that file before the server when down, properly not.. lol someone must of know about the file…? its a .config file so its a configuration file so telling the E3 what to do.

From: Antony Stone<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎3‎ ‎April‎ ‎2019 ‎16‎:‎24
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

> Emailer can download it. https://nam02.safelinks.protection.outlook.com/?url=http%3A%2F%2F212.225.36.174%2Fdelta_e_live.config&amp;data=02%7C01%7C%7C532a092283a84e996e8808d6b8488464%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636899018949941886&amp;sdata=Tq7RVeAvpSlgbFrlj89bCr4k3H07M01uu5JWTRhz2gQ%3D&amp;reserved=0 and it

Antony.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://nam02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C532a092283a84e996e8808d6b8488464%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636899018949941886&amp;sdata=I73rqewySsB4wzKIP2vzq%2BDk7gPZrGaqomXbPRp0qO0%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Wed, 3 Apr 2019 17:07:34 +0000

As far as I know when you connect this to serial you don’t get a console, like if you connect TheC64 Mini to Putty using a CPC 2102 USB to TTL serial convertor, you can log on with your root user and password so you can add files, change games and edit files and that ,TheC64 Mini uses Uboot to boot up with not PBL so it must be the PBL that's stopping the console coming up so if we could hack the PBL (Primary Boot Loader) and keep the firmware on the NAND so its still boots up with Amstrad E3 logo and that, we need to see the system files and see what can be changed. PBL is on the NOR Flash and the Kernel and System is on the NAND Flash. I don’t know anything about PBL so we need someone who does.it all most works the same as TheC64 Mini,(Its a small Commodore 64, Mini Console, its here.. https://www.c64-wiki.com/wiki/THEC64Mini)  The mini has 2 partitions, One for Uboot and other for the Kernel and System. but only has one chip, NAND Flash, its made by Toshiba too.. 😊. Amstrad E3 has 2 chips NOR and NAND Flash. and is using a different Boot loader.

Oh.. Can I use my CPC 2102 USB to TTL serial converter to connect to the serial on the E3..? this is a pic of it here.. https://sc02.alicdn.com/kf/HTB11eb9PFXXXXcLaXXXq6xXFXXXd/CP2102-USB-2-0-to-TTL-UART.jpg_350x350.jpg I have used it on my TheC64 Mini and my Gotek Drive.

Spanner..

---

From: Jake Sloan <[email-masked]>
Date: Wed, 3 Apr 2019 18:41:52 +0100

> happy to be pointed at a correction if I'm wrong).

https://www.earth.li/pipermail/e3-hacking/2008-January/000795.html

That was about as far as I took it ..

Mr Lawson, iirc, mentioned the source data for the hash was a verse from 
the bible, which should collapse the keyspace quite a bit.

> Is that "specific value" generic, or device-specific?
bootloader specific, so will work for any 5.1 version.

O.

I should dig out whatever old E3 info I have stashed away somewhere and 
refresh my memory.

---

From: David Given <[email-masked]>
Date: Wed, 3 Apr 2019 19:51:57 +0200

I've got a tool which speaks the PBL protocol and will let you read and
write the flash: http://cowlark.com/amstrad/

It's also got details of the serial pinout.

On Wed, 3 Apr 2019 at 19:07 Nick Griffin <[email-masked]> wrote:

> As far as I know when you connect this to serial you don’t get a console,
> like if you connect TheC64 Mini to Putty using a CPC 2102 USB to TTL serial
> convertor, you can log on with your root user and password so you can add
> files, change games and edit files and that ,TheC64 Mini uses Uboot to boot
> up with not PBL so it must be the PBL that's stopping the console coming up
> so if we could hack the PBL (Primary Boot Loader) and keep the firmware on
> the NAND so its still boots up with Amstrad E3 logo and that, we need to
> see the system files and see what can be changed. PBL is on the NOR Flash
> and the Kernel and System is on the NAND Flash. I don’t know anything about
> PBL so we need someone who does.it all most works the same as TheC64
> Mini,(Its a small Commodore 64, Mini Console, its here..
> https://www.c64-wiki.com/wiki/THEC64Mini)  The mini has 2 partitions, One
> for Uboot and other for the Kernel and System. but only has one chip, NAND
> Flash, its made by Toshiba too.. 😊. Amstrad E3 has 2 chips NOR and NAND
> Flash. and is using a different Boot loader.
>
> Oh.. Can I use my CPC 2102 USB to TTL serial converter to connect to the
> serial on the E3..? this is a pic of it here..
> *https://sc02.alicdn.com/kf/HTB11eb9PFXXXXcLaXXXq6xXFXXXd/CP2102-USB-2-0-to-TTL-UART.jpg_350x350.jpg*
> <https://sc02.alicdn.com/kf/HTB11eb9PFXXXXcLaXXXq6xXFXXXd/CP2102-USB-2-0-to-TTL-UART.jpg_350x350.jpg> I
> have used it on my TheC64 Mini and my Gotek Drive.
>
> Spanner..
> https://www.earth.li/mailman/listinfo/e3-hacking
>

---

From: Antony Stone <[email-masked]>
Date: Wed, 3 Apr 2019 20:39:48 +0200

> write the flash: http://cowlark.com/amstrad/

Thanks for (re?) posting this link to a very useful tool.

Antony.

-- 
This space intentionally has nothing but text explaining why this space has 
nothing but text explaining that this space would otherwise have been left 
blank, and would otherwise have been left blank.

---

From: Nick Griffin <[email-masked]>
Date: Wed, 3 Apr 2019 18:52:38 +0000

On your site..
“In order to talk to the E2, you need the appropriate cable. Irritatingly, while the E2 has a serial port, it runs at TTL line levels not RS232 levels. This means that if you're going to connect it to a PC, you need a line level converter”

So I can use a CPC 2102 USB to TTL serial converter because its a line level converter… 😊 and its RX line is 3.3 volt, this can’t take 5 volts because it could blow the UART0…?

Spanner..

From: David Given<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎3‎ ‎April‎ ‎2019 ‎18‎:‎52
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

I've got a tool which speaks the PBL protocol and will let you read and write the flash: http://cowlark.com/amstrad/<https://nam04.safelinks.protection.outlook.com/?url=http://cowlark.com/amstrad/&data=02%7c01%7c%7c0ff5e97479d549450d8208d6b85d225c%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899107478251836&sdata=1rV57mYpj1Hs38RqCM3fqnEhqzLh5F3vWhwQWqW9AuM%3D&reserved=0>

On Wed, 3 Apr 2019 at 19:07 Nick Griffin <[email-masked]<mailto:[email-masked]>> wrote:
As far as I know when you connect this to serial you don’t get a console, like if you connect TheC64 Mini to Putty using a CPC 2102 USB to TTL serial convertor, you can log on with your root user and password so you can add files, change games and edit files and that ,TheC64 Mini uses Uboot to boot up with not PBL so it must be the PBL that's stopping the console coming up so if we could hack the PBL (Primary Boot Loader) and keep the firmware on the NAND so its still boots up with Amstrad E3 logo and that, we need to see the system files and see what can be changed. PBL is on the NOR Flash and the Kernel and System is on the NAND Flash. I don’t know anything about PBL so we need someone who does.it<https://nam04.safelinks.protection.outlook.com/?url=http://does.it&data=02%7c01%7c%7c0ff5e97479d549450d8208d6b85d225c%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899107478261846&sdata=cKbkujL//PuqTj5W5Dtacrb2GoLLKmqXMA81FjPrIDE%3D&reserved=0> all most works the same as TheC64 Mini,(Its a small Commodore 64, Mini Console, its here.. https://www.c64-wiki.com/wiki/THEC64Mini<https://nam04.safelinks.protection.outlook.com/?url=https://www.c64-wiki.com/wiki/THEC64Mini&data=02%7c01%7c%7c0ff5e97479d549450d8208d6b85d225c%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899107478271851&sdata=bd45fNPeGF/ASugX1AaQYewd6OIAxHko0Z9iDRsRAbI%3D&reserved=0>)  The mini has 2 partitions, One for Uboot and other for the Kernel and System. but only has one chip, NAND Flash, its made by Toshiba too.. 😊. Amstrad E3 has 2 chips NOR and NAND Flash. and is using a different Boot loader.

Oh.. Can I use my CPC 2102 USB to TTL serial converter to connect to the serial on the E3..? this is a pic of it here.. https://sc02.alicdn.com/kf/HTB11eb9PFXXXXcLaXXXq6xXFXXXd/CP2102-USB-2-0-to-TTL-UART.jpg_350x350.jpg<https://nam04.safelinks.protection.outlook.com/?url=https://sc02.alicdn.com/kf/HTB11eb9PFXXXXcLaXXXq6xXFXXXd/CP2102-USB-2-0-to-TTL-UART.jpg_350x350.jpg&data=02%7c01%7c%7c0ff5e97479d549450d8208d6b85d225c%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899107478281862&sdata=P8EsfPfMK3uzbtWcuKbOcwf1gTPEVk3IFhNWzhTzLIk%3D&reserved=0> I have used it on my TheC64 Mini and my Gotek Drive.

Spanner..
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://nam04.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c0ff5e97479d549450d8208d6b85d225c%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899107478291867&sdata=1y6cn51sOKEHHpvkAfK37Sm4yBmS3QNSEadRK1KH6dY%3D&reserved=0>

---

From: David Given <[email-masked]>
Date: Wed, 3 Apr 2019 20:56:48 +0200

RS232 is actually +/- 12V! My recollection is that the E3 runs at 0V/5V (I
described it as TTL back in 2003). A 3.3V serial converter might work, I
couldn't say.
On Wed, 3 Apr 2019 at 20:52 Nick Griffin <[email-masked]> wrote:

> On your site..
> “In order to talk to the E2, you need the appropriate cable. Irritatingly,
> while the E2 has a serial port, it runs at TTL line levels not RS232
> levels. This means that if you're going to connect it to a PC, you need a
> line level converter”
>
> So I can use a CPC 2102 USB to TTL serial converter because its a line
> level converter… 😊 and its RX line is 3.3 volt, this can’t take 5
> volts because it could blow the UART0…?
>
> Spanner..
>
> *From:* David Given <[email-masked]>
> *Sent:* ‎Wednesday‎, ‎3‎ ‎April‎ ‎2019 ‎18‎:‎52
> *To:* Discussion of the Amstrad E3 emailer hardware/software
> <[email-masked]>
>
> <https://nam04.safelinks.protection.outlook.com/?url=http://cowlark.com/amstrad/&data=02%7c01%7c%7c0ff5e97479d549450d8208d6b85d225c%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899107478251836&sdata=1rV57mYpj1Hs38RqCM3fqnEhqzLh5F3vWhwQWqW9AuM%3D&reserved=0>
>
>
>> PBL so we need someone who does.it
>> <https://nam04.safelinks.protection.outlook.com/?url=http://does.it&data=02%7c01%7c%7c0ff5e97479d549450d8208d6b85d225c%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899107478261846&sdata=cKbkujL//PuqTj5W5Dtacrb2GoLLKmqXMA81FjPrIDE%3D&reserved=0>
>> all most works the same as TheC64 Mini,(Its a small Commodore 64, Mini
>> Console, its here.. https://www.c64-wiki.com/wiki/THEC64Mini
>> <https://nam04.safelinks.protection.outlook.com/?url=https://www.c64-wiki.com/wiki/THEC64Mini&data=02%7c01%7c%7c0ff5e97479d549450d8208d6b85d225c%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899107478271851&sdata=bd45fNPeGF/ASugX1AaQYewd6OIAxHko0Z9iDRsRAbI%3D&reserved=0>)
>> The mini has 2 partitions, One for Uboot and other for the Kernel and
>> System. but only has one chip, NAND Flash, its made by Toshiba too.. 😊.
>> Amstrad E3 has 2 chips NOR and NAND Flash. and is using a different Boot
>> loader.
>>
>> <https://nam04.safelinks.protection.outlook.com/?url=https://sc02.alicdn.com/kf/HTB11eb9PFXXXXcLaXXXq6xXFXXXd/CP2102-USB-2-0-to-TTL-UART.jpg_350x350.jpg&data=02%7c01%7c%7c0ff5e97479d549450d8208d6b85d225c%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899107478281862&sdata=P8EsfPfMK3uzbtWcuKbOcwf1gTPEVk3IFhNWzhTzLIk%3D&reserved=0> I
>> <https://nam04.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c0ff5e97479d549450d8208d6b85d225c%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899107478291867&sdata=1y6cn51sOKEHHpvkAfK37Sm4yBmS3QNSEadRK1KH6dY%3D&reserved=0>
>>

---

From: Nick Griffin <[email-masked]>
Date: Wed, 3 Apr 2019 19:15:20 +0000

The Amstrad E3 lasted 3 months for it deactivated itself and it had games on it so recorded them before they disappeared. Tetris and Space Invaders.

https://www.youtube.com/watch?v=d9tS0rgrt0E

Spanner..

---

From: Nick Griffin <[email-masked]>
Date: Wed, 3 Apr 2019 19:51:53 +0000

OK, thanks, I was looking at this site.. http://www.cambridgewargames.org.uk/members/andy/emailer/

It says on here 3.3v device so was guessing it would work but I don’t understand the inverting the TX Line, would I need to do that with this..? I was reding this…

”Amstrad emailer E3 serial port (18/01/06)

A fair bit of confusion exists on the serial port of the E3 with some sources saying a line driver chip is needed, and other saying one is not needed, to connect this to a PC.

I've spent a bit of time looking at this and can now offer some explanation. A normal RS232 port will transmit a digital 1 as a negative voltage, usually at least -5V. A 0 is transmitted as a positive voltage, typically at least +5V. The emailer does not do this. Using a rather old poorly calibrated scope it appears to actually transmits either 0V or +5V.

Now some serial ports will probably accept this, but a 0V input is not a logical anything as far as the RS232 spec is concerned. So your PC, like mine, may ignore this. The fact that this works for some peoples PCs implies it is transmitting a logical 1 as 0v and a logical 0 as +5V.

A typical RS232 line driver expects a logical 0 to be 0v and a logical 1 to be +5v (or +3.3V if using a 3.3v device). So you end up with an inverted RS232 data and like me and see horrible gibberish on hyperterminal

Now, to get a boot log you need to invert the TX signal from the E3 (I used a 74HC04) then pass this to a line driver chip. The only line driver chip I had to hand was a MAX3233E, which is a 3.3 volt part. For this reason I ran both chips from 3.3V and placed a 100ohm resistor between the E3's TX pin nad the input to the inverter. Some logic families get very upset if you exceed the supply voltage on an input by more than about 0.6v... The series resistor limits the current and is a paranoia measure, quicker than looking up the datasheet :-) Anyway, it was a horrible quick bodge but it worked.

Here is the output captured from hyperterminal boot.txt<http://www.cambridgewargames.org.uk/members/andy/emailer/boot.txt> settings were 115,200 8n1 no handshaking.

I'll try and post up a diagram of something better in the next few days. I've also built something for the reverse direction but havent had a chance to work out if its working yet....”

I do have one made by FTDI too a FTDI FT232RL FT232 USB to TTL 5v 3.3v serial adaptor that has 3.3 v and 5v, it has a jumper to change voltage on RX Line, what about that one..? https://www.xcluma.com/ftdi-ft232rl-ft232-usb-to-ttl-5v-3.3v-serial-adaptor-for-arduino
There is no info on using one of theses because in 2006 they didn’t exsits.. 😊
They exist now because of Raspberry PI and Arduino, The Amstrad Emailer uses a singer board computer inside it, The RPI and Arduino are what has become of the technology the Emailer uses. The mini consoles use the technology too.

Spanner..

From: David Given<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎3‎ ‎April‎ ‎2019 ‎19‎:‎57
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

RS232 is actually +/- 12V! My recollection is that the E3 runs at 0V/5V (I described it as TTL back in 2003). A 3.3V serial converter might work, I couldn't say.
On Wed, 3 Apr 2019 at 20:52 Nick Griffin <[email-masked]<mailto:[email-masked]>> wrote:
On your site..
“In order to talk to the E2, you need the appropriate cable. Irritatingly, while the E2 has a serial port, it runs at TTL line levels not RS232 levels. This means that if you're going to connect it to a PC, you need a line level converter”

Spanner..

I've got a tool which speaks the PBL protocol and will let you read and write the flash: http://cowlark.com/amstrad/<https://nam03.safelinks.protection.outlook.com/?url=http://cowlark.com/amstrad/&data=02%7c01%7c%7c09f58ed443864a97d08808d6b86632a2%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899146427885270&sdata=ZTUttHYZe8W%2Bp6P%2BIDBCIg1vQDqKRwzM9y4Mrf%2B4HAw%3D&reserved=0>

On Wed, 3 Apr 2019 at 19:07 Nick Griffin <[email-masked]<mailto:[email-masked]>> wrote:
As far as I know when you connect this to serial you don’t get a console, like if you connect TheC64 Mini to Putty using a CPC 2102 USB to TTL serial convertor, you can log on with your root user and password so you can add files, change games and edit files and that ,TheC64 Mini uses Uboot to boot up with not PBL so it must be the PBL that's stopping the console coming up so if we could hack the PBL (Primary Boot Loader) and keep the firmware on the NAND so its still boots up with Amstrad E3 logo and that, we need to see the system files and see what can be changed. PBL is on the NOR Flash and the Kernel and System is on the NAND Flash. I don’t know anything about PBL so we need someone who does.it<https://nam03.safelinks.protection.outlook.com/?url=http://does.it&data=02%7c01%7c%7c09f58ed443864a97d08808d6b86632a2%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899146427895281&sdata=m1xYQJZEIyNyS4SWf7kDZ%2BZO6CGhFKUgU3%2BBedRPN3I%3D&reserved=0> all most works the same as TheC64 Mini,(Its a small Commodore 64, Mini Console, its here.. https://www.c64-wiki.com/wiki/THEC64Mini<https://nam03.safelinks.protection.outlook.com/?url=https://www.c64-wiki.com/wiki/THEC64Mini&data=02%7c01%7c%7c09f58ed443864a97d08808d6b86632a2%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899146427905286&sdata=lecxYohNL06ij7PeSWsWCsz4fEUgCHizc0HgJXTo%2Buc%3D&reserved=0>)  The mini has 2 partitions, One for Uboot and other for the Kernel and System. but only has one chip, NAND Flash, its made by Toshiba too.. 😊. Amstrad E3 has 2 chips NOR and NAND Flash. and is using a different Boot loader.

Oh.. Can I use my CPC 2102 USB to TTL serial converter to connect to the serial on the E3..? this is a pic of it here.. https://sc02.alicdn.com/kf/HTB11eb9PFXXXXcLaXXXq6xXFXXXd/CP2102-USB-2-0-to-TTL-UART.jpg_350x350.jpg<https://nam03.safelinks.protection.outlook.com/?url=https://sc02.alicdn.com/kf/HTB11eb9PFXXXXcLaXXXq6xXFXXXd/CP2102-USB-2-0-to-TTL-UART.jpg_350x350.jpg&data=02%7c01%7c%7c09f58ed443864a97d08808d6b86632a2%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899146427915291&sdata=KroTh2plWQe%2BxRae/OKV%2BnUB/C%2BXTMrTgayWOyOxHR0%3D&reserved=0> I have used it on my TheC64 Mini and my Gotek Drive.

Spanner..
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://nam03.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c09f58ed443864a97d08808d6b86632a2%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899146427925302&sdata=M7M89b3As6E8QlWFY7Sn0dCFF2Pz/bdHoz5%2BpVm22mw%3D&reserved=0>
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://nam03.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c09f58ed443864a97d08808d6b86632a2%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899146427935307&sdata=VtxiLX0xNAl1drhDPS1n5ZQGUjbALCZhxh8AFYzf5W4%3D&reserved=0>

---

From: Nick Griffin <[email-masked]>
Date: Wed, 3 Apr 2019 20:40:57 +0000

There is 2 reason why I want to do this..
1.) So I can find a way to restore its services and be able to use it like a normal phone and maybe more.
2.)I have a Amstrad Emailer Plus(E2) too, Its has the Configuration Change on it, if I can back up its Nan then I can share the back up who want to get there's working that's deactivated(Locked) and be able to use it like a normal phone too.. 😊

I have a go at getting it working tomorrow.

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎3‎ ‎April‎ ‎2019 ‎20‎:‎52
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

OK, thanks, I was looking at this site.. http://www.cambridgewargames.org.uk/members/andy/emailer/<https://eur03.safelinks.protection.outlook.com/?url=http://www.cambridgewargames.org.uk/members/andy/emailer/&data=02%7c01%7c%7cc50113d7016041be38d508d6b86ddbf5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899179308605202&sdata=zDMBbvlEKuNMEGdkRXFdUSmjFj/tSiXcoAokoZGATkw%3D&reserved=0>

Here is the output captured from hyperterminal boot.txt<https://eur03.safelinks.protection.outlook.com/?url=http://www.cambridgewargames.org.uk/members/andy/emailer/boot.txt&data=02%7c01%7c%7cc50113d7016041be38d508d6b86ddbf5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899179308625218&sdata=OUBqGj0EApDvIHRdhvvmZg35n7k6/Dr9tadAv5z%2BzGc%3D&reserved=0> settings were 115,200 8n1 no handshaking.

I do have one made by FTDI too a FTDI FT232RL FT232 USB to TTL 5v 3.3v serial adaptor that has 3.3 v and 5v, it has a jumper to change voltage on RX Line, what about that one..? https://www.xcluma.com/ftdi-ft232rl-ft232-usb-to-ttl-5v-3.3v-serial-adaptor-for-arduino<https://eur03.safelinks.protection.outlook.com/?url=https://www.xcluma.com/ftdi-ft232rl-ft232-usb-to-ttl-5v-3.3v-serial-adaptor-for-arduino&data=02%7c01%7c%7cc50113d7016041be38d508d6b86ddbf5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899179308635223&sdata=m4ppt5/iAq8M6841kX3u3si/KxGiO5JzCWse1n5xmoU%3D&reserved=0>
There is no info on using one of theses because in 2006 they didn’t exsits.. 😊
They exist now because of Raspberry PI and Arduino, The Amstrad Emailer uses a singer board computer inside it, The RPI and Arduino are what has become of the technology the Emailer uses. The mini consoles use the technology too.

Spanner..

Spanner..

I've got a tool which speaks the PBL protocol and will let you read and write the flash: http://cowlark.com/amstrad/<https://eur03.safelinks.protection.outlook.com/?url=http://cowlark.com/amstrad/&data=02%7c01%7c%7cc50113d7016041be38d508d6b86ddbf5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899179308645228&sdata=N6frWE0wYMl19JThGTV17ul8SQlXYtAXFbGXUwOYfkg%3D&reserved=0>

On Wed, 3 Apr 2019 at 19:07 Nick Griffin <[email-masked]<mailto:[email-masked]>> wrote:
As far as I know when you connect this to serial you don’t get a console, like if you connect TheC64 Mini to Putty using a CPC 2102 USB to TTL serial convertor, you can log on with your root user and password so you can add files, change games and edit files and that ,TheC64 Mini uses Uboot to boot up with not PBL so it must be the PBL that's stopping the console coming up so if we could hack the PBL (Primary Boot Loader) and keep the firmware on the NAND so its still boots up with Amstrad E3 logo and that, we need to see the system files and see what can be changed. PBL is on the NOR Flash and the Kernel and System is on the NAND Flash. I don’t know anything about PBL so we need someone who does.it<https://eur03.safelinks.protection.outlook.com/?url=http://does.it&data=02%7c01%7c%7cc50113d7016041be38d508d6b86ddbf5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899179308655245&sdata=8UZdLqM5pNVmuKUId0Z6DfzP%2BfN8nRfg4Bldo1cYYP0%3D&reserved=0> all most works the same as TheC64 Mini,(Its a small Commodore 64, Mini Console, its here.. https://www.c64-wiki.com/wiki/THEC64Mini<https://eur03.safelinks.protection.outlook.com/?url=https://www.c64-wiki.com/wiki/THEC64Mini&data=02%7c01%7c%7cc50113d7016041be38d508d6b86ddbf5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899179308665244&sdata=jDpZ%2BY8H9VejOHHIyT6bgRDRgoqh0HKMYultFQdX6%2BU%3D&reserved=0>)  The mini has 2 partitions, One for Uboot and other for the Kernel and System. but only has one chip, NAND Flash, its made by Toshiba too.. 😊. Amstrad E3 has 2 chips NOR and NAND Flash. and is using a different Boot loader.

Oh.. Can I use my CPC 2102 USB to TTL serial converter to connect to the serial on the E3..? this is a pic of it here.. https://sc02.alicdn.com/kf/HTB11eb9PFXXXXcLaXXXq6xXFXXXd/CP2102-USB-2-0-to-TTL-UART.jpg_350x350.jpg<https://eur03.safelinks.protection.outlook.com/?url=https://sc02.alicdn.com/kf/HTB11eb9PFXXXXcLaXXXq6xXFXXXd/CP2102-USB-2-0-to-TTL-UART.jpg_350x350.jpg&data=02%7c01%7c%7cc50113d7016041be38d508d6b86ddbf5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899179308675255&sdata=jgPvSV2Dt5JyFTBhUCKufS2xOPxdlwNSriXHkTnmgQ4%3D&reserved=0> I have used it on my TheC64 Mini and my Gotek Drive.

Spanner..
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://eur03.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7cc50113d7016041be38d508d6b86ddbf5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899179308685266&sdata=QJj3kjxdqs0bmwzmyBmEkf4yqTw08XkP8x0gTnxqvtE%3D&reserved=0>
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://eur03.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7cc50113d7016041be38d508d6b86ddbf5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899179308695270&sdata=AGDCFmB5lhDcRN7mQwkp5ih74i5U9B/L7i5sXeAitF8%3D&reserved=0>

---

From: Nick Griffin <[email-masked]>
Date: Wed, 3 Apr 2019 21:26:04 +0000

Can you use a USB Ethernet Dongle by plugging it into the USB port..?
If so how did you use one, it will not work with mine at the moment will it.

Looking at the mailing list there was someone from Amstrad called Cliff Lawson commenting,shame he's not here now.He could help unlocking the E3 now ..😊
Has anyone tried a USB HUB..??

Spanner..

---

From: David Given <[email-masked]>
Date: Thu, 4 Apr 2019 00:36:07 +0200

Okay, so this is unclear. That article's talking about connecting the
emailer via actual RS232 via a TTL-to-RS232 level converter. Nobody does
this any more; instead you use a USB TTL serial adapter. But it sounds like
the emailer's output levels are inverted, so logic 1 is 0V and logic 0 is
5V.

I have no memory of this whatsoever --- but this was years ago.

*Don't* connect the emailer directly to a RS232 port. You'll fry it. RS232
voltages are +/- 12V and are way too high. (I killed mine that way.)

I definitely had the thing working with the cable pictured on my website,
but I have no idea whether that chip emits inverted signals or not. I'm
afraid you'll just have to try it and see what happens.

On Wed, 3 Apr 2019 at 22:41 Nick Griffin <[email-masked]> wrote:

> 2.)I have a Amstrad Emailer Plus(E2) too, Its has the Configuration Change
> on it, if I can back up its Nan then I can share the back up who want
> to get there's working that's deactivated(Locked) and be able to use it
> like a normal phone too.. 😊
>
> *From:* Nick Griffin <[email-masked]>
> *Sent:* ‎Wednesday‎, ‎3‎ ‎April‎ ‎2019 ‎20‎:‎52
> OK, thanks, I was looking at this site..
> http://www.cambridgewargames.org.uk/members/andy/emailer/
> <https://eur03.safelinks.protection.outlook.com/?url=http://www.cambridgewargames.org.uk/members/andy/emailer/&data=02%7c01%7c%7cc50113d7016041be38d508d6b86ddbf5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899179308605202&sdata=zDMBbvlEKuNMEGdkRXFdUSmjFj/tSiXcoAokoZGATkw%3D&reserved=0>
>
> It says on here 3.3v device so was guessing it would work but I don’t
> understand the inverting the TX Line, would I need to do that with this..?
> I was reding this…
>
> A fair bit of confusion exists on the serial port of the E3 with some
> sources saying a line driver chip is needed, and other saying one is not
> needed, to connect this to a PC.
>
> I've spent a bit of time looking at this and can now offer some
> explanation. A normal RS232 port will transmit a digital 1 as a negative
> voltage, usually at least -5V. A 0 is transmitted as a positive voltage,
> typically at least +5V. The emailer does *not* do this. Using a rather
> old poorly calibrated scope it appears to actually transmits either 0V or
> +5V.
>
> Now some serial ports will probably accept this, but a 0V input is not a
> logical anything as far as the RS232 spec is concerned. So your PC, like
> mine, may ignore this. The fact that this works for some peoples PCs
> implies it is transmitting a logical 1 as 0v and a logical 0 as +5V.
>
> A typical RS232 line driver expects a logical 0 to be 0v and a logical 1
> to be +5v (or +3.3V if using a 3.3v device). So you end up with an inverted
> RS232 data and like me and see horrible gibberish on hyperterminal
>
> Now, to get a boot log you need to invert the TX signal from the E3 (I
> used a 74HC04) then pass this to a line driver chip. The only line driver
> chip I had to hand was a MAX3233E, which is a 3.3 volt part. For this
> reason I ran both chips from 3.3V and placed a 100ohm resistor between the
> E3's TX pin nad the input to the inverter. Some logic families get very
> upset if you exceed the supply voltage on an input by more than about
> 0.6v... The series resistor limits the current and is a paranoia measure,
> quicker than looking up the datasheet :-) Anyway, it was a horrible quick
> bodge but it worked.
>
> Here is the output captured from hyperterminal *boot.txt*
> <https://eur03.safelinks.protection.outlook.com/?url=http://www.cambridgewargames.org.uk/members/andy/emailer/boot.txt&data=02%7c01%7c%7cc50113d7016041be38d508d6b86ddbf5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899179308625218&sdata=OUBqGj0EApDvIHRdhvvmZg35n7k6/Dr9tadAv5z%2BzGc%3D&reserved=0>
>  settings were 115,200 8n1 no handshaking.
>
> I'll try and post up a diagram of something better in the next few days.
> I've also built something for the reverse direction but havent had a chance
> to work out if its working yet....”
>
> I do have one made by FTDI too a FTDI FT232RL FT232 USB to TTL 5v 3.3v
> serial adaptor that has 3.3 v and 5v, it has a jumper to change voltage on
> RX Line, what about that one..?
> https://www.xcluma.com/ftdi-ft232rl-ft232-usb-to-ttl-5v-3.3v-serial-adaptor-for-arduino
> <https://eur03.safelinks.protection.outlook.com/?url=https://www.xcluma.com/ftdi-ft232rl-ft232-usb-to-ttl-5v-3.3v-serial-adaptor-for-arduino&data=02%7c01%7c%7cc50113d7016041be38d508d6b86ddbf5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899179308635223&sdata=m4ppt5/iAq8M6841kX3u3si/KxGiO5JzCWse1n5xmoU%3D&reserved=0>
> They exist now because of Raspberry PI and Arduino, The Amstrad Emailer
> uses a singer board computer inside it, The RPI and Arduino are what has
> become of the technology the Emailer uses. The mini consoles use the
> technology too.
>
> Spanner..
>
> *Sent:* ‎Wednesday‎, ‎3‎ ‎April‎ ‎2019 ‎19‎:‎57
>> “In order to talk to the E2, you need the appropriate cable.
>> Irritatingly, while the E2 has a serial port, it runs at TTL line levels
>> not RS232 levels. This means that if you're going to connect it to a PC,
>> you need a line level converter”
>>
>> <https://eur03.safelinks.protection.outlook.com/?url=http://cowlark.com/amstrad/&data=02%7c01%7c%7cc50113d7016041be38d508d6b86ddbf5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899179308645228&sdata=N6frWE0wYMl19JThGTV17ul8SQlXYtAXFbGXUwOYfkg%3D&reserved=0>
>>
>>
>>> As far as I know when you connect this to serial you don’t get a
>>> console, like if you connect TheC64 Mini to Putty using a CPC 2102 USB to
>>> TTL serial convertor, you can log on with your root user and password so
>>> you can add files, change games and edit files and that ,TheC64 Mini uses
>>> Uboot to boot up with not PBL so it must be the PBL that's stopping the
>>> console coming up so if we could hack the PBL (Primary Boot Loader) and
>>> keep the firmware on the NAND so its still boots up with Amstrad E3 logo
>>> and that, we need to see the system files and see what can be changed. PBL
>>> is on the NOR Flash and the Kernel and System is on the NAND Flash. I don’t
>>> know anything about PBL so we need someone who does.it
>>> <https://eur03.safelinks.protection.outlook.com/?url=http://does.it&data=02%7c01%7c%7cc50113d7016041be38d508d6b86ddbf5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899179308655245&sdata=8UZdLqM5pNVmuKUId0Z6DfzP%2BfN8nRfg4Bldo1cYYP0%3D&reserved=0>
>>> <https://eur03.safelinks.protection.outlook.com/?url=https://www.c64-wiki.com/wiki/THEC64Mini&data=02%7c01%7c%7cc50113d7016041be38d508d6b86ddbf5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899179308665244&sdata=jDpZ%2BY8H9VejOHHIyT6bgRDRgoqh0HKMYultFQdX6%2BU%3D&reserved=0>)
>>> <https://eur03.safelinks.protection.outlook.com/?url=https://sc02.alicdn.com/kf/HTB11eb9PFXXXXcLaXXXq6xXFXXXd/CP2102-USB-2-0-to-TTL-UART.jpg_350x350.jpg&data=02%7c01%7c%7cc50113d7016041be38d508d6b86ddbf5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899179308675255&sdata=jgPvSV2Dt5JyFTBhUCKufS2xOPxdlwNSriXHkTnmgQ4%3D&reserved=0> I
>>> <https://eur03.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7cc50113d7016041be38d508d6b86ddbf5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899179308685266&sdata=QJj3kjxdqs0bmwzmyBmEkf4yqTw08XkP8x0gTnxqvtE%3D&reserved=0>
>>>
>> <https://eur03.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7cc50113d7016041be38d508d6b86ddbf5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899179308695270&sdata=AGDCFmB5lhDcRN7mQwkp5ih74i5U9B/L7i5sXeAitF8%3D&reserved=0>
>>

---

From: David Given <[email-masked]>
Date: Thu, 4 Apr 2019 00:37:08 +0200

Oh yeah, there's more information here.
http://www.earth.li/~noodles/hardware-e3.html

On Thu, 4 Apr 2019 at 00:36 David Given <[email-masked]> wrote:

> *Don't* connect the emailer directly to a RS232 port. You'll fry it.
> RS232 voltages are +/- 12V and are way too high. (I killed mine that way.)
>
>> 2.)I have a Amstrad Emailer Plus(E2) too, Its has the Configuration
>> Change on it, if I can back up its Nan then I can share the back up who
>> want to get there's working that's deactivated(Locked) and be able to use
>> it like a normal phone too.. 😊
>>
>> RS232 is actually +/- 12V! My recollection is that the E3 runs at 0V/5V
>> (I described it as TTL back in 2003). A 3.3V serial converter might work, I
>> couldn't say.
>>>> Oh.. Can I use my CPC 2102 USB to TTL serial converter to connect to
>>>> the serial on the E3..? this is a pic of it here..

---

From: Ralph Corderoy <[email-masked]>
Date: Thu, 04 Apr 2019 00:28:09 +0100

Hi,

> http://www.earth.li/~noodles/hardware-e3.html

And there might still be some useful information amongst my old pages.
https://inputplus.co.uk/ralph/emailer/

-- 
Cheers, Ralph.

---

From: Brian Walton <[email-masked]>
Date: Thu, 4 Apr 2019 08:19:35 +0100

If the E3 has a TTL serial port as reported here then a USB to TTL serial
adapter should work fine. No need for line drivers or level adjustment, nor
any need for inverters. Just connect it straight through. These USB to TTL
serial are very common and cheap because they don't have the MAX232 (or
similar) conversion chips. Wire:

GND --- GND
TX --- RX
RX --- TX

Do not use a real RS233 port as it will use higher (and lower) voltage and
be inverted.

These cheap USB serial devices are a couple of quid on eBay.

Walt

---

From: Sean Furey <[email-masked]>
Date: Thu, 4 Apr 2019 10:20:18 +0100

On Thu, Apr 04, 2019 at 08:19:35AM +0100, Brian Walton wrote:
> adapter should work fine.

I seem to remember the logic levels used by the E3 to be the reverse of what is normally used for TTL serial, hence the need for an invertor.  Don't know if the USB TTL serial devices support that variation.

When I briefly was playing with this a long time ago I used:

- USB to RS232
- MAX (of some sort) to level shift to TTL
- MAX (well same one, it had two sets of level shifters) to level shift back to RS232
- E3

>From what I remember, the MAX was liberal enough on the RS232 rx side attached to the E3 tx line to cope with the non-RS232 levels.  As for the E3 rx line, I presume it coped ok, but in hindsight I'm a little surprised.

Sean

---

From: Sean Furey <[email-masked]>
Date: Thu, 4 Apr 2019 10:22:46 +0100

On Wed, Apr 03, 2019 at 09:26:04PM +0000, Nick Griffin wrote:
> Looking at the mailing list there was someone from Amstrad called Cliff Lawson commenting,shame he's not here now.He could help unlocking the E3 now ..

Cliff mentioned using USB ethernet, but in the context of replacing the firmware with your own code.  I don't believe he ever suggested the amstrad firmware supported it.

Sean

---

From: David Given <[email-masked]>
Date: Thu, 4 Apr 2019 12:18:56 +0200

Provided the E3 and the USB device ran off isolated supplies, you might be
able to get away with connecting the 5V (or whatever) on the USB adapter to
the GND on the jack. That would cause the logic levels to be interpreted
inverted.

Note, this does not constitute advice, not responsible for any device
destruction caused by doing this, etc...

On Thu, 4 Apr 2019, 11:51 Sean Furey, <[email-masked]>
wrote:

> I seem to remember the logic levels used by the E3 to be the reverse of
> what is normally used for TTL serial, hence the need for an invertor.
> Don't know if the USB TTL serial devices support that variation.
>
> From what I remember, the MAX was liberal enough on the RS232 rx side
> attached to the E3 tx line to cope with the non-RS232 levels.  As for the
> E3 rx line, I presume it coped ok, but in hindsight I'm a little surprised.
>
> Sean
>

---

From: Nick Griffin <[email-masked]>
Date: Thu, 4 Apr 2019 11:11:18 +0000

Thanks for the advice people.. 😊
I don’t have RS232 on my PC, I only use USB to TTL on it.
Do I use a headphone jack that's mono so it only has 3 connections on it, not a stereo one, any one got a pic of it so I know what to get(I know what it looks like just need to see if it a normal headphone mono jack),I might have one in my wire draw.. 😊

Spanner..

From: David Given<mailto:[email-masked]>
Sent: ‎Thursday‎, ‎4‎ ‎April‎ ‎2019 ‎11‎:‎19
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Provided the E3 and the USB device ran off isolated supplies, you might be able to get away with connecting the 5V (or whatever) on the USB adapter to the GND on the jack. That would cause the logic levels to be interpreted inverted.

Note, this does not constitute advice, not responsible for any device destruction caused by doing this, etc...

On Thu, 4 Apr 2019, 11:51 Sean Furey, <[email-masked]<mailto:[email-masked]>> wrote:

- USB to RS232

Sean

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://nam01.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c05328d160a5d4536978708d6b8e70303%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899699656647646&sdata=Y/n6vUszwD6OgKTbo0aAsJ1CMx9rJDJ2WwRpjhSHwBg%3D&reserved=0>

---

From: Nick Griffin <[email-masked]>
Date: Thu, 4 Apr 2019 11:11:26 +0000

Thanks, I guested that your would need your own firmware on the Emailer..😊

Spanner..

From: Sean Furey<mailto:[email-masked]>
Sent: ‎Thursday‎, ‎4‎ ‎April‎ ‎2019 ‎10‎:‎51
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Sean

_______________________________________________
e3-hacking mailing list
[email-masked]
https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C8c382f00bc0e423e070e08d6b8e326a5%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636899683072783477&amp;sdata=VqxQrT8VbKT5OssSsK8ezETOMGwkV3iVvaX%2FDWtlL2o%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Thu, 4 Apr 2019 11:50:00 +0000

Hi me again.. 😊 WOW I have lit this place up like a xmas tree… 😊
Does anyone know how the Emailer works when it deactivates itself (locks itself, I came up with the word activate/deactivate because that's what its doing when it stops its features on the Emailer, deactivated non functional)

I think it might be downloading a file or something so if it can’t download the file it deactivates the Emailer.

I would of done it that way because the file can be very small (bytes size) and quick to download in a couple of seconds.

And like how it removes its games after a week or four weeks, after a set time of not being able to connect to the server, it deletes the file and the Emailer then deactivates itself because the file is not there no more.
Mine took 3 months to deactivate, I remembered when I got it from eBay and turn it on, I had it on continually, but still have it on now. (but that's because the firmware has a bug in it so it lets you make a call on it even when it deactivated, more about that in another post)
The E3 its way better looking than the rest.. 😊 the E1 look better then the E2.

It does make senses, but I might be completely wrong, If you know how it works please post.

Thanks and have a great day.

Spanner..

---

From: Sean Furey <[email-masked]>
Date: Thu, 4 Apr 2019 13:28:58 +0100

> the GND on the jack. That would cause the logic levels to be interpreted

I'd have thought that would make the USB dev see the E3's 0V - 5V as 5V - 10V, and the E3 to see the USB's 0V - 5V as -5V - 0V.  Which doesn't sound like it helps - am I missing something?

Sean

---

From: David Given <[email-masked]>
Date: Thu, 4 Apr 2019 16:30:46 +0200

Yes, you're right, that's clearly nonsense.

Why would the E3 generate an inverted signal, anyway? If it's just the raw
output from the processor (which I think it is) then it should be standard
TTL levels, because it's supposed to be fed into something like a MAX232
for conversion to RS232 levels. Inverting it but leaving it at TTL seems
very odd.

On Thu, 4 Apr 2019, 14:25 Sean Furey, <[email-masked]>
wrote:

> I'd have thought that would make the USB dev see the E3's 0V - 5V as 5V -
> 10V, and the E3 to see the USB's 0V - 5V as -5V - 0V.  Which doesn't sound
> like it helps - am I missing something?
>
> Sean
>

---

From: Nick Griffin <[email-masked]>
Date: Thu, 4 Apr 2019 15:44:13 +0000

I have connected the CP2102 and I am getting garbage text in Putty..

 ▒▒▒▒▒y▒▒7▒w5'=▒▒▒_{g▒S▒▒▒▒{-'7▒▒▒▒▒▒}5w5;1▒myu▒▒▒▒▒▒▒e{▒c}cw▒▒▒▒V▒▒▒▒▒ii▒VW▒▒▒6▒g-%▒▒▒▒▒▒▒▒▒/▒y!75u#7▒▒▒▒▒▒▒▒▒/▒▒▒▒▒_{g▒▒▒▒▒▒▒▒▒▒▒▒▒▒gY▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒y▒▒/▒5%▒%!7'5▒'!=75▒▒gw[▒S▒▒▒▒{-'7▒▒▒▒▒▒}5▒e!7▒9=#▒▒▒▒▒▒▒▒▒▒!▒▒▒▒▒▒▒▒▒▒▒eue▒▒▒▒▒▒▒▒▒▒▒▒▒3'=/▒▒▒▒▒▒▒▒▒▒▒▒_}[eY▒▒▒▒▒▒▒▒▒▒▒▒▒3'=/▒▒▒▒▒▒▒▒▒▒▒▒gw[▒▒▒▒▒▒▒▒▒▒▒▒▒3'=/▒▒▒▒▒▒▒▒▒▒▒▒gmcUO▒▒▒▒▒▒▒▒▒▒▒▒▒3'=/▒▒▒▒▒▒▒▒▒▒▒▒▒Q▒+
                                               ▒▒'5▒▒▒▒▒9/59)-#1▒gw[▒S▒▒=▒▒▒▒▒▒▒▒▒▒▒='-5▒▒▒▒'!=7▒▒▒▒▒▒▒▒▒▒▒9/59)-#1▒gmcUO▒S▒▒=▒▒▒▒▒▒▒▒▒▒▒='-5▒▒▒▒'!=7▒▒▒▒▒▒▒▒▒▒▒9/59)-#1▒eue▒S▒▒=▒▒▒▒▒▒▒▒▒▒▒='-5▒▒▒▒'!=7▒▒▒s▒▒▒▒▒▒▒9/59)-#1▒_}[eY▒S▒▒=▒▒▒▒▒▒▒▒▒▒▒='-5▒▒▒▒'!=7▒▒▒▒▒▒▒▒▒▒뗿e!7'5▒557▒▒▒▒=▒='-7▒▒▒gw[▒/-#)▒1'!;='▒#%;53!/5%▒-▒▒▒▒▒s!#7▒%!7▒▒gmcUO▒▒S▒▒▒=▒▒▒▒▒▒▒▒▒▒▒s!#7▒%!7▒▒_}[eY▒▒S▒▒▒=▒▒▒▒▒▒▒▒▒▒▒g-#▒9!%%=#7▒'-#▒!▒57-▒▒▒▒s!#7▒%!7▒▒gmcUO▒▒S▒▒▒=▒▒▒▒▒▒▒▒▒▒▒U▒!#7▒▒▒g-#▒=▒=%▒▒}#
                                             *▒-#1▒g-#▒▒▒▒▒
                                                           ▒:▒▒

                                                               ▒-#1▒/5▒)5'▒▒▒Vi▒▒5▒▒▒▒▒▒A%'▒▒▒=%▒75'=▒▒75▒▒'-#▒▒▒▒W-7▒;▒▒--!#▒▒▒▒▒=9/-#5▒▒}eY▒wugW}▒ae}_▒▒▒▒▒▒J!75%▒5#=;'5▒▒▒▒▒a#▒#!75▒▒▒!='=15▒▒▒▒▒▒▒▒!#5▒▒▒▒▒▒▒▒▒▒=15▒▒▒!#5▒▒▒▒▒▒▒=15▒▒▒!#5▒▒▒5▒9%3▒▒▒▒#▒▒-#-▒▒=9%3▒-#5▒▒9!#!'5▒
▒75▒737;▒▒=%A%%!7A;=5▒▒▒▒sss▒▒▒▒=%A%%!7A-
                                         5▒▒sss▒%5%▒▒▒e▒=%A%!7A5
▒'!!▒▒▒▒dً▒▒{!1!em_Y▒▒YMIH▒h▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒▒!#!'5▒▒9!'!7%%
▒9!#3-17▒▒V]▒▒▒▒▒[S[▒▒VM▒▒:▒▒-55▒▒▒▒9▒▒▒▒▒▒▒▒▒▒▒▒▒▒-/▒#!▒5'▒!-!#▒5#=;'57▒▒▒Q(▒▒▒뺿▒333;▒▒▒▒▒▒-▒▒▒▒▒▒-▒=▒ae}_▒U}[W▒▒▒Q(▒▒▒뺿▒5;▒▒▒▒▒▒▒▒-▒▒▒▒▒▒-▒=~Y%=Yey▒▒HIOT▒9▒▒[Wy▒!5▒5▒755957▒▒▒*▒▒▒▒u#=;'-#1▒[Wy▒▒▒▒S:▒%5▒y'!9)▒w▒▒▒▒▒▒R▒JZ▒▒▒▒'!▒555▒▒;=9/▒▒▒▒▒▒▒ݵe▒▒7-#--='-
                  57▒▒▒▒▒[}e▒7-)▒!3▒▒▒▒▒i▒-
                                           5▒▒▒▒▒▒;'!9)-
                                                        5▒▒W▒u▒#▒s{▒▒9▒▒▒▒▒▒▒[-715[#▒▒m#9▒▒▒V
             Jj▒▒

Spanner..

From: David Given<mailto:[email-masked]>
Sent: ‎Thursday‎, ‎4‎ ‎April‎ ‎2019 ‎15‎:‎31
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Why would the E3 generate an inverted signal, anyway? If it's just the raw output from the processor (which I think it is) then it should be standard TTL levels, because it's supposed to be fed into something like a MAX232 for conversion to RS232 levels. Inverting it but leaving it at TTL seems very odd.

On Thu, 4 Apr 2019, 14:25 Sean Furey, <[email-masked]<mailto:[email-masked]>> wrote:

Sean

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://eur04.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c64dbfacfa42248ac2b5b08d6b90a3077%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899850738926902&sdata=rc92e4TFDT/922oXR4ZiH9TOiTuUHFWyOzVNjFa7fdk%3D&reserved=0>

---

From: Antony Stone <[email-masked]>
Date: Thu, 4 Apr 2019 17:47:21 +0200

> I have connected the CP2102 and I am getting garbage text in Putty..

That suggests the wrong baud rate to me.

Antony.

>  ▒▒▒▒▒y▒▒7▒w5'=▒▒▒_{g▒S▒▒▒▒{-'7▒▒▒▒▒▒}5w5;1▒myu▒▒▒▒▒▒▒e{▒c}cw▒▒▒▒V▒▒▒▒▒ii▒V
> W▒▒▒6▒g-%▒▒▒▒▒▒▒▒▒/▒y!75u#7▒▒▒▒▒▒▒▒▒/▒▒▒▒▒_{g▒▒▒▒▒▒▒▒▒▒▒▒▒▒gY▒▒▒▒▒▒▒▒▒▒▒▒▒▒
> ▒▒▒▒▒▒▒▒▒▒y▒▒/▒5%▒%!7'5▒'!=75▒▒gw[▒S▒▒▒▒{-'7▒▒▒▒▒▒}5▒e!7▒9=#▒▒▒▒▒▒▒▒▒▒!▒▒▒▒
> ▒▒▒▒▒▒▒eue▒▒▒▒▒▒▒▒▒▒▒▒▒3'=/▒▒▒▒▒▒▒▒▒▒▒▒_}[eY▒▒▒▒▒▒▒▒▒▒▒▒▒3'=/▒▒▒▒▒▒▒▒▒▒▒▒gw
> [▒▒▒▒▒▒▒▒▒▒▒▒▒3'=/▒▒▒▒▒▒▒▒▒▒▒▒gmcUO▒▒▒▒▒▒▒▒▒▒▒▒▒3'=/▒▒▒▒▒▒▒▒▒▒▒▒▒Q▒+
> ▒▒'5▒▒▒▒▒9/59)-#1▒gw[▒S▒▒=▒▒▒▒▒▒▒▒▒▒▒='-5▒▒▒▒'!=7▒▒▒▒▒▒▒▒▒▒▒9/59)-#1▒gmcUO
> ▒S▒▒=▒▒▒▒▒▒▒▒▒▒▒='-5▒▒▒▒'!=7▒▒▒▒▒▒▒▒▒▒▒9/59)-#1▒eue▒S▒▒=▒▒▒▒▒▒▒▒▒▒▒='-5▒▒▒▒
> '!=7▒▒▒s▒▒▒▒▒▒▒9/59)-#1▒_}[eY▒S▒▒=▒▒▒▒▒▒▒▒▒▒▒='-5▒▒▒▒'!=7▒▒▒▒▒▒▒▒▒▒뗿e!7'5▒5
> 57▒▒▒▒=▒='-7▒▒▒gw[▒/-#)▒1'!;='▒#%;53!/5%▒-▒▒▒▒▒s!#7▒%!7▒▒gmcUO▒▒S▒▒▒=▒▒▒▒▒▒
> ▒▒▒▒▒s!#7▒%!7▒▒_}[eY▒▒S▒▒▒=▒▒▒▒▒▒▒▒▒▒▒g-#▒9!%%=#7▒'-#▒!▒57-▒▒▒▒s!#7▒%!7▒▒gm
> cUO▒▒S▒▒▒=▒▒▒▒▒▒▒▒▒▒▒U▒!#7▒▒▒g-#▒=▒=%▒▒}# *▒-#1▒g-#▒▒▒▒▒
>                                                            ▒:▒▒
> 
>                                                               
> ▒-#1▒/5▒)5'▒▒▒Vi▒▒5▒▒▒▒▒▒A%'▒▒▒=%▒75'=▒▒75▒▒'-#▒▒▒▒W-7▒;▒▒--!#▒▒▒▒▒=9/-#5▒
> ▒}eY▒wugW}▒ae}_▒▒▒▒▒▒J!75%▒5#=;'5▒▒▒▒▒a#▒#!75▒▒▒!='=15▒▒▒▒▒▒▒▒!#5▒▒▒▒▒▒▒▒▒▒
> =15▒▒▒!#5▒▒▒▒▒▒▒=15▒▒▒!#5▒▒▒5▒9%3▒▒▒▒#▒▒-#-▒▒=9%3▒-#5▒▒9!#!'5▒
> ▒9!#3-17▒▒V]▒▒▒▒▒[S[▒▒VM▒▒:▒▒-55▒▒▒▒9▒▒▒▒▒▒▒▒▒▒▒▒▒▒-/▒#!▒5'▒!-!#▒5#=;'57▒▒▒
> Q(▒▒▒뺿▒333;▒▒▒▒▒▒-▒▒▒▒▒▒-▒=▒ae}_▒U}[W▒▒▒Q(▒▒▒뺿▒5;▒▒▒▒▒▒▒▒-▒▒▒▒▒▒-▒=~Y%=Yey▒
> ▒HIOT▒9▒▒[Wy▒!5▒5▒755957▒▒▒*▒▒▒▒u#=;'-#1▒[Wy▒▒▒▒S:▒%5▒y'!9)▒w▒▒▒▒▒▒R▒JZ▒▒▒▒
> '!▒555▒▒;=9/▒▒▒▒▒▒▒ݵe▒▒7-#--='- 57▒▒▒▒▒[}e▒7-)▒!3▒▒▒▒▒i▒-
>                                            5▒▒▒▒▒▒;'!9)-
>                                                        
> 5▒▒W▒u▒#▒s{▒▒9▒▒▒▒▒▒▒[-715[#▒▒m#9▒▒▒V Jj▒▒

-- 
René Descartes walks in to a bar.
The barman asks him "Do you want a drink?"
Descartes says "I think not," and disappears.

---

From: Antony Stone <[email-masked]>
Date: Thu, 4 Apr 2019 17:50:59 +0200

> That suggests the wrong baud rate to me.

http://www.cambridgewargames.org.uk/members/andy/emailer/ and 
http://www.earth.li/~noodles/hardware-e3.html say 115,200 8n1 no handshake.

Antony.

> > ▒▒▒▒▒▒▒eue▒▒▒▒▒▒▒▒▒▒▒▒▒3'=/▒▒▒▒▒▒▒▒▒▒▒▒_}[eY▒▒▒▒▒▒▒▒▒▒▒▒▒3'=/▒▒▒▒▒▒▒▒▒▒▒
> > ▒gw [▒▒▒▒▒▒▒▒▒▒▒▒▒3'=/▒▒▒▒▒▒▒▒▒▒▒▒gmcUO▒▒▒▒▒▒▒▒▒▒▒▒▒3'=/▒▒▒▒▒▒▒▒▒▒▒▒▒Q▒+
> > ▒▒▒▒▒s!#7▒%!7▒▒_}[eY▒▒S▒▒▒=▒▒▒▒▒▒▒▒▒▒▒g-#▒9!%%=#7▒'-#▒!▒57-▒▒▒▒s!#7▒%!7▒
> > ▒gm cUO▒▒S▒▒▒=▒▒▒▒▒▒▒▒▒▒▒U▒!#7▒▒▒g-#▒=▒=%▒▒}# *▒-#1▒g-#▒▒▒▒▒
> > 
> >                                                            ▒:▒▒
> > 
> > ▒}eY▒wugW}▒ae}_▒▒▒▒▒▒J!75%▒5#=;'5▒▒▒▒▒a#▒#!75▒▒▒!='=15▒▒▒▒▒▒▒▒!#5▒▒▒▒▒▒▒
> > ▒▒▒ =15▒▒▒!#5▒▒▒▒▒▒▒=15▒▒▒!#5▒▒▒5▒9%3▒▒▒▒#▒▒-#-▒▒=9%3▒-#5▒▒9!#!'5▒
> > ▒HIOT▒9▒▒[Wy▒!5▒5▒755957▒▒▒*▒▒▒▒u#=;'-#1▒[Wy▒▒▒▒S:▒%5▒y'!9)▒w▒▒▒▒▒▒R▒JZ▒
> > ▒▒▒ '!▒555▒▒;=9/▒▒▒▒▒▒▒ݵe▒▒7-#--='- 57▒▒▒▒▒[}e▒7-)▒!3▒▒▒▒▒i▒-
> > 
> >                                            5▒▒▒▒▒▒;'!9)-
> > 

-- 
Police have found a cartoonist dead in his house.  They say that details are 
currently sketchy.

---

From: Nick Griffin <[email-masked]>
Date: Thu, 4 Apr 2019 16:38:15 +0000

This is my settings in putty, 15200, 8 bits, no parity and 1 stop bit. And no flow control.
from https://wiki.earth.li/E3_Getting_Started website.

Spanner..

From: Antony Stone<mailto:[email-masked]>
Sent: ‎Thursday‎, ‎4‎ ‎April‎ ‎2019 ‎16‎:‎51
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

> That suggests the wrong baud rate to me.

https://eur01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.cambridgewargames.org.uk%2Fmembers%2Fandy%2Femailer%2F&amp;data=02%7C01%7C%7C1582cfe263ef4d5cdbde08d6b915666b%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636899898889909349&amp;sdata=zjSspT0Ft5FobfMYnBdrxtc6MvEywB4MRky%2B6hHxkaY%3D&amp;reserved=0 and
https://eur01.safelinks.protection.outlook.com/?url=http:%2F%2Fwww.earth.li%2F~noodles%2Fhardware-e3.html&amp;data=02%7C01%7C%7C1582cfe263ef4d5cdbde08d6b915666b%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636899898889919354&amp;sdata=rOH%2Fb0v1uOAfmesV3LLdYH3lctIkFptlTV4wZlWHIWU%3D&amp;reserved=0 say 115,200 8n1 no handshake.

Antony.

                                                   Please reply to the list;
                                                         please *don't* CC me.
_______________________________________________
e3-hacking mailing list
[email-masked]
https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C1582cfe263ef4d5cdbde08d6b915666b%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636899898889919354&amp;sdata=dWNs4RpdUiZbF1at%2FUuXTIlzGnCVBpnc03M8VQ7j10E%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Thu, 4 Apr 2019 16:52:42 +0000

Could it be that I might have the RX and TX round there wrong way..? red is TX (Ring) so it connected to TX pin on CP 2102,White is RX (Tip) so it connected to RX pin on CP 2102,black is Ground (Sleeve) connected to GND pin on CP 2102..??

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Thursday‎, ‎4‎ ‎April‎ ‎2019 ‎17‎:‎38
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

This is my settings in putty, 15200, 8 bits, no parity and 1 stop bit. And no flow control.
from https://wiki.earth.li/E3_Getting_Started<https://eur02.safelinks.protection.outlook.com/?url=https://wiki.earth.li/E3_Getting_Started&data=02%7c01%7c%7c8343a951477f40a3e91e08d6b91bf8a8%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899927114394676&sdata=eJ6FIlyJnpqQz98sp/vDUm28K3vSBQxw40LxQgsZVBA%3D&reserved=0> website.

Spanner..

Antony.

---

From: David Given <[email-masked]>
Date: Thu, 4 Apr 2019 18:57:22 +0200

It's probably a typo, but just to check: you said 15200, but it should be
115200?

On Thu, 4 Apr 2019, 18:52 Nick Griffin, <[email-masked]> wrote:

> Could it be that I might have the RX and TX round there wrong way..? red
> is TX (Ring) so it connected to TX pin on CP 2102,White is RX (Tip) so it
> connected to RX pin on CP 2102,black is Ground (Sleeve) connected to GND
> pin on CP 2102..??
>
> Spanner..
>
> *Sent:* ‎Thursday‎, ‎4‎ ‎April‎ ‎2019 ‎17‎:‎38
> from https://wiki.earth.li/E3_Getting_Started
> <https://eur02.safelinks.protection.outlook.com/?url=https://wiki.earth.li/E3_Getting_Started&data=02%7c01%7c%7c8343a951477f40a3e91e08d6b91bf8a8%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899927114394676&sdata=eJ6FIlyJnpqQz98sp/vDUm28K3vSBQxw40LxQgsZVBA%3D&reserved=0>
> website.
>
> Spanner..
>
> *From:* Antony Stone <[email-masked]>
> *Sent:* ‎Thursday‎, ‎4‎ ‎April‎ ‎2019 ‎16‎:‎51
> > > ▒gw
>                                                    Please reply to the
> list;
>                                                          please *don't* CC
> me.

---

From: J <[email-masked]>
Date: Fri, 5 Apr 2019 07:39:23 +0100

I think this should work, but can't remember if rx & tx are the right way
round. Google TTL-232R-3V3-AJ.
From what I remember there were 2 versions of pbl, one was hacked to allow
a new kernel. The upgraded version was encrypted / required a signed
binary. But Amstrad never released the key.
the kernel on the hacked version was a 2.4 Linux. The community upgraded it
to 2.6 but it wasn't given a front end HMI.
I seem to remember massive incompatibility / a lot of patching to get it
building on the latest version of Linux & busybox at the time (2007).

On Thu, 4 Apr 2019 17:57 David Given, <[email-masked]> wrote:

>>                                                          please *don't*
>> CC me.

---

From: David Given <[email-masked]>
Date: Fri, 5 Apr 2019 16:48:42 +0200

I think I had USB ethernet working using the custom Linux kernel (I wasn't
interested in using the stock firmware). It's only USB 1, though, and I
have very faint memories of it not liking hubs very much?

BTW, Nick: I just discovered a bunch of your messages in the Gmail spam
folder. It looks like you're using live.com --- there shouldn't be a
problem there, surely? Maybe it doesn't like your custom font?

On Thu, 4 Apr 2019 at 13:11, Nick Griffin <[email-masked]> wrote:

> Thanks, I guested that your would need your own firmware on the Emailer..[image:
> 😊]
>
> Spanner..
>
> *From:* Sean Furey <[email-masked]>
> *Sent:* ‎Thursday‎, ‎4‎ ‎April‎ ‎2019 ‎10‎:‎51
> > Looking at the mailing list there was someone from Amstrad called Cliff
> Lawson commenting,shame he's not here now.He could help unlocking the E3
> now ..
>
> Cliff mentioned using USB ethernet, but in the context of replacing the
> firmware with your own code.  I don't believe he ever suggested the amstrad
> firmware supported it.
>
> Sean
>

-- 
┌─── http://www.cowlark.com ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

---

From: Nick Griffin <[email-masked]>
Date: Fri, 5 Apr 2019 18:04:50 +0000

Its still getting garbled text with CP 2102. 15200 was a typo on here.. 😊 in Putty its 115200.
I thought I try my FTDI 232,its text is garbled too… it does it on both of them.??
I am connecting it to pc then to FTDI232 or CP 2102 they connect to E3 then running Putty on PC and unplugging the E3 to restart it and garbled text on Putty. I can’t see the boot log text is unreadable…?

I have only one more thing I can try, I have a USB to RS232 Cable that's Prolific USB to Serial and see if that works.

Spanner..

From: David Given<mailto:[email-masked]>
Sent: ‎Thursday‎, ‎4‎ ‎April‎ ‎2019 ‎17‎:‎57
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

It's probably a typo, but just to check: you said 15200, but it should be 115200?

On Thu, 4 Apr 2019, 18:52 Nick Griffin, <[email-masked]<mailto:[email-masked]>> wrote:
Could it be that I might have the RX and TX round there wrong way..? red is TX (Ring) so it connected to TX pin on CP 2102,White is RX (Tip) so it connected to RX pin on CP 2102,black is Ground (Sleeve) connected to GND pin on CP 2102..??

Spanner..

This is my settings in putty, 15200, 8 bits, no parity and 1 stop bit. And no flow control.
from https://wiki.earth.li/E3_Getting_Started<https://nam03.safelinks.protection.outlook.com/?url=https://wiki.earth.li/E3_Getting_Started&data=02%7c01%7c%7cf0dec062bb9b4f39405408d6b91eacb8%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899938727285441&sdata=6mx9RKhkgvgpcoK8%2Bg%2BHvDpWdaW5jbBVujdVKbfL2Ao%3D&reserved=0> website.

Spanner..

> That suggests the wrong baud rate to me.

https://eur01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.cambridgewargames.org.uk%2Fmembers%2Fandy%2Femailer%2F&amp;data=02%7C01%7C%7C1582cfe263ef4d5cdbde08d6b915666b%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636899898889909349&amp;sdata=zjSspT0Ft5FobfMYnBdrxtc6MvEywB4MRky%2B6hHxkaY%3D&amp;reserved=0<https://nam03.safelinks.protection.outlook.com/?url=http://www.cambridgewargames.org.uk/members/andy/emailer/&data=02%7c01%7c%7cf0dec062bb9b4f39405408d6b91eacb8%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899938727295446&sdata=er/vonGJwLudAOVY%2BLEH4%2BkvsIZ1HKDuvk97AHfTbEs%3D&reserved=0> and
https://eur01.safelinks.protection.outlook.com/?url=http:%2F%2Fwww.earth.li%2F~noodles%2Fhardware-e3.html&amp;data=02%7C01%7C%7C1582cfe263ef4d5cdbde08d6b915666b%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636899898889919354&amp;sdata=rOH%2Fb0v1uOAfmesV3LLdYH3lctIkFptlTV4wZlWHIWU%3D&amp;reserved=0<https://nam03.safelinks.protection.outlook.com/?url=http://www.earth.li/~noodles/hardware-e3.html&data=02%7c01%7c%7cf0dec062bb9b4f39405408d6b91eacb8%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899938727305457&sdata=9LGKgveQXDSG5hLVHsdK3s1C9bbqDLH3GLgzW16oE80%3D&reserved=0> say 115,200 8n1 no handshake.

Antony.

                                                   Please reply to the list;
                                                         please *don't* CC me.
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C1582cfe263ef4d5cdbde08d6b915666b%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636899898889919354&amp;sdata=dWNs4RpdUiZbF1at%2FUuXTIlzGnCVBpnc03M8VQ7j10E%3D&amp;reserved=0<https://nam03.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7cf0dec062bb9b4f39405408d6b91eacb8%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899938727315462&sdata=I%2BgqoTz9YWrhZkoaX6YHOBe1rXAGOFn38yxLMy2n4IY%3D&reserved=0>
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://nam03.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7cf0dec062bb9b4f39405408d6b91eacb8%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899938727325467&sdata=s3ahy3D12ZbHNuRociRqKU5XntrysVoYfHaNI6dytAs%3D&reserved=0>

---

From: David Given <[email-masked]>
Date: Fri, 5 Apr 2019 20:10:42 +0200

It belatedly occurs to me that inverted TTL serial probably looks just like
non-inverted TTL serial except the data will be garbled. So most likely you
have it hooked up to the right pins but you somehow need to invert the
signal.

I found an article, which shows almost exactly the same result that you
have: https://www.sparkfun.com/news/2461

On Fri, 5 Apr 2019 at 20:05, Nick Griffin <[email-masked]> wrote:

> I am connecting it to pc then to FTDI232 or CP 2102 they connect to E3
> then running Putty on PC and unplugging the E3 to restart it and garbled
> text on Putty. I can’t see the boot log text is unreadable…?
>
> I have only one more thing I can try, I have a USB to RS232 Cable that's
> Prolific USB to Serial and see if that works.
>
> Spanner..
>
> *Sent:* ‎Thursday‎, ‎4‎ ‎April‎ ‎2019 ‎17‎:‎57
>> <https://nam03.safelinks.protection.outlook.com/?url=https://wiki.earth.li/E3_Getting_Started&data=02%7c01%7c%7cf0dec062bb9b4f39405408d6b91eacb8%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899938727285441&sdata=6mx9RKhkgvgpcoK8%2Bg%2BHvDpWdaW5jbBVujdVKbfL2Ao%3D&reserved=0>
>> website.
>>
>> Spanner..
>>
>> https://eur01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.cambridgewargames.org.uk%2Fmembers%2Fandy%2Femailer%2F&amp;data=02%7C01%7C%7C1582cfe263ef4d5cdbde08d6b915666b%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636899898889909349&amp;sdata=zjSspT0Ft5FobfMYnBdrxtc6MvEywB4MRky%2B6hHxkaY%3D&amp;reserved=0
>> <https://nam03.safelinks.protection.outlook.com/?url=http://www.cambridgewargames.org.uk/members/andy/emailer/&data=02%7c01%7c%7cf0dec062bb9b4f39405408d6b91eacb8%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899938727295446&sdata=er/vonGJwLudAOVY%2BLEH4%2BkvsIZ1HKDuvk97AHfTbEs%3D&reserved=0>
>> and
>>
>> https://eur01.safelinks.protection.outlook.com/?url=http:%2F%2Fwww.earth.li%2F~noodles%2Fhardware-e3.html&amp;data=02%7C01%7C%7C1582cfe263ef4d5cdbde08d6b915666b%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636899898889919354&amp;sdata=rOH%2Fb0v1uOAfmesV3LLdYH3lctIkFptlTV4wZlWHIWU%3D&amp;reserved=0
>> <https://nam03.safelinks.protection.outlook.com/?url=http://www.earth.li/~noodles/hardware-e3.html&data=02%7c01%7c%7cf0dec062bb9b4f39405408d6b91eacb8%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899938727305457&sdata=9LGKgveQXDSG5hLVHsdK3s1C9bbqDLH3GLgzW16oE80%3D&reserved=0>
>> say 115,200 8n1 no handshake.
>>
>>
>> Antony.
>>
>> > >
>> <https://nam03.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7cf0dec062bb9b4f39405408d6b91eacb8%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899938727315462&sdata=I%2BgqoTz9YWrhZkoaX6YHOBe1rXAGOFn38yxLMy2n4IY%3D&reserved=0>
>> <https://nam03.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7cf0dec062bb9b4f39405408d6b91eacb8%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636899938727325467&sdata=s3ahy3D12ZbHNuRociRqKU5XntrysVoYfHaNI6dytAs%3D&reserved=0>
>>

---

From: J <[email-masked]>
Date: Fri, 5 Apr 2019 19:55:30 +0100

Ftdi have a programming tool ftdi-prog that allows you to invert rx and tx.

---

From: Nick Griffin <[email-masked]>
Date: Fri, 5 Apr 2019 19:22:44 +0000

USB to RS232 Cable (Prolific USB to Serial) it works, I can see text…😊

Amstrad Delta - PBL V4.9 Build:1311 Assert Debug ICE
PBL 32MB NAND
0MB.-->MEMv01.00.002,CopyLim=00220000h,CodeEnd=01400000h-->PBL......1MB.......2MB*

System module loader - LDR V1.5 Build:0008 Assert
Mod scan 10010100 to 10230100
MEM - 10024000 (flash 00404000)
PARMS - 10024400 (flash 00404400)
LDR - 10024800 (flash 00404800)
LINUX - 10044000 (flash 00424000)
num modules: 4
checking LDR V1 at 10024800, alive=0, load=10002000
checking LINUX V1 at 10044000, alive=0, load=11800000
checking MEM V1 at 10024000, alive=0, load=11F00000
checking PARMS V1 at 10024400, alive=0, load=11900000
4 Modules processed, 4 are valid
LDR thinks global number for them is 1
Found mod <LINUX> V=1 at 10044000
Found mod <PARMS> V=1 at 10024400
Linux command line module (PARMS) found at 10024400
INITRD Not found
Linux start-up params (Any key to edit)
Found mod <LINUX> V=1 at 10044000
Uncompressing Linux........................................................ done, booting the kernel.
Linux version 2.4.18_mvl30-ams-delta (droberts@dev1-linux<mailto:droberts@dev1-linux>) (gcc version 3.2.1 20020930 (MontaVista)) #1 Mon Aug 23 07:34:07 BST 2004
CPU: ARM/TI925 Arm925Tsid(wb) revision 2
Machine: AMS-DELTA/OMAP1510
modem enable 0
On node 0 totalpages: 7424
zone(0): 7424 pages.
zone(1): 0 pages.
zone(2): 0 pages.
Kernel command line: console=ttyS0,115200n8 init=/start_cramfs rootfstype=cramfs root=/dev/dfdb4 ro ams_mmod_base=0x10FFF000 ams_mmod_size=0xFFF mem=29M ams_mod_ver=1
unmask_irq(#e)
rtsched version <20011203.1609.50>
Console: colour dummy device 80x30
Calibrating delay loop... 74.75 BogoMIPS
Memory: 29MB = 29MB total
Memory: 27272KB available (1386K code, 493K data, 64K init)
Dentry-cache hash table entries: 4096 (order: 3, 32768 bytes)
Inode-cache hash table entries: 2048 (order: 2, 16384 bytes)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
Buffer-cache hash table entries: 1024 (order: 0, 4096 bytes)
Page-cache hash table entries: 8192 (order: 3, 32768 bytes)
POSIX conformance testing by UNIFIX
Linux NET4.0 for Linux 2.4
Based upon Swansea University Computer Society NET3.039
Initializing RT netlink socket
Starting kswapd
Disabling the Out Of Memory Killer
Installing stub AMS_DELTA keyboard driver.
pty: 256 Unix98 ptys configured
SERIAL DRVR
Serial driver version 5.05c (2001-07-08) with no serial options enabled
ttyS00 at 0xfffb0000 (irq = 46) is a OMAP UART
ttyS01 at 0xeb000000 (irq = 66) is a Smart SMC
omap-rtc: RTC power up reset detected.
omap-rtc: Enabling RTC.
Real Time Clock Driver v1.0
block: 64 slots per queue, batch=16
RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
DSPLinux FB (c) 2001 RidgeRun, Inc.
Looking for mono/colour, GPIO=FB93, proc_conf_bit=800
LCD is colour, 16BPP
tifb_init v_screen_base:C1C81000

Spanner..

From: J<mailto:[email-masked]>
Sent: ‎Friday‎, ‎5‎ ‎April‎ ‎2019 ‎19‎:‎55
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

On Fri, 5 Apr 2019 19:05 Nick Griffin, <[email-masked]<mailto:[email-masked]>> wrote:
Its still getting garbled text with CP 2102. 15200 was a typo on here.. 😊 in Putty its 115200.
I thought I try my FTDI 232,its text is garbled too… it does it on both of them.??
I am connecting it to pc then to FTDI232 or CP 2102 they connect to E3 then running Putty on PC and unplugging the E3 to restart it and garbled text on Putty. I can’t see the boot log text is unreadable…?

Spanner..

Spanner..

This is my settings in putty, 15200, 8 bits, no parity and 1 stop bit. And no flow control.
from https://wiki.earth.li/E3_Getting_Started<https://eur01.safelinks.protection.outlook.com/?url=https://wiki.earth.li/E3_Getting_Started&data=02%7c01%7c%7cd1639360107448e0886008d6b9f8558f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636900873564293591&sdata=TYDNHQD5T0sLlL5zo0C70lJ6bgbX7PT4iSqiSdzNTzQ%3D&reserved=0> website.

Spanner..

> That suggests the wrong baud rate to me.

https://eur01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.cambridgewargames.org.uk%2Fmembers%2Fandy%2Femailer%2F&amp;data=02%7C01%7C%7C1582cfe263ef4d5cdbde08d6b915666b%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636899898889909349&amp;sdata=zjSspT0Ft5FobfMYnBdrxtc6MvEywB4MRky%2B6hHxkaY%3D&amp;reserved=0<https://eur01.safelinks.protection.outlook.com/?url=http://www.cambridgewargames.org.uk/members/andy/emailer/&data=02%7c01%7c%7cd1639360107448e0886008d6b9f8558f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636900873564303602&sdata=6TcMIF0LruD/Cze1TPV/u5ufwRn4Rdd/ZIyUnTHN83w%3D&reserved=0> and
https://eur01.safelinks.protection.outlook.com/?url=http:%2F%2Fwww.earth.li%2F~noodles%2Fhardware-e3.html&amp;data=02%7C01%7C%7C1582cfe263ef4d5cdbde08d6b915666b%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636899898889919354&amp;sdata=rOH%2Fb0v1uOAfmesV3LLdYH3lctIkFptlTV4wZlWHIWU%3D&amp;reserved=0<https://eur01.safelinks.protection.outlook.com/?url=http://www.earth.li/~noodles/hardware-e3.html&data=02%7c01%7c%7cd1639360107448e0886008d6b9f8558f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636900873564313613&sdata=f6A/AuWHLhay8L6TePRfLa%2BpQrhvWTaNvK4APCSdMdE%3D&reserved=0> say 115,200 8n1 no handshake.

Antony.

                                                   Please reply to the list;
                                                         please *don't* CC me.
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C1582cfe263ef4d5cdbde08d6b915666b%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636899898889919354&amp;sdata=dWNs4RpdUiZbF1at%2FUuXTIlzGnCVBpnc03M8VQ7j10E%3D&amp;reserved=0<https://eur01.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7cd1639360107448e0886008d6b9f8558f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636900873564323612&sdata=BkL/V/sEjPMbEeFvG53fe5dzKuxwjzeW6I80C9jGUZM%3D&reserved=0>
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://eur01.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7cd1639360107448e0886008d6b9f8558f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636900873564333623&sdata=ixm2DgtjtsDuiUJiVIu9M%2B88FwNHn67gt%2BBVtN2ropA%3D&reserved=0>
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://eur01.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7cd1639360107448e0886008d6b9f8558f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636900873564343634&sdata=x5Ot5mzjR3nna41qecOB/X9BMmugp66ZjPsEvnPxQNE%3D&reserved=0>

---

From: Nick Griffin <[email-masked]>
Date: Sat, 6 Apr 2019 17:52:06 +0000

I was thinking,again,I do that.. 😊 We don’t need a Emailer with the Configuration Change on, if we can backup its NAND and then Copy over it with the backup, all we need is someone with a activated emailer that works, but you would not know how long before the emailer would deactivate, ones it deactivates all you do is copy over it again with the baxckup and it be back to how it was when you copied over the NAND in the beginning, so all you are doing is taking a snapshot of someone's Emailer and coping it to yours to activate it but will have to do it every time it deactivates itself, so a bit like what you do with Windows when you have to activate it every 120 days because you are using Microsoft Toolkit.

and if someone has got a emailer with games on and is activated, you can do the same thing once the games expirer, all you do is copy the backup of the NAND with the games on that have like 4 weeks remaining then you have the games back.

Spanner..

---

From: Nick Griffin <[email-masked]>
Date: Sat, 6 Apr 2019 17:55:51 +0000

I found Cliff Lawson old website about Amstrad.. 😊 The files work on there too, so if you need to download something for you PPC640… 😊

https://web.archive.org/web/20100111065846/http://web.ukonline.co.uk:80/cliff.lawson/<https://nam02.safelinks.protection.outlook.com/?url=https://web.archive.org/web/20100111065846/http://web.ukonline.co.uk:80/cliff.lawson/&data=02%7c01%7c%7cec60a40c8c474674a9e108d6baafc57f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636901661420165108&sdata=AYuOwEPXcqIuCLVxgq/VMaeODqQOjHtk9ctgHx/uiEY%3D&reserved=0>

If anyone needs to contact him I found him on Twitter here.. https://twitter.com/1903wrightflyer<https://nam02.safelinks.protection.outlook.com/?url=https://twitter.com/1903wrightflyer&data=02%7c01%7c%7cec60a40c8c474674a9e108d6baafc57f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636901661420175125&sdata=X32EcDRvPPm3S9fdDN7ppvq2MJyDMUrRf/mJ9eMHYjw%3D&reserved=0>

Spanner..

---

From: Antony Stone <[email-masked]>
Date: Sat, 6 Apr 2019 21:16:30 +0200

On Saturday 06 April 2019 at 19:55:51, Nick Griffin wrote:

> I found Cliff Lawson old website about Amstrad.. 😊 The files work on there
> too, so if you need to download something for you PPC640… 😊
> 
> https://web.archive.org/web/20100111065846/http://web.ukonline.co.uk:80/cli
> ff.lawson/<https://nam02.safelinks.protection.outlook.com/?url=https://web.
> archive.org/web/20100111065846/http://web.ukonline.co.uk:80/cliff.lawson/&d
> ata=02%7c01%7c%7cec60a40c8c474674a9e108d6baafc57f%7c84df9e7fe9f640afb435aaa
> aaaaaaaaa%7c1%7c0%7c636901661420165108&sdata=AYuOwEPXcqIuCLVxgq/VMaeODqQOjH
> tk9ctgHx/uiEY%3D&reserved=0>

That link gives me "Hrm.
The Wayback Machine has not archived that URL.
This page is not available on the web
because of server error"

Antony.

-- 
3 logicians walk into a bar. The bartender asks "Do you all want a drink?"
The first logician says "I don't know."
The second logician says "I don't know."
The third logician says "Yes!"

---

From: Nick Griffin <[email-masked]>
Date: Sat, 6 Apr 2019 20:59:16 +0000

Try this… https://web.archive.org/web/20070531214536/http://web.ukonline.co.uk/cliff.lawson/index.htm

Spanner..

From: Antony Stone<mailto:[email-masked]>
Sent: ‎Saturday‎, ‎6‎ ‎April‎ ‎2019 ‎20‎:‎16
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

On Saturday 06 April 2019 at 19:55:51, Nick Griffin wrote:

> https://eur04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fweb.archive.org%2Fweb%2F20100111065846%2Fhttp%3A%2F%2Fweb.ukonline.co.uk%3A80%2Fcli&amp;data=02%7C01%7C%7Cbc9b4e19deb44187e20008d6bac46ea3%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636901750176337201&amp;sdata=GFCxZFCrRLFe7Shitjk2HsN3h76CFjvXyD%2FDcXVpRkM%3D&amp;reserved=0

That link gives me "Hrm.

Antony.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://eur04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7Cbc9b4e19deb44187e20008d6bac46ea3%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636901750176337201&amp;sdata=BOoiQWY4%2FpEAEmPPwiUPVROOxCteTdg34YQwUYFer%2Bk%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Sun, 7 Apr 2019 12:21:34 +0000

I Need your help..?
Can someone who knows Cliff contact him to ask how the Amstrad Emailer deactivates itself or locks its features please…? I don’t see why you wouldn’t tell us now the device is obsolete, I did send a message on Twitter but no reply, that’s probably because he don’t know me, I need to know how it locks and how it does it, if we know then we might be able to find a way to activate, unlock them.

Has anyone managed to backed up there NAND from the E3,if so did you backup it when the Emailer was activated, if yes to both please can you shear it, I want to test and see if I can writing over my NAND with it, and how did you do it, there is no walkthrough on explaining on how to do this with pblq..?

Sky took over Amstrad in 2007 for 125 million, they got full control of it in 2010, (Sky removed the name Amstrad of they Sky+HD boxes and replaced it with the name Sky in 2010)that why they closed the Emailer service in 2011,they closed it because the phone numbers were from BT and Sky would have of paid BT to keep them(Amstrad did a deal with BT in 2000 with the first E1, its even had BT on the device), all they wanted was the satellite box part of Amstrad, that's how they made Sky Q (they brought it in-house so they could make them themselves) and Now TV, they never existed before and would not exist if they didn’t buy Amstrad. I wonder if Cliff works for Sky now or moved on. Amstrad exists only in name now, it don’t make or build anything, its the so Sky can hold on to what copyright Amstrad has like the copyright to the name and likeness of the ZX Spectrum, so when the ZX Spectrum Vega was made Retro Computer LTD had to pay Sky for the copyright to use its name and likeness.

”Yes I know a lot about Amstrad and the Emailer,I had to,to add stuff to the Amstrad and Emailer Wikipedia pages.. 😊 I have all 3 manualsE1,E3,E2(Shame they gone now from the Amstrad site, the links are there to the PDFs but they are dead because they go to Amstrad’s download site but that's been taken down by Sky,well Amserve.co.uk don’t work no more so it only time before Amstrad main site disappears) and 3 Emailers one E3 and 2 E2 Plusesssss.. lol. One of my Plus has the Configuration Change on it, I got that last year same as my E3, from eBay, they cost me £12 each with P+P,the other don’t work well it does but deactivated but keeping it and I got that in 2004, My mum bought for me before she died, she died 3 months later in October.”

Have a nice day..

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Saturday‎, ‎6‎ ‎April‎ ‎2019 ‎21‎:‎59
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Try this… https://web.archive.org/web/20070531214536/http://web.ukonline.co.uk/cliff.lawson/index.htm<https://nam03.safelinks.protection.outlook.com/?url=https://web.archive.org/web/20070531214536/http://web.ukonline.co.uk/cliff.lawson/index.htm&data=02%7c01%7c%7ceb33954ea3244a4b540108d6bad2c7ac%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636901811786841556&sdata=C7Axhbx4LR4wtjQfwieQqr9ul9y5lm3dVPALpplgNyw%3D&reserved=0>

Spanner..

That link gives me "Hrm.

Antony.

---

From: Ralph Corderoy <[email-masked]>
Date: Sun, 07 Apr 2019 13:37:49 +0100

Hi Nick,

> Can someone who knows Cliff contact him to ask how the Amstrad Emailer
> deactivates itself or locks its features please…? I don’t see why you
> wouldn’t tell us now the device is obsolete

I expect he's probably divulged everything he can recall after quite a
few contacts over the years.

> I need to know how it locks and how it does it, if we know then we
> might be able to find a way to activate, unlock them.

Isn't it the lack of being able to `phone home' that causes it to
deactivate after a while?  I seem to recall discussion on this list
about hooking up a modem in place of the phone line to `take' the call.
`AT+VTS' generates a dial tone?  These days, perhaps a
Asterisk/PoTS/VoIP bit of hardware could do similar.

> Has anyone managed to backed up there NAND from the E3,if so did you
> backup it when the Emailer was activated, if yes to both please can
> you shear it

Good idea.

The older firmware, before it got encrypted, could be disassembled and
studied some more, probably easier now than then with tool advancements,
and the phone-call code found so it can be stubbed out and the firmware
re-programmed.

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Sun, 7 Apr 2019 15:14:56 +0000

I need help with PBLQ I don’t understand its commands and options what am I as pose to know how to use it, when there are no instructions on how to use it, all it has is a read me,please can David Given help me because he made it..?? or anyone who has used it…??
Like “ writeflash <filename> <offset>” I don’t understand what is offset and length is ,is length the size of the NAND..????
I am don’t know about pbl commands..??? Has anyone used this program before,I just hope I am not talking to myself or I will go mad…lol

”live@commodoreos<mailto:live@commodoreos> ~
READY.
pblq -h
pblq: Amstrad PBL boot load client v0.3.pre1.
(C) 2005 David Given.
Usage: pblq [<options>] <command...>
Options:
   -h         Displays this message
   -v         Switch on verbose mode (what that)
   -r         Reuse an already existing connection
   -e <model> Set which emailer model to use (what Mode do not understand)
   -p <port>  Sets the serial port to use
   -s <rate>  Sets the slow baud rate
   -f <rate>  Sets the fast baud rate
   -m <size>  Sets the maximum packet size (0=ask PBL)
Commands:
   ping       Pings the device, testing communication
   term       Start simple serial terminal (is this like Putty, when I reset the email there is no txt just binary.)
   bless <filename>
              Makes a PBL image bootable (does this copy PBL to your PC as a bootable image or something)
   execute <address>
              Executes an on-device program and enters the terminal (not sure need more explaining)
   checksum <startaddress> <length>
              Calculates the checksum of an area of memory ( not sure is the binary code,so need the code for the area in the Memory so it can grab it)
   read <filename> <startaddress> <length>
              Reads data from RAM into the specified file ( Reads data from the memory and copies into a file,so you can copy it back)
   write <filename> <startaddress>
              Writes data from the specified file into RAM ( same as above but the opposite)
   readflash <filename> <offset> <length>
              Reads data from the NAND flash (very, very slowly)( not sure need help with offset and length do not understand)
   writeflash <filename> <offset>
              Writes data into the NAND flash ( same as above but the opposite)
Addresses should begin 0x if you want them in hex. ( hex ok  so starts with 0x so 0x1234567)
WARNING. Use this program at your own risk. The author accepts no responsibility
    for any damage this program may do to your hardware. You have been warned!”

This needs a manual on how to use it properly,some I understand not all. I have notice there is not a lot of info on flashing the emailer and its not explained well, its like you put it up to show you have hacked it, but how do you expected to do it yourself, I have looked there is nothing on how to read the NAND from the E3,please someone make a walkthrough or explain offset and length..?

Not beaning funny but posting on here is hard, I have never used  email so much,well I don’t use email, I know people on here don’t like Facebook so what about a Forum so all info can be in one place not scattered over different websites, it very hard to look up any thing in the Mailing list Archive because it has no search options so you have to press on each thread one by one.

Would you be happy If I make a forum for the Emailer, no point me making one if no one uses it..?? I am proberly 8 years to late…lol, I am good at making them, I make one for TheC64 Mini. http://thec64community.online

I think I know why you made the E3 Hacking Mailing list because you could at the time look at it on the Emailer by redirecting the emails to your email addy on Amserve.… 😊 would of cost a bomb to look at it at the time at 20p a collection. I only connected email once a day when I was using it and that was about £6.20 a month so it cost about £75 a year just to have it turn on…lol

Thanks..
Spanner..

---

From: David Given <[email-masked]>
Date: Sun, 7 Apr 2019 18:35:55 +0200

I don't think I had anything written down --- this was all years ago,
remember. I have managed to dig up this old Getting Started page, with
instructions on reflashing the E3 with Linux:
https://wiki.earth.li/E3_Getting_Started Remember that we were all
interested in running stock Linux on the machine rather than hacking the
built-in firmware. Those instructions are all based around pbltool, which
was the *other* tool for talking to PBL and which I'd completely forgotten
about, but should work fine. Bear in mind that this will replace the stock
firmware.

Regarding forums... I've never met a forum yet which was as easy to use as
email, let alone coming close to the convenience of getting messages
delivered directly to my inbox. (If this had been a forum I would never
have seen your posts!)

Have you seen the mailing list archives at
https://www.earth.li/pipermail/e3-hacking/?

On Sun, 7 Apr 2019 at 17:15, Nick Griffin <[email-masked]> wrote:

> I need help with PBLQ I don’t understand its commands and options what am
> I as pose to know how to use it, when there are no instructions on how to
> use it, all it has is a read me,please can David Given help me because he
> made it..?? or anyone who has used it…??
> Like “ writeflash <filename> <offset>” I don’t understand what is offset
> and length is ,is length the size of the NAND..????
> I am don’t know about pbl commands..??? Has anyone used this program
> before,I just hope I am not talking to myself or I will go mad…lol
>
> ”live@commodoreos ~
> READY.
> pblq -h
>    term       Start simple serial terminal (is this like Putty, when I
> reset the email there is no txt just binary.)
>    bless <filename>
>               Calculates the checksum of an area of memory ( not sure is
> the binary code,so need the code for the area in the Memory so it can grab
> it)
>               Reads data from RAM into the specified file ( Reads data
> from the memory and copies into a file,so you can copy it back)
>               Reads data from the NAND flash (very, very slowly)( not sure
> need help with offset and length do not understand)
> This needs a manual on how to use it properly,some I understand not all. I
> have notice there is not a lot of info on flashing the emailer and its not
> explained well, its like you put it up to show you have hacked it, but how
> do you expected to do it yourself, I have looked there is nothing on how to
> read the NAND from the E3,please someone make a walkthrough or explain
> offset and length..?
>
> Not beaning funny but posting on here is hard, I have never used  email so
> much,well I don’t use email, I know people on here don’t like Facebook so
> what about a Forum so all info can be in one place not scattered over
> different websites, it very hard to look up any thing in the Mailing list
> Archive because it has no search options so you have to press on each
> thread one by one.
>
> Would you be happy If I make a forum for the Emailer, no point me making
> one if no one uses it..?? I am proberly 8 years to late…lol, I am good at
> making them, I make one for TheC64 Mini. http://thec64community.online
>
> I think I know why you made the E3 Hacking Mailing list because you could
> at the time look at it on the Emailer by redirecting the emails to your
> email addy on Amserve.… 😊 would of cost a bomb to look at it at the time
> at 20p a collection. I only connected email once a day when I was using
> it and that was about £6.20 a month so it cost about £75 a year just to
> have it turn on…lol
>
> Thanks..
> Spanner..
>

---

From: Ralph Corderoy <[email-masked]>
Date: Sun, 07 Apr 2019 18:48:48 +0100

Hi Nick,

>               Reads data from RAM into the specified file
>               Reads data from the NAND flash (very, very slowly)

Is it the distinction between RAM and NAND flash that's confusing you?
Otherwise, they're pretty similar.

> Not beaning funny but posting on here is hard, I have never used email
> so much,well I don’t use email

It's always a good time to learn to use email properly.  It's the core
of many projects' communications.  Lots of data can flow into email,
e.g. RSS feed readers, and cron-job output.  And there are many programs
that can read it, search it, and store it as a text file per email for
access by the normal Unix text processing tools.  Email is king.  :-)

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Sun, 7 Apr 2019 20:20:12 +0000

I am trying to read the NAND to my PC,but don’t know to to put as the command..?

pblq nand.img
pblq: syntax error: readflash <filename> <start> <length>
readflash <filename> <offset> <length>
            Reads data from the NAND flash (very, very slowly)
pblq nand.img <whats the offset><whats the length>

Is the start of the nand 0x something, can you help me or is there a website that explains this..? I DO NOT KNOW…?? I DO NOT Know about this stuff or about PBL.All I want to do is copy the NAND.

Is the stuff in need in the console info like here…??
LDR - 10024800 (flash 00404800)
is LDR the NAND..??

Its says here..
“The second stage loader is stored in a Q;Q; format block in NAND, and is called LDR. It's responsible for finding the kernel parameters block and the kernel itself, then booting it. The kernel mounts a cramfs filesystem from the flash as its root, then pivot_roots so that the root is a ramdisk with a symlink farm into the cramfs.”

so does LDR hold the OS, thats where the main software is..?

Spanner..

From: Ralph Corderoy<mailto:[email-masked]>
Sent: ‎Sunday‎, ‎7‎ ‎April‎ ‎2019 ‎18‎:‎49
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Hi Nick,

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C4b361f293703449c720208d6bb815225%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636902561427846053&amp;sdata=WuT228KN8FYfD13fzwPVjOSCQ%2BQJUAa%2Bhi17a8Ac5r4%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Sun, 7 Apr 2019 20:43:59 +0000

Werid no one ever thought of backing up the firmware before putting new firmware on it,what would happen if you didn’t work.

You don’t have anything on the program you made pblq..?

This is the bit I want to get working..

“readflash <filename> <offset> <length>
              Reads data from the NAND flash (very, very slowly)”

What's the offset and length, I don’t know what that means..?

Spanner..

From: David Given<mailto:[email-masked]>
Sent: ‎Sunday‎, ‎7‎ ‎April‎ ‎2019 ‎17‎:‎37
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

I don't think I had anything written down --- this was all years ago, remember. I have managed to dig up this old Getting Started page, with instructions on reflashing the E3 with Linux: https://wiki.earth.li/E3_Getting_Started<https://nam04.safelinks.protection.outlook.com/?url=https://wiki.earth.li/E3_Getting_Started&data=02%7c01%7c%7c0e1a78592f874400258108d6bb774552%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636902518268872757&sdata=jSA8dIr7CFXUXgZwB59gzrKtzW7KRwpMzxRnlplSnv0%3D&reserved=0> Remember that we were all interested in running stock Linux on the machine rather than hacking the built-in firmware. Those instructions are all based around pbltool, which was the other tool for talking to PBL and which I'd completely forgotten about, but should work fine. Bear in mind that this will replace the stock firmware.

Regarding forums... I've never met a forum yet which was as easy to use as email, let alone coming close to the convenience of getting messages delivered directly to my inbox. (If this had been a forum I would never have seen your posts!)

Have you seen the mailing list archives at https://www.earth.li/pipermail/e3-hacking/<https://nam04.safelinks.protection.outlook.com/?url=https://www.earth.li/pipermail/e3-hacking/&data=02%7c01%7c%7c0e1a78592f874400258108d6bb774552%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636902518268882768&sdata=qH/ycQtfYV6AwdUsRX94KqcBx3jpohM0Pscv9V5mZQg%3D&reserved=0>?

On Sun, 7 Apr 2019 at 17:15, Nick Griffin <[email-masked]<mailto:[email-masked]>> wrote:
I need help with PBLQ I don’t understand its commands and options what am I as pose to know how to use it, when there are no instructions on how to use it, all it has is a read me,please can David Given help me because he made it..?? or anyone who has used it…??
Like “ writeflash <filename> <offset>” I don’t understand what is offset and length is ,is length the size of the NAND..????
I am don’t know about pbl commands..??? Has anyone used this program before,I just hope I am not talking to myself or I will go mad…lol

Would you be happy If I make a forum for the Emailer, no point me making one if no one uses it..?? I am proberly 8 years to late…lol, I am good at making them, I make one for TheC64 Mini. http://thec64community.online<https://nam04.safelinks.protection.outlook.com/?url=http://thec64community.online&data=02%7c01%7c%7c0e1a78592f874400258108d6bb774552%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636902518268902778&sdata=Uu4HkXdGmCj9HpotHubvvHsTlC4MPczZd9Baa10CkfY%3D&reserved=0>

Thanks..
Spanner..

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://nam04.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c0e1a78592f874400258108d6bb774552%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636902518268912789&sdata=pNgvmXtovV%2BjHvR97iBJANQDgL%2Bc/XFX%2BAR/Mr4zemo%3D&reserved=0>

--
┌─── http://www.cowlark.com<https://nam04.safelinks.protection.outlook.com/?url=http://www.cowlark.com&data=02%7c01%7c%7c0e1a78592f874400258108d6bb774552%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636902518268922794&sdata=auc4K/aVGK%2BnSp5vwYC9iLdbwregkmB1dARtq0qrJ3c%3D&reserved=0> ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

---

From: Jonathan McDowell <[email-masked]>
Date: Sun, 7 Apr 2019 21:48:26 +0100

On Sun, Apr 07, 2019 at 08:43:59PM +0000, Nick Griffin wrote:
> Werid no one ever thought of backing up the firmware before putting
> new firmware on it,what would happen if you didn’t work.

Anyone who uses the ams-delta-install script will have a NAND backup -
there are 6 partitions and it backed them all up to the install USB
stick. Don't ask me what they were or if I happen to still have my
copies though! I didn't spend a lot of time looking at the original
Amstrad firmware, I was more focussed on getting a clean Linux install
up and running.

J.

-- 
Sleep?  Isn't that some inferior replacement for caffeine?

---

From: David Given <[email-masked]>
Date: Sun, 7 Apr 2019 23:22:20 +0200

readflash won't work. I'm not kidding about it being slow --- it's only a
few bytes per second. PBL doesn't have a command to read data, so what pblq
does is to tell it to checksum one byte at a time, and it figures out what
the byte is from that. It's strictly a hack.

On Sun, 7 Apr 2019 at 22:44, Nick Griffin <[email-masked]> wrote:

> Werid no one ever thought of backing up the firmware before putting new
> firmware on it,what would happen if you didn’t work.
>
> *Sent:* ‎Sunday‎, ‎7‎ ‎April‎ ‎2019 ‎17‎:‎37
> https://wiki.earth.li/E3_Getting_Started
> <https://nam04.safelinks.protection.outlook.com/?url=https://wiki.earth.li/E3_Getting_Started&data=02%7c01%7c%7c0e1a78592f874400258108d6bb774552%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636902518268872757&sdata=jSA8dIr7CFXUXgZwB59gzrKtzW7KRwpMzxRnlplSnv0%3D&reserved=0> Remember
> that we were all interested in running stock Linux on the machine rather
> than hacking the built-in firmware. Those instructions are all based around
> pbltool, which was the *other* tool for talking to PBL and which I'd
> completely forgotten about, but should work fine. Bear in mind that this
> will replace the stock firmware.
>
> https://www.earth.li/pipermail/e3-hacking/
> <https://nam04.safelinks.protection.outlook.com/?url=https://www.earth.li/pipermail/e3-hacking/&data=02%7c01%7c%7c0e1a78592f874400258108d6bb774552%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636902518268882768&sdata=qH/ycQtfYV6AwdUsRX94KqcBx3jpohM0Pscv9V5mZQg%3D&reserved=0>
> ?
>
>>               Reads data from the NAND flash (very, very slowly)( not
>> sure need help with offset and length do not understand)
>> This needs a manual on how to use it properly,some I understand not all.
>> I have notice there is not a lot of info on flashing the emailer and its
>> not explained well, its like you put it up to show you have hacked it, but
>> how do you expected to do it yourself, I have looked there is nothing on
>> how to read the NAND from the E3,please someone make a walkthrough or
>> explain offset and length..?
>>
>> so much,well I don’t use email, I know people on here don’t like Facebook
>> so what about a Forum so all info can be in one place not scattered over
>> <https://nam04.safelinks.protection.outlook.com/?url=http://thec64community.online&data=02%7c01%7c%7c0e1a78592f874400258108d6bb774552%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636902518268902778&sdata=Uu4HkXdGmCj9HpotHubvvHsTlC4MPczZd9Baa10CkfY%3D&reserved=0>
>>
>> <https://nam04.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c0e1a78592f874400258108d6bb774552%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636902518268912789&sdata=pNgvmXtovV%2BjHvR97iBJANQDgL%2Bc/XFX%2BAR/Mr4zemo%3D&reserved=0>
>>
>
>
> --
> ┌─── http://www.cowlark.com
> <https://nam04.safelinks.protection.outlook.com/?url=http://www.cowlark.com&data=02%7c01%7c%7c0e1a78592f874400258108d6bb774552%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636902518268922794&sdata=auc4K/aVGK%2BnSp5vwYC9iLdbwregkmB1dARtq0qrJ3c%3D&reserved=0>
> ───

---

From: Nick Griffin <[email-masked]>
Date: Sun, 7 Apr 2019 21:46:51 +0000

So no way of backing up the Nand then ..?

Sent from my Samsung Galaxy smartphone.

-------- Original message --------
From: David Given <[email-masked]>
Date: 07/04/2019 22:22 (GMT+00:00)
To: Discussion of the Amstrad E3 emailer hardware/software <[email-masked]>
Subject: Re: [E3-hacking] Fw: I found Cliff Lawson old website about Amstrad

readflash won't work. I'm not kidding about it being slow --- it's only a few bytes per second. PBL doesn't have a command to read data, so what pblq does is to tell it to checksum one byte at a time, and it figures out what the byte is from that. It's strictly a hack.

On Sun, 7 Apr 2019 at 22:44, Nick Griffin <[email-masked]<mailto:[email-masked]>> wrote:
Werid no one ever thought of backing up the firmware before putting new firmware on it,what would happen if you didn’t work.

Spanner..

I don't think I had anything written down --- this was all years ago, remember. I have managed to dig up this old Getting Started page, with instructions on reflashing the E3 with Linux: https://wiki.earth.li/E3_Getting_Started<https://nam01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwiki.earth.li%2FE3_Getting_Started&data=02%7C01%7C%7C7c55375aea6a4a77e90508d6bb9f2cdf%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636902689655542999&sdata=H2PLBCxlm0DisFSVtC2GXqxPWeeLAzOU8bAz1HIRXXY%3D&reserved=0> Remember that we were all interested in running stock Linux on the machine rather than hacking the built-in firmware. Those instructions are all based around pbltool, which was the other tool for talking to PBL and which I'd completely forgotten about, but should work fine. Bear in mind that this will replace the stock firmware.

Have you seen the mailing list archives at https://www.earth.li/pipermail/e3-hacking/<https://nam01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fpipermail%2Fe3-hacking%2F&data=02%7C01%7C%7C7c55375aea6a4a77e90508d6bb9f2cdf%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636902689655553004&sdata=MBwkP77N8Af1BpvQS%2BXHA50Aebe1omhbjFRwwEjebow%3D&reserved=0>?

Would you be happy If I make a forum for the Emailer, no point me making one if no one uses it..?? I am proberly 8 years to late…lol, I am good at making them, I make one for TheC64 Mini. http://thec64community.online<https://nam01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fthec64community.online&data=02%7C01%7C%7C7c55375aea6a4a77e90508d6bb9f2cdf%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636902689655563015&sdata=77fvUVmw5y677FSsw5KgXBYO7FZtm984vri4E%2FR6jkg%3D&reserved=0>

Thanks..
Spanner..

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://nam01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&data=02%7C01%7C%7C7c55375aea6a4a77e90508d6bb9f2cdf%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636902689655573020&sdata=uzA0EQ%2BCvYJ31DAJYFOjvF%2FQHEY97ApzIjgm7ILnod4%3D&reserved=0>

--
┌─── http://www.cowlark.com<https://nam01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.cowlark.com&data=02%7C01%7C%7C7c55375aea6a4a77e90508d6bb9f2cdf%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636902689655583031&sdata=JPEXGPH%2B3bjjI8hlB1GXAINhWg0Cu2uz1GmVgExrOLk%3D&reserved=0> ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://nam01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&data=02%7C01%7C%7C7c55375aea6a4a77e90508d6bb9f2cdf%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636902689655593036&sdata=TjdHQKQ3b1H8%2FqWCpuB2S50HKudEySxnjG2X8Y74yAo%3D&reserved=0>

--
┌─── http://www.cowlark.com<https://nam01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.cowlark.com&data=02%7C01%7C%7C7c55375aea6a4a77e90508d6bb9f2cdf%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636902689655613052&sdata=MUWWHk3ZGErG8trWLkzWafvutCIwGxxvFMiRoFD3aKY%3D&reserved=0> ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

---

From: Nick Griffin <[email-masked]>
Date: Fri, 5 Apr 2019 23:00:27 +0000

I compiled pblq OK on Commodore OS
What's the command line to copy the NAND from the E3 to my PC in PBLQ..?
Do I need to copy the NOR too..?

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Friday‎, ‎5‎ ‎April‎ ‎2019 ‎22‎:‎16
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Spanner..

Spanner..

Spanner..

This is my settings in putty, 15200, 8 bits, no parity and 1 stop bit. And no flow control.
from https://wiki.earth.li/E3_Getting_Started<https://eur04.safelinks.protection.outlook.com/?url=https://wiki.earth.li/E3_Getting_Started&data=02%7c01%7c%7cf2af200a61bc4579aa9a08d6ba0bf91e%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636900957917086106&sdata=n8ubw4thLdC3UUfqiL%2B2XFeKXr91NzYvIm4y/VVreys%3D&reserved=0> website.

Spanner..

> That suggests the wrong baud rate to me.

https://eur01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.cambridgewargames.org.uk%2Fmembers%2Fandy%2Femailer%2F&amp;data=02%7C01%7C%7C1582cfe263ef4d5cdbde08d6b915666b%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636899898889909349&amp;sdata=zjSspT0Ft5FobfMYnBdrxtc6MvEywB4MRky%2B6hHxkaY%3D&amp;reserved=0<https://eur04.safelinks.protection.outlook.com/?url=http://www.cambridgewargames.org.uk/members/andy/emailer/&data=02%7c01%7c%7cf2af200a61bc4579aa9a08d6ba0bf91e%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636900957917086106&sdata=ksx65teiSA/3yDIZ7Xa4zaNEpg7Zi2jZ6wPekIyePd8%3D&reserved=0> and
https://eur01.safelinks.protection.outlook.com/?url=http:%2F%2Fwww.earth.li%2F~noodles%2Fhardware-e3.html&amp;data=02%7C01%7C%7C1582cfe263ef4d5cdbde08d6b915666b%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636899898889919354&amp;sdata=rOH%2Fb0v1uOAfmesV3LLdYH3lctIkFptlTV4wZlWHIWU%3D&amp;reserved=0<https://eur04.safelinks.protection.outlook.com/?url=http://www.earth.li/~noodles/hardware-e3.html&data=02%7c01%7c%7cf2af200a61bc4579aa9a08d6ba0bf91e%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636900957917096118&sdata=XnTlIu9qQH5zhacKTyZbILAv0aWpNSmkoMRymW4qacs%3D&reserved=0> say 115,200 8n1 no handshake.

Antony.

                                                   Please reply to the list;
                                                         please *don't* CC me.
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C1582cfe263ef4d5cdbde08d6b915666b%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636899898889919354&amp;sdata=dWNs4RpdUiZbF1at%2FUuXTIlzGnCVBpnc03M8VQ7j10E%3D&amp;reserved=0<https://eur04.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7cf2af200a61bc4579aa9a08d6ba0bf91e%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636900957917106122&sdata=TD%2BL8ua0%2Bq8Gi1TA9zacqvbSDUUP2dngGKFpI4uy6n8%3D&reserved=0>
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://eur04.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7cf2af200a61bc4579aa9a08d6ba0bf91e%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636900957917106122&sdata=TD%2BL8ua0%2Bq8Gi1TA9zacqvbSDUUP2dngGKFpI4uy6n8%3D&reserved=0>
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://eur04.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7cf2af200a61bc4579aa9a08d6ba0bf91e%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636900957917116131&sdata=TpSn/UbUnbE69nHP6fdp54vXHHUY/EjolyxXSvBXhaQ%3D&reserved=0>

---

From: Nick Griffin <[email-masked]>
Date: Sat, 6 Apr 2019 11:22:59 +0000

I don’t anything about configuring a serial in Lunux even thought I made Commodore OS..😊

Do I need a app to setup the serial or can I do it in pblq..? I am using my USB to RS232 Cable (Prolific USB to Serial) I plugged the wires in Red to RX and While to TX and black to GND and it works fine. Its a original Prolific USB to Serial not a clone, I worked out this would work cos the Nokia 5100 uses the same chip(PL-2303) in its data cable. Glad you showed a picture of the board on your site.
Only seen the boot log in Putty in Windows…?
How do I find out what COM port its using in Linux..?

Spanner..

Spanner..

Spanner..

Spanner..

Spanner..

Antony.

---

From: Nick Griffin <[email-masked]>
Date: Mon, 8 Apr 2019 14:38:29 +0000

Anyone know what all the games were that were available at the time, is there a list if them..?

I only know of 5 or 6 I think, Donkey Kong, Tetris, Space Invaders, Jetpac, Crazy Cars and Pac man, I wonder if it had all the ZX Spectrum games in its library..??
Donkey Kong was the first one I downloaded… 😊

OH I just noticed Cliff Lawson's name in the Demo that runs if you hold CALC and SHIFT, its on the Address Book Page ..HAHAHHAAAAA.I thought I had seen his name before...

Spanner..

---

From: Nick Griffin <[email-masked]>
Date: Thu, 11 Apr 2019 21:02:51 +0000

Who owns the wiki page at https://wiki.earth.li/E3 would it be ok if I up dated it, I have up dated the Emailer and Amstrad Pages on Wikipedia and added Jonathans McDowell comment from his’s website about the hardware, and what it is, if you look at it now its a lot bigger now,I explain about how it deactivates after 3 months and about the Configuration Change. I might be adding more soon.I have found out a lot more, been taking to Cliff, and that file I found (delta_e_live.config) is the file that it downloads to keep it(a live)activated, it keeps it working, it gets deleted after the time runs out and deactivates the emailer, they all work the same, they all need that file to function that why it has e and live in its name, emailer live and the more it downloaded the file the more time is added to the emailer,3 months was added each time it downloaded the file, so if can’t connect to the server(Amserve) but it connects to the server twice in the same day the Emailer would be a live for 6 months(if you never connected it for 6 months it would stay live for that time),mine lasted 3 months so it connected once before it was turned off, my E3 was last used in 2006 online until last year when I got it from eBay and started to use it all the time, I use it for looking at the time and making calls.

The only way to keep the E3 Emailer activated is to flash a copy of the firmware that has been registered and activated for 3 months or more or has the configuration change on but that would be like looking for a needle in a haystack, they are very rare, so when it deactivates(runs out of time) flash it again, its would be like a snapshot of the emailers state.

You can’t activate E1,E2 or E3 that are deactivated because the technology don’t existed anymore that added time to them and would activated them, you need the Amserve server to do it, You would have to make a HTTP server and get the Emailer to connect to it and fool it into thinking its connected to Amserve and it would need to download the delta_e_live.config(Emailer Live Configuration file) but would need the same PI address (http://212.225.36.174) that points to the Emailer Live file because the PI is hard coded into the emaler so you can’t change it.so the server would have to have that IP address and login and password to Amserve too for it to work.

The Way forward would be the Amstrad Installer Script and see how it dumps the Amstrad E3 Emailer firmware into 6 files and reverse engineer it so it flashes the Amstrad Firmware back to the E3,it hacks it because it should not be able to do it Because Amstrad didn’t want there hardware used this way. But all Linux based devices get hacked.

the Amstrad Installer Script is a Bash script and use about 22 lines to nand dump the Nand flash from the E3 to the USB Stick in the back of the E3.

Looks like dev/mtd has 6 partitions :0,1,2,3,4,5 (mtd0,mtd1,mtd2 and so on)so each partition would be part of the system.

When it flash's Linux to the E3 it only uses partitions mtd0,mtd1,mtd3 and mtd4, so mtd2 and mtd3 is not used.

If this could be worked out then this would get your E3 working again, you would need a working E3 emailer as the donor system.

I have copied the Amstrad Install script on here so if you want to look at it to see if you help,you don’t have to do it if you don’t want to.

Spanner
---------------------------------------------------------------------------------------------------------------------
#!/bin/sh

if (! grep -q /dev/sda1 /proc/mounts); then
 echo "No install media mounted; couldn't find /dev/sda in /proc/mounts"
 exit 1;
fi

echo Do you wish to backup your existing E3 NAND? If you say yes then 6
echo "e3-nand-backup.<n> files will be written containing the current contents"
echo of your flash.
echo -n "[y/N]: "

read i
if [ "x$i" = "xy" -o "x$i" = "xY" ]; then
 echo Backing up NAND. Be patient - this can take a few hours.
 for i in 0 1 2 3 4 5; do
  echo "   mtd$i"
  nanddump -f /media/sda1/e3-nand-backup.$i /dev/mtd$i
 done
else
 echo Skipping NAND backup.
fi

echo

echo "Ready to install. This process will completely wipe your E3's NAND."
echo The Amstrad firmware will no longer exist on the device. Are you
echo -n "sure you wish to continue? [y/N]: "

read i

if [ ! "x$i" = "xy" -a ! "x$i" = "xY" ]; then
 echo
 echo Aborting.
 exit 1
fi

echo
echo Starting install.

if [ -e /media/sda1/uImage ]; then
 echo Found a kernel.
 echo "  Erasing /dev/mtd0"
 flash_eraseall /dev/mtd0
 echo "  Writing kernel to /dev/mtd0"
 nandwrite -p /dev/mtd0 /media/sda1/uImage
fi

if [ -e /media/sda1/u-boot.bin ]; then
 echo Found u-boot.bin
 echo "  Erasing /dev/mtd1"
 flash_eraseall /dev/mtd1
 echo "  Writing u-boot to /dev/mtd1"
 nandwrite -p /dev/mtd1 /media/sda1/u-boot.bin
fi

if [ -e /media/sda1/ldr.img ]; then
 echo Found ldr.img
 echo "  Erasing /dev/mtd3"
 flash_eraseall /dev/mtd3
 echo "  Writing ldr.img to /dev/mtd3"
 dd if=/media/sda1/ldr.img of=/dev/mtdblock3
fi

if [ -e /media/sda1/root.tar.gz ]; then
 echo Found root tarball.
 echo "  Erasing /dev/mtd4 and formatting as jffs2"
 flash_eraseall -j /dev/mtd4
 echo "  Mounting /dev/mtdblock4"
 mount -t jffs2 /dev/mtdblock4 /media/realroot
 if (! grep -q /dev/mtdblock4 /proc/mounts); then
  echo "Failed to format and mount /dev/mtdblock4. Aborting."
  exit 1
 fi
 echo "  Untarring root tarball onto mtd4"
 tar -zxvf /media/sda1/root.tar.gz -C /media/realroot
 echo "  Unmounting /dev/mtdblock4"
 umount /media/realroot
fi

echo "Done."

---

From: Nick Griffin <[email-masked]>
Date: Thu, 11 Apr 2019 22:27:24 +0000

I have mine next to me near my PC, its on the Emailer page on Wikipedia, I still use it to make a call if I want, I sometime get it to play demo mode..😊

https://upload.wikimedia.org/wikipedia/commons/f/f2/Amstrad_E-mailer_Plus_and_E3.jpg

My Amstrad E2CC Plus is on the left and E3 is on the right.

Still looking out for a E3 with the Configuration Change on but its very rare. I have it on my E2 Plus and was the only one I have seen on eBay.

If I could dump the firmware on the E2CC(CC stands for Config Change) I could share it.

Spanner..

---

From: Jonathan McDowell <[email-masked]>
Date: Fri, 12 Apr 2019 07:38:37 +0100

On Thu, Apr 11, 2019 at 09:02:51PM +0000, Nick Griffin wrote:
> Who owns the wiki page at https://wiki.earth.li/E3 would it be ok if I
> up dated it,

It's running on my machine but go ahead and do any updates you think
would make it more useful - the whole point of having it as a wiki was
to make it possible for anyone to update.

(Thanks to spammers the process of registering might be a little tricky,
but let me know if you hit problems.)

J.

-- 
If a program is useful, it must be changed.

---

From: Nick Griffin <[email-masked]>
Date: Fri, 12 Apr 2019 10:28:44 +0000

Thanks..😊 You host it on your PC did you say, I am going to be doing that soon, I did it years ago, I use a wampserver on Windows because you install it and works and all I have to do is point it to my outside IP then a domain name and its done then start adding pages, I use to host a forum that way but my internet was to slow, now its not.

Going to host the old Amstrad website from 2004 and Cliff old UK Online site(UK Online was owned by Sky too and they closed it in 2011 the same time Amstrad was close down, that's why Cliff’s site disappeared)Sky buys companies and take there technology and add it to there own and then shut it down,it sound like the Borg to me.. SKY Resistant is Futile… 😊

If you are wondering why I am not using the Amstrad E2(Plus) its because they are rare with the Configuration Change on and I don’t want to ware it out, that why I want to find a way of backing up its firmware, so if the hardware fails, all I need is another E2(Plus) to replace it with.
And I share it here too and then the E2 Plus can be of some use of all the other E2s out there that are deactivated.
Did anyone manage to backup the E2s firmware or hack it at all..?
All I have seen is the E3 hacked to install Linux on..?

Spanner..

From: Jonathan McDowell<mailto:[email-masked]>
Sent: ‎Friday‎, ‎12‎ ‎April‎ ‎2019 ‎07‎:‎38
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

On Thu, Apr 11, 2019 at 09:02:51PM +0000, Nick Griffin wrote:
> Who owns the wiki page at https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwiki.earth.li%2FE3&amp;data=02%7C01%7C%7C3ad8b110e0834f7ac97d08d6bf11877c%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636906479333994180&amp;sdata=Y7ZdIIgpga9XQDtMnEs9LYSpQ%2FCWUNzXbLxALrc6yE4%3D&amp;reserved=0 would it be ok if I
> up dated it,

J.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C3ad8b110e0834f7ac97d08d6bf11877c%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636906479333994180&amp;sdata=ZNRMKCTr3VTmhnU483Xccucl7hSp0fewssZ4OdHf3DA%3D&amp;reserved=0

---

From: Ralph Corderoy <[email-masked]>
Date: Fri, 12 Apr 2019 11:39:38 +0100

Hi Nick,

> Did anyone manage to backup the E2s firmware or hack it at all..?

So you're interested in reading the contents of the
Samsung K9F6408U0C-TCB0 described at
https://inputplus.co.uk/ralph/emailer/emailerplus.html#hardware-7 ?
I'd expect that to be possible using the JTAG test points on the board,
though I don't know if enrab's photos are available now his site has
gone.  https://inputplus.co.uk/ralph/emailer/emailerplus.html#jtag

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Fri, 12 Apr 2019 13:01:43 +0000

“When it flash's Linux to the E3 it only uses partitions mtd0,mtd1,mtd3 and mtd4, so mtd2 and mtd3 is not used.”

mtd0 - kernel
mtd1 - PBL ( Maybe, I say this because Uboot is flashed there.)
mtd3 - ldr ( File System..? uses mtdblock3 of mtd3)
mtd4 - Root( Root File System,maybe ?? uses mtdblock4 of mtd4)

What are mtd2 and mtd5 used for..??

Trying to find out what each Partition is used for?

Is the Amstrad Install Script running in a Ramdisk..??
You have 2 Uboot images the same, one for flashing the other on for the install so you made it a bit like FEL mode where you hold down the FEL Button and can boot into Uboot +ramdisk  from you PC thought its usb cable that powers it then you can mount the system partition to get into files and folders, that's on TheC64 Mini.
Most Developing Boards now have the FEL button.

Just trying to find out more ,it dumps the firmware into 6 partitions, when it dumps them, can they be put back the way they are or do they need to be converted, so what I am say, are they raw files so they can’t be used the way they are at the moment…?

You can backup your firmware with this script without installing Linux on the E3,you can say no to installing it, right..?? if so I will try and see if I can back the E3 up to get the 6 backup files.

P.S Have not done anything with my E2Plus yet, if I can backup its firmware and then flash it back then I can fix the dead E2s out there, but I need help.
If I can backup its firmware I am willing to share it.But don’t worry my E2Plus is going no where.. 😊 Just been looking at you page Ralph,One of the problem with the E2 is it don’t run Linux, I am trying to find out more about its firmware at the moment.
The E1 and E2 use the same Firmware and same CPU Sharp LH79531 ARM (L136 00B), the only difference in them is the Plus had ZX Spectrum games. So I might be able to use the firmware from the E2 on the E1. The E3 had a different CPU because it need a MMU for the Colour LCD screen so need to be more powerful than the E1,E2.

Spanner..

---

From: Nick Griffin <[email-masked]>
Date: Fri, 12 Apr 2019 13:10:26 +0000

Oh one more thing.. the USB memory stick,does it matter if its fat or fat32 formatted to copy the 6 files over to it,it don’t say in the Readme..?

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Friday‎, ‎12‎ ‎April‎ ‎2019 ‎14‎:‎02
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

mtd0 - kernel

Spanner..

---

From: Nick Griffin <[email-masked]>
Date: Fri, 12 Apr 2019 18:31:37 +0000

Just copy the Amstrad Firmware to USB and as well flash Linux on the E3 so now I have to find a way to flash it back.. 😊 wow its takes a long time to boot, it took about a hour to copy the Amstrad Firmware over to USB.Is each file a copy of the partition(mtd0,1,2,3,4,5,) only mtd0,1,3 and 4 get flashed with the new system, so if the backups are complete copies then they could be flash back the same way, maybe something like this, taking the code for mdt0..

”if [ -e /media/sda1/e3-nand-backup.0 ]; then
 echo Found Amstrad kernel.
 echo "  Erasing /dev/mtd0"
 flash_eraseall /dev/mtd0
 echo "  Writing Amstrad kernel to /dev/mtd0"
nandwrite -on /dev/mtd0 /media/sda1/e3-nand-backup.0
fi”

Mtd0,2,3,4,5 Size 16384,Page Size 512, 00B Size 16
only need to restore mtd0,1,3 and 4 so ones with a * on.
mtd0: Dumping Data Starting at 0x00000000 and ending at 0x00300000*
mtd1: Dumping Data Starting at 0x00000000 and ending at 0x00040000*
mtd2: Dumping Data Starting at 0x00000000 and ending at 0x00040000
mtd3: Dumping Data Starting at 0x00000000 and ending at 0x00040000*
mtd4: Dumping Data Starting at 0x00000000 and ending at 0x01b00000*
mtd5: Dumping Data Starting at 0x00000000 and ending at 0x000c0000
I don’t know how much of the Nand you would need to erase for each partition..?
So lucky I recored the install..😊 I be uploading soon once I have edited it.
This is just guess work don’t know if it would work, need someone who knows about the code. If I manage to flash the Amstrad Firmware back and it works then you be able to flash any E3 firmware this way so even with one with the config change on it.

There is info here how to flash to mtd ..  https://forum.doozan.com/read.php?3,16789,16800

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Friday‎, ‎12‎ ‎April‎ ‎2019 ‎14‎:‎10
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Spanner..

mtd0 - kernel

Spanner..

---

From: Nick Griffin <[email-masked]>
Date: Fri, 12 Apr 2019 21:04:16 +0000

Can someone look at this…
Just edited the ams-delta-install script and renamed it to ams-delta-restore-e3-install

I can do all the work and tests, Just need a expert to look at the code and see if it OK because I am just reading up on MTD NAND write and dumping stuff on the net. This is how you learn you ask someone to help you and they help you and if you are wrong then you will remember how to do it next time… 😊

”#!/bin/sh

echo

echo "This process will completely restore your E3's NAND."
echo This will try and restore The Amstrad firmware on the device. Are you
echo -n "sure you wish to continue? [y/N]: "

read i

echo
echo Starting restore...

if [ -e /media/sda1/e3-nand-backup.0 ]; then
 echo Found e3-nand-backup.0
 echo "  Erasing /dev/mtd0"
 flash_erase /dev/mtd0 0 16
 echo "  Writing e3-nand-backup.0 to /dev/mtd0"
 nandwrite -on /dev/mtd0 /media/sda1/e3-nand-backup.0
fi

if [ -e /media/sda1/e3-nand-backup.1 ]; then
 echo Found e3-nand-backup.1
 echo "  Erasing /dev/mtd1"
 flash_erase /dev/mtd1 0 16
 echo "  Writing e3-nand-backup.1 to /dev/mtd1"
 nandwrite -on /dev/mtd1 /media/sda1/e3-nand-backup.1
fi

if [ -e /media/sda1/e3-nand-backup.3 ]; then
 echo Found e3-nand-backup.3
 echo "  Erasing /dev/mtd3"
 flash_erase /dev/mtd3 0 16
 echo "  Writing e3-nand-backup.3 to /dev/mtd3"
 nandwrite -on /dev/mtd3  /media/sda1/e3-nand-backup.3
fi

if [ -e /media/sda1/e3-nand-backup.4 ]; then
 echo Found e3-nand-backup.4
 echo "  Erasing /dev/mtd4"
 flash_erase /dev/mtd4 0 16
 echo "  Writing e3-nand-backup.4 to /dev/mtd4"
 nandwrite -on /dev/mtd3  /media/sda1/e3-nand-backup.3
fi

echo "Done."

What do you think… Would this work…?

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Friday‎, ‎12‎ ‎April‎ ‎2019 ‎19‎:‎32
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

There is info here how to flash to mtd ..  https://forum.doozan.com/read.php?3,16789,16800<https://eur04.safelinks.protection.outlook.com/?url=https://forum.doozan.com/read.php?3%2c16789%2c16800&data=02%7c01%7c%7c43dd69f306b24fa4d01308d6bf7526b0%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636906907207602767&sdata=l0A1sVMwvXx2BYpNyQBhS72Osn/%2BKERDRDUddCciVB8%3D&reserved=0>

Spanner..

Spanner..

mtd0 - kernel

Spanner..

---

From: Nick Griffin <[email-masked]>
Date: Fri, 12 Apr 2019 22:26:35 +0000

Made a mistake.. ..☹
This at the end of the code e3-nand-backup.4, its says ” nandwrite -on /dev/mtd3  /media/sda1/e3-nand-backup.3” what it should be mtd4 and 4 at the end of this code “nandwrite -on /dev/mtd4  /media/sda1/e3-nand-backup.4”

 nandwrite -on /dev/mtd4  /media/sda1/e3-nand-backup.4
fi

echo "Done.
“

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Friday‎, ‎12‎ ‎April‎ ‎2019 ‎22‎:‎04
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

”#!/bin/sh

echo

read i

echo
echo Starting restore...

echo "Done."

Spanner..

There is info here how to flash to mtd ..  https://forum.doozan.com/read.php?3,16789,16800<https://eur02.safelinks.protection.outlook.com/?url=https://forum.doozan.com/read.php?3%2c16789%2c16800&data=02%7c01%7c%7c4e14113df08b4714a45708d6bf8a762e%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636906998736410136&sdata=4rRkSMMFT0JJOseEcWKRtZOmqeUCO7RRRhFioD6wIZ0%3D&reserved=0>

Spanner..

Spanner..

mtd0 - kernel

Spanner..

---

From: Ralph Corderoy <[email-masked]>
Date: Sat, 13 Apr 2019 10:03:14 +0100

Hi Nick,

> mtd1 - PBL ( Maybe, I say this because Uboot is flashed there.)

Aren't PBL and Uboot two distinct separate things?  PBL was written by
Clive at Amstrad.  On the E2, it's the sole occupant of the small 64 KiB
flash so it isn't at risk of corruption when it writes to the main 8 MiB
flash.
https://inputplus.co.uk/ralph/emailer/emailerplus.html#hardware-ics

> Trying to find out what each Partition is used for?

If you have extracted the contents of those partitions then start poking
around their contents.  file(1), hexdump(1), etc.  And Google some
resources on reverse-engineering flash blobs to identify their contents.

> One of the problem with the E2 is it don’t run Linux
...
> The E3 had a different CPU because it need a MMU for the Colour LCD
> screen so need to be more powerful than the E1,E2.

I think Clive wanted to take advantage of Linux for the E3, given its
higher, more complex, workload and thus needed the MMU.

-- 
Cheers, Ralph.

---

From: Ralph Corderoy <[email-masked]>
Date: Sat, 13 Apr 2019 10:09:17 +0100

Hi Nick,

> I don’t know how much of the Nand you would need to erase for each

I don't quite understand the question.  Those `ending' values suggest
the size of each partition given all the `starting' are zero?  You need
to find out what that first line of information means.  I suspect `Size'
is the number of pages and `Page Size' is in bytes.  That would mean
8 MiB in total.

Depending on the flash device, the smallest erasable amount might be a
block of pages.

-- 
Cheers, Ralph.

---

From: Ralph Corderoy <[email-masked]>
Date: Sat, 13 Apr 2019 10:18:10 +0100

Hi Nick,

>  nandwrite -on /dev/mtd0 /media/sda1/e3-nand-backup.0

Parameterise the code to extract the error-prone repetition,
and avoid the reader having lots of versions to compare.

    perhaps_write_flash()
    {
        p=${1?} erase=${2?}
        f=/media/sda1/e3-nand-backup.$p
        dev=/dev/mtd$p

        test -e $f || return

        echo found $f
        echo erasing $erase on $dev
        flash_erase $dev 0 $erase
        echo writing flash
        nandwrite -on $dev $f
    }

    perhaps_write_flash 0 16
    perhaps_write_flash 1 ...

Untested, obviously.

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Sat, 13 Apr 2019 12:02:16 +0000

Its Cliff Lawson not Clive,who is Clive.. What Clive Sinclair … 😊

“Aren't PBL and Uboot two distinct separate things?”
Yes I know they are but mtd0 is where boot (like the bios on a PC) would be so PBL or Uboot would be there.

Example..  https://forum.doozan.com/read.php?3,16789,16800<https://forum.doozan.com/read.php?3%2c16789%2c16800>

device nand0 <orion_nand>, # parts = 5
 #: name                size            offset          mask_flags
 0: u-boot              0x00200000      0x00000000      0
 1: uImage              0x00300000      0x00200000      0
 2: uImage2             0x00300000      0x00500000      0
 3: failsafe            0x00800000      0x00800000      0
 4: root                0x07000000      0x01000000      0

active partition: nand0,2 - (uImage2) 0x00300000 @ 0x00500000

defaults:
mtdids  : none
mtdparts: none

I videoed the install but I shorting it so its like 22 minutes long. Its took about a hour and a half to do, the backing up of the E3 took the longest, flashing Linux took about 2 to 3 minutes because the OS is not very big. but if you want Linux on your E3 you don’t need to install it, the Installer is a ramdisk so you can test it on that. Its like FEL mode. I just want to record it for my channel on You Tube and false me to have to restore it.

Its say on that website.. “If you need to restore mtd1 to mtd4, then calculate the number of blocks for each mtd (i.e. a block is 128K, 1M is 8 blocks)”

 Erase mtd0:

#flash_erase /dev/mtd0 0 16
Erase Total 16 Units
Performing Flash Erase of length 131072 at offset 0x1e0000 done

flash _erase line I got from this site but it will not delete the right amount of blocks.
So 16 units make the block size 131072 so what is the unit for block size 16384,mtd0 to 5 are all the same block size..?? I am not great at maths…lol

Thank for the help Ralph..😊 Once I get this working again I move on to the E2(Amstrad E-M@iler<mailto:E-M@iler> Plus)..😊

Spanner..

From: Ralph Corderoy<mailto:[email-masked]>
Sent: ‎Saturday‎, ‎13‎ ‎April‎ ‎2019 ‎10‎:‎03
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Hi Nick,

Aren't PBL and Uboot two distinct separate things?  PBL was written by
Clive at Amstrad.  On the E2, it's the sole occupant of the small 64 KiB
flash so it isn't at risk of corruption when it writes to the main 8 MiB
flash.
https://nam01.safelinks.protection.outlook.com/?url=https%3A%2F%2Finputplus.co.uk%2Fralph%2Femailer%2Femailerplus.html%23hardware-ics&amp;data=02%7C01%7C%7C98de71a5da4c439d992708d6bfeeecbb%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636907430224288747&amp;sdata=LqkjcsSy62DcL04jS5U0mhtqVbReqh9NVioinst3eyk%3D&amp;reserved=0

...

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://nam01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C98de71a5da4c439d992708d6bfeeecbb%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636907430224298752&amp;sdata=K5AfU%2BK55Fq9LXFCKbaXu9eWEXvJto8XxcC3rV9woK4%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Sat, 13 Apr 2019 13:08:32 +0000

Can you Loading a Animated gif into E3 Linux and display on the E3 screen say from the USB Stick so its like a sceen saver..?

I have animated gifs of the E3s adverts..😊 I wanted to see if I can get them to play on the screen and maybe then by pressing the advent button on the screen it stops them and put it back to Linux command line. It be good for displaying them and how it looked with the adverts on E3 screen in 2004/5.

Well you could then use it as a picture viewer then.

Spanner..
------------------------------------------------------------------------------------------------------------
e3-hacking mailing list
[email-masked]
------------------------------------------------------------------------------------------------------------

---

From: Nick Griffin <[email-masked]>
Date: Sat, 13 Apr 2019 15:46:32 +0000

root@amsdelta<mailto:root@amsdelta>:~#  cat /proc/mtd
dev:          size       erasesize          name
mtd0: 00380000 00004000 "Kernel"
mtd1: 00040000 00004000 "u-boot"
mtd2: 00040000 00004000 "u-boot params"
mtd3: 00040000 00004000 "Amstrad LDR"
mtd4: 01b00000 00004000 "File system"
mtd5: 000c0000 00004000 "PBL reserved"
 Just realised there are all the same Block size, look at the erasesize.
“flash_erase /dev/mtd0 0 16” whats the 16 for at the end of the line, is it what block size to  erase, ( can’t work out what number to put there)could I just erase the whole partition(mtd0) with “flash_erase /dev/mtd0 0 0”..? I don’t want to made a mistake..??

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Saturday‎, ‎13‎ ‎April‎ ‎2019 ‎16‎:‎24
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

mtd0
Block Size 16384,Page Size 512, 00B Size 16
Dumping data starting at 0x00000000 and ending at 0x00380000...*
mtd1
Block Size 16384,Page Size 512, 00B Size 16
Dumping data starting at 0x00000000 and ending at 0x00040000...*
mtd2
Block Size 16384,Page Size 512, 00B Size 16
Dumping data starting at 0x00000000 and ending at 0x00040000...
mtd3
Block Size 16384,Page Size 512, 00B Size 16
Dumping data starting at 0x00000000 and ending at 0x00040000...*
mtd4
Block Size 16384,Page Size 512, 00B Size 16
Dumping data starting at 0x00000000 and ending at 0x01b00000...*
mtd5
Block Size 16384,Page Size 512, 00B Size 16
Dumping data starting at 0x00000000 and ending at 0x000c0000...

Why are there saying all the same block size..?

Only need to restore mtd0, mtd1, mtd3 and mtd4 so ones with a star(*) on.mtd2, mtd5 are not flashed over.

Spanner..

Spanner..

Spanner..

mtd0 - kernel

Spanner..

---

From: Nick Griffin <[email-masked]>
Date: Sat, 13 Apr 2019 16:21:32 +0000

https://github.com/hpjansson/chafa

Chafa is a command-line utility that converts all kinds of images, including animated GIFs, into ANSI/Unicode character output that can be displayed in a terminal.

It is highly configurable, with support for alpha transparency and multiple color modes and color spaces, combining selectable ranges of Unicode characters to produce the desired output.

The core functionality is provided by a C library with a public, well-documented API.

It has official web pages<https://hpjansson.org/chafa/> and C API documentation<http://hpjansson.org/chafa/ref/> online

Spanner..

---

From: Nick Griffin <[email-masked]>
Date: Sat, 13 Apr 2019 19:46:57 +0000

Dam..Just tried to flash the E3 and now it don’t boot, ah well..☹
With that's code and it starred coming up with “Flashing Data to NAND Flash without EEC in not recommended”

On Putty it just comes up with this and that's it..
“Amstrad Delta - PBL V4.9 Build:1311 Assert Debug ICE
PBL 32MB NAND
0MB.-->MEMv01.00.002,CopyLim=00220000h,CodeEnd=01400000h-->PBL......1MB.......2MB*”
Dam have to buy another one now. Ah well if you don’t try you’ll never learn.. 😊

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Saturday‎, ‎13‎ ‎April‎ ‎2019 ‎16‎:‎46
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Spanner..

mtd0

Spanner..

There is info here how to flash to mtd ..  https://forum.doozan.com/read.php?3,16789,16800<https://nam03.safelinks.protection.outlook.com/?url=https://eur04.safelinks.protection.outlook.com/?url%3Dhttps://forum.doozan.com/read.php?3%252c16789%252c16800%26data%3D02%257c01%257c%257c43dd69f306b24fa4d01308d6bf7526b0%257c84df9e7fe9f640afb435aaaaaaaaaaaa%257c1%257c0%257c636906907207602767%26sdata%3Dl0A1sVMwvXx2BYpNyQBhS72Osn/%252BKERDRDUddCciVB8%253D%26reserved%3D0&data=02%7c01%7c%7c4337d4d22ed34c948f7e08d6c0273e89%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636907672114917921&sdata=8zfyyhh%2Bl3lzg4S9X0RSMoAihn%2BsTAdIdxyDb7m8tzo%3D&reserved=0>

Spanner..

Spanner..

mtd0 - kernel

Spanner..

---

From: Nick Griffin <[email-masked]>
Date: Sat, 13 Apr 2019 15:24:17 +0000

mtd0

Spanner..

Spanner..

Spanner..

mtd0 - kernel

Spanner..

---

From: David Given <[email-masked]>
Date: Sat, 13 Apr 2019 23:57:45 +0200

It's pretty hard to brick them --- PBL's in a different ROM chip to the
main flash (and I think you can't reflash it anyway?), so even if you've
trashed the main flash PBL runs. So, you should be able to connect pbltool
or pblq to it and read and reflash, even if it doesn't boot.

On Sat, 13 Apr 2019 at 21:47, Nick Griffin <[email-masked]> wrote:

> *Sent:* ‎Saturday‎, ‎13‎ ‎April‎ ‎2019 ‎16‎:‎46
> root@amsdelta:~#  cat /proc/mtd
> dev:          size       erasesize          name
> “flash_erase /dev/mtd0 0 16” whats the 16 for at the end of the line, is
> it what block size to  erase, ( can’t work out what number to put
> there)could I just erase the whole partition(mtd0) with “flash_erase
> /dev/mtd0 0 0”..? I don’t want to made a mistake..??
>
> Spanner..
>
> *Sent:* ‎Saturday‎, ‎13‎ ‎April‎ ‎2019 ‎16‎:‎24
> *Sent:* ‎Friday‎, ‎12‎ ‎April‎ ‎2019 ‎19‎:‎32
> Just copy the Amstrad Firmware to USB and as well flash Linux on the E3 so
> now I have to find a way to flash it back.. 😊 wow its takes a long time to
> boot, it took about a hour to copy the Amstrad Firmware over to USB.Is each
> file a copy of the partition(mtd0,1,2,3,4,5,) only mtd0,1,3 and 4 get
> flashed with the new system, so if the backups are complete copies then
> they could be flash back the same way, maybe something like this, taking
> the code for mdt0..
>
> This is just guess work don’t know if it would work, need someone who
> knows about the code. If I manage to flash the Amstrad Firmware back and it
> works then you be able to flash any E3 firmware this way so even with one
> with the config change on it.
>
> There is info here how to flash to mtd ..
> https://forum.doozan.com/read.php?3,16789,16800
> <https://nam03.safelinks.protection.outlook.com/?url=https://eur04.safelinks.protection.outlook.com/?url%3Dhttps://forum.doozan.com/read.php?3%252c16789%252c16800%26data%3D02%257c01%257c%257c43dd69f306b24fa4d01308d6bf7526b0%257c84df9e7fe9f640afb435aaaaaaaaaaaa%257c1%257c0%257c636906907207602767%26sdata%3Dl0A1sVMwvXx2BYpNyQBhS72Osn/%252BKERDRDUddCciVB8%253D%26reserved%3D0&data=02%7c01%7c%7c4337d4d22ed34c948f7e08d6c0273e89%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636907672114917921&sdata=8zfyyhh%2Bl3lzg4S9X0RSMoAihn%2BsTAdIdxyDb7m8tzo%3D&reserved=0>
>
> Spanner..
>
> *Sent:* ‎Friday‎, ‎12‎ ‎April‎ ‎2019 ‎14‎:‎10
> Oh one more thing.. the USB memory stick,does it matter if its fat or
> fat32 formatted to copy the 6 files over to it,it don’t say in the Readme..?
>
> Spanner..
>
> *Sent:* ‎Friday‎, ‎12‎ ‎April‎ ‎2019 ‎14‎:‎02
> You have 2 Uboot images the same, one for flashing the other on for the
> install so you made it a bit like FEL mode where you hold down the FEL
> Button and can boot into Uboot +ramdisk  from you PC thought its usb cable
> that powers it then you can mount the system partition to get into files
> and folders, that's on TheC64 Mini.
> Just trying to find out more ,it dumps the firmware into 6 partitions,
> when it dumps them, can they be put back the way they are or do they need
> to be converted, so what I am say, are they raw files so they can’t be used
> the way they are at the moment…?
>
> You can backup your firmware with this script without installing Linux on
> the E3,you can say no to installing it, right..?? if so I will try and
> see if I can back the E3 up to get the 6 backup files.
>
> P.S Have not done anything with my E2Plus yet, if I can backup its
> firmware and then flash it back then I can fix the dead E2s out there, but
> I need help.
> If I can backup its firmware I am willing to share it.But don’t worry my
> E2Plus is going no where.. 😊 Just been looking at you page Ralph,One of
> the problem with the E2 is it don’t run Linux, I am trying to find out more
> about its firmware at the moment.
> The E1 and E2 use the same Firmware and same CPU Sharp LH79531 ARM (L136
> 00B), the only difference in them is the Plus had ZX Spectrum games. So I
> might be able to use the firmware from the E2 on the E1. The E3 had a
> different CPU because it need a MMU for the Colour LCD screen so need to be
> more powerful than the E1,E2.
>
> Spanner..
>

---

From: Nick Griffin <[email-masked]>
Date: Sun, 14 Apr 2019 02:37:12 +0000

Its lights flash when you plug it in and thats it pbltool says probbing and nothing else...?

-------- Original message --------
From: David Given <[email-masked]>
Date: 13/04/2019 22:58 (GMT+00:00)
To: Discussion of the Amstrad E3 emailer hardware/software <[email-masked]>
Subject: Re: [E3-hacking] Understanding the E3s Partitions

It's pretty hard to brick them --- PBL's in a different ROM chip to the main flash (and I think you can't reflash it anyway?), so even if you've trashed the main flash PBL runs. So, you should be able to connect pbltool or pblq to it and read and reflash, even if it doesn't boot.

On Sat, 13 Apr 2019 at 21:47, Nick Griffin <[email-masked]<mailto:[email-masked]>> wrote:
Dam..Just tried to flash the E3 and now it don’t boot, ah well..☹
With that's code and it starred coming up with “Flashing Data to NAND Flash without EEC in not recommended”

Spanner..

Spanner..

mtd0

Spanner..

There is info here how to flash to mtd ..  https://forum.doozan.com/read.php?3,16789,16800<https://nam02.safelinks.protection.outlook.com/?url=https%3A%2F%2Feur04.safelinks.protection.outlook.com%2F%3Furl%3Dhttps%3A%2F%2Fforum.doozan.com%2Fread.php%3F3%252c16789%252c16800%26data%3D02%257c01%257c%257c43dd69f306b24fa4d01308d6bf7526b0%257c84df9e7fe9f640afb435aaaaaaaaaaaa%257c1%257c0%257c636906907207602767%26sdata%3Dl0A1sVMwvXx2BYpNyQBhS72Osn%2F%252BKERDRDUddCciVB8%253D%26reserved%3D0&data=02%7C01%7C%7C9e77728c4b964d7c249608d6c05b1f98%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636907894932883709&sdata=2%2B12YTPjS2b4AIgYs5ITr7bSUACkrz5lUYqq9GTPeEU%3D&reserved=0>

Spanner..

Spanner..

mtd0 - kernel

Spanner..

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://nam02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&data=02%7C01%7C%7C9e77728c4b964d7c249608d6c05b1f98%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636907894932903725&sdata=yoQFjKFldJJyXTpTxihfkRZVI0habkdsSqja6Drv%2Bk8%3D&reserved=0>

--
┌─── http://www.cowlark.com<https://nam02.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.cowlark.com&data=02%7C01%7C%7C9e77728c4b964d7c249608d6c05b1f98%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636907894932913736&sdata=deHC%2F7bAIe5TA5FHTaOwDsfDj3CwxIUKwSRJNsizr2k%3D&reserved=0> ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

---

From: Ralph Corderoy <[email-masked]>
Date: Sun, 14 Apr 2019 09:35:46 +0100

Hi,

> Chafa is a command-line utility that converts all kinds of images,
> including animated GIFs, into ANSI/Unicode character output that can
> be displayed in a terminal.

Can we stick to on-topic stuff, please?  We've been asleep on the list
for many years, and the flurry of emails is a bit of a shock.
Superfluous ones like this don't help.  :-)

-- 
Cheers, Ralph.

---

From: Ralph Corderoy <[email-masked]>
Date: Sun, 14 Apr 2019 09:43:00 +0100

Hi Nick,

> Why are there saying all the same block size..?

Because they are all the same block size.  It looks like that flash has
pages and blocks.  Reading/writing is a page at a time, 256 B, whilst
erasing is a block at a time, 16 KiB, and erases all the pages in the
block.  Only an erased page can be written.  Erasing tends to be slow.
See http://www.linux-mtd.infradead.org/doc/nand.html, especially the
`NAND technical view'.

-- 
Cheers, Ralph.

---

From: Ralph Corderoy <[email-masked]>
Date: Sun, 14 Apr 2019 09:46:14 +0100

Hi Nick,

> Just realised there are all the same Block size, look at the erasesize.

Yes, all 16 KiB.

> “flash_erase /dev/mtd0 0 16” whats the 16 for at the end of the line,
> is it what block size to  erase, ( can’t work out what number to put

See https://github.com/vamanea/mtd-utils/blob/master/flash_erase.c#L60

-- 
Cheers, Ralph.

---

From: Ralph Corderoy <[email-masked]>
Date: Sun, 14 Apr 2019 09:49:49 +0100

Hi Nick,

> Dam have to buy another one now.

I agree with David; PBL survives, by design, and you can try again.

> probbing and nothing else...?

You'd need to look into what pbltool is seeking and not finding.
But as long as you're still getting PBL printing out its banner, it's
there and willing to alter the main flash memory for you.

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Sun, 14 Apr 2019 10:31:05 +0000

Hi..
I just wanted to know if I could install its tarball because E3 Linux don’t have a repository to install programs, but it might need dependencies<https://askubuntu.com/questions/361741/what-are-dependencies> so its trial and error to see which programs works and what don’t, I thought it was a good idea using it as photo viewer, the goal was to  put Linux on the E3 but now, you have to find something to do with it otherwise what's the point of putting Linux on it in the first place, Well part of it is a learning curve and to see if it was possible, hats of to all that made it possible.. 😊 but it needs a end result,the whole idea is to make it better and useful, what it really needs is a basic desktop, something bit like what's on the Raspberry PI 1 or Zero but the E3 is probably not powerful enough or it needs its own custom GUI.

It would be good if it had a splash screen while its booting so you know its doing something.

This is the only place I can ask, there's no support for E3 Linux anyway else.

It does need a repository of the programs that work with E3 Linux. That way it can be updated too, but it would need to be connected to the internet by a Ethernet adapter but only certain ones will work becase all it drivers are in its kernel, and have to be installed there to get a new device working,I know abit about Linux, well I did make Commodore OS.. 😊

Anyway hope you all  have a great day.. 😉

Spanner..

From: Ralph Corderoy<mailto:[email-masked]>
Sent: ‎Sunday‎, ‎14‎ ‎April‎ ‎2019 ‎09‎:‎36
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Hi,

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7Cd5b402ce97ea4787fc5708d6c0b43a28%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636908277640884766&amp;sdata=esGg3HaCiUaEz53HV5%2FmAfJqQAMoi88OaxRGun%2FcMOs%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Sun, 14 Apr 2019 10:59:54 +0000

>there and willing to alter the main flash memory for you.

I don’t know what I need to do next and how to find out what pbltool is looking for..?
I don’t know anything about pbltool,I only run it in the V2 release of E3 Linux to install it.
Can you please help.
Thanks.

Spanner..

From: Ralph Corderoy<mailto:[email-masked]>
Sent: ‎Sunday‎, ‎14‎ ‎April‎ ‎2019 ‎09‎:‎50
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Hi Nick,

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7Cbca0e60e2f2f4a3b456308d6c0b62e92%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636908286026369338&amp;sdata=C63LbYb%2B1U8j%2Fx%2BtjoMaTO7H1D1kbEbwP4N%2BEO0tqR8%3D&amp;reserved=0

---

From: Antony Stone <[email-masked]>
Date: Sun, 14 Apr 2019 13:05:46 +0200

On Sunday 14 April 2019 at 12:31:05, Nick Griffin wrote:

> Hi..
> I just wanted to know if I could install its tarball because E3 Linux don’t
> have a repository to install programs, but it might need dependencies so its
> trial and error to see which programs works and what don’t, I thought it was
> a good idea using it as photo viewer, the goal was to put Linux on the E3
> but now, you have to find something to do with it otherwise what's the point 
of putting Linux on it in the first place, Well part of it is a learning curve
> and to see if it was possible, hats of to all that made it possible.. 😊 but
> it needs a end result,the whole idea is to make it better and useful, what
> it really needs is a basic desktop, something bit like what's on the
> Raspberry PI 1 or Zero but the E3 is probably not powerful enough or it
> needs its own custom GUI.

I do find myself wondering "what are you trying to achieve with this process?"

 - what are you trying to end up with being able to do with your E3?

If it's primarily a learning process, then I believe you are already 
succeeding - congratulations.

Antony.

-- 
This sentence contains exacly three erors.

---

From: Ralph Corderoy <[email-masked]>
Date: Sun, 14 Apr 2019 12:26:53 +0100

Hi Nick,

> > But as long as you're still getting PBL printing out its banner,
> > it's there and willing to alter the main flash memory for you.
>
> I don’t know what I need to do next and how to find out what pbltool
> is looking for..?  I don’t know anything about pbltool,I only run it
> in the V2 release of E3 Linux to install it.

>From your questions, it seems you're at the level of wanting to install
Linux on the E3 so you can run programs on it, ideally by installing
pre-built packages, etc.  I don't recall the work done with the E3 being
that much of a `plug and play', e.g. like trying out one Linux distro
after another on a PC.

To troubleshoot, you'll need to start poking about the source code of
the programs like pbltool that you're trying to run, then when you
understand what they're attempting, research further to see what might
be the cause of the failure, etc.  And programs you want to run on the
E3 will probably need building from source, and perhaps cross-compiling
for it too.

IOW, there's quite a variety of skills needed to poke about and get
things going;  that's part of the fun, but it doesn't make for quick
progress.  I expect the lists' members are happy to answer technical
questions based on what they recall, but we haven't been near the
machines in many years and can't just try the same thing that you're
doing.

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Sun, 14 Apr 2019 12:57:24 +0000

I have made a video so you can see it for yourself, its just not doing anything,in pbltool it says Prodding and not going no further ,in Putty you only see Amstrad Delta - PBL V4.9 Build:1311 Assert Debug ICE
> 0MB.-->MEMv01.00.002,CopyLim=00220000h,CodeEnd=01400000h-->PBL......1MB.......2MB*
and that's it stops and nothing happens. No more text comes up …dead... ☹ Its like it can’t talk thought serial no more.
If I can’t fix this I have to buy another one and the cheapest one on eBay is £30..wow.
Here is the video on you tube.. https://www.youtube.com/watch?v=rl8-QUlJvpU
Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Sunday‎, ‎14‎ ‎April‎ ‎2019 ‎12‎:‎00
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Spanner..

Hi Nick,

--
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Sun, 14 Apr 2019 16:12:17 +0000

Fingered it out, Had to stop pbltool from Prodding and had to tell the E3 I have already handshaked..😊and BING it worked, now have Linux back on the E3..feeewwww..lol

Here is the command just incase it happens to anyone else…

Use it in a Terminal under Linux, well pbltool only works under Linux..😊 ..

“./pbltool -d  -f /dev/ttyS0 -n oe-install.pbl” I had to put -d command switch in for pbltool to stop prodding.. 😊 Its was looking for a singnal from the E3 but was not getting one because the system was corrupt so couldn’t boot properly.

Worked it out in the end, and now I have worked something else out too,more in another email soon,(its good news,it about the Amstrad E3 Original Firmware and its file system)I need to go and have a tea break now.. 😊

Talk more later..

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Sunday‎, ‎14‎ ‎April‎ ‎2019 ‎13‎:‎57
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

and that's it stops and nothing happens. No more text comes up …dead... ☹ Its like it can’t talk thought serial no more.
If I can’t fix this I have to buy another one and the cheapest one on eBay is £30..wow.
Here is the video on you tube.. https://www.youtube.com/watch?v=rl8-QUlJvpU<https://eur04.safelinks.protection.outlook.com/?url=https://www.youtube.com/watch?v%3Drl8-QUlJvpU&data=02%7c01%7c%7c438501f942924fac458b08d6c0d8c61a%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636908434593799638&sdata=fqKXmDWREsLLRPyntXteILXrl249IiKp%2BJ%2Bbpzb227s%3D&reserved=0>
Spanner..

Spanner..

Hi Nick,

--
Cheers, Ralph.

---

From: Ralph Corderoy <[email-masked]>
Date: Sun, 14 Apr 2019 17:35:48 +0100

Hi Nick,

> Had to stop pbltool from Prodding and had to tell the E3 I have
> already handshaked..😊and BING it worked, now have Linux back on the
> E3..feeewwww..lol

Well done.

> Here is the command just incase it happens to anyone else…

Thanks; that will help future searchers of the mailing-list archive.

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Sun, 14 Apr 2019 20:05:45 +0000

I was thinking of the GNOME Desktop, It would need a light, or is it not possible because the E3 is not powerful enough..?

Has anyone looked into this..?

Spanner..

---

From: David Given <[email-masked]>
Date: Sun, 14 Apr 2019 22:21:30 +0200

Not a chance, sorry! Just running X is a stretch. The E3 only has 32MB of
RAM; you're going to struggle to get *anything* graphical in that. I
believe that back in the day I managed to get something working with
Kdrive, but most likely you'll need something framebuffer or console based.

On Sun, 14 Apr 2019 at 22:06, Nick Griffin <[email-masked]> wrote:

> I was thinking of the GNOME Desktop, It would need a light, or is it not
> possible because the E3 is not powerful enough..?
>

---

From: Antony Stone <[email-masked]>
Date: Sun, 14 Apr 2019 22:23:47 +0200

> possible because the E3 is not powerful enough..?

I don't know quite what sort of light you're thinking of using, but there is 
no way the E3 has anything like enough RAM to run a "standard" Linux graphical 
desktop environment.

The CPU may be slow, but without enough RAM you'll get nowhere.

Antony.

-- 
In Heaven, the beer is Belgian, the chefs are Italian, the supermarkets are 
British, the mechanics are German, the lovers are French, the entertainment is 
American, and everything is organised by the Swiss.

In Hell, the beer is American, the chefs are British, the supermarkets are 
German, the mechanics are French, the lovers are Swiss, the entertainment is 
Belgian, and everything is organised by the Italians.

---

From: Piotr Michniewski <[email-masked]>
Date: Sun, 14 Apr 2019 22:38:39 +0200

I used to run KDE 1.x and GNOME 1.x and even Mozilla on a PC with 32MB of
RAM. But that was ~15 years ago. I think modern Mozilla would refuse to run
with that.
You could probably try to run some lightweight WMs like IceWM or something.

-- 
Piotr Michniewski

---

From: Nick Griffin <[email-masked]>
Date: Sun, 14 Apr 2019 20:48:32 +0000

I guest it would be imposable, Has anyone got any ideas on how to show a gif on the E3 screen..?

Spanner..

From: Piotr Michniewski<mailto:[email-masked]>
Sent: ‎Sunday‎, ‎14‎ ‎April‎ ‎2019 ‎21‎:‎39
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

I used to run KDE 1.x and GNOME 1.x and even Mozilla on a PC with 32MB of RAM. But that was ~15 years ago. I think modern Mozilla would refuse to run with that.
You could probably try to run some lightweight WMs like IceWM or something.

--
Piotr Michniewski

niedz., 14 kwi 2019 o 22:24 Antony Stone <[email-masked]<mailto:[email-masked]>> napisał(a):

Antony.

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://eur03.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c180114fae4be4caf0c7b08d6c1193b78%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636908711441579093&sdata=ohlAW7%2BiQrwzMvq4K0Bdnp11rujST9XxxE0HlwyZNQY%3D&reserved=0>

---

From: Piotr Michniewski <[email-masked]>
Date: Sun, 14 Apr 2019 23:00:19 +0200

You could try animate from ImageMagick.

-- 
Piotr Michniewski

niedz., 14 kwi 2019 o 22:48 Nick Griffin <[email-masked]> napisał(a):

> *From:* Piotr Michniewski <[email-masked]>
> *Sent:* ‎Sunday‎, ‎14‎ ‎April‎ ‎2019 ‎21‎:‎39
>> <https://eur03.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c180114fae4be4caf0c7b08d6c1193b78%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636908711441579093&sdata=ohlAW7%2BiQrwzMvq4K0Bdnp11rujST9XxxE0HlwyZNQY%3D&reserved=0>
>>

---

From: Ed Robbins <[email-masked]>
Date: Sun, 14 Apr 2019 22:19:02 +0100

gmenu2x is probably your best bet. It's a GUI that runs on the framebuffer
using SDL, generally used to launch SDL applications. It's used on the
zipit z2, gp2x etc (similar specs) mostly for launching emulators, music
players etc.

---

From: Ed Robbins <[email-masked]>
Date: Sun, 14 Apr 2019 22:19:46 +0100

> zipit z2, gp2x etc (similar specs) mostly for launching emulators, music

Note: It's nothing like a proper desktop environment though.

>>> I used to run KDE 1.x and GNOME 1.x and even Mozilla on a PC with 32MB
>>> of RAM. But that was ~15 years ago. I think modern Mozilla would refuse to
>>> run with that.

---

From: Ralph Corderoy <[email-masked]>
Date: Mon, 15 Apr 2019 10:04:14 +0100

Hi Nick,

> Has anyone got any ideas on how to show a gif on the E3 screen..?

If you have a working framebuffer then fbvis is a image viewer by
Ali Gholami Rudi who no longer uses X11.  See his `FRAMEBUFFER' section.
http://litcave.rudi.ir/

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Mon, 15 Apr 2019 10:40:44 +0000

Thanks, do I download the latest version, its a shame this can’t run Android, Android uses Linux to run, well Android is Linux in a way, it come from it If Linux didn’t exist Android wouldn't.

Spanner..

From: Ralph Corderoy<mailto:[email-masked]>
Sent: ‎Monday‎, ‎15‎ ‎April‎ ‎2019 ‎10‎:‎04
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Hi Nick,

If you have a working framebuffer then fbvis is a image viewer by
Ali Gholami Rudi who no longer uses X11.  See his `FRAMEBUFFER' section.
https://eur03.safelinks.protection.outlook.com/?url=http%3A%2F%2Flitcave.rudi.ir%2F&amp;data=02%7C01%7C%7Cc23d3bd2aac54a03c6ed08d6c181602e%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636909158734999545&amp;sdata=R9NgcWO9AfU17MsJECM78S1jZbOirwzBTlgvtOxnrXQ%3D&amp;reserved=0

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7Cc23d3bd2aac54a03c6ed08d6c181602e%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636909158735009556&amp;sdata=mH6fIns%2FMyEii1L4LGsrvSCMkhYzBKnUEmkJ1ft2n98%3D&amp;reserved=0

---

From: David Given <[email-masked]>
Date: Mon, 15 Apr 2019 12:57:00 +0200

Android's also way too big! Even the earliest version (I have one on my
desk) needed 192MB. Current versions get a bit uncomfortable in 2048MB..

Linux is really too big for the E3; the OS, even the 10-year-old version
the E3 used, doesn't scale down well that far. Now, if you wanted to port
something like Minix to it...

On Mon, 15 Apr 2019 at 12:40, Nick Griffin <[email-masked]> wrote:

> Thanks, do I download the latest version, its a shame this can’t run
> Android, Android uses Linux to run, well Android is Linux in a way, it come
> from it If Linux didn’t exist Android wouldn't.
>
> Spanner..
>
> *From:* Ralph Corderoy <[email-masked]>
> *Sent:* ‎Monday‎, ‎15‎ ‎April‎ ‎2019 ‎10‎:‎04

---

From: Nick Griffin <[email-masked]>
Date: Mon, 15 Apr 2019 11:29:02 +0000

This is another idea I have, this is about the Amstrad E3 Original Firmware, I wish I thought of this before I flashed E3 Linux on mine. This will only work if your E3 that is activated(unlocked).
The installer for installing E3 Linux on the E3 Release V2 uses a Ramdisk to boot up so it can flash E3 Linux to the E3s NAND.
My idea is you should be able to mount the Amstrad Original file system,its in one of the mtd partitions,I don’t know of hand what command you would use to mount it, once you have mounted it, this may work but may not I can’t test it because I flashed mine with E3 Linux V2,I wish I didn’t now, anyway.
Once in the file system(you need the partition with the Main Software on) look for Delta_e_live.config its should be in there somewhere, If the E3 is works and is unlocked Activated, Plug in your USB Stick, copy it to your USB Stick for save keeping and to keep the config the way it is, like a snapshot of it (you add more time to the E3 by coping it over the file again, this is why you need a copy of the file)if you can, but should be able to copy it or edit it, if you do find it can you please share it, I would like to look at it, I am hoping its just a text file but this is just guess work will not know until we find the config file.

Let me know if this works or you find the config file.

Oh the E2 (Amstrad Emailer Plus) has one too, its called Gamma_e_live.confg. and works the same way as on the E3.

Hope this works.. 😊

Spanner..

---

From: Nick Griffin <[email-masked]>
Date: Mon, 15 Apr 2019 11:46:31 +0000

Sorry had to add abit I missed..😊

This is another idea I have, this is about the Amstrad E3 Original Firmware, I wish I thought of this before I flashed E3 Linux on mine. This will only work if your E3 is activated(unlocked).

The installer for installing E3 Linux on the E3 Release V2 uses a Ramdisk to boot up so it can flash E3 Linux to the E3s NAND.
Only read the part in brakets if you don’t know how to run the e3 Linux Release v2 so it runs its ramdisk.. move to “My idea…” if you do..
(You need to connect your E3 by Serial then download http://the.earth.li/pub/e3/E3_release_v2.tar.gz and uncompress it,this will only work on Linux, it don’t work on Windows,then click on readme to find out how to boot in to E3 Linux BUT DO NOT INSTALL IT, Only run the Installer but using the pbltool command in the readme Once you have logged on with root then you need to find out how to mount a MTD Partition<https://www.google.co.uk/search?client=opera&q=how+to+mount+a+MTD+Partition&sourceid=opera&ie=UTF-8&oe=UTF-8>.)

Hope this works.. 😊

Spanner..

---

From: Nick Griffin <[email-masked]>
Date: Mon, 15 Apr 2019 12:11:16 +0000

I believe it needs a hacked version of the original firmware really and everything would work and if you could hack the internet and email apps in the Main Software so it would work with a network adapter to download email and that.

But that will never happen because there is no interest in the device no more and its too old now. I would like a hacked version of it. You could put a Raspberry PI in it and would need a 6 inch screen. I would like to use it as intended, as a phone and that.

Spanner..

From: David Given<mailto:[email-masked]>
Sent: ‎Monday‎, ‎15‎ ‎April‎ ‎2019 ‎11‎:‎57
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Android's also way too big! Even the earliest version (I have one on my desk) needed 192MB. Current versions get a bit uncomfortable in 2048MB..

Linux is really too big for the E3; the OS, even the 10-year-old version the E3 used, doesn't scale down well that far. Now, if you wanted to port something like Minix to it...

On Mon, 15 Apr 2019 at 12:40, Nick Griffin <[email-masked]<mailto:[email-masked]>> wrote:
Thanks, do I download the latest version, its a shame this can’t run Android, Android uses Linux to run, well Android is Linux in a way, it come from it If Linux didn’t exist Android wouldn't.

Spanner..

Hi Nick,

If you have a working framebuffer then fbvis is a image viewer by
Ali Gholami Rudi who no longer uses X11.  See his `FRAMEBUFFER' section.
https://eur03.safelinks.protection.outlook.com/?url=http%3A%2F%2Flitcave.rudi.ir%2F&amp;data=02%7C01%7C%7Cc23d3bd2aac54a03c6ed08d6c181602e%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636909158734999545&amp;sdata=R9NgcWO9AfU17MsJECM78S1jZbOirwzBTlgvtOxnrXQ%3D&amp;reserved=0<https://nam02.safelinks.protection.outlook.com/?url=http://litcave.rudi.ir/&data=02%7c01%7c%7c55fc20814aba4056b1a708d6c191259e%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636909226493582912&sdata=Mj5QB1qQspKqvPKiCIAIuuxQerS1U3HvjW4NLasb3RA%3D&reserved=0>

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7Cc23d3bd2aac54a03c6ed08d6c181602e%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636909158735009556&amp;sdata=mH6fIns%2FMyEii1L4LGsrvSCMkhYzBKnUEmkJ1ft2n98%3D&amp;reserved=0<https://nam02.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c55fc20814aba4056b1a708d6c191259e%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636909226493592922&sdata=68iLavmOCqqZ4BPlY5b9EYh4%2BM8u6JzkOfDkYBZZmbo%3D&reserved=0>
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://nam02.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c55fc20814aba4056b1a708d6c191259e%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636909226493602927&sdata=FUgtQjMNnhZNDmIfuTGX5Yc%2BlGssiVXfQjvnasbUvyQ%3D&reserved=0>

--
┌─── http://www.cowlark.com<https://nam02.safelinks.protection.outlook.com/?url=http://www.cowlark.com&data=02%7c01%7c%7c55fc20814aba4056b1a708d6c191259e%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636909226493612932&sdata=sNI7%2B4a9qH0ZIIQ5WwdyHgRqDTKLM7WigFjeTCaFnjI%3D&reserved=0> ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

---

From: Nick Griffin <[email-masked]>
Date: Mon, 15 Apr 2019 12:17:17 +0000

I wouldn’t know how to port Minix,can anyone else do it..?

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Monday‎, ‎15‎ ‎April‎ ‎2019 ‎13‎:‎11
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Spanner..

Spanner..

Hi Nick,

If you have a working framebuffer then fbvis is a image viewer by
Ali Gholami Rudi who no longer uses X11.  See his `FRAMEBUFFER' section.
https://eur03.safelinks.protection.outlook.com/?url=http%3A%2F%2Flitcave.rudi.ir%2F&amp;data=02%7C01%7C%7Cc23d3bd2aac54a03c6ed08d6c181602e%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636909158734999545&amp;sdata=R9NgcWO9AfU17MsJECM78S1jZbOirwzBTlgvtOxnrXQ%3D&amp;reserved=0<https://nam02.safelinks.protection.outlook.com/?url=http://litcave.rudi.ir/&data=02%7c01%7c%7cd9bb905f844c498706b708d6c19b7f22%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636909270933083383&sdata=xj8H8mLF42Oxb0gYar6xQicn9vtg9ohRL9vH%2B%2BCLtPQ%3D&reserved=0>

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7Cc23d3bd2aac54a03c6ed08d6c181602e%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636909158735009556&amp;sdata=mH6fIns%2FMyEii1L4LGsrvSCMkhYzBKnUEmkJ1ft2n98%3D&amp;reserved=0<https://nam02.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7cd9bb905f844c498706b708d6c19b7f22%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636909270933103405&sdata=OWb3uuk8YZ2x/Uw7DGgnSrKequW/P5DT2gnYqGw2E1o%3D&reserved=0>
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://nam02.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7cd9bb905f844c498706b708d6c19b7f22%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636909270933113411&sdata=pRCI/5x3BaRJcxRwj7Vk4hHq%2BMty4dkZJf0d0TLF6yY%3D&reserved=0>

--
┌─── http://www.cowlark.com<https://nam02.safelinks.protection.outlook.com/?url=http://www.cowlark.com&data=02%7c01%7c%7cd9bb905f844c498706b708d6c19b7f22%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636909270933133427&sdata=egyY8xHHsc6Kz2C0UfsYi/lt%2BlYS5KuYjTroRkr4WYw%3D&reserved=0> ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

---

From: Nick Griffin <[email-masked]>
Date: Mon, 15 Apr 2019 16:11:14 +0000

Well it didn’t flash, and I think it didn’t erase too so my code is wrong I think… looks like it has bad blocks too and they and made the files bigger in size than the partition..???

This process will completely restore your E3's NAND.
This will try and restore The Amstrad firmware on the device. Are you
sure you wish to continue? [y/N]: y

Starting restore.. This might take a while...
Found e3-nand-backup.0
  Erasing /dev/mtd0
Erase Total 0 Units
 done
  Writing e3-nand-backup.0 to /dev/mtd0
Image 3784704 bytes, NAND page 512 bytes, OOB area 512 bytes, device size 3670016 bytes
Input file does not fit into device: Success
Data did not fit into device, due to bad blocks
: Success
Found e3-nand-backup.1
  Erasing /dev/mtd1
Erase Total 0 Units
 done
  Writing e3-nand-backup.1 to /dev/mtd1
Image 270336 bytes, NAND page 512 bytes, OOB area 512 bytes, device size 262144 bytes
Input file does not fit into device: Success
Data did not fit into device, due to bad blocks
: Success
Found e3-nand-backup.3
  Erasing /dev/mtd3
Erase Total 0 Units
 done
  Writing e3-nand-backup.3 to /dev/mtd3
Image 270336 bytes, NAND page 512 bytes, OOB area 512 bytes, device size 262144 bytes
Input file does not fit into device: Success
Data did not fit into device, due to bad blocks
: Success
Found e3-nand-backup.4
  Erasing /dev/mtd4
Erase Total 0 Units
 done
  Writing e3-nand-backup.4 to /dev/mtd4
Image 29196288 bytes, NAND page 512 bytes, OOB area 512 bytes, device size 28311552 bytes
Input file does not fit into device: Success
Data did not fit into device, due to bad blocks
: Success
Finished restoring the Amstrad E3 Firmware,
Type Reboot to see if the Amstrad E3 splashcreen comes up

Spanner..

---

From: Nick Griffin <[email-masked]>
Date: Mon, 15 Apr 2019 21:33:56 +0000

It looks like when it backs up the NAND its copies the blocks that are bad too making the image bigger,  so if you try and restore the E3 back to the way it was, you can’t because the bad Blocks stop it from installing,  if you want to use Linux on the E3 use it from the Ramdisk in Release V2 here<http://the.earth.li/pub/e3/E3_release_v2.tar.gz>,Just don’t run ams-delta-install then you will not lose the Amstrad E3 Original Firmware. Like I did and I am gutted. I have to now buy another one and its going to cost me £30 because they are not cheap because they are retro, well…😊How can it be retro when the service only was close 8 years ago. A Commodore 64 or ZX Spectrum is retro..😊

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Monday‎, ‎15‎ ‎April‎ ‎2019 ‎17‎:‎11
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Spanner..

---

From: David Given <[email-masked]>
Date: Mon, 15 Apr 2019 23:59:32 +0200

There'll be a way to extract the data from the flash backups you have,
which you can then write to the device in a way that knows about the bad
blocks. The ams_delta installer script will be doing exactly this. I can't
remember what any of the E3 partitions do any more but the big one will
most likely be a JFFS2 filesystem. Loopback mounting those JFFS2 images is
a pain because you need to use mtdram to fake a flash device.

If all else fails, you can always run ams_delta on it.

On Mon, 15 Apr 2019 at 23:34, Nick Griffin <[email-masked]> wrote:

> It looks like when it backs up the NAND its copies the blocks that are bad
> too making the image bigger,  so if you try and restore the E3 back to the
> way it was, you can’t because the bad Blocks stop it from installing,  if
> you want to use Linux on the E3 use it from the Ramdisk in Release V2 here
> <http://the.earth.li/pub/e3/E3_release_v2.tar.gz>,Just don’t run
> ams-delta-install then you will not lose the Amstrad E3 Original Firmware.
> Like I did and I am gutted. I have to now buy another one and its going to
> cost me £30 because they are not cheap because they are retro, well…😊How
> can it be retro when the service only was close 8 years ago. A Commodore 64
> or ZX Spectrum is retro..😊
>
> Spanner..
>
> *Sent:* ‎Monday‎, ‎15‎ ‎April‎ ‎2019 ‎17‎:‎11
> Well it didn’t flash, and I think it didn’t erase too so my code is wrong
> I think… looks like it has bad blocks too and they and made the
> files bigger in size than the partition..???
>
>
>
> *This process will completely restore your E3's NAND. This will try and
> restore The Amstrad firmware on the device. Are you sure you wish to
> continue? [y/N]: y*
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> *Starting restore.. This might take a while... Found e3-nand-backup.0
> Erasing /dev/mtd0 Erase Total 0 Units  done   Writing e3-nand-backup.0 to
> /dev/mtd0 Image 3784704 bytes, NAND page 512 bytes, OOB area 512 bytes,
> device size 3670016 bytes Input file does not fit into device: Success Data
> did not fit into device, due to bad blocks : Success Found e3-nand-backup.1
>   Erasing /dev/mtd1 Erase Total 0 Units  done   Writing e3-nand-backup.1 to
> /dev/mtd1 Image 270336 bytes, NAND page 512 bytes, OOB area 512 bytes,
> device size 262144 bytes Input file does not fit into device: Success Data
> did not fit into device, due to bad blocks : Success Found e3-nand-backup.3
>   Erasing /dev/mtd3 Erase Total 0 Units  done   Writing e3-nand-backup.3 to
> /dev/mtd3 Image 270336 bytes, NAND page 512 bytes, OOB area 512 bytes,
> device size 262144 bytes Input file does not fit into device: Success Data
> did not fit into device, due to bad blocks : Success Found e3-nand-backup.4
>   Erasing /dev/mtd4 Erase Total 0 Units  done   Writing e3-nand-backup.4 to
> /dev/mtd4 Image 29196288 bytes, NAND page 512 bytes, OOB area 512 bytes,
> device size 28311552 bytes Input file does not fit into device: Success
> Data did not fit into device, due to bad blocks : Success Finished
> restoring the Amstrad E3 Firmware, Type Reboot to see if the Amstrad E3
> splashcreen comes up*
>
> Spanner..
>

---

From: Nick Griffin <[email-masked]>
Date: Tue, 16 Apr 2019 08:02:49 +0000

Is there any website about extracting the data from the Amstrad E3 images,if I can’t find a way I be buying another this week, I flashed E3 Linux on it thinking I could put the original Firmware back, ah well, there is nothing you can do with E3 Linux becase it missing so mush programs that in normal Linux because its slimed down..it don’t even have make on it to compile programs on it, this is why it not used and now there are development boards out there now that are faster and can hold Linux on without having to slim it down but this was not made for this, at the end of the day its just a phone and should used as one now.

Spanner..

From: David Given<mailto:[email-masked]>
Sent: ‎Monday‎, ‎15‎ ‎April‎ ‎2019 ‎22‎:‎59
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

There'll be a way to extract the data from the flash backups you have, which you can then write to the device in a way that knows about the bad blocks. The ams_delta installer script will be doing exactly this. I can't remember what any of the E3 partitions do any more but the big one will most likely be a JFFS2 filesystem. Loopback mounting those JFFS2 images is a pain because you need to use mtdram to fake a flash device.

On Mon, 15 Apr 2019 at 23:34, Nick Griffin <[email-masked]<mailto:[email-masked]>> wrote:
It looks like when it backs up the NAND its copies the blocks that are bad too making the image bigger,  so if you try and restore the E3 back to the way it was, you can’t because the bad Blocks stop it from installing,  if you want to use Linux on the E3 use it from the Ramdisk in Release V2 here<https://eur04.safelinks.protection.outlook.com/?url=http://the.earth.li/pub/e3/E3_release_v2.tar.gz&data=02%7c01%7c%7c47d96ca1b9fc41e51db808d6c1edb3b6%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636909623990816699&sdata=17YCNEtuH%2BeK%2B2BNb6gJ4qiIKmFbDFPl2LcDxvIqpWA%3D&reserved=0>,Just don’t run ams-delta-install then you will not lose the Amstrad E3 Original Firmware. Like I did and I am gutted. I have to now buy another one and its going to cost me £30 because they are not cheap because they are retro, well…😊How can it be retro when the service only was close 8 years ago. A Commodore 64 or ZX Spectrum is retro..😊

Spanner..

Spanner..

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://eur04.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c47d96ca1b9fc41e51db808d6c1edb3b6%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636909623990826703&sdata=8fjy%2Bw3/obQABiGJwYk0MZkPRiiKH/XvoQQiPl6xAKo%3D&reserved=0>

--
┌─── http://www.cowlark.com<https://eur04.safelinks.protection.outlook.com/?url=http://www.cowlark.com&data=02%7c01%7c%7c47d96ca1b9fc41e51db808d6c1edb3b6%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636909623990826703&sdata=MdJtjF1dAjhiRVwxmNf7kYnjEcfM5IIZm2r77RRMnrI%3D&reserved=0> ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

---

From: Nick Griffin <[email-masked]>
Date: Tue, 16 Apr 2019 13:04:41 +0000

Just bought another one but Good News is that its working and Activated so hopefully be able to get the delta_e_live.config from it.
If the emailer is activated then the file is in the system, when it deactivated then the file has been deleted.

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Tuesday‎, ‎16‎ ‎April‎ ‎2019 ‎09‎:‎03
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Spanner..

On Mon, 15 Apr 2019 at 23:34, Nick Griffin <[email-masked]<mailto:[email-masked]>> wrote:
It looks like when it backs up the NAND its copies the blocks that are bad too making the image bigger,  so if you try and restore the E3 back to the way it was, you can’t because the bad Blocks stop it from installing,  if you want to use Linux on the E3 use it from the Ramdisk in Release V2 here<https://eur04.safelinks.protection.outlook.com/?url=http://the.earth.li/pub/e3/E3_release_v2.tar.gz&data=02%7c01%7c%7ca81b3b1bffcd45d3586508d6c241f55d%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636909985870739791&sdata=ZNxcj1BbEU60rSiE%2B0W3aTIcQp/dUzU2AKifheWowB0%3D&reserved=0>,Just don’t run ams-delta-install then you will not lose the Amstrad E3 Original Firmware. Like I did and I am gutted. I have to now buy another one and its going to cost me £30 because they are not cheap because they are retro, well…😊How can it be retro when the service only was close 8 years ago. A Commodore 64 or ZX Spectrum is retro..😊

Spanner..

Spanner..

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://eur04.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7ca81b3b1bffcd45d3586508d6c241f55d%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636909985870749808&sdata=zzf6FOxs0dWzNFbUWsxkShkCgiVyzfqZ21z5iOeROmc%3D&reserved=0>

--
┌─── http://www.cowlark.com<https://eur04.safelinks.protection.outlook.com/?url=http://www.cowlark.com&data=02%7c01%7c%7ca81b3b1bffcd45d3586508d6c241f55d%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636909985870749808&sdata=0Z9fYaQT6opZ8zIjD990MAh0RSu8kSY3GZp8/DbSQB4%3D&reserved=0> ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

---

From: Nick Griffin <[email-masked]>
Date: Tue, 16 Apr 2019 19:45:20 +0000

Got to just find out how to mount a mtd partition with the system on it, then that file (delta_e_live.config) will be in there somewhere…😊

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Tuesday‎, ‎16‎ ‎April‎ ‎2019 ‎14‎:‎04
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Spanner..

Spanner..

On Mon, 15 Apr 2019 at 23:34, Nick Griffin <[email-masked]<mailto:[email-masked]>> wrote:
It looks like when it backs up the NAND its copies the blocks that are bad too making the image bigger,  so if you try and restore the E3 back to the way it was, you can’t because the bad Blocks stop it from installing,  if you want to use Linux on the E3 use it from the Ramdisk in Release V2 here<https://eur03.safelinks.protection.outlook.com/?url=http://the.earth.li/pub/e3/E3_release_v2.tar.gz&data=02%7c01%7c%7cc5291e35571543ca34c408d6c26c1fe0%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636910166973216848&sdata=aaN9t11isvaBv31NMEoD0szYuWlnbrIxgkBncakToEs%3D&reserved=0>,Just don’t run ams-delta-install then you will not lose the Amstrad E3 Original Firmware. Like I did and I am gutted. I have to now buy another one and its going to cost me £30 because they are not cheap because they are retro, well…😊How can it be retro when the service only was close 8 years ago. A Commodore 64 or ZX Spectrum is retro..😊

Spanner..

Spanner..

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://eur03.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7cc5291e35571543ca34c408d6c26c1fe0%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636910166973236871&sdata=723%2BGzCgqXNRc4aYMa0orzGjJG2G3tVxAS6dgscOFDc%3D&reserved=0>

--
┌─── http://www.cowlark.com<https://eur03.safelinks.protection.outlook.com/?url=http://www.cowlark.com&data=02%7c01%7c%7cc5291e35571543ca34c408d6c26c1fe0%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636910166973246876&sdata=2wtvPbdlB2jZ4gQYMwpTS2d8wA1ffyMKR5mx%2BQS%2BcK0%3D&reserved=0> ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

---

From: Nick Griffin <[email-masked]>
Date: Tue, 16 Apr 2019 20:24:09 +0000

Here is the backup to my E3 original Firmware,6 files are zipped up in a zip file. download it here<https://drive.google.com/open?id=1oAZ5oUuoHOttOP0neAN3RMQoy0Hu7LfK>.. Maybe someone might find it useful..😊 This is not activated but someone might be able to extract the OS from it and get there E3 partly working again. I sheared this so you can have a play with it, if you want.
Remember that it has bad blocks too so they need to be removed or data need extracted ,you can’t flash it to the E3 the way it is, It will not work, the biggest file, e3-nand-backup.4 is the OS it 27.8mb.

e3-nand-backup.0 is 360mb,e3-nand-backup.1 is 264kb, e3-nand-backup.2 is 264kb, e3-nand-backup.3 is 264kb, e3-nand-backup.4 is 27.8mb, e3-nand-backup.5 is 792kb.

Good luck with it.

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Tuesday‎, ‎16‎ ‎April‎ ‎2019 ‎20‎:‎45
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Spanner..

Spanner..

Spanner..

On Mon, 15 Apr 2019 at 23:34, Nick Griffin <[email-masked]<mailto:[email-masked]>> wrote:
It looks like when it backs up the NAND its copies the blocks that are bad too making the image bigger,  so if you try and restore the E3 back to the way it was, you can’t because the bad Blocks stop it from installing,  if you want to use Linux on the E3 use it from the Ramdisk in Release V2 here<https://eur02.safelinks.protection.outlook.com/?url=http://the.earth.li/pub/e3/E3_release_v2.tar.gz&data=02%7c01%7c%7ce53ab1dbbb2942fa729f08d6c2a417b7%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636910407358132598&sdata=z7wAKaWg04ZUsu1iKQPybfra8a35n4eTSTmTOYeBpKw%3D&reserved=0>,Just don’t run ams-delta-install then you will not lose the Amstrad E3 Original Firmware. Like I did and I am gutted. I have to now buy another one and its going to cost me £30 because they are not cheap because they are retro, well…😊How can it be retro when the service only was close 8 years ago. A Commodore 64 or ZX Spectrum is retro..😊

Spanner..

Spanner..

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://eur02.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7ce53ab1dbbb2942fa729f08d6c2a417b7%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636910407358142615&sdata=BL2S2t0sNhC3Q/axN8fe4ifnccqDGuwSszTM1qCGeIc%3D&reserved=0>

--
┌─── http://www.cowlark.com<https://eur02.safelinks.protection.outlook.com/?url=http://www.cowlark.com&data=02%7c01%7c%7ce53ab1dbbb2942fa729f08d6c2a417b7%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636910407358162631&sdata=jNJ9BmPulpXKxTk2j6K%2BbDSVDEnX/yu6gIfJezJS/Hc%3D&reserved=0> ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

---

From: SJS Doherty <[email-masked]>
Date: Wed, 17 Apr 2019 00:28:03 +0000

Nick,

If possible, could you remove me from the E3 mailing lists. My mother is ill at the moment and I’m watching the email on my phone for updates, so I’m trying to exclude non-essential emails.

Thank you and best wishes with the E3 work.

James

James Doherty

On 16 Apr 2019, at 21:25, Nick Griffin <[email-masked]<mailto:[email-masked]>> wrote:

Here is the backup to my E3 original Firmware,6 files are zipped up in a zip file. download it here<https://apc01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdrive.google.com%2Fopen%3Fid%3D1oAZ5oUuoHOttOP0neAN3RMQoy0Hu7LfK&data=02%7C01%7C%7Cd7a05748fd5045154b2908d6c2a999a8%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636910431025839954&sdata=eKFtMXORKCLYcE2T2B77xR6BHS36RUsNGDK2t4ZCKTI%3D&reserved=0>.. Maybe someone might find it useful..😊 This is not activated but someone might be able to extract the OS from it and get there E3 partly working again. I sheared this so you can have a play with it, if you want.
Remember that it has bad blocks too so they need to be removed or data need extracted ,you can’t flash it to the E3 the way it is, It will not work, the biggest file, e3-nand-backup.4 is the OS it 27.8mb.

Good luck with it.

Spanner..

Spanner..

Spanner..

Spanner..

On Mon, 15 Apr 2019 at 23:34, Nick Griffin <[email-masked]<mailto:[email-masked]>> wrote:
It looks like when it backs up the NAND its copies the blocks that are bad too making the image bigger,  so if you try and restore the E3 back to the way it was, you can’t because the bad Blocks stop it from installing,  if you want to use Linux on the E3 use it from the Ramdisk in Release V2 here<https://apc01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fthe.earth.li%2Fpub%2Fe3%2FE3_release_v2.tar.gz&data=02%7C01%7C%7Cd7a05748fd5045154b2908d6c2a999a8%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636910431025849959&sdata=8RmdeUXNv3YoWp2Jkz2UScNPDjT9wVp3btU5F2nINUk%3D&reserved=0>,Just don’t run ams-delta-install then you will not lose the Amstrad E3 Original Firmware. Like I did and I am gutted. I have to now buy another one and its going to cost me £30 because they are not cheap because they are retro, well…😊How can it be retro when the service only was close 8 years ago. A Commodore 64 or ZX Spectrum is retro..😊

Spanner..

Spanner..

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://apc01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&data=02%7C01%7C%7Cd7a05748fd5045154b2908d6c2a999a8%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636910431025859970&sdata=AvvngzxMhMR%2FuG1csoeJbjU7K9u9fPmzqJx28yDekvg%3D&reserved=0>

--
┌─── http://www.cowlark.com<https://apc01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.cowlark.com&data=02%7C01%7C%7Cd7a05748fd5045154b2908d6c2a999a8%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636910431025869987&sdata=b8IzvYpw2641%2B1RVZ6XbHTkTbtpwwhjiFDQK7xspxKc%3D&reserved=0> ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://apc01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7Cd7a05748fd5045154b2908d6c2a999a8%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636910431025910013&amp;sdata=P1UlARNraKJdcX6BGidOsYcNh4cPqMXJZOI%2FCj0%2B3Iw%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Tue, 16 Apr 2019 13:00:21 +0000

These looks like a flat version of the Emailer… 😊 Cliff properly used something like this to develop the Amstrad Emailers software. Properly the software was made first and see if the hardware works with it so if it didn’t then they can be changed it quickly, he did have to port the Emailer software from the E2(Plus) the E3 so using the source code from the E2 (Plus) and ported it to work with Linux and the E3 hardware, Not sure what OS the E2 used.
Maybe someone can answer that…??

Spanner..

Spanner..

Spanner..

Spanner..

---

From: Jonathan McDowell <[email-masked]>
Date: Wed, 17 Apr 2019 09:26:28 +0100

On Wed, Apr 17, 2019 at 12:28:03AM +0000, SJS Doherty wrote:
> If possible, could you remove me from the E3 mailing lists. My mother
> is ill at the moment and I’m watching the email on my phone for
> updates, so I’m trying to exclude non-essential emails.

I've dealt with this, but in general if people want to modify their list
settings they can + should do so themselves at:

 https://www.earth.li/mailman/options/e3-hacking

J.

-- 
I'm from the tax office. I'm here to take all your money.

---

From: Jonathan McDowell <[email-masked]>
Date: Wed, 17 Apr 2019 09:28:20 +0100

On Tue, Apr 16, 2019 at 07:45:20PM +0000, Nick Griffin wrote:
> Got to just find out how to mount a mtd partition with the system on
> it, then that file (delta_e_live.config) will be in there somewhere…😊

I have a vague memory that the E3 used a read-only cramfs or similar
filesystem for the actual OS/base application stuff, and then a custom
filesystem (based on Q;Q; blocks in flash) for all the ads / games /
ringtones / other content. I don't recall anyone spending time on
working out how to modify that custom setup.

J.

-- 
"I've checked, but I can't find anything in the bible which supports
C++." -- Malcolm Ray

---

From: Nick Griffin <[email-masked]>
Date: Wed, 17 Apr 2019 11:53:48 +0000

Thanks for the info, but the emailer would have to download the config file ever time it looked for mail so rewriting on the top of the old config,so to reset the time back to 90days,it has to be on apart off the system that has full rights if it was read only it would not be able to download the config file. Maybe the Config file is in a place where the games are download.I don’t know yet, It only there if the emailer is activated, if you never connected the email to Amserve the config file would not be there.They all worked the same way.

Spanner..

From: Jonathan McDowell<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎17‎ ‎April‎ ‎2019 ‎09‎:‎28
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

J.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C8763ef23dfc44568680e08d6c30eaba4%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636910865103040359&amp;sdata=j8Zv0P%2FZXyck%2BHpdbv6ujPiey5ReXDn%2BgaUoRleglQE%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Wed, 17 Apr 2019 13:26:40 +0000

Sorry forget to add..
Do you remember if you were able to mount the Cramfs and look at its filesystem..?
What's Q;Q; blocks in flash, another files system…? Can’t find any info on it, were you able to mount that too. So does it have 2 partitions on mtd4 then..?
At the time no one would of looked into the file system cos that would validate the rules on using the Emailer,It now matters cos there all are dead and If we can get to the config file, then maybe get other E3s working again, Amstrad had a 500+ page manual on it cos there could add things to the emaler like different oprtions and that to it,that config file was the heart to the system, Made everything tick.. 😊 without it its a dead machine.

Does anyone remember the command line to mount a mtd partition..?

Spanner..

J.

---

From: Nick Griffin <[email-masked]>
Date: Wed, 17 Apr 2019 16:30:57 +0000

Try to find out the block size for the mtd partitions for ​

#flash_erase /dev/mtd0 0 16 - don’t know what number 16 should be for each mtdx partition..?

Can someone help me please..??

Is the size where it says ending at 0x00380000 so what would the number be for it to erase the right amount of memory from the mtd partition..?

mtd0

Spanner..

From: Jonathan McDowell<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎17‎ ‎April‎ ‎2019 ‎09‎:‎26
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

 https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Foptions%2Fe3-hacking&amp;data=02%7C01%7C%7Ca709034a55814af2ee7c08d6c30e6b66%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636910864024417436&amp;sdata=i0ROcQQVG%2FdHIAvX0syEjbXktACPpnX7lULyawgTQOM%3D&amp;reserved=0

J.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7Ca709034a55814af2ee7c08d6c30e6b66%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636910864024427453&amp;sdata=6S0W%2F%2F2kr3%2FqzUWU%2BgBPpSw%2F6v822nBJ2YwxgWgG1mw%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Thu, 18 Apr 2019 09:14:37 +0000

Hi just setup a forum of the Amstrad Emailer, all the question on the mailing list will be added,it will take a while but not long.
Its has a Chat Box on there so you can leave messages and talk live,You don’t have to join to use it but please no spam, if there is spam then it will be deleted, If you need help quickly post it in the Chat Box.

http://amstrad-e3-hacking.freeforums.net
I hope you find it useful, I am not making you to join, join or not join its up to you, but Its easier to communicate on there and if you miss anything in your post you can edit it, You can’t do that on here because its email.

If you want me to add anything to the forum just ask and I see if I can.. 😊

Spanner..

---

From: Jonathan McDowell <[email-masked]>
Date: Thu, 18 Apr 2019 11:58:11 +0100

On Wed, Apr 17, 2019 at 01:26:40PM +0000, Nick Griffin wrote:

> Do you remember if you were able to mount the Cramfs and look at its
> filesystem..?  What's Q;Q; blocks in flash, another files system…?
> Can’t find any info on it, were you able to mount that too. So does it
> have 2 partitions on mtd4 then..?

You need to remember the E3 dates from a time when embedded Linux
systems were a lot simpler, and the E3 was designed to be a low cost
platform (even allowing for the subsidy). It doesn't have the sort of
NAND setup seen on modern systems; it simply didn't have the resources.

So, the MTD partitions do not directly map to a kernel or a Linux
filesystem. The "Q;Q;" blocks are an Amstrad specific way of putting
data into those partitions, with a type + description associated with
each one. For example the kernel lives in a Q;Q; block in mtd3 called
"LINUX". mtd3 also has Q;Q; blocks for LDR (the second stage boot
loader), and PARMS (the kernel boot parameters).

The CRAMFS filesystem is in mtd4; Q;Q; block name "LNXFSYS". There are 2
of them (I imagine to allow for an active + fallback). There are various
other bits of content in mtd4 too - you can see them by doing:

 hexdump -C e3-nand-backup.4 | grep -A 1 "Q;Q;"

Finally the nanddump files have 16 bytes of out of band (OOB) data per
512 byte block, so if you want something that might be writable back to
the flash you need to strip those out. The attached Python should do the
trick:

 nand-oob-strip e3-nand-backup.0 e3-nand.0

will dump out e3-nand.0 with the OOB data stripped.

J.

-- 
    One-seventh of your life is    |  .''`.  Debian GNU/Linux Developer
         spent on Monday.          | : :' :  Happy to accept PGP signed
                                   | `. `'   or encrypted mail - RSA
                                   |   `-    key on the keyservers.

---

From: Nick Griffin <[email-masked]>
Date: Thu, 18 Apr 2019 12:52:37 +0000

Where do I put attached Python script, in my Linux not in the E3..?

So I do each file with it..?

Spanner..

From: Jonathan McDowell<mailto:[email-masked]>
Sent: ‎Thursday‎, ‎18‎ ‎April‎ ‎2019 ‎11‎:‎58
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

J.

---

From: Ralph Corderoy <[email-masked]>
Date: Thu, 18 Apr 2019 14:35:25 +0100

Hi Nick,

> looks like it has bad blocks too and they and made the files bigger in
> size than the partition..???

No, I don't think so.

...
...
...
> Image 29196288 bytes, NAND page 512 bytes, OOB area 512 bytes, device size 28311552 bytes

    3784704 - 3670016 = 114,688
    114,688 / 1024 = 112
    3670016 / 1024 / 32 = 112
    3784704 / 3670016 = 1.03125

    270336 - 262144 = 8,192
    8,192 / 1024 = 8
    262144 / 1024 / 32 = 8
    270336 / 262144 = 1.03125

    29196288 - 28311552 = 884,736
    884,736 / 1024 = 864
    28311552 / 1024 / 32 = 864
    29196288 / 28311552 = 1.03125

    1 / (1.03125 - 1) = 32

The image is always the same factor bigger than the device size, 1/32th,
suggesting a consistent overhead in the data format.

-- 
Cheers, Ralph.

---

From: Jonathan McDowell <[email-masked]>
Date: Thu, 18 Apr 2019 21:09:13 +0100

Yes, you run it on a proper Linux box, not the E3. The script isn't
going to magically fix anything, but it'll turn the dumps that include
OOB information into dumps without OOB information that might help you
do some sleuthing about their contents.

J.

-- 
I'm dangerous when I know what I'm doing.

---

From: Nick Griffin <[email-masked]>
Date: Thu, 18 Apr 2019 20:20:37 +0000

live@commodoreos<mailto:live@commodoreos> /media/live/E3
READY.
sudo nand-oob-strip.py e3-nand-backup.0 e3-nand.0: No such file or directory

Spanner..

From: Jonathan McDowell<mailto:[email-masked]>
Sent: ‎Thursday‎, ‎18‎ ‎April‎ ‎2019 ‎21‎:‎09
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

J.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7Cec5f9e059ac04cfb6dfa08d6c439c19c%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636912149665586653&amp;sdata=DdEDodAV1hnS9KjUDy6bAmwvHU5phkgshzFfYCk9r8Y%3D&amp;reserved=0

---

From: Ralph Corderoy <[email-masked]>
Date: Sat, 20 Apr 2019 18:39:23 +0100

Hi Nick,

> sudo nand-oob-strip.py e3-nand-backup.0 e3-nand.0: No such file or

Two things.  You probably don't need sudo as your ordinary user should
be able to read e3-nand-backup.0 and write e3-nand.0.  You have to
specify a path to the nand-oob-strip.py script for the shell to find it.
Since it's in the current directory, that's just `.', i.e.

    ./nand-oob-strip.py in.0 out.0

If that complains, then it's because ./nand-oob-strip.py lacks the
`execute' permission for you.  Either add it with chmod(1), or run the
Python interpreter directly:

    python3 nand-oob-strip.py in.0 out.0

Alternatively, to modify the file in place, so ensure they're not your
only copies, you can do

    LC_ALL=C perl -i -0777pe 's/(.{512})(.{16})/$1/gs' \
        e3-nand-backup.{0..5}

which substitutes every 512 bytes followed by 16 bytes with just the
512.

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Sat, 20 Apr 2019 21:25:21 +0000

OK sorted it out now, (thanks to Ollie), will I be able to use these files to put the Amstrad firmware back on the E3 at all..?

question is here too http://amstrad-e3-hacking.freeforums.net/thread/9/config-content-filesystem?page=1&scrollTo=92

You don’t need to register to reply or leave a new thread there now.

Spanner..

From: Ralph Corderoy<mailto:[email-masked]>
Sent: ‎Saturday‎, ‎20‎ ‎April‎ ‎2019 ‎18‎:‎39
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Hi Nick,

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C0c848394242c4830fc6e08d6c5b72a85%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636913787811205410&amp;sdata=0kD8t8q7zfl%2FGDLfdCSjfHE%2B1A2ZbQ8DuiwML03509A%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Sun, 21 Apr 2019 10:40:38 +0000

I do wish I never flashed E3 Linux on it now,theres no point to it,you can’t put anything on it or run anything on it cos its too old and E3 Linux didn’t go anywhere, its just a command line version because the E3 is not powerful to run proper Linux. I installed E3 Linux release v2 (E3 Linux sound better that just Linux or release v2 this way you know what I am taking about)from the.earth.li/pub/e3/<http://the.earth.li/pub/e3/>  what are the rest of the stuff in there, can I update it to 2.6.19,its at 2.6.16 that what release v2 is…?

I would like to put a program on it so it shows images on it screen you have to make it on it and it don’t even have make on it to make a program so make need to be installed first.
If I can’t put the original firmware back or put a program on it so it shows a animated gif then it useless and I will end up putting it in the bin. I have about 8 gifs of its old adverts and want to show them on the E3s screen, can anyone help me please. I am not used to installing programs from source code, I am use to installing it from a repository.

Oh and what happen to this…  http://amstrad-e3-hacking.freeforums.net/thread/7/support-status-update  why did the work on E3 Linux stop and only get to 2.6.19…?

and very interested in this bit at the end.. “BTW, my 12-bit framebuffer display support has been accepted and included in
mplayer svn revision 31139 on May 6th. Using it, I can enjoy a prescaled
422x316 5fps MSMPEG-4 encoded live video stream playing fluently in
fullscreen mode on my E3 display.”

Leave a reply in there and tell us what happened to E3 Linux 2.6.34..

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Saturday‎, ‎20‎ ‎April‎ ‎2019 ‎22‎:‎25
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

question is here too http://amstrad-e3-hacking.freeforums.net/thread/9/config-content-filesystem?page=1&scrollTo=92<https://eur02.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net/thread/9/config-content-filesystem?page%3D1%26scrollTo%3D92&data=02%7c01%7c%7cfab65edec780419544a308d6c5d6bc84%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636913923402583395&sdata=QNkcyk8O/nnJW2g2N8/KnpdebyFkKDumHgYwEfuYdZI%3D&reserved=0>

Spanner..

Hi Nick,

--
Cheers, Ralph.

---

From: David Given <[email-masked]>
Date: Sun, 21 Apr 2019 20:40:44 +0200

If you just want to put images onto the screen, write a tiny script that
copies files from the USB stick and cats them to /dev/fb0. Converting
images to the right format's a little bit harder but I wouldn't be
surprised if ImageMagick could do it out of the box. That'll run happily in
the ams-delta mini distribution.

Alternatively, you can boot an old Debian from a USB stick using that
kernel --- although you'll need to hunt around to find a userland old
enough; I think Debian woody works. That'll give you a (very slow)
development system running on the E3 itself. Then you can write your own
SDL programs to draw whatever you like, although I should warn you against
extended typing on that keyboard unless you hate your fingers.

On Sun, 21 Apr 2019 at 12:40, Nick Griffin <[email-masked]> wrote:

> I do wish I never flashed E3 Linux on it now,theres no point to it,you
> can’t put anything on it or run anything on it cos its too old and E3 Linux
> didn’t go anywhere, its just a command line version because the E3 is not
> powerful to run proper Linux. I installed E3 Linux release v2 (E3 Linux
> sound better that just Linux or release v2 this way you know what I am
> taking about)from the.earth.li/pub/e3/  what are the rest of the stuff in
> there, can I update it to 2.6.19,its at 2.6.16 that what release v2 is…?
>
> I would like to put a program on it so it shows images on it screen you
> have to make it on it and it don’t even have make on it to make a program
> so make need to be installed first.
> If I can’t put the original firmware back or put a program on it so it
> shows a animated gif then it useless and I will end up putting it in the
> bin. I have about 8 gifs of its old adverts and want to show them on the
> E3s screen, can anyone help me please. I am not used to installing programs
> from source code, I am use to installing it from a repository.
>
> Oh and what happen to this…
> http://amstrad-e3-hacking.freeforums.net/thread/7/support-status-update
> why did the work on E3 Linux stop and only get to 2.6.19…?
>
> and very interested in this bit at the end.. “BTW, my 12-bit framebuffer
> display support has been accepted and included in
> *Sent:* ‎Saturday‎, ‎20‎ ‎April‎ ‎2019 ‎22‎:‎25
> OK sorted it out now, (thanks to Ollie), will I be able to use these
> files to put the Amstrad firmware back on the E3 at all..?
>
> question is here too
> http://amstrad-e3-hacking.freeforums.net/thread/9/config-content-filesystem?page=1&scrollTo=92
> <https://eur02.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net/thread/9/config-content-filesystem?page%3D1%26scrollTo%3D92&data=02%7c01%7c%7cfab65edec780419544a308d6c5d6bc84%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636913923402583395&sdata=QNkcyk8O/nnJW2g2N8/KnpdebyFkKDumHgYwEfuYdZI%3D&reserved=0>
>
> *Sent:* ‎Saturday‎, ‎20‎ ‎April‎ ‎2019 ‎18‎:‎39

---

From: Nick Griffin <[email-masked]>
Date: Sun, 21 Apr 2019 21:45:08 +0000

What the ams-delta mini distribution ..?
Which one do I download… https://www.imagemagick.org/script/download.php and how do I install it on the E3..?

Spanner..

From: David Given<mailto:[email-masked]>
Sent: ‎Sunday‎, ‎21‎ ‎April‎ ‎2019 ‎19‎:‎41
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

If you just want to put images onto the screen, write a tiny script that copies files from the USB stick and cats them to /dev/fb0. Converting images to the right format's a little bit harder but I wouldn't be surprised if ImageMagick could do it out of the box. That'll run happily in the ams-delta mini distribution.

Alternatively, you can boot an old Debian from a USB stick using that kernel --- although you'll need to hunt around to find a userland old enough; I think Debian woody works. That'll give you a (very slow) development system running on the E3 itself. Then you can write your own SDL programs to draw whatever you like, although I should warn you against extended typing on that keyboard unless you hate your fingers.

On Sun, 21 Apr 2019 at 12:40, Nick Griffin <[email-masked]<mailto:[email-masked]>> wrote:
I do wish I never flashed E3 Linux on it now,theres no point to it,you can’t put anything on it or run anything on it cos its too old and E3 Linux didn’t go anywhere, its just a command line version because the E3 is not powerful to run proper Linux. I installed E3 Linux release v2 (E3 Linux sound better that just Linux or release v2 this way you know what I am taking about)from the.earth.li/pub/e3/<https://nam04.safelinks.protection.outlook.com/?url=http://the.earth.li/pub/e3/&data=02%7c01%7c%7ca0b9c24dc4674add1b8b08d6c688ee6f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914688762358339&sdata=FOzBMM3LtY1wHF6x7%2BBQNWYAGuV5iYw7lbtnVBH6OTk%3D&reserved=0>  what are the rest of the stuff in there, can I update it to 2.6.19,its at 2.6.16 that what release v2 is…?

Oh and what happen to this…  http://amstrad-e3-hacking.freeforums.net/thread/7/support-status-update<https://nam04.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net/thread/7/support-status-update&data=02%7c01%7c%7ca0b9c24dc4674add1b8b08d6c688ee6f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914688762378349&sdata=NXv3LlBFMP0bxp1Ool7i0X0cLJG6yYCDwj0OeESE7AI%3D&reserved=0>  why did the work on E3 Linux stop and only get to 2.6.19…?

Spanner..

http://amstrad-e3-hacking.freeforums.net<https://nam04.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net&data=02%7c01%7c%7ca0b9c24dc4674add1b8b08d6c688ee6f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914688762388360&sdata=xExnrysiLE/Vq28Z5a67CWbOwNjerR5gqFXWbALCjIc%3D&reserved=0>

question is here too http://amstrad-e3-hacking.freeforums.net/thread/9/config-content-filesystem?page=1&scrollTo=92<https://nam04.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net/thread/9/config-content-filesystem?page%3D1%26scrollTo%3D92&data=02%7c01%7c%7ca0b9c24dc4674add1b8b08d6c688ee6f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914688762398366&sdata=5OC%2BRe0pVyTRImDzqgh5EffiWn%2BP%2BVFM88xPc5sCT1c%3D&reserved=0>

Spanner..

http://amstrad-e3-hacking.freeforums.net<https://nam04.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net&data=02%7c01%7c%7ca0b9c24dc4674add1b8b08d6c688ee6f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914688762408377&sdata=M1rVu2d/c5pYf8f6JZVL67OIum2QDZe1hOvCleoKTnI%3D&reserved=0>

Hi Nick,

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C0c848394242c4830fc6e08d6c5b72a85%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636913787811205410&amp;sdata=0kD8t8q7zfl%2FGDLfdCSjfHE%2B1A2ZbQ8DuiwML03509A%3D&amp;reserved=0<https://nam04.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7ca0b9c24dc4674add1b8b08d6c688ee6f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914688762418382&sdata=RdVAHRoazYlT/JmyzsIjYtDnjHKATRWJH/ajeZfZplc%3D&reserved=0>
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://nam04.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7ca0b9c24dc4674add1b8b08d6c688ee6f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914688762428393&sdata=3vwoSxqdvz55lqVCv4VM4ResEDyH7J9oRa%2BZbE28/mg%3D&reserved=0>

--
┌─── http://www.cowlark.com<https://nam04.safelinks.protection.outlook.com/?url=http://www.cowlark.com&data=02%7c01%7c%7ca0b9c24dc4674add1b8b08d6c688ee6f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914688762438399&sdata=GdboSf%2Bcx4vDx2CqT3gSKUcHpcfCI43tN3ZesHYKAXg%3D&reserved=0> ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

---

From: David Given <[email-masked]>
Date: Mon, 22 Apr 2019 00:05:19 +0200

You wouldn't run imagemagick on the E3 itself. (Apart from anything else
the E3 distribution is, IIRC, something based on OpenEmbedded/Angstrom and
is very hard to get software for?) You'd run it on a PC and use it to
convert files to put on a USB stick, and then use simple scripting on the
E3 to draw them on the screen.

That said, I remember the E3 framebuffer format to be pretty weird, so you
may be better off writing a program (on a PC) to do some kind of custom
conversion. fbset on the E3 should tell you the exact format.

On Sun, 21 Apr 2019 at 23:45, Nick Griffin <[email-masked]> wrote:

> *Sent:* ‎Sunday‎, ‎21‎ ‎April‎ ‎2019 ‎19‎:‎41
>> taking about)from the.earth.li/pub/e3/
>> <https://nam04.safelinks.protection.outlook.com/?url=http://the.earth.li/pub/e3/&data=02%7c01%7c%7ca0b9c24dc4674add1b8b08d6c688ee6f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914688762358339&sdata=FOzBMM3LtY1wHF6x7%2BBQNWYAGuV5iYw7lbtnVBH6OTk%3D&reserved=0>
>> what are the rest of the stuff in there, can I update it to 2.6.19,its at
>> 2.6.16 that what release v2 is…?
>>
>> <https://nam04.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net/thread/7/support-status-update&data=02%7c01%7c%7ca0b9c24dc4674add1b8b08d6c688ee6f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914688762378349&sdata=NXv3LlBFMP0bxp1Ool7i0X0cLJG6yYCDwj0OeESE7AI%3D&reserved=0>
>> <https://nam04.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net&data=02%7c01%7c%7ca0b9c24dc4674add1b8b08d6c688ee6f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914688762388360&sdata=xExnrysiLE/Vq28Z5a67CWbOwNjerR5gqFXWbALCjIc%3D&reserved=0>
>>
>> <https://nam04.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net/thread/9/config-content-filesystem?page%3D1%26scrollTo%3D92&data=02%7c01%7c%7ca0b9c24dc4674add1b8b08d6c688ee6f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914688762398366&sdata=5OC%2BRe0pVyTRImDzqgh5EffiWn%2BP%2BVFM88xPc5sCT1c%3D&reserved=0>
>>
>> <https://nam04.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net&data=02%7c01%7c%7ca0b9c24dc4674add1b8b08d6c688ee6f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914688762408377&sdata=M1rVu2d/c5pYf8f6JZVL67OIum2QDZe1hOvCleoKTnI%3D&reserved=0>
>>
>> <https://nam04.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7ca0b9c24dc4674add1b8b08d6c688ee6f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914688762418382&sdata=RdVAHRoazYlT/JmyzsIjYtDnjHKATRWJH/ajeZfZplc%3D&reserved=0>
>> <https://nam04.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7ca0b9c24dc4674add1b8b08d6c688ee6f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914688762428393&sdata=3vwoSxqdvz55lqVCv4VM4ResEDyH7J9oRa%2BZbE28/mg%3D&reserved=0>
>>
>
>
> --
> <https://nam04.safelinks.protection.outlook.com/?url=http://www.cowlark.com&data=02%7c01%7c%7ca0b9c24dc4674add1b8b08d6c688ee6f%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914688762438399&sdata=GdboSf%2Bcx4vDx2CqT3gSKUcHpcfCI43tN3ZesHYKAXg%3D&reserved=0>
> ───

---

From: Ralph Corderoy <[email-masked]>
Date: Mon, 22 Apr 2019 15:24:41 +0100

Hi Jonathan,

> loader), and PARMS (the kernel boot parameters).

Agreed.  I guessed a 32-byte struct based on various `Q;Q;'s seen.

    $ qq() {
    >     LC_ALL=C perl -0777ne 'print $& while /Q;Q;.{0,32}/g' "$@" |
    >     hexdump -ve '36/1 "%_p" "\n"';
    > }
    $
    $ qq e3-nand-backup.3
    Q;Q;...@............MEM.............
    Q;Q;................PARMS...........
    Q;Q;....Hf..........LDR.............
    Q;Q;.....x..........LINUX...........
    $

> The CRAMFS filesystem is in mtd4; Q;Q; block name "LNXFSYS". There are
> 2 of them (I imagine to allow for an active + fallback).

    $ qq e3-nand-backup.4 | grep LNXFSYS
    Q;Q;................LNXFSYS.........
    Q;Q;...6............LNXFSYS.........
    $

> There are various other bits of content in mtd4 too - you can see them
> by doing:
>

That's where my 32-byte-long guess comes unstuck.  A Q;Q; appears within
the structs around LIBC's.

    $ qq e3-nand-backup.4 | fgrep -3 .LIBC
    Q;Q;..^.. ..........WTL_MAILCON.....
    Q;Q;..... ..........WTL_RES.........
    Q;Q;..M.  ........Q;Q;..... ........
    Q;Q;..... ..........LIBC............
    Q;Q;..... ........Q;Q;...Q. ........
    ..WTL_WAV.........Q;Q;..... ........
    ..WTL_CHUNK.......Q;Q;..$.. ........
    $

And so it's out of step for a while.  Perhaps there's Q;Q;-formatted
data inside a Q;Q; block, or the last struct in the initial `list' is
shorter and its struct's content indicate that.

    $ qq e3-nand-backup.4 | grep -1 ^Q | grep -3 ^-
    Q;Q;..... ..........LIBC............
    Q;Q;..... ........Q;Q;...Q. ........
    ..WTL_WAV.........Q;Q;..... ........
    --
    ..M_USERPREF......Q;Q;.....V........
    Q;Q;.....1..........M_WTL_WTAI......
    Q;Q;.....A..........M_VPARSE........
    $

I expect a bit of peering at the words in each struct would spot a
length or similar of each `file's data to save searching through for the
next Q;Q;.

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Mon, 22 Apr 2019 18:29:55 +0000

The post is called Support status update<https://www.mail-archive.com/search?l=[email-masked]&q=subject:%22%5C%5BE3%5C-hacking%5C%5D+Support+status+update%22&o=newest> and posted by Janusz Krzysztofikand its its here  https://www.mail-archive.com/[email-masked]/msg00189.html

Where could you download it from..?

Janusz Krzysztofik<https://www.mail-archive.com/search?l=[email-masked]&q=from:%22Janusz+Krzysztofik%22> Mon, 17 May 2010 13:35:30 -0700<https://www.mail-archive.com/search?l=[email-masked]&q=date:20100517>

Hi,

As linux-2.6.34 is out, a few words on what's new regarding our E3's.

Modem support and dependant audio mixer functionality, that got broken in
2.6.33, have been corrected and should work again.

Contrast control has been added (not extremely usefull, but just for
completeness). You should be able to play with it by writing
to /sys/class/lcd/omapfb/contrast and /sys/class/lcd/omapfb/lcd_power.
Unfortunatelly, I failed to get the updated ams_delta_defconfig included, so
you have to select this manually for now:

        Device Drivers  --->
          Graphics support  --->
            [*] Backlight & LCD device support  --->
              <*>   Lowlevel LCD controls

For the same reason, you may have to make more corrections to the default
configuration if you would still like to use the new kernel together with old
installation tools, otherwise the resulting uImage would probably be too big.
Try these changes that got accepted too late for inclusion:

        General setup  --->
          RCU Subsystem  --->
            RCU Implementation  --->
              (X) Preemptable tree-based hierarchical RCU

        [*] Enable the block layer  --->
          [ ]   Support for large (2TB+) block devices and files

        Kernel hacking  --->
          [ ] Verbose BUG() reporting (adds 70K)

That's all for 2.6.34. The long awaited external keyboard support is already
present in linux-omap and should appear in mainline as soon as 2.6.35-rc1 is
out.

BTW, my 12-bit framebuffer display support has been accepted and included in
mplayer svn revision 31139 on May 6th. Using it, I can enjoy a prescaled
422x316 5fps MSMPEG-4 encoded live video stream playing fluently in
fullscreen mode on my E3 display.

Thanks,
Janusz

Spanner..

---

From: Ralph Corderoy <[email-masked]>
Date: Tue, 23 Apr 2019 13:33:32 +0100

Hi again,

>     >     hexdump -ve '36/1 "%_p" "\n"';

Silly me, forgot the `s'.

    $ qq() {
    >     LC_ALL=C perl -0777ne 'print $& while /Q;Q;.{0,32}/gs' "$@" |
    $

> That's where my 32-byte-long guess comes unstuck.  A Q;Q; appears
> within the structs around LIBC's.
>

    $ qq e3-nand-backup.4 | fgrep -3 .LIBC
    Q;Q;..... ..........WTL_RES.........
    Q;Q;..M.  ..........WTL_TXT.........
    Q;Q;..... ..........WTL_TOBMP.......
    Q;Q;..... ..........LIBC............
    Q;Q;..... ..........RENDER..........
    Q;Q;...Q. ..........WTL_WAV.........
    Q;Q;..... ..........WTL_CHUNK.......
    $

-- 
Cheers, Ralph.

---

From: Jonathan McDowell <[email-masked]>
Date: Tue, 23 Apr 2019 13:37:47 +0100

> Agreed.  I guessed a 32-byte struct based on various `Q;Q;'s seen.

It's a 124 byte struct from my notes;

 0:   0x3B513B51      # Q;Q;
 4:
 6:   2 byte checksum
 8:   Length if uncompressed?
 C:
10:
14:   # Block name, 16 chars
24:   # Block description, 48 chars
64:   Entry vector?
68:   0xB513B513      # Note, inverted Q;Q
6c:   Load address?
70:   Compression flag, 0 == plain, 2 == compressed
74:   Compressed length
78:
7C:   END

Compression is LZRW1 without the leading 4 flag bytes.

J.

-- 
] https://www.earth.li/~noodles/ [] Replace repetitive expressions by  [
]  PGP/GPG Key @ the.earth.li    []    calls to a common function.     [
] via keyserver, web or email.   []                                    [
] RSA: 4096/0x94FA372B2DA8B985   []                                    [

---

From: Nick Griffin <[email-masked]>
Date: Sun, 21 Apr 2019 16:22:45 +0000

It looks like the first emailer abit, its has the same layout ,see the keyboard at the bottom and uses the Pocket Dock IT too and has PB in its name like PBL for the Boot Loader, I guess that's where PBL came from.. weird, its called a Amstrad PB1500 and PB Stands for Phone Book. So Phone Book Loader…😊 well that makes sence,when you turn on the Emailer it loading up its phone book so you can make a call.. 😊 Phone Book is Address Book just another name for it.

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Sunday‎, ‎21‎ ‎April‎ ‎2019 ‎11‎:‎40
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

I do wish I never flashed E3 Linux on it now,theres no point to it,you can’t put anything on it or run anything on it cos its too old and E3 Linux didn’t go anywhere, its just a command line version because the E3 is not powerful to run proper Linux. I installed E3 Linux release v2 (E3 Linux sound better that just Linux or release v2 this way you know what I am taking about)from the.earth.li/pub/e3/<https://nam02.safelinks.protection.outlook.com/?url=http://the.earth.li/pub/e3/&data=02%7c01%7c%7c840b4cbdc1144202f49908d6c645d49b%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914400552286012&sdata=G0BDfgsHg/sYeCygQes4FwIOjf39Uy92wVNnDT20ZdI%3D&reserved=0>  what are the rest of the stuff in there, can I update it to 2.6.19,its at 2.6.16 that what release v2 is…?

Oh and what happen to this…  http://amstrad-e3-hacking.freeforums.net/thread/7/support-status-update<https://nam02.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net/thread/7/support-status-update&data=02%7c01%7c%7c840b4cbdc1144202f49908d6c645d49b%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914400552296023&sdata=Sz12Lx9X8WFByYU/vSme5aD2fP4oDx9mC%2BWoJgaTf5c%3D&reserved=0>  why did the work on E3 Linux stop and only get to 2.6.19…?

Spanner..

question is here too http://amstrad-e3-hacking.freeforums.net/thread/9/config-content-filesystem?page=1&scrollTo=92<https://nam02.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net/thread/9/config-content-filesystem?page%3D1%26scrollTo%3D92&data=02%7c01%7c%7c840b4cbdc1144202f49908d6c645d49b%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914400552306028&sdata=0qVbgCV4iqyAupGIKOwRmIhBCVM2drsvfy3XHjl%2BSzw%3D&reserved=0>

Spanner..

Hi Nick,

--
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Mon, 22 Apr 2019 10:15:09 +0000

OK so converting the gif to something maybe like in a video format or something, I don’t know, I won't know where to start, I never scripted stuff in Linux before, I am not a coder,I have played around with scripts in Linux but easy stuff,this is way over my head,I need a step by step instructions on how to do it,Once I am showed I will,remember how,I understand reading the file from the USB stick ,but I not got a clue how to do it,If this is possible we might of found something to do with it,you wouldn’t just be able to show the adverts on the screen you would able to show anything on it, It would be good as a image viewer and a video player. You could get it to show the adverts and have it a display model of what the emailer was like so you could show parts of what the menu was like to if you wanted but would have to make the image of the menu to show, the adverts are very easy to make, you could make  them yourself, or make a slideshow of your own pictures and videos on the screen.

But I need someone who knows how to do scripting in Linux because I don’t know how. I played around with the scripts in Commodore OS but they are really simply ones and nothing like this, If anyone has some spear time and would like to help I would really appreciate it.

Thanks..

Spanner..
PS… Dose anyone know what was used to make the Main Software (The GUI) on the E3,I want to add it to the page on Wikipedia..? (Phone Book Loader….HAHAHA that makes me laugh but dose make sense.. 😊.)
Looking forward to my new ish Amstrad E3 coming and E1 too.. I have the whole set now..😊 When E3 comes I be copying it firmware and sharing it because its activated so has the .confg file still on it. its will properly operate for 3 Months before deactivating and removing the config file. Someone has to just find a why be able to flash it back properly.

I am good at thinking up ideas but have a problem of making them a reality.. 😊
http://amstrad-e3-hacking.freeforums.net

From: David Given<mailto:[email-masked]>
Sent: ‎Sunday‎, ‎21‎ ‎April‎ ‎2019 ‎23‎:‎05
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

You wouldn't run imagemagick on the E3 itself. (Apart from anything else the E3 distribution is, IIRC, something based on OpenEmbedded/Angstrom and is very hard to get software for?) You'd run it on a PC and use it to convert files to put on a USB stick, and then use simple scripting on the E3 to draw them on the screen.

That said, I remember the E3 framebuffer format to be pretty weird, so you may be better off writing a program (on a PC) to do some kind of custom conversion. fbset on the E3 should tell you the exact format.

On Sun, 21 Apr 2019 at 23:45, Nick Griffin <[email-masked]<mailto:[email-masked]>> wrote:
What the ams-delta mini distribution ..?
Which one do I download… https://www.imagemagick.org/script/download.php<https://nam04.safelinks.protection.outlook.com/?url=https://www.imagemagick.org/script/download.php&data=02%7c01%7c%7c1884cbd3e3714908d56e08d6c6a5825b%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914811491696574&sdata=aHJgcEqUtJC3i7OzT1atOz9D3rblq0Dytc95jvLXl/4%3D&reserved=0> and how do I install it on the E3..?

Spanner..

http://amstrad-e3-hacking.freeforums.net<https://nam04.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net&data=02%7c01%7c%7c1884cbd3e3714908d56e08d6c6a5825b%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914811491706591&sdata=nnVvEl1kTsxMCPzYzvGs819SEFqv3pWXUl333oqrj5I%3D&reserved=0>

On Sun, 21 Apr 2019 at 12:40, Nick Griffin <[email-masked]<mailto:[email-masked]>> wrote:
I do wish I never flashed E3 Linux on it now,theres no point to it,you can’t put anything on it or run anything on it cos its too old and E3 Linux didn’t go anywhere, its just a command line version because the E3 is not powerful to run proper Linux. I installed E3 Linux release v2 (E3 Linux sound better that just Linux or release v2 this way you know what I am taking about)from the.earth.li/pub/e3/<https://nam04.safelinks.protection.outlook.com/?url=http://the.earth.li/pub/e3/&data=02%7c01%7c%7c1884cbd3e3714908d56e08d6c6a5825b%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914811491716590&sdata=WhRGFTM%2Bj7BOhOgH9a6MOCgfC5EM%2BFGaM%2B4pBZ5R0ZA%3D&reserved=0>  what are the rest of the stuff in there, can I update it to 2.6.19,its at 2.6.16 that what release v2 is…?

Oh and what happen to this…  http://amstrad-e3-hacking.freeforums.net/thread/7/support-status-update<https://nam04.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net/thread/7/support-status-update&data=02%7c01%7c%7c1884cbd3e3714908d56e08d6c6a5825b%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914811491726595&sdata=rS6frR9nj3Dw6Uk401ios9A7ClAg%2Beb7FCz3JxtqjeI%3D&reserved=0>  why did the work on E3 Linux stop and only get to 2.6.19…?

Spanner..

http://amstrad-e3-hacking.freeforums.net<https://nam04.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net&data=02%7c01%7c%7c1884cbd3e3714908d56e08d6c6a5825b%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914811491736606&sdata=Cx/wuv%2BCat9fjIPnkO316gOAgt26I8ph1ys4%2B67UXwg%3D&reserved=0>

question is here too http://amstrad-e3-hacking.freeforums.net/thread/9/config-content-filesystem?page=1&scrollTo=92<https://nam04.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net/thread/9/config-content-filesystem?page%3D1%26scrollTo%3D92&data=02%7c01%7c%7c1884cbd3e3714908d56e08d6c6a5825b%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914811491756622&sdata=WnQymjcLXaV8GN2ieI9cD77vbv%2BwNd3zNhlEWCCtysc%3D&reserved=0>

Spanner..

http://amstrad-e3-hacking.freeforums.net<https://nam04.safelinks.protection.outlook.com/?url=http://amstrad-e3-hacking.freeforums.net&data=02%7c01%7c%7c1884cbd3e3714908d56e08d6c6a5825b%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914811491766639&sdata=Sh3ONgTbkDmzgQuGRpouo2l2oMg%2B00jgP9jxdCYEd1E%3D&reserved=0>

Hi Nick,

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C0c848394242c4830fc6e08d6c5b72a85%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636913787811205410&amp;sdata=0kD8t8q7zfl%2FGDLfdCSjfHE%2B1A2ZbQ8DuiwML03509A%3D&amp;reserved=0<https://nam04.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c1884cbd3e3714908d56e08d6c6a5825b%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914811491776638&sdata=1UdPGdiwOHk1qx4H7xsGqKP7Z%2BCq01UV%2BROo2d0BYyk%3D&reserved=0>
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://nam04.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c1884cbd3e3714908d56e08d6c6a5825b%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914811491786643&sdata=Iw94CN0xg6f%2Bj9sILhvGo82SoHXW%2BOK9mhHLaFqFjYw%3D&reserved=0>

--
┌─── http://www.cowlark.com<https://nam04.safelinks.protection.outlook.com/?url=http://www.cowlark.com&data=02%7c01%7c%7c1884cbd3e3714908d56e08d6c6a5825b%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914811491796655&sdata=upA/QNd%2B9i81BaaA/UkmCyS4HTj3n3pDcsrL52dasx0%3D&reserved=0> ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://nam04.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c1884cbd3e3714908d56e08d6c6a5825b%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914811491806672&sdata=5dzcJg5yjKrvWd743/V/yROQYM1oGWPbROz9IhcfmgY%3D&reserved=0>

--
┌─── http://www.cowlark.com<https://nam04.safelinks.protection.outlook.com/?url=http://www.cowlark.com&data=02%7c01%7c%7c1884cbd3e3714908d56e08d6c6a5825b%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636914811491816677&sdata=6b1mpO6K1WxMTYXhLdNYpjGWKg4qyvoWHXHVxhOCH04%3D&reserved=0> ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

---

From: Nick Griffin <[email-masked]>
Date: Mon, 22 Apr 2019 10:23:38 +0000

Does anyone want the E3 adverts, they are not big, there are 7 of them in gif format they are the same size as the screen on the E3 is 480x320, I can upload them for you to download them if you like might make it easier if some wants to look into getting them working on the E3..?
The adverts are the ones from the Amserve website ,I have had them for years lucky,you can’t get the no more. site it dead now.

Spanner..

Spanner..

Spanner..

Spanner..

Hi Nick,

--
Cheers, Ralph.

---

From: Ralph Corderoy <[email-masked]>
Date: Tue, 23 Apr 2019 14:09:44 +0100

Hi Nick,

> Janusz Krzysztofik

I think he's at Intel now.

> Where could you download it from..?

https://mirrors.edge.kernel.org/pub/linux/kernel/v2.6/ but that the
source code and it would then need building;  not a trivial exercise.

-- 
Cheers, Ralph.

---

From: Ralph Corderoy <[email-masked]>
Date: Tue, 23 Apr 2019 14:14:28 +0100

Hi Nick,

> Does anyone want the E3 adverts, they are not big, there are 7 of them
> in gif format they are the same size as the screen on the E3 is
> 480x320, I can upload them

Yes, do that, e.g. to Dropbox like with the other files.  I expect I'm
not the only one to squirrel stuff away so copies live on.

-- 
Cheers, Ralph.

---

From: Ralph Corderoy <[email-masked]>
Date: Tue, 23 Apr 2019 14:27:10 +0100

Hi Nick,

> its just a command line version because the E3 is not powerful to run
> proper Linux.

Linux as you know it is three main parts.  There's the kernel, that's
what Linux really is, and it talks to the hardware.  Atop of that are
the user-space programs, like the shell, ls(1), etc.  They give you the
command line that many of us appreciate.  And then a bunch of user-space
programs can together provide a graphical environment with windows,
menus, etc.;  a `desktop', like Gnome, or XFCE.  Linux distributions
bundle those all up together.

So the E3 is powerful enough to run a Linux kernel, but doesn't have
enough memory to run a modern version, just as Intel 386 processors are
no longer supported.

> If I can’t put the original firmware back

That should be possible as you have the files, now without their
16 bytes per 512 bytes overhead.  You need to work out how many blocks
to erase based on the size of each file you're trying to put back.
IIRC I pointed out a block is the unit of erasure and it's 16 KiB.

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Tue, 23 Apr 2019 17:25:09 +0000

Yeah I know Linux runs from its Kernel,it has a 2.6.19 kernel, without the kernel there be on Linux.. 😊 ,Windows has a kernel too.

I don't understand how to erase the blocks, I was never good at Maths that why I am not a programmer, I have Autism but am dyslexic too so need things said to me  step by step otherwise I don’t understand.

So e3-nand.0 is 3584 KB so how many blocks go into it…? so how many times dose 16KB going in to 3584KB…?? I don’t know..?? I can’t divide. Iam a bit ok on Add not brilliant at Times but can’t do Divide.
I was crap a Maths,I left school in 87,32 years ago… 😊 I got a 5 for Maths. that's a E ,…lol

Could you work it out for me, I do not know how too..?

How do I know how many files there are in each image(mtd0,1,2,3,4,5) and what size they are, you can’t open it like a normal partition, Dam Amstrad this will take forever…lol ☹

I be copying and sharing the firmware from my new E3 I am waiting for it to arrive, its activated.

My plan is to flash the copy of the firmware every time the E3 deactivates itself to activate it again, hopefully for 3 months,you see… 😊 ? My plan is to get all E3 working, well to the point you can use the Phone, Address Book and Answer Machine and that.

I still think the firmware needs hacking…😊 if we could get in and edit the Delta_e_live.config you could open up the whole system, that file configs the emailer so Amstrad could added different options in Setup(Setup Button) too that file so they show up, that's why some options in Setup only has like 1,2,3 options because the rest is hidden.

Spanner..

From: Ralph Corderoy<mailto:[email-masked]>
Sent: ‎Tuesday‎, ‎23‎ ‎April‎ ‎2019 ‎14‎:‎27
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Hi Nick,

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C049c474ec2e04e76ee6108d6c7ef6bfa%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636916228463676345&amp;sdata=PlMWe2oz4gFIfcsWsiz57MAiaw6YrXH1tJ2PKB%2BVAYc%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Tue, 23 Apr 2019 17:46:37 +0000

You can get them here…  http://amstrad-e3-hacking.freeforums.net/thread/16/amstrad-e3-adverts?page=1&scrollTo=96  click on one and it will come up on its own page then right click on it and click on save as...

Spanner..

From: Ralph Corderoy<mailto:[email-masked]>
Sent: ‎Tuesday‎, ‎23‎ ‎April‎ ‎2019 ‎14‎:‎14
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Hi Nick,

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://eur04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C836ed8e5d05a48868cfa08d6c7eda49e%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636916220806929359&amp;sdata=SWfJubseUZIyKsU6N%2BsjJIJoxvD6HzP5Wi8PP%2F9P8Dc%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Tue, 23 Apr 2019 22:00:07 +0000

Is this right,I have just did this on my calculator 3584(KB) Divided by 16(KB) = 224 so 16 goes into it 224 times then it needs 224 blocks to be deleted..??

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Tuesday‎, ‎23‎ ‎April‎ ‎2019 ‎18‎:‎25
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Spanner..

Hi Nick,

--
Cheers, Ralph.

---

From: Ralph Corderoy <[email-masked]>
Date: Wed, 24 Apr 2019 10:45:51 +0100

Hi Nick,

> > That should be possible as you have the files, now without their 16
> > bytes per 512 bytes overhead.  You need to work out how many blocks
> So e3-nand.0 is 3584 KB so how many blocks go into it…? so how many
> times dose 16KB going in to 3584KB…?? I don’t know..?? I can’t divide.
> Iam a bit ok on Add not brilliant at Times but can’t do Divide.

Having stripped the excess OOB data, I have these sizes for each file in
bytes.

     3670016  e3-nand-backup.0
      262144  e3-nand-backup.1
      262144  e3-nand-backup.2
      262144  e3-nand-backup.3
    28311552  e3-nand-backup.4
      786432  e3-nand-backup.5

You're right, 3,670,016 B is 3,584 KiB because
    3,670,016 / 1,024 = 3,584
so 1,024 goes into 3,670,016 exactly 3,584 times.

But the size of the erase block is 16 KiB which is
    16 * 1,024 = 16,384
so we want to know how many times 16,384 goes into 3,670,016.
    3,670,016 / 16,384 = 224
224 is what you worked out in your other email.

Taking those six sizes above and repeating the same sum gives

     3,670,016 / 16,384 =   224
       262,144 / 16,384 =    16
       262,144 / 16,384 =    16
       262,144 / 16,384 =    16
    28,311,552 / 16,384 = 1,728
       786,432 / 16,384 =    48

Now I haven't been carefully following along how to extract
e3-nand-backup.* in the first place, and how to write them back.
I'm aware there's a script involved and a command where one of the
parameters is the number of 16 KiB blocks to erase.  Hopefully, plugging
in those numbers above for each of the matching areas will work, but
it's your responsibility whether to go ahead as you're the one actually
doing all this;  I've just been sitting at a keyboard.  :-)

-- 
Cheers, Ralph.

---

From: David Given <[email-masked]>
Date: Wed, 24 Apr 2019 11:50:31 +0200

The E3 is based on an ARM reference design, isn't it? What's the
feasibility of emulating one?

---

From: Nick Griffin <[email-masked]>
Date: Wed, 24 Apr 2019 10:13:30 +0000

So you would put in the number 224 in the flash_erase line at the end..

flash_erase /dev/mtd0 0 224

I just hope it works if it dose then we have just fixed the E3,all you need is a copy of the firware that's activated and when it deactives just reflash it again to activate it..😊

Spanner..

From: Ralph Corderoy<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎24‎ ‎April‎ ‎2019 ‎10‎:‎46
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Hi Nick,

     3670016  e3-nand-backup.0
      262144  e3-nand-backup.1
      262144  e3-nand-backup.2
      262144  e3-nand-backup.3

     3,670,016 / 16,384 =   224
       262,144 / 16,384 =    16
       262,144 / 16,384 =    16
       262,144 / 16,384 =    16

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://eur04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C20675962b35c45b5e91008d6c899c7ab%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636916960131227371&amp;sdata=Qin1SjyUGh%2FHaTK7CwRcRPphPkjKv6%2BOR1twUP5c%2Bgs%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Wed, 24 Apr 2019 10:14:20 +0000

Thanks btw Ralph.. 😊

Spanner..

From: David Given<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎24‎ ‎April‎ ‎2019 ‎10‎:‎50
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

The E3 is based on an ARM reference design, isn't it? What's the feasibility of emulating one?

On Wed, 24 Apr 2019 at 11:46, Ralph Corderoy <[email-masked]<mailto:[email-masked]>> wrote:
Hi Nick,

     3670016  e3-nand-backup.0
      262144  e3-nand-backup.1
      262144  e3-nand-backup.2
      262144  e3-nand-backup.3

     3,670,016 / 16,384 =   224
       262,144 / 16,384 =    16
       262,144 / 16,384 =    16
       262,144 / 16,384 =    16

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://eur03.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c0df2e909e3ec4a6374b308d6c89a58e5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636916962567858253&sdata=m1P6LLywgyzcPvmNnnOCKI24l10pj4F%2Bn4k/G9ioPFk%3D&reserved=0>

--
┌─── http://www.cowlark.com<https://eur03.safelinks.protection.outlook.com/?url=http://www.cowlark.com&data=02%7c01%7c%7c0df2e909e3ec4a6374b308d6c89a58e5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636916962567868258&sdata=SrjgcoTr64yno0ANKsd/5zeRRh4m19MCMmosVhmifD8%3D&reserved=0> ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

---

From: Ralph Corderoy <[email-masked]>
Date: Wed, 24 Apr 2019 11:27:38 +0100

Hi Nick,

>     flash_erase /dev/mtd0 0 224

I'd say yes, based on
https://github.com/vamanea/mtd-utils/blob/master/flash_erase.c#L60

Others that have actually used flash_erase may want to chip in.

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Wed, 24 Apr 2019 10:48:36 +0000

This is the code I made for it… so if anyone wants to try it on theres,you can’t damge the E3 doing it,if it don’t work it will not get past the PBL line,lucky they put PBL on the nor flash you can’t brick it..😊 if it don’t work just when using the Pbltool put -n in the line to stop it from “Probbing” and “handshaking” because it will not find PBL V4.9 otherwise.
And say “Probbing” forever.. 😊 and not find anything.

You have to put the script on the USB Stick and run it from it on the E3 for it to work.

so .. cd /media/sda1/
ams-delta-of-install

The code…
-----------------------------------------------------------------------------------------

#!/bin/sh

echo

read i

echo
echo Starting restore.. This might take a while...

if [ -e /media/sda1/e3-nand.0 ]; then
 echo Found e3-nand.0
 echo "  Erasing /dev/mtd0"
 flash_erase /dev/mtd0 0 224
 echo "  Writing e3-nand.0  4mb to /dev/mtd0"
 nandwrite /dev/mtd0 /media/sda1/e3-nand.0
fi

if [ -e /media/sda1/e3-nand.1 ]; then
 echo Found e3-nand.1
 echo "  Erasing /dev/mtd1"
 flash_erase /dev/mtd0 0 16
 echo "  Writing e3-nand-backup.1 264kb to /dev/mtd1"
 nandwrite /dev/mtd1 /media/sda1/e3-nand.1
fi

if [ -e /media/sda1/e3-nand.2 ]; then
 echo Found e3-nand.2
 echo "  Erasing /dev/mtd2"
 flash_erase /dev/mtd0 0 16
 echo "  Writing e3-nand-backup.2 264kb to /dev/mtd2"
 nandwrite /dev/mtd2 /media/sda1/e3-nand.2
fi

if [ -e /media/sda1/e3-nand.3 ]; then
 echo Found e3-nand.3
 echo "  Erasing /dev/mtd3"
 flash_erase /dev/mtd0 0 16
 echo "  Writing e3-nand-backup.3 264kb to /dev/mtd3"
 nandwrite /dev/mtd3 /media/sda1/e3-nand.3
fi

if [ -e /media/sda1/e3-nand.4 ]; then
 echo Found e3-nand.4
 echo "  Erasing /dev/mtd4"
 flash_erase /dev/mtd0 0 1728
 echo "  Writing e3-nand-backup.4  32 mb to /dev/mtd4"
 nandwrite /dev/mtd4 /media/sda1/e3-nand.4
fi

if [ -e /media/sda1/e3-nand.5 ]; then
 echo Found e3-nand.5
 echo "  Erasing /dev/mtd5"
 flash_erase /dev/mtd0 0 48
 echo "  Writing e3-nand-backup.5  792kb to /dev/mtd5"
 nandwrite /dev/mtd5 /media/sda1/e3-nand.5
fi

echo "Finished restoring the Amstrad E3 Firmware,"
echo "Type Reboot or unplug E3 to see if the Amstrad E3 Splash Screen”
echo "comes up (Fingers Crossed) If not just reinstall E3 Linux with the"
echo "pbltool with the -n in the line to stop Handshaking otherwise it will"
echo "not find PBL V4.9 Build:1311 bootloader."

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎24‎ ‎April‎ ‎2019 ‎11‎:‎14
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Thanks btw Ralph.. 😊

Spanner..

     3670016  e3-nand-backup.0
      262144  e3-nand-backup.1
      262144  e3-nand-backup.2
      262144  e3-nand-backup.3

     3,670,016 / 16,384 =   224
       262,144 / 16,384 =    16
       262,144 / 16,384 =    16
       262,144 / 16,384 =    16

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://eur02.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7c69c6e14295c74042cbee08d6c89da440%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636916976717334364&sdata=H8JmqamoTJhIAa7TQhXCgsEi3PcAkEvrW%2Bay%2BXLRoX8%3D&reserved=0>

--
┌─── http://www.cowlark.com<https://eur02.safelinks.protection.outlook.com/?url=http://www.cowlark.com&data=02%7c01%7c%7c69c6e14295c74042cbee08d6c89da440%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636916976717344381&sdata=Abpjta6/p30KJcUM%2B0iv7RleOUP1AKBymsAfb1mhhSI%3D&reserved=0> ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

---

From: Ralph Corderoy <[email-masked]>
Date: Wed, 24 Apr 2019 11:54:56 +0100

Hi Nick,

...
>  flash_erase /dev/mtd0 0 16

It always mtd0.  There's too much repetition in the code so errors like
this are likely to creep in.  Consider the approach I suggested in
https://www.earth.li/pipermail/e3-hacking/2019-April/001314.html
Then the `0' of mtd0, etc., it only typed once.

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Wed, 24 Apr 2019 11:08:41 +0000

is this right…??

perhaps_write_flash()
    {
        p=${1?} erase=${2?}

        test -e $f || return

        echo found $f

    perhaps_write_flash 0 224
    perhaps_write_flash 0 16
 perhaps_write_flash 0 16
 perhaps_write_flash 0 16
 perhaps_write_flash 0 1728
 perhaps_write_flash 0 48

Spanner..

From: Ralph Corderoy<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎24‎ ‎April‎ ‎2019 ‎11‎:‎55
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Hi Nick,

...

It always mtd0.  There's too much repetition in the code so errors like
this are likely to creep in.  Consider the approach I suggested in
https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fpipermail%2Fe3-hacking%2F2019-April%2F001314.html&amp;data=02%7C01%7C%7C3698329065b24dc1983108d6c8a3522f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636917001111275025&amp;sdata=6HxFeGP9mAKyYCGbBLR%2FyibGpJ5zDrlJKtEwH%2FpuZdk%3D&amp;reserved=0
Then the `0' of mtd0, etc., it only typed once.

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://nam03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C3698329065b24dc1983108d6c8a3522f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636917001111275025&amp;sdata=TgNw2UJuSOOgeXqrqlGa3123K2fKTJFK%2BtjOzDWmJYo%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Wed, 24 Apr 2019 11:32:28 +0000

Or is this part … perhaps like this… lol

 perhaps_write_flash 0 224
 perhaps_write_flash 1 16
 perhaps_write_flash 2 16
 perhaps_write_flash 3 16
 perhaps_write_flash 4 1728
 perhaps_write_flash 5 48

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎24‎ ‎April‎ ‎2019 ‎12‎:‎08
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

is this right…??

perhaps_write_flash()
    {
        p=${1?} erase=${2?}

        test -e $f || return

        echo found $f

Spanner..

Hi Nick,

...

--
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Wed, 24 Apr 2019 11:46:24 +0000

New code I don’t know if this is right…??

#!/bin/sh

echo

read i

echo

perhaps_write_flash()
    {
        p=${1?} erase=${2?}

        test -e $f || return

        echo found $f

echo "Type Reboot or unplug E3 to see if the Amstrad E3 Splash Screen"

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎24‎ ‎April‎ ‎2019 ‎12‎:‎32
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Spanner..

is this right…??

perhaps_write_flash()
    {
        p=${1?} erase=${2?}

        test -e $f || return

        echo found $f

Spanner..

Hi Nick,

...

--
Cheers, Ralph.

---

From: Ralph Corderoy <[email-masked]>
Date: Wed, 24 Apr 2019 12:48:12 +0100

Hi Nick,

>     flash_erase $dev 0 $erase

That bit is.

> perhaps_write_flash 0 1728

The function takes two parameters, in $1 and $2 at the start.
The first parameter, copied into p, is the partition number,
and so it needs to go 0, 1, ...

I also think you might want to remove the `-backup' in f's definition
near the start because your script said they were called e3-nand.0, etc.

What you've given here replaces the six blocks of if...then...fi lines
in your original script, leaving the bit before and after.

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Wed, 24 Apr 2019 11:51:41 +0000

Changed…

#!/bin/sh

echo

read i

echo

perhaps_write_flash()
    {
        p=${1?} erase=${2?}
        f=/media/sda1/e3-nand.$p
        dev=/dev/mtd$p

        test -e $f || return

        echo found $f

Spanner..

From: Ralph Corderoy<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎24‎ ‎April‎ ‎2019 ‎12‎:‎48
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Hi Nick,

That bit is.

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7Cd86c48c82c0c4d94d32908d6c8aac186%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636917033045425120&amp;sdata=qKwBVIsPGXyAvKUyZ4ZUvSBdDRTSXlZxAiB2ZAr72iY%3D&amp;reserved=0

---

From: Ralph Corderoy <[email-masked]>
Date: Wed, 24 Apr 2019 13:01:45 +0100

Hi Nick,

> Changed…

Looks good enough to try to me, based on your original.

> echo "Type Reboot or unplug E3 to see if the Amstrad E3 Splash Screen"

It's `reboot' that needs typing as command names on Linux are case
sensitive.

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Wed, 24 Apr 2019 12:09:16 +0000

OK try it in about hour busy at the moment. My other E3 is on it way… 😊

I have added the new script..

Spanner..

From: Ralph Corderoy<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎24‎ ‎April‎ ‎2019 ‎13‎:‎01
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Hi Nick,

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7Caec7a59b4dab4bbb2cfb08d6c8aca64d%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636917041180915001&amp;sdata=yc83O14JdRp25XjWGFcFCfcmafLftmxu5Bcq8p3XqmI%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Wed, 24 Apr 2019 15:07:49 +0000

Code works but didn’t realise the code don’t have nandwrite to write the 5 backup files to the nand… lol

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎24‎ ‎April‎ ‎2019 ‎13‎:‎09
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Spanner..

Hi Nick,

--
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Wed, 24 Apr 2019 15:13:36 +0000

What code would I add to the erase code to add the 5 backup images to nandwrite to nand..?

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎24‎ ‎April‎ ‎2019 ‎16‎:‎08
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Spanner..

Spanner..

Hi Nick,

--
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Wed, 24 Apr 2019 15:31:00 +0000

Ignor last message,silly me..looks like the backup didn’t flash on to the nand..

Starting restore.. This might take a while...
found /media/sda1/e3-nand.0
erasing 224 on /dev/mtd0
Erase Total 224 Units
Performing Flash Erase of length 16384 at offset 0x37c000 done offset 0x1f8000
writing flash
Input file is not page aligned
Data did not fit into device, due to bad blocks

What bad blocks…? Input file is not page aligned…???

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎24‎ ‎April‎ ‎2019 ‎16‎:‎13
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Spanner..

Spanner..

Spanner..

Hi Nick,

--
Cheers, Ralph.

---

From: Ralph Corderoy <[email-masked]>
Date: Wed, 24 Apr 2019 18:01:52 +0100

Hi Nick,

> Input file is not page aligned

That's nandwrite detecting the file's length means it doesn't contain a
whole number of what it expects.

> Data did not fit into device, due to bad blocks

That's just a secondary error caused by the first that can be ignored;
a bug in nandwrite.

https://github.com/vamanea/mtd-utils/blob/master/nandwrite.c#L46 says -o
means image contains OOB data, but we've stripped it out so the
    nandwrite -on $dev $f
you have needs to be
    nandwrite -n $dev $f

That's assuming it's okay to write the data without the OOB part;
I don't know about mtd but that's the implication I picked up from
earlier in this thread.

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Wed, 24 Apr 2019 17:23:31 +0000

I copied it twice not and still getting..

and that's it…??????

Spanner..

From: Ralph Corderoy<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎24‎ ‎April‎ ‎2019 ‎18‎:‎02
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Hi Nick,

https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fvamanea%2Fmtd-utils%2Fblob%2Fmaster%2Fnandwrite.c%23L46&amp;data=02%7C01%7C%7Cd36d4996bec941d4b67b08d6c8d6960c%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636917221299719040&amp;sdata=tqQAEOxwu7Ey0gQMAqIlKTqnndQi23B7602etPhZbTs%3D&amp;reserved=0 says -o
means image contains OOB data, but we've stripped it out so the
    nandwrite -on $dev $f
you have needs to be
    nandwrite -n $dev $f

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7Cd36d4996bec941d4b67b08d6c8d6960c%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636917221299719040&amp;sdata=lKEW6KrsdX2A56l5nHqGm8eI3MrTny0BCG4ZRs8Nuns%3D&amp;reserved=0

---

From: Ralph Corderoy <[email-masked]>
Date: Wed, 24 Apr 2019 18:30:27 +0100

Hi Nick,

> I copied it twice not

What's the output of copying it once?

> 0MB.-->MEMv01.00.002,CopyLim=00220000h,CodeEnd=01400000h-->PBL......1MB.......2MB*

What if you try reading out the flash.  Do you get what you put in?
`cmp foo bar' compares all the bytes in those two files and complains if
any differ.

Otherwise, I think you'll have to wait for someone that knows mtd to
come along and offer suggestions.

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Thu, 25 Apr 2019 10:17:35 +0000

All it does is show the PBL line on terminal and a black screen on the E3 and nothing else, its like it can’t get past it.

Spanner..

From: Ralph Corderoy<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎24‎ ‎April‎ ‎2019 ‎18‎:‎30
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Hi Nick,

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://nam04.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C7e771ee689d44d2e2a3708d6c8da91b3%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636917238407255934&amp;sdata=9aSwi%2FcYoSJiQxT3YOnLEpBnflwfq4pKUlBKp8J2rus%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Thu, 25 Apr 2019 10:24:24 +0000

As its flashing to the Nand it is reporting bad blocks but still flashing the image, its missing some of them so not flashing them all over to the Nand. I think mtd 5 it said “ image don’t fit because of bad blocks” I just don’t have a clue.

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Thursday‎, ‎25‎ ‎April‎ ‎2019 ‎11‎:‎17
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Spanner..

Hi Nick,

--
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Thu, 25 Apr 2019 10:30:12 +0000

>`cmp foo bar' compares all the bytes in those two files and complains if

Just noticed what you wrote, how do I do this,flash the Nand then after its done it type >`cmp foo bar' ..?

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Thursday‎, ‎25‎ ‎April‎ ‎2019 ‎11‎:‎24
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Spanner..

Spanner..

Hi Nick,

--
Cheers, Ralph.

---

From: Ralph Corderoy <[email-masked]>
Date: Thu, 25 Apr 2019 13:25:39 +0100

Hi Nick,

> As its flashing to the Nand it is reporting bad blocks but still
> flashing the image, its missing some of them so not flashing them all
> over to the Nand.

You could try adding the -m option to nandwrite to mark the bad blocks.
    nandwrite -mn $dev $f
But it's risky.  I don't know if it's the correct thing to do, and if it
needlessly marks blocks as bad for some reason, I don't know how to
cancel that, though I assume it's possible.

In short, you're outside the scope of what I know.

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Fri, 26 Apr 2019 20:01:29 +0000

Ok thanks,I got my new E3 today and the seller told me it was working and able to make a call on it before I bought it and its unregistered so deactivated…dam it.. ☹ ,he said to me he don’t understand how it was reset when it was working…??? Well it can do it by itself without you pressing Delete,Stop and Handsfree at boot up….lol
Its Main Software is V4 so the dial for email trick don’t work. so no point in copying the firmware but I am glad I have the clock back, I do like the look of the firmware on the E3.. 😊 Well its my clock now. Its a shame, I never buy another E3 again unless I see it working(picture of its screen) and it activated or have CC on it, but trying to get one that has CC on it is like looking for a needle in a haystack..lol

Has anyone have a idea of copying the firmware on the E1 or E2, I have a E1 that activated too now.. 😊I don’t know how the E1/E2 E-mailers OS work maybe someone can explain, well it not Linux like E3 so what does it use..?

Spanner..

From: Ralph Corderoy<mailto:[email-masked]>
Sent: ‎Thursday‎, ‎25‎ ‎April‎ ‎2019 ‎13‎:‎25
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Hi Nick,

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://apc01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C84fb685e11164dde4b8408d6c9792aa3%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636917919589784871&amp;sdata=zYMJbN8wAp6x0xdil2v2%2Bz646CJRCP2N4hK9wZBSm9E%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Fri, 26 Apr 2019 20:23:09 +0000

just found this about bad blocks on the NAND.. https://e2e.ti.com/support/legacy_forums/embedded/linux/f/354/t/457249

Spanner..

Hi Nick,

--
Cheers, Ralph.

---

From: Antony Stone <[email-masked]>
Date: Fri, 26 Apr 2019 22:31:32 +0200

On Friday 26 April 2019 at 22:01:29, Nick Griffin wrote:

> Ok thanks,I got my new E3 today

So, does that mean you have two now?

> and the seller told me it was working and able to make a call on it before I
> bought it and its unregistered so deactivated…

Sounds good so far...

> dam it.. ☹ ,he said to me he don’t understand how it was reset when it was
> working…???

What do you mean by "reset"?

> Its Main Software is V4 so the dial for email trick don’t work.

Please remind me what this "trick" is?

> so no point in copying the firmware

I disagree - a comparison (especially of the boot loader, not necessarily the 
main software) could be instructive.

> but I am glad I have the clock back,

Be thankful for small mercies :))

> Has anyone have a idea of copying the firmware on the E1 or E2,

You mean copying the firmware for interest's sake, or with the idea of copying 
from the E1/E2 to the E3?

I really doubt that E1/E2 firmware would work on an E3.  Different CPUs, for a 
start.

> I have a E1 that activated too now.. 😊I don’t know how the E1/E2 E-mailers
> OS work maybe someone can explain, well it not Linux like E3 so what does it
> use..?

Remember that there was a day when people wrote firmware for devices from 
scratch, without using an "operating system".  It's only since the days when 
embedded devices like wireless routers, telephones, televisions etc have had 
enough CPU and RAM to run Linux that this has been a simpler starting point.

> Spanner..

Why do you always write this at the end of your emails?

Regards,

Antony.

-- 
"If I've told you once, I've told you a million times - stop exaggerating!"

---

From: Nick Griffin <[email-masked]>
Date: Fri, 26 Apr 2019 21:23:19 +0000

>So, does that mean you have two now?

Yes I have 2 E3 now.. lol

>What do you mean by "reset"?

I mean if you hold Down Delete, Stop and Handfree when you boot up the E3 it puts in back to factory defaults where you have to register it and says” Press the [Email] button to get connected”

>Please remind me what this "trick" is?

With the Main Software V2 if its deactivated you could lift hand set and press and hold email down until it says aborting email please wait.. and it would activate the phone, it don’t work on V4.

I can copy the firmware if you want it and share it…?

from the E1/E2 to the E3?
No copying the firmware from the E1/E2 to copy it back to a E1/E2 that's deactivated to activate them.

>Why do you always write this at the end of your emails?

Spanner is my name, My real name is Nick, I have not been called Nick for about 15 years. Last person to call me Nick was my mum, she died 15 years ago in 2004. I go by Spanner or Span now… 😊

Its a nickname I got at school, my partner started calling me it because I am good at working things out or fixing things then I started to use it as a username online.

Spanner..

From: Antony Stone<mailto:[email-masked]>
Sent: ‎Friday‎, ‎26‎ ‎April‎ ‎2019 ‎21‎:‎31
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Sounds good so far...

Regards,

Antony.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://eur03.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C0cec744a3e744933fb9d08d6ca86394f%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636919075177321832&amp;sdata=7RGnHIIotBRp4gY%2F3FrAgejVyPFwh6LwJdLzI014zUk%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Sat, 27 Apr 2019 20:14:17 +0000

So you can show pictures and video on the screen, there is info here about it here on how to do it on a laptop.. http://www.amusings.com/linux-powered-digital-picture-frame/  There is nothing on how to do it on a E3, well there wouldn’t be, if anyone can give me some points on how to do this,but I don’t want to take the E3 a part just add the software to make it act like a Digital Picture Frame.

One way of recycling it..😠

Oh.. I am at the moment making one of the adverts that were on the E3,I am rebuilding the AOL advert, its the one in red and white and say AOL.. One Month Free, because I found it but its too small. I going to make more..😊 It funny it say on the advert in small writing that a PC in required… lol

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Friday‎, ‎26‎ ‎April‎ ‎2019 ‎22‎:‎23
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Spanner..

Sounds good so far...

Regards,

Antony.

---

From: Nick Griffin <[email-masked]>
Date: Sat, 27 Apr 2019 20:53:12 +0000

I need someone on here who knows what there are doing flashing the Amstrad firmware back on the E3.

Has anyone still got there E3 on here but only if you have flashed E3 Linux on it already then you can test trying flashing Amstrad E3 Original Firmware back and see it you can get it working, More people doing it would be better because one of us might get it working.

And I might of missed something you might find.. 😊

Any one willing to do this..?

Mine don’t go anywhere it don’t even get to this line …

What am I missing…??

Spanner..

Spanner..

Sounds good so far...

Regards,

Antony.

---

From: David Given <[email-masked]>
Date: Sat, 27 Apr 2019 22:57:40 +0200

As said before, drawing a picture on the screen with the ams-delta Linux
distribution is as simple as copying a file from the USB stick to
/dev/fb0...

mount /dev/sda1 /mnt
cat /mnt/image.dat > /dev/fb0

You'll need to get the image into the right format, and the E3 screen
format is kinda weird, so you'll need to experiment with tools to figure
out how to do this (and it may need some custom programming), but it
shouldn't be difficult. IIRC it's 12-bit RGB. Once that's done writing a
little shell script which displays an image carousel which runs on the E3
is trivial.

On Sat, 27 Apr 2019 at 22:14, Nick Griffin <[email-masked]> wrote:

> So you can show pictures and video on the screen, there is info here about
> it here on how to do it on a laptop..
> http://www.amusings.com/linux-powered-digital-picture-frame/  There is
> nothing on how to do it on a E3, well there wouldn’t be, if anyone can give
> me some points on how to do this,but I don’t want to take the E3 a part
> just add the software to make it act like a Digital Picture Frame.
>
> Oh.. I am at the moment making one of the adverts that were on the E3,I am
> rebuilding the AOL advert, its the one in red and white and say AOL.. One
> Month Free, because I found it but its too small. I going to make more..😊
> It funny it say on the advert in small writing that a PC in required… lol
>
> Spanner..
>
> *Sent:* ‎Friday‎, ‎26‎ ‎April‎ ‎2019 ‎22‎:‎23
> I mean if you hold Down Delete, Stop and Handfree when you boot up the E3
> it puts in back to factory defaults where you have to register it and says”
> Press the [Email] button to get connected”
>
> With the Main Software V2 if its deactivated you could lift hand set and
> press and hold email down until it says aborting email please wait.. and it
> would activate the phone, it don’t work on V4.
>
> Spanner is my name, My real name is Nick, I have not been called Nick for
> about 15 years. Last person to call me Nick was my mum, she died 15 years
> ago in 2004. I go by Spanner or Span now… 😊
>
> Its a nickname I got at school, my partner started calling me it because I
> am good at working things out or fixing things then I started to use it as
> a username online.
>
> Spanner..
>
> *Sent:* ‎Friday‎, ‎26‎ ‎April‎ ‎2019 ‎21‎:‎31

---

From: Nick Griffin <[email-masked]>
Date: Sun, 28 Apr 2019 09:46:35 +0000

Does anyone know what mtd partition this line is from…

Its the first line that comes up in the boot log after Amstrad Delta - PBL V4.9 … , after I flash the mtdx it only comes up with Amstrad Delta - PBL V4.9 … than stops at 2MB* and no splash screen, just a black screen..?

I am trying to work out what mtd it looks at first, mtd0 …?

It looks like to me that its flashing it back to the NAND wrong and that why its not booting, this is why I need someone to test it who knows what they are doing and knows about flashing to mtd partitions ..?

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Saturday‎, ‎27‎ ‎April‎ ‎2019 ‎21‎:‎53
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

What am I missing…??

Spanner..

Spanner..

Sounds good so far...

Regards,

Antony.

---

From: Ralph Corderoy <[email-masked]>
Date: Sun, 28 Apr 2019 13:44:12 +0100

Hi Nick,

> System module loader - LDR V1.5 Build:0008 Assert

    $ LC_ALL=C grep -boa 'LDR V1.5 Build:0008 Assert' e3-nand-backup.?
    e3-nand-backup.3:18472:LDR V1.5 Build:0008 Assert
    $ 

18472 is the zero-based byte offset.

That's the same file with the Q;Q; for LDR.

    $ qq() {
    >     hexdump -ve '36/1 "%_p" "\n"';
    $
    $ for f in e3-nand-backup.?; do
    >     qq $f | grep LDR | sed "s/^/$f /"
    > done
    e3-nand-backup.3 Q;Q;....Hf..........LDR.............
    $

-- 
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Sun, 28 Apr 2019 13:16:05 +0000

Ok so PBL boots from mtd3 partition first then so maybe its not flashing mtd3 properly…??

If you can see the data from the images I made then the data is there so what the hell it going on, why will it not boot up, just a black screen..??

Just found a site on info about NAND .. might be interesting reading.. <https://www.google.co.uk/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=2ahUKEwiOubGz2vLhAhWDyKQKHVTuA0MQFjAAegQIAxAB&url=http%3A%2F%2Fwww.linux-mtd.infradead.org%2Fdoc%2Fnand.html&usg=AOvVaw3BVVUuToL0Qz0nX11699kb>
NAND data - Memory Technology Device (MTD) Subsystem for Linux

Spanner..

From: Ralph Corderoy<mailto:[email-masked]>
Sent: ‎Sunday‎, ‎28‎ ‎April‎ ‎2019 ‎13‎:‎44
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Hi Nick,

    $ qq() {
    $

--
Cheers, Ralph.

_______________________________________________
e3-hacking mailing list
[email-masked]
https://nam02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7Cb24f4cea327848637d7808d6cbd73f7d%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636920522676824619&amp;sdata=jJS55M0P5wsB1z%2B7Uz0qZzV34nQlLPPwYD6xdpvi9rw%3D&amp;reserved=0

---

From: Nick Griffin <[email-masked]>
Date: Mon, 29 Apr 2019 00:02:06 +0000

I noticed you were talking about the E1 and the Pocket Dock IT, How far did your investigations get with the E1..?

Does anyone know how the Pocket Dock IT works and the slot it connects to on the E-mailer(E1/2/3) I ask this because you can use the Pocket Dock IT to copy the Configuration Change Set Up from one E-mailer to another E-mailer but has to be the same model and activated. I was wondering how it copies the setup over to the Pocket Dock IT and back, if we could interface with the dock or Pocket Dock IT we could maybe save the setup from the E-mailer or Pocket Dock IT to the PC.

If the batteries in the Pocket Dock IT run out, the setup from the E-mailer gets deleted.

Just a idea..??

Spanner..

http://amstrad-e3-hacking.freeforums.net/thread/6/e1

---

From: David Given <[email-masked]>
Date: Mon, 29 Apr 2019 16:06:35 +0200

The Pocket Dockit interface is just a TTL serial connection attached to (I
think) the other UART on the processor, although I've no idea whether it's
inverted or not. It's probably really easy to reverse engineer and spoof,
with some basic electronics skills and a logic analyser. I know if anyone's
investigated it.

It'd theoretically be possible to exploit bugs in the emailer software, if
there are any, to break into the stock firmware that way even on a PBL 5.1
system. That'd be a *hellish* amount of work, though.

On Mon, 29 Apr 2019 at 02:02, Nick Griffin <[email-masked]> wrote:

> I noticed you were talking about the E1 and the Pocket Dock IT, How far
> did your investigations get with the E1..?
>
> Does anyone know how the Pocket Dock IT works and the slot it connects to
> on the E-mailer(E1/2/3) I ask this because you can use the Pocket Dock IT
> to copy the Configuration Change Set Up from one E-mailer to another
> E-mailer but has to be the same model and activated. I was wondering how it
> copies the setup over to the Pocket Dock IT and back, if we could interface
> with the dock or Pocket Dock IT we could maybe save the setup from the
> E-mailer or Pocket Dock IT to the PC.
>

---

From: Nick Griffin <[email-masked]>
Date: Wed, 24 Apr 2019 18:23:56 +0000

I  think it needs the OOB data in the image.
Just looked on the net about ,it say…

How does this combination of nandsim, nandwrite and nandddump decide which ECC scheme to use? The flash is from a TI AM335 system, and as far as I know, the ECC scheme is decided by a combination of the processor and OS. How do these utilities know what to do?

First of all the ECC scheme used does not necessarily have to be for all the flash erase blocks. There are ususally 3 different types of flash partitions used and for every type the method to specify the used ECC code differs:

  1.  The one that are accessed by the ROM bootcode
  2.  The ones that are accessed by the bootloader (usually u-boot)
  3.  The ones that are accessed by the operating system (assuming you are using Linux)

In general the use of a specific ECC method is limited by the OOB size of the flash. The AM335x_U-Boot_User's_Guide (cannot post link here because of reputation) explains it in sections BCH Flash OOB Layout and the example matches to the flash chip you are using. The 64 bytes per 2k page effectively limit the usable ECC algorithms to BCH8, BCH4 or HAMMING codes.

BCH Flash OOB Layout

For any ECC scheme we need to add some extra data while writing so as to detect and correct (if possible) the errors introduced by the NAND part. In case of BCH scheme some bytes are needed to store the ECC related info.

The section of NAND memory where addition info like ECC data is stored is referred to as Out Of Band or OOB section.

The first 2 bytes are used for Bad block marker – 0xFFFF => Good block

The next ‘N’ bytes is used for BCH bytes

N = B * Number of 512-byte sectors in a page

B = 8 bytes per 512 byte sector in BCH4 B = 14 bytes per 512 byte sector in BCH8 B = 26 bytes per 512 byte sector in BCH16

So for a 2k page-size NAND flash with 64-byte OOB size, we will use BCH8. This will consume 2 + (14*4) = 58 bytes out of 64 bytes available.

ECC used by ROM bootcode

The AM335x processor's ROM bootcode decides which ECC scheme to use for NAND flash depending on the mechanism expalined in the AM335x technical reference manual chapter 26.1.7.4 NAND

ECC Correction The default ECC correction applied is BCH 8b/sector using the GPMC and ELM hardware. For device ID codes D3h, C3h, D5h, C5h, D7h, C7h, DEh, CEh when manufacturer code (first ID byte) is 98h the Cell type information is checked in the 4th byte of ID data. If it is equal to 10b then the ECC correction applied is BCH 16b/sector. In addition ECC computation done by the ROM can be turned off completely by using SYSBOOT[9]. This is particularly useful when interfacing with NAND devices that have built in ECC engines.

Other ways to control the ECC behavior are ONFI or and I2C EEPROM but the H27U1G8F2BTR datasheet does not mention ONFI so I guess it is not supported by the flash chip.

So basically BCH8 or BCH16 or no ECC mechanism is used for the first 128K the ROM bootloader reads from NAND flash.

ECC used by the bootloader

The bootloader decides this on his own. For example for U-boot this information is compiled into u-boot and the first level bootloader (SPL/MLO) as well. The information is controlled by U-Boot configuration settings set at compile time. Recent versions of U-boot can switch the ecc at runtime using the nandecc command.

ECC used by the OS

The selection is completely OS specific. For Linux embedded systems using AM335x processors I know that this information is passed into the kernel using the device tree.

Which ECC method does nandsim use

There is a parameter called bch which can be passed to the nandsim module to select an ecc code. From the code I guess It is initialized to zero so it won't use any ECC code. So it seems that nandsim can use BCH8 and BCH16 but only one for the whole flash that is simulated.

modprobe nandsim bch=8 first_id_byte=0xad second_id_byte=0xf1 third_id_byte=0x00 fourth_id_byte=0x1d

Which ECC method does nanddump/nandwrite use

Again, this depends on the OS/Linux you used to dump the flash. Similar to the nandsim module real mtd drivers have ways to specify the used ECC scheme (kernel parameters, device tree). But you can instruct nanddump to ignore the ECC information, too.

References

  *   AM335x technical reference manual http://www.ti.com/lit/gpn/am3359
  *   bch Linux Kernel parameter for nandsim http://lxr.free-electrons.com/source/drivers/mtd/nand/nandsim.c#L175
  *   The AM335x_U-Boot_User's_Guide

Spanner..

Hi Nick,

--
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Wed, 24 Apr 2019 19:59:39 +0000

No still don’t load any well. Maybe Jonathan could help…????? I don’t have a clue.????

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎24‎ ‎April‎ ‎2019 ‎19‎:‎39
To: Nick Griffin<mailto:[email-masked]>

I try again with the images with the oob in them and see if that works.

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎24‎ ‎April‎ ‎2019 ‎19‎:‎37
To: Nick Griffin<mailto:[email-masked]>

Yes we need Jonathan I think, he understands this more..???? I think he gave the code to remove it so you could look at the data in the files better by hex.

Spanner..

From: Nick Griffin<mailto:[email-masked]>
Sent: ‎Wednesday‎, ‎24‎ ‎April‎ ‎2019 ‎19‎:‎23
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

BCH Flash OOB Layout

ECC used by ROM bootcode

ECC used by the OS

References

  *   AM335x technical reference manual http://www.ti.com/lit/gpn/am3359<https://nam04.safelinks.protection.outlook.com/?url=http://www.ti.com/lit/gpn/am3359&data=02%7c01%7c%7c16df7f386a994d2be7b108d6c8e43135%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636917279735746078&sdata=QK2zBg9NLcQoPN0jAYwzIUCip3/CAerEkb5so1y/rls%3D&reserved=0>
  *   bch Linux Kernel parameter for nandsim http://lxr.free-electrons.com/source/drivers/mtd/nand/nandsim.c#L175<https://nam04.safelinks.protection.outlook.com/?url=http://lxr.free-electrons.com/source/drivers/mtd/nand/nandsim.c%23L175&data=02%7c01%7c%7c16df7f386a994d2be7b108d6c8e43135%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636917279735756083&sdata=9vLfBSY5vTUhDrBZQXn5a5efp5zMuIB9SWfWEu/g5mU%3D&reserved=0>
  *   The AM335x_U-Boot_User's_Guide

Spanner..

Hi Nick,

--
Cheers, Ralph.

---

From: Nick Griffin <[email-masked]>
Date: Thu, 9 May 2019 13:48:30 +0000

I was just wondering what font the emailer uses, all 3 models use the same font..?

Span..

---

From: Nick Griffin <[email-masked]>
Date: Sun, 12 May 2019 16:32:35 +0000

I was wondering, Did anyone use there Emailer up until the end of the service in 2011 on here, I must admit I didn’t, I still had a Emailer Plus in 2008 but my partner didn’t like the 20p charge a day for it that's like £5.20 a month and that's over £15 a quarter on your phone bill,.

Nick..