Subject: RE: [E3-hacking] Another hello

From: Cliff Lawson <[email-masked]>
Date: Thu, 19 Jan 2006 09:24:08 -0000

Yup, I have to say I was surprised when folks were saying they could connect
an E3 to a PC without a MAX232?! Both E2 and E3 signals are at TTL levels
so, by rights, you shouldn't be able to just connect direct and have it work
as the 16550 in the PC is supposed to be expecting RS232 -/+12 but maybe
some of them are a bit more "lenient" ? Also, as Andy says, the E3 signals
are inverted (saved the cost of an inverter on the board!) so we use MAX232
boxes with a switched 74 series inverter in there too and use it non
inverted for E2 and inverted for E3. Your mileage may vary.

Cliff

> -----Original Message-----
> From: Andy [mailto:[email-masked]]
> Sent: 18 January 2006 20:21
> To: Discussion of the Amstrad E3 emailer hardware/software
> Subject: Re: [E3-hacking] Another hello
> 
> The short answer is what comes out is inverted,  like RS232, 
> but is not 
> at valid RS232 voltage levels as it never swings negative. Some PCs 
> might let you get away with this, many wont. Being already inverted 
> connecting this to typical RS232 line driver chip then re-inverts the 
> signal and that wont work either.

This e-mail and any attachments are confidential and intended exclusively for the addressee. If you are not the intended recipient please delete it from your system and notify the sender immediately. This message is attributed to the sender and may not necessarily reflect the views of Amstrad Plc or its subsidiaries.

For further information on Amstrad Plc please visit our website: www.amstrad.com

Amstrad Plc.
Brentwood House
169 Kings Road
Brentwood
Essex CM14 4EF
Registered in England : No. 955321

---

From: Ian Stirling <[email-masked]>
Date: Thu, 19 Jan 2006 16:43:46 +0000

> inverted for E2 and inverted for E3. Your mileage may vary.

Back in the dim and distant past, this may have been true.
However, with the growth of low-power devices on the 232 bus, more and 
more stuff has quietly lowered the level at which 0 becomes 1 from 7(?) 
of the MC1488/1489, down to 5V, or even lower.
5V signalling will work just fine with many of todays PCs, even 3.3V on 
quite a lot of them.
Of course, you really need protection, rather than just connecting the 
PC serial port to delicate inputs.
But any 74 buffer chip with a resistor on the 'rx' line from the PC to 
limit the current when it's high should generally work just fine.
Of course, if they are inverted, it working would indeed be kind of odd.