Subject: [E3-hacking] Universal E2/E3 serial interface design

From: Andy <[email-masked]>
Date: Sat, 21 Jan 2006 14:51:38 +0000

Hiya,

As per my earlier posting I've now designed and built a universal E2/E3 
interface board that should convert to/from legal RS232 levels. A jumper 
is used to select E2 or E3 mode. I've also produced a circuit diagram 
from my prototype and put this here:

http://www.cambridgewargames.org.uk/members/andy/emailer/

I would welcome any feedback on the design and would also appreciate 
people sanity check I've not put any stupid mistakes in the circuit 
diagram when copying from my stipboard prototype.

    Have a good weekend,

          Andy M

---

From: Ian Stirling <[email-masked]>
Date: Sat, 21 Jan 2006 15:02:27 +0000

> diagram when copying from my stipboard prototype.

The 1K resistors are not quite adequate protection on the input of IC1A.
A static spark could easily generate 2Kv, or a 2A pulse.
This will probably not kill the 4070 the first time.

Four diodes, one each between the tip/ring connections, and VCC/ground 
would be a good idea.
1Nn4148 or similar would be fine.

---

From: mark <[email-masked]>
Date: Sat, 21 Jan 2006 16:06:18 +0000

Ian Stirling wrote:
> Andy wrote:
>> Hiya,
>>
>> As per my earlier posting I've now designed and built a universal
>> E2/E3 interface board that should convert to/from legal RS232 levels.
>> A jumper is used to select E2 or E3 mode. I've also produced a
>> circuit diagram from my prototype and put this here:
>>
> _______________________________________________
> e3-hacking mailing list
> [email-masked]
> http://www.earth.li/cgi-bin/mailman/listinfo/e3-hacking
>
Hi,

Is it really necessary to adapt the voltage levels for the E3?

I know its the sane thing to do but I've been extracting the flash for
about 3 days now :(
with a direct serial connect between a standard 9 pin serial and the EXT
port and it has been fine.

Mark.

---

From: Jasmine Strong <[email-masked]>
Date: Sat, 21 Jan 2006 17:09:17 +0100

> The 1K resistors are not quite adequate protection on the input of  

I agree, and I would use 4k7 resistors here.

> Four diodes, one each between the tip/ring connections, and VCC/ 
> ground would be a good idea.
> 1N4148 or similar would be fine.

Or a chip diode pack.

And "SLEAVE" should be "SLEEVE".

-J.