Subject: [E3-hacking] AT commands to make voice calls - need help!

From: Martin Whitaker <[email-masked]>
Date: Wed, 9 Aug 2006 18:42:16 +0100

Hey Folks,

I've been trying to find the right sequence of AT command to make a normal voice call on the E3 through it's internal modem. I haven't managed it yet, so am looking for suggestions. Apologies for the long mail!

So far I've managed to make a phone call through the speaker and mic on the base using:

AT+FCLASS=8
AT+VIP
AT+VNH=1
AT+VSP=1
AT+VGM=127 
ATDT<number>

..all fairly standard stuff. Having done that I then tried messing around with AT+VLS to set the source, only I didn't get very far. All of the options either reported 'ERROR' or resulted in no source connected, with the exception of AT+VLS=2 and AT+VLS=3, both of which seem to connected the handset as well as the speakerphone, mostly causing lots of feedback.

AT+VLS=? will report the valid options, here is the output:

AT+VLS=?                                                                        
0," ",0000000000,0000000000,B084008000                                          
1,"T",0B8418E000,0FE418E000,0B8419E000                                          
2,"L",0884008000,0CE4008000,0884018000                                          
3,"LT",0B8418E000,0FE418E000,0B8419E000                                         
4,"S",0084008000,0484008000,3084018000                                          
5,"ST",0B8418E000,0FE418E000,0B8419E000                                         
6,"M",0084008000,04E4008000,3084008000                                          
8,"S1",0084008000,0484008000,3084018000                                         
9,"S1T",0B8418E000,0FE418E000,0B8419E000                                        
11,"M1",0084008000,04E4008000,3084008000                                        
13,"M1S1T",0B8418E000,0FE418E000,0B8419E000                                     
14,"H",0084008000,04E4008000,3084018000                                         
15,"HT",0B8418E000,0FE418E000,0B8419E000                                        
19,"M1S1",0084008000,04E4008000,3084018000                                      
20,"t",0B8418E000,0FE418E000,BB8419E000

According to the Conexant AT command reference the letters in the first column mean:

L Local Phone.
T Telephone Line.
M Internal Microphone.
M1 External Microphone.
S Internal Speaker.
S1 External Speaker.
H External Microphone and Speaker combination (handset or headset).

..so it would appear that the handset on the E3 is classed as the 'local phone'. Not that it really helps me much.

On a different thread of investigation I can successfully use 'vm' from the mgetty/vgetty package to record and playback sounds from the handset. When I do that the base speaker and microphone are definatly NOT turned on, so all appears well. So... I dumped the list of AT command which 'vm' was sending to the modem... they are as follows:

voice command: 'AT+FCLASS=8' -> 'OK'            : Place in voice mode
voice command: 'AT+VSM=?' -> ''                 : List compression modes available
voice command: 'AT+VSD=40,70' -> 'OK'           : Silence detection                                         
voice command: 'AT+VGT=127' -> 'OK'             : Voice gain transmit (playback volume)                                         
voice command: 'AT+VGR=127' -> 'OK'             : Voice gain receive (record gain)                                         
voice command: 'AT+VRA=70;+VRN=10' -> 'OK'      : Ringback goes away timer, Ringback never appeared timer
voice command: 'AT+IFC=2,2' -> 'OK'             : Setup Flow control
voice command: 'AT+VCID=1' -> 'OK'              : CallerID enabled with formatted info
voice command: 'AT+VNH=0' -> 'OK'               : Enable automatic hangups                                             
voice command: 'AT+VIT=0' -> 'OK'               : Voice inactivity timer                                             
voice command: 'AT+VDR=1,15' -> 'OK'            : Distinctive ring

voice command: 'AT+FCLASS=0' -> 'OK'            : Put back into normal mode
voice command: 'AT' -> 'OK'                                                     
voice command: 'AT+FCLASS?' -> ''               : Report available modes
voice command: '' -> 'OK'                                                       

voice command: 'AT+FCLASS=8' -> 'OK'            : Place in voice mode
voice command: 'AT' -> 'OK'                                                     
voice command: 'AT+VLS=2' -> 'OK'               : Select analog source '2'                               
voice command: 'AT+VSM=130,8000' -> 'OK'        : Setup compression method                         
voice command: 'AT+VSM=130,8000' -> 'OK'        : Setup compression method                         
voice command: 'AT+IFC=2,2' -> 'OK'             : Setup Flow control
voice command: 'AT+VTX' -> 'CONNECT'            : Enter playback mode

(plays voice here)

So.... does anyone have any suggestions as to what I can try next? (or even better has anyone managed to make a phone call with just the handset enabled and can tell me how?).

Regards,
Martin.

---

From: "Martin Whitaker" <[email-masked]>
Date: Tue, 15 Aug 2006 19:25:15 +0100

Hey again!

Just an update incase this information is of use to anyone else. I've
managed to make a normal voice telephone call using the E3 through the
handset.

Here are the commands I used:

ATZ
AT+FCLASS=8
AT+VIP
ATM0
ATX0
AT+VNH=1
AT+VLS=2
ATDT<number>;

You can probably get away without some of those - the important ones really
are:

AT+FCLASS=8   <places the modem into voice mode>
ATM0          <turns off the internal speaker>
ATX0          <prevents looking for a dialtone before dialing - you may not
need this>
AT+VLS=2      <selects the handset as the analogue source / destination>
ATDT<number>; <note the semicolon at the end - this causes the modem to make
a voice call not a data one>

Noodles suggested the use of ATM0 - works a treat! Thanks.

M.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On
Behalf Of Martin Whitaker
Sent: 09 August 2006 18:42
To: [email-masked]
Cc: Martin Whitaker
Subject: [E3-hacking] AT commands to make voice calls - need help!

Hey Folks,

I've been trying to find the right sequence of AT command to make a normal
voice call on the E3 through it's internal modem. I haven't managed it yet,
so am looking for suggestions. Apologies for the long mail!

So far I've managed to make a phone call through the speaker and mic on the
base using:

AT+FCLASS=8
AT+VIP
AT+VNH=1
AT+VSP=1
AT+VGM=127
ATDT<number>

..all fairly standard stuff. Having done that I then tried messing around
with AT+VLS to set the source, only I didn't get very far. All of the
options either reported 'ERROR' or resulted in no source connected, with the
exception of AT+VLS=2 and AT+VLS=3, both of which seem to connected the
handset as well as the speakerphone, mostly causing lots of feedback.

AT+VLS=?

According to the Conexant AT command reference the letters in the first
column mean:

L Local Phone.
T Telephone Line.
M Internal Microphone.
M1 External Microphone.
S Internal Speaker.
S1 External Speaker.

..so it would appear that the handset on the E3 is classed as the 'local
phone'. Not that it really helps me much.

On a different thread of investigation I can successfully use 'vm' from the
mgetty/vgetty package to record and playback sounds from the handset. When I
do that the base speaker and microphone are definatly NOT turned on, so all
appears well. So... I dumped the list of AT command which 'vm' was sending
to the modem... they are as follows:

voice command: 'AT+FCLASS=8' -> 'OK'            : Place in voice mode
voice command: 'AT+VSM=?' -> ''                 : List compression modes
available
voice command: 'AT+VSD=40,70' -> 'OK'           : Silence detection
voice command: 'AT+VGT=127' -> 'OK'             : Voice gain transmit
(playback volume)
voice command: 'AT+VGR=127' -> 'OK'             : Voice gain receive (record
gain)
voice command: 'AT+VRA=70;+VRN=10' -> 'OK'      : Ringback goes away timer,
Ringback never appeared timer
voice command: 'AT+IFC=2,2' -> 'OK'             : Setup Flow control
voice command: 'AT+VCID=1' -> 'OK'              : CallerID enabled with
formatted info
voice command: 'AT+VNH=0' -> 'OK'               : Enable automatic hangups
voice command: 'AT+VIT=0' -> 'OK'               : Voice inactivity timer
voice command: 'AT+VDR=1,15' -> 'OK'            : Distinctive ring

(plays voice here)

So.... does anyone have any suggestions as to what I can try next? (or even
better has anyone managed to make a phone call with just the handset enabled
and can tell me how?).

Regards,
Martin.

_______________________________________________
e3-hacking mailing list
[email-masked]
http://www.earth.li/cgi-bin/mailman/listinfo/e3-hacking