Subject: [E3-hacking] setenv command unknown

From: Dan Ellis <[email-masked]>
Date: Thu, 19 Oct 2006 19:41:52 +0100

Hi,

I bought an E3 a couple of days ago in the hope of doing something
interesting with it. I was pleased to find that lots of really great
work has already been done.

I'm following the 'getting started' this, but I've encountered this problem:

Prodding...
Handshaking...
Done handshaking
Talking to PBL v4.9 Build 1311
PBL v4.9> setenv bootargs mem=32M console=tty0 console=ttyS0,115200n8
root=/dev/ram initrd=0x11c00000,4M
Got command setenv
Unknown command!
PBL v4.9> help
Got command help

read <start addr> <len> <file>
write <start addr> <file>
write <start addr>
setbaud <baud rate>
readflash <start addr> <len> <file>
writeflash <start addr> <file>
eraseflash <start addr> <number of 16k pages>
quit
exit
PBL v4.9>

So it seems I perhaps have a later v4.9 than other people are using? Or
must setenv be enabled in some way?

Has anyone else seen this?

Regards,
Dan.

---

From: Jonathan McDowell <[email-masked]>
Date: Thu, 19 Oct 2006 19:51:45 +0100

> must setenv be enabled in some way?

setenv is a u-boot command, not a PBL command. It looks like you
haven't provide a command file for pbltool to run? The linux.pbl file
should load u-boot, the kernel and rootfs image for you, and then run
u-boot, which is where you type the setenv command.

J.

-- 
General Failure reading drive A:  Please remove your fist.

---

From: Dan Ellis <[email-masked]>
Date: Thu, 19 Oct 2006 20:00:50 +0100

Jonathan McDowell wrote:
> It looks like you
> haven't provide a command file for pbltool to run?
Oh! Some selective blindness there. Indeed, with linux.pbl specified
everything boots up as expected. I look forward to some tinkering.

Thanks,
Dan.