Subject: [E3-hacking] E3 serial connection

From: David Given <[email-masked]>
Date: Tue, 21 Feb 2006 18:05:13 +0000

Does anyone have a definitive answer as to what I need to hook up an E3 to a 
PC serial port?

The various opinions I've seen so far are:

* If you just wire it up, it may work, but you run some risk of frying the 
UART in the E3.

* If you just wire it up, it won't work, because you need to invert the signal 
levels.

* You can wire it up to an E2 line level converter and it will work.

Which one of these, if any, is right?

-- 
+- David Given --McQ-+ 
|  [email-masked]    | ACRONYM: A Contrived Reduction of Nomenclature
| ([email-masked]) | Yielding Mnemonics
+- www.cowlark.com --+

---

From: Jonathan McDowell <[email-masked]>
Date: Tue, 21 Feb 2006 18:08:46 +0000

On Tue, Feb 21, 2006 at 06:05:13PM +0000, David Given wrote:
> Does anyone have a definitive answer as to what I need to hook up an
> E3 to a PC serial port?
>

True; I have mine wired up at present with no converter or level
shifter.

> * If you just wire it up, it won't work, because you need to invert
> the signal levels.
> 

True if taken together I believe; you need an E2 style converter plus an
inverter.

J.

-- 
noodles is good in nagahama

---

From: "J. Snell" <[email-masked]>
Date: Tue, 21 Feb 2006 18:48:24 +0000

I'm using the cable from an old serial digital camera that I have. I
guess I struck lucky there. I don't think it has any electronics in
it, as neither end looks big enough to contain any.

On 2/21/06, Jonathan McDowell <[email-masked]> wrote:
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.4.1 (GNU/Linux)
>
> iD8DBQFD+1cu8b1L5FtDA2cRAndXAJ90AqcoNSeMuhpa7pZXdft05trczgCfavpw
> plBjiacFxQxjN/UF5T4g65U=
> =JkH2
> -----END PGP SIGNATURE-----
>
>
> _______________________________________________
> e3-hacking mailing list
> [email-masked]
> http://www.earth.li/cgi-bin/mailman/listinfo/e3-hacking
>
>
>

---

From: David Given <[email-masked]>
Date: Wed, 22 Feb 2006 21:19:19 +0000

On Tuesday 21 February 2006 18:08, Jonathan McDowell wrote:
[...]
> > * If you just wire it up, it may work, but you run some risk of frying
> > the UART in the E3.
>

Hmm.

[...]
> True if taken together I believe; you need an E2 style converter plus an

If I were to wire it up to an E2 converter *backwards* --- so that logic 0 was 
-5V and logic 1 was 0V --- would the tolerances in the E3's UART and the 
converter's own chip make it work? After all, if the E3 can cope with +/- 25V 
for RS232, it ought to be tough enough to manage -5V...

-- 
+- David Given --McQ-+ "A psychic? That sounds like science fiction."
|  [email-masked]    | "Dear, you live on a spaceship."
| ([email-masked]) | "So?"
+- www.cowlark.com --+ --- Firefly, _Objects in Space_