Subject: [E3-hacking] Hello!

From: Adam Ainsworth <[email-masked]>
Date: Sun, 21 Jul 2019 10:27:45 +0100

Hi all,

Came across this list while looking for hacking info on the Emailer. It's a bit out of my usual area of interest, normally I'm playing with 8-bit computers and old PC-alikes. 

I got an Emailer Plus in new condition about a while back, but forgot about it until recently when I picked up a Pocket Dockit to go with it. I just fired it up to see what it could do, and that turned out to be...nothing! I watched the Chinnyvision video on it, and he came to the same conclusion.

 https://youtu.be/aY6R72nWJsU

I did find a couple of articles, although one (where the author appeared to have Linux running on it) is presumably by someone on this list, given the URL. There was also mention of hooking up a Raspberry Pi to it. I'm also wondering if a wifi modem would do the trick, although presumably we'd need to know how the server software worked if it did connect. 

Without me going through all of the list archives, can someone just give me a quick update on the current status of hacking it? Has someone found a way in, or have I wasted £12 or so on the hardware?

Thanks very much!

Adam

========

---

From: David Given <[email-masked]>
Date: Sun, 21 Jul 2019 21:08:58 +0200

Some models can be reflashed with stock Linux using various poorly
documented and largely forgotten tools; the Linux distribution is here:
http://the.earth.li/pub/e3/ and there's some writeup on it here:
https://www.earth.li/~noodles/hardware-e3.html

The downside is that that Linux distribution is actually built with
OpenEmbedded and won't run binaries built anywhere else, which is
irritating. I have successfully run Debian on an E3 via a USB hub with a
hard drive attached by simply cross-installing the userland from a PC and
then configuring u-boot on the emailer to boot from it. However the
emailer's only got 32MB of RAM so whatever you do it's going to have to be
very lightweight. Finding a sufficiently old userland might be hard, too
--- it'll need to work with a 2.6.19 kernel.

Also, Amstrad eventually locked down the bootloader and later versions
can't be flashed. If you have one of those, you may be out of luck.

You'll also need to build a serial cable. The signals are TTL 5V, except
*inverted*, so 0V = logic 1 and 5V = logic 0 (it's intended to be passed
directly to a level shifter).

The best thing you can probably do with one of these is to use it as a dumb
terminal --- USB ethernet devices work just fine with the OpenEmbedded
distribution, so you may be able to telnet into (or out of) it. The phone's
supported as an ordinary modem but I don't think I ever got it to work.

I'd suggest building the cable, trying to install the OpenEmbedded
distribution above, and seeing what happens. It's not like you can make it
less useful...

On Sun, 21 Jul 2019 at 11:28, Adam Ainsworth <[email-masked]>
wrote:

> Hi all,
>
> Came across this list while looking for hacking info on the Emailer. It's
> a bit out of my usual area of interest, normally I'm playing with 8-bit
> computers and old PC-alikes.
>
> I got an Emailer Plus in new condition about a while back, but forgot
> about it until recently when I picked up a Pocket Dockit to go with it. I
> just fired it up to see what it could do, and that turned out to
> be...nothing! I watched the Chinnyvision video on it, and he came to the
> same conclusion.
>
> I did find a couple of articles, although one (where the author appeared
> to have Linux running on it) is presumably by someone on this list, given
> the URL. There was also mention of hooking up a Raspberry Pi to it. I'm
> also wondering if a wifi modem would do the trick, although presumably we'd
> need to know how the server software worked if it did connect.
>
> Without me going through all of the list archives, can someone just give
> me a quick update on the current status of hacking it? Has someone found a
> way in, or have I wasted £12 or so on the hardware?
>
> Thanks very much!
>
> Adam
>
> ========
> _______________________________________________
> e3-hacking mailing list
> [email-masked]
> https://www.earth.li/mailman/listinfo/e3-hacking
>

-- 
┌─── http://www.cowlark.com ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

---

From: Adam Ainsworth <[email-masked]>
Date: Thu, 1 Aug 2019 13:24:42 +0100

Hi David,

thanks for the reply and apologies in the delay in responding - it's been very busy at work and it was my son's birthday at the weekend.

It does indeed sound like a bit of a mission to get it up and running, and I may just be completely out of luck. It's a shame that's the case, as it's a nice piece of kit, but sadly the money men have sought to limit it for a quick buck.

As it stands, I've had to put my Emailer in storage for a few weeks as I'm having a re-jig of my man cave, but I hope to get it out again when I have some time in the autumn.

Thanks again for your advice,

Adam

========
> On 2019-07-21 20:08, David Given wrote:
> documented and largely forgotten tools; the Linux distribution is
> here: http://the.earth.li/pub/e3/ and there's some writeup on it here:
> irritating. I have successfully run Debian on an E3 via a USB hub with
> a hard drive attached by simply cross-installing the userland from a
> PC and then configuring u-boot on the emailer to boot from it. However
> the emailer's only got 32MB of RAM so whatever you do it's going to
> have to be very lightweight. Finding a sufficiently old userland might
> be hard, too --- it'll need to work with a 2.6.19 kernel.
> You'll also need to build a serial cable. The signals are TTL 5V,
> except _inverted_, so 0V = logic 1 and 5V = logic 0 (it's intended to
> be passed directly to a level shifter).
> The best thing you can probably do with one of these is to use it as a
> dumb terminal --- USB ethernet devices work just fine with the
> OpenEmbedded distribution, so you may be able to telnet into (or out
> of) it. The phone's supported as an ordinary modem but I don't think I
> ever got it to work.
> distribution above, and seeing what happens. It's not like you can
> make it less useful...
> On Sun, 21 Jul 2019 at 11:28, Adam Ainsworth
> <[email-masked]> wrote:
>> Hi all,
>> Came across this list while looking for hacking info on the Emailer.
>> It's a bit out of my usual area of interest, normally I'm playing
>> with 8-bit computers and old PC-alikes.
>> I got an Emailer Plus in new condition about a while back, but
>> forgot about it until recently when I picked up a Pocket Dockit to
>> go with it. I just fired it up to see what it could do, and that
>> turned out to be...nothing! I watched the Chinnyvision video on it,
>> and he came to the same conclusion.
>> I did find a couple of articles, although one (where the author
>> appeared to have Linux running on it) is presumably by someone on
>> this list, given the URL. There was also mention of hooking up a
>> Raspberry Pi to it. I'm also wondering if a wifi modem would do the
>> trick, although presumably we'd need to know how the server software
>> worked if it did connect.
>> Without me going through all of the list archives, can someone just
>> give me a quick update on the current status of hacking it? Has
>> someone found a way in, or have I wasted £12 or so on the hardware?
>> Thanks very much!
>> Adam
>> ========_______________________________________________
>> e3-hacking mailing list
>> [email-masked]