Subject: [E3-hacking] e3 won't boot

From: Matt Callow <[email-masked]>
Date: Sun, 19 Feb 2006 13:06:56 +0000

Hi all,

I've been reading this list with interest for few months. Finally decided to buy an e3 this week, and I've broken it already! I've got it hooked up to my PC serial port and got pbltool working. Then i tried to get a shell prompt by modifying the init params in the 2nd block of the flash as follows:

./pbltool readflash 0x4000 0x400 block2
cp block2 block2.mod
<modify params in block2.mod>
./pbltool eraseflash 0x4000 1
./pbltool writeflash 0x4000 block2.mod

The e3 now fails to boot, so I tried copying back the original block2:
./pbltool eraseflash 0x4000 1
./pbltool writeflash 0x4000 block2

The e3 still does not boot! When I hook up a terminal to see the boot messages I get:

Amstrad Delta - PBL V4.9 Build:1311 Assert Debug ICE
PBL 32MB NAND
0MB.-->MEMv01.00.002,CopyLim=00220000h,CodeEnd=01400000h-->PBL......1MB.......2MB*

and then it hangs.

Any idea what I've done wrong?

Matt

---

From: "J. Snell" <[email-masked]>
Date: Sun, 19 Feb 2006 13:57:43 +0000

eraseflash erases 16K pages, so it looks like you've erased more than you read.

On 2/19/06, Matt Callow <[email-masked]> wrote:
> _______________________________________________
> e3-hacking mailing list
> [email-masked]
> http://www.earth.li/cgi-bin/mailman/listinfo/e3-hacking
>