Subject: Re: [E3-hacking] NAND backup

From: Nick Griffin <[email-masked]>
Date: Sun, 7 Apr 2019 22:12:41 +0000

Whats the
ams-delta-install script ..? And where can i get it from.never heard of it.remember i don't know about the flashing side to the emailer I am not aksing you to do anything i can do it just need to be pointed in the right direction. You can use a USB Stick to back it up...? Anyone have the script...?

Sent from my Samsung Galaxy smartphone.

-------- Original message --------
From: Jonathan McDowell <[email-masked]>
Date: 07/04/2019 21:48 (GMT+00:00)
To: Discussion of the Amstrad E3 emailer hardware/software <[email-masked]>
Subject: Re: [E3-hacking] NAND backup

On Sun, Apr 07, 2019 at 08:43:59PM +0000, Nick Griffin wrote:
> Werid no one ever thought of backing up the firmware before putting
> new firmware on it,what would happen if you didn’t work.

Anyone who uses the ams-delta-install script will have a NAND backup -
there are 6 partitions and it backed them all up to the install USB
stick. Don't ask me what they were or if I happen to still have my
copies though! I didn't spend a lot of time looking at the original
Amstrad firmware, I was more focussed on getting a clean Linux install
up and running.

J.

--
Sleep?  Isn't that some inferior replacement for caffeine?

_______________________________________________
e3-hacking mailing list
[email-masked]
https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C5b38fa099a8048e9de9408d6bb9a6878%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636902669176113587&amp;sdata=hLYmsR2K8a3%2F0EyonPhxIaQ0N9AXHn172hnU3azhBDs%3D&amp;reserved=0

---

From: David Given <[email-masked]>
Date: Mon, 8 Apr 2019 00:49:53 +0200

Hmm, I thought that was documented on the 'getting started' wiki page ---
turns out it's not.

This is part of the turnkey Linux distribution for the E3. You can get it
here: http://the.earth.li/pub/e3/ Get the E3_release_v2.tar.gz file, and
follow the instructions in the README.

Really this should be front and centre when it comes to doing stuff with
the E3, but, well, this was all 14 years ago and the information's all
bitrotted (I'd certainly forgotten it ever existed until you prompted me).

On Mon, 8 Apr 2019 at 00:12, Nick Griffin <[email-masked]> wrote:

>
> Whats the
> ams-delta-install script ..? And where can i get it from.never heard of
> it.remember i don't know about the flashing side to the emailer I am not
> aksing you to do anything i can do it just need to be pointed in the right
> direction. You can use a USB Stick to back it up...? Anyone have the
> script...?
>
>
>
> https://www.earth.li/mailman/listinfo/e3-hacking
>

-- 
┌─── http://www.cowlark.com ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup

---

From: Nick Griffin <[email-masked]>
Date: Mon, 8 Apr 2019 11:51:26 +0000

So if I flash V2 Linux http://the.earth.li/pub/e3/ to my E3 it will backup the original firmware first before flashing V2 on to the E3,is that what your saying,I need to know cos,I would need to flash it back to put back to normal again,I don’t want Linux on it because I can still use it as a phone at the moment because of the bug in the Main Software V2, I want to activate(unlock) it.

Just out of curiosity,has anyone tried to run a ZX Spectrum Emulator on it with the Linux build on it, you would have to compile it on it..? That’s one thing you could use it for, or you could take all its insides out and replace it with a ZX Spectrum Vega, its runs on composite so would have get a new screen, screens are better now,the E3 screen has a shadow on it when things are moving fast a cross it, look at the video I post showing the games on it you can see it on there. Its not a bad screen for been made in 2003.. 😊

I like the E3 I use to use the Plus when I got it in 2004, I even downloaded a ringtone to see what its like, its like the old mobiles ringtones before MP3, Polyphonic, sounds like the old Game and Watch handhelds from the 80s.I only downloaded one took about 2 to 3 mins I think. And at £1.50 a min that's a lot.

Properly a lot of you never used yours just flashed Linux straight on it.

Are you now playing anything similar like Mini Consoles, they are Identical but easer to hack because they use UBoot.

Can you replace PBL with UBoot but keep its Main Software..?

So like TheC64 Mini to get into it you use a FTDI232 or a CP2102 (this is at 3.3v already on it but has to be at 3.3 v on RX because you can blow it UART I did it to mine and had to get another one.To use its console when its booting you have press and hold “s” down to interrupt its boot so you can make a root user on it so you can then just login with root.it uses Uboot to boot, it has 2 partitions: nanda: Linux kernel,Uboot, nandb: root filesystem, ext2 format. I made a guide on how to add games to it here.. http://thec64community.online/thread/76/thec64-modding-games-little-guide

Spanner..

From: David Given<mailto:[email-masked]>
Sent: ‎Sunday‎, ‎7‎ ‎April‎ ‎2019 ‎23‎:‎50
To: Discussion of the Amstrad E3 emailer hardware/software<mailto:[email-masked]>

Hmm, I thought that was documented on the 'getting started' wiki page --- turns out it's not.

This is part of the turnkey Linux distribution for the E3. You can get it here: http://the.earth.li/pub/e3/<https://eur02.safelinks.protection.outlook.com/?url=http://the.earth.li/pub/e3/&data=02%7c01%7c%7cf72dfc7c025941e40e7308d6bbab77e5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636902742453231414&sdata=qkst42hPENWcCnz/920uMGm%2B1TJ0uj1LcHPk4LBhbws%3D&reserved=0> Get the E3_release_v2.tar.gz file, and follow the instructions in the README.

Really this should be front and centre when it comes to doing stuff with the E3, but, well, this was all 14 years ago and the information's all bitrotted (I'd certainly forgotten it ever existed until you prompted me).

On Mon, 8 Apr 2019 at 00:12, Nick Griffin <[email-masked]<mailto:[email-masked]>> wrote:

Whats the

-------- Original message --------
From: Jonathan McDowell <[email-masked]<mailto:[email-masked]>>
Date: 07/04/2019 21:48 (GMT+00:00)
To: Discussion of the Amstrad E3 emailer hardware/software <[email-masked]<mailto:[email-masked]>>
Subject: Re: [E3-hacking] NAND backup

J.

_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://eur02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.earth.li%2Fmailman%2Flistinfo%2Fe3-hacking&amp;data=02%7C01%7C%7C5b38fa099a8048e9de9408d6bb9a6878%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636902669176113587&amp;sdata=hLYmsR2K8a3%2F0EyonPhxIaQ0N9AXHn172hnU3azhBDs%3D&amp;reserved=0<https://eur02.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7cf72dfc7c025941e40e7308d6bbab77e5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636902742453241413&sdata=Q3wJgcjkQZpqg3qoW9EWyGXUAFEZggjMNYWfk9M4984%3D&reserved=0>
_______________________________________________
e3-hacking mailing list
[email-masked]<mailto:[email-masked]>
https://www.earth.li/mailman/listinfo/e3-hacking<https://eur02.safelinks.protection.outlook.com/?url=https://www.earth.li/mailman/listinfo/e3-hacking&data=02%7c01%7c%7cf72dfc7c025941e40e7308d6bbab77e5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636902742453251418&sdata=cBB0mJx8OGKrJJMjM5vdzbnWACvL3HfbWTz7Z5d8ANY%3D&reserved=0>

--
┌─── http://www.cowlark.com<https://eur02.safelinks.protection.outlook.com/?url=http://www.cowlark.com&data=02%7c01%7c%7cf72dfc7c025941e40e7308d6bbab77e5%7c84df9e7fe9f640afb435aaaaaaaaaaaa%7c1%7c0%7c636902742453261429&sdata=ti/R0o06aALEG1Cpoi7rG5Wuii5J%2Bvt7HJaJs1Q/ONM%3D&reserved=0> ───
│ "I have always wished for my computer to be as easy to use as my
│ telephone; my wish has come true because I can no longer figure out
│ how to use my telephone." --- Bjarne Stroustrup