Subject: Re: [E3-hacking] An E3 which thinks it's a Spectrum!

From: "Iain Learmonth" <[email-masked]>
Date: Thu, 15 Feb 2007 07:39:41 +0000

Date: Tue, 13 Feb 2007 22:16:53 -0000
From: "Martin Whitaker" <[email-masked]>
Subject: [E3-hacking] An E3 which thinks it's a Spectrum!
To: "Discussion of the Amstrad E3 emailer hardware/software"
        <[email-masked]>
Message-ID: <EAEMINPLLHDBJGEIKJPHOENBCIAA
>
> [email-masked]>
> Content-Type: text/plain;       charset="iso-8859-1"
>
> I've been playing with the E3 some more and couldn't resist compiling
> libspectrum and Fuse for it (from
> http://fuse-emulator.sourceforge.net/fuse.php).
>
> It runs it at about original speed, however it's going flat-out doing that
> and increasing the emulation speed above 100% seems to make little
> difference.
>
> A couple of screen-shots are at:
>
> http://www.whitakernet.com/e3/spectrum_on_e3_1.jpg
> http://www.whitakernet.com/e3/spectrum_on_e3_2.jpg
>
> I had to make a few simple changes to Fuse to get it to work with the
> strange resolution framebuffer of the e3. If anyone wants to build Fuse
> themselves let me know and I'll post the patches here.
>
> All of this is totally pointless, of course, but it bought back memories
> typing single-keystroke commands using a rubber keyboard!!!

Could I have  the patches you applied for this,  I would like to try it out.
[:

Also,  how did you compile it, i can't find a cross-compiler for ARM9 that
actually compiles ?

tuxish,

---

From: David Reynolds <[email-masked]>
Date: Thu, 15 Feb 2007 14:27:29 +0000

On Thu, Feb 15, 2007 at 07:39:41AM +0000, Iain Learmonth wrote:
> 
> Could I have  the patches you applied for this,  I would like to try it out. [:
> 

I'd also be interested to know how you went about compiling fuse for the
E3..

Cheers,

Dave

--
David Reynolds
[email-masked]

---

From: "Martin Whitaker" <[email-masked]>
Date: Thu, 15 Feb 2007 14:59:25 -0000

> I'd also be interested to know how you went about compiling fuse for the

Okay, I'll post the patch to Fuse here over the next few days (I do feel
obliged to tidy it up a bit first though!).

With regards to compiling... I've given up with cross compiling - I got fed
up with little things taking hours of faffing to make work. Chris Steel
(also on this mailing list) provided me with a cross compiled rootfs
containing gcc-4.1.1 and glibc-2.5 for native building (although I guess you
could get buildroot to provide you with this - there certainly has been a
working E3 buildroot config at some point). I mount the rootfs over an NFS
mount (from bootup using root=nfs nfsroot=...) and also enable swap over NFS
(it sounds worse than it is). I then configure and build everything
natively.

Most packages configure and compile in under a couple of hours, and so far
very few packages have required any changes to get them to build properly.
Chris suggested I get distcc running to speed things up a bit, so far I
haven't felt the need though.

I'm not saying this is the best way of donig things, however it suits me and
keeps it all at a level I can still understand :-)

This is a list of the packages I've compiled using this method so far (in no
particular order):

DirectFB-1.0.0-rc2
minicom-2.2
freetype-2.3.0
mtd-20050122.orig
fuse-0.7.0
glib-2.12.9
perl-5.8.8
fbset-2.1
jpeg-6b
libpng-1.2.15
zlib-1.2.3
libspectrum-0.2.2
bison-2.3
flex-2.5.33
m4-1.4.8
pkg-config-0.21
findutils-4.2.29
gettext-0.16.1
ncurses-5.6

I can't remember which ones are dependencies to build libspectrum/fuse.

Unfortunatly I can't give anyone an easy recipie to follow to do all of
this - perhaps I ought to do it again from scratch and make proper notes as
I go! I'll try to answer questions if you get stuck though, as I probably
had to deal with the same problems.

Martin.

---

From: David Reynolds <[email-masked]>
Date: Thu, 15 Feb 2007 22:53:02 +0000

> (it sounds worse than it is). I then configure and build everything

Any chance of making the rootfs available?

> keeps it all at a level I can still understand :-)

It certainly sounds like an interesting and fairly simple for a
beginnner like me to get to grips with :)

Thanks,

Dave